Re: [libav-devel] [PATCH] lavu: add snprintf(), vsnprint() and strtod() replacements on MSVC.

2012-08-05 Thread Måns Rullgård
Diego Biurrun writes: > On Fri, Aug 03, 2012 at 09:38:29PM +0100, Måns Rullgård wrote: >> "Ronald S. Bultje" writes: >> >> Other than that, >> >> this feels like it belongs in compat/ rather than libavutil. Not really >> >> sure how best to build it though. >> > >> > I was actually thinking of

Re: [libav-devel] [PATCH] lavu: add snprintf(), vsnprint() and strtod() replacements on MSVC.

2012-08-05 Thread Diego Biurrun
On Fri, Aug 03, 2012 at 09:38:29PM +0100, Måns Rullgård wrote: > "Ronald S. Bultje" writes: > >> Other than that, > >> this feels like it belongs in compat/ rather than libavutil. Not really > >> sure how best to build it though. > > > > I was actually thinking of that for the header, yes. I supp

Re: [libav-devel] [PATCH] lavu: add snprintf(), vsnprint() and strtod() replacements on MSVC.

2012-08-03 Thread Ronald S. Bultje
Hi, On Fri, Aug 3, 2012 at 5:22 PM, Ronald S. Bultje wrote: > Hi, > > On Fri, Aug 3, 2012 at 5:08 PM, Måns Rullgård wrote: >> "Ronald S. Bultje" writes: >> >>> Hi, >>> >>> [.. as for the rest ..] >>> >>> On Fri, Aug 3, 2012 at 1:38 PM, Måns Rullgård wrote: "Ronald S. Bultje" writes:

Re: [libav-devel] [PATCH] lavu: add snprintf(), vsnprint() and strtod() replacements on MSVC.

2012-08-03 Thread Ronald S. Bultje
Hi, On Fri, Aug 3, 2012 at 5:08 PM, Måns Rullgård wrote: > "Ronald S. Bultje" writes: > >> Hi, >> >> [.. as for the rest ..] >> >> On Fri, Aug 3, 2012 at 1:38 PM, Måns Rullgård wrote: >>> "Ronald S. Bultje" writes: >>> > Other than that, > this feels like it belongs in compat/ rather t

Re: [libav-devel] [PATCH] lavu: add snprintf(), vsnprint() and strtod() replacements on MSVC.

2012-08-03 Thread Måns Rullgård
"Ronald S. Bultje" writes: > Hi, > > [.. as for the rest ..] > > On Fri, Aug 3, 2012 at 1:38 PM, Måns Rullgård wrote: >> "Ronald S. Bultje" writes: >> Other than that, this feels like it belongs in compat/ rather than libavutil. Not really sure how best to build it though. >>> >

Re: [libav-devel] [PATCH] lavu: add snprintf(), vsnprint() and strtod() replacements on MSVC.

2012-08-03 Thread Ronald S. Bultje
Hi, [.. as for the rest ..] On Fri, Aug 3, 2012 at 1:38 PM, Måns Rullgård wrote: > "Ronald S. Bultje" writes: > >>> Other than that, >>> this feels like it belongs in compat/ rather than libavutil. Not really >>> sure how best to build it though. >> >> I was actually thinking of that for the h

Re: [libav-devel] [PATCH] lavu: add snprintf(), vsnprint() and strtod() replacements on MSVC.

2012-08-03 Thread Ronald S. Bultje
Hi, On Fri, Aug 3, 2012 at 1:38 PM, Måns Rullgård wrote: > "Ronald S. Bultje" writes: +} else if (!av_strncasecmp(nptr, "0x", 2) || + !av_strncasecmp(nptr, "-0x", 3) || + !av_strncasecmp(nptr, "+0x", 3)) { +return strtol(nptr, endptr, 1

Re: [libav-devel] [PATCH] lavu: add snprintf(), vsnprint() and strtod() replacements on MSVC.

2012-08-03 Thread Måns Rullgård
"Ronald S. Bultje" writes: >> Other than that, >> this feels like it belongs in compat/ rather than libavutil. Not really >> sure how best to build it though. > > I was actually thinking of that for the header, yes. I suppose we can > do it for the source also, but then again, we'd need to link

Re: [libav-devel] [PATCH] lavu: add snprintf(), vsnprint() and strtod() replacements on MSVC.

2012-08-03 Thread Ronald S. Bultje
Hi, On Fri, Aug 3, 2012 at 2:14 AM, Måns Rullgård wrote: > "Ronald S. Bultje" writes: >> I'm adding this under _MSC_VER (rather than a configure check) because >> I'm not quite sure how the configure check would work, so consider this >> a RFC more than anything. The idea is to compile in os_sup

Re: [libav-devel] [PATCH] lavu: add snprintf(), vsnprint() and strtod() replacements on MSVC.

2012-08-03 Thread Ronald S. Bultje
Hi, On Fri, Aug 3, 2012 at 8:19 AM, Måns Rullgård wrote: > "Ronald S. Bultje" writes: >> On Fri, Aug 3, 2012 at 2:14 AM, Måns Rullgård wrote: >>> "Ronald S. Bultje" writes: +} else if (!av_strncasecmp(nptr, "0x", 2) || + !av_strncasecmp(nptr, "-0x", 3) || +

Re: [libav-devel] [PATCH] lavu: add snprintf(), vsnprint() and strtod() replacements on MSVC.

2012-08-03 Thread Måns Rullgård
"Ronald S. Bultje" writes: > Hi, > > On Fri, Aug 3, 2012 at 2:14 AM, Måns Rullgård wrote: >> "Ronald S. Bultje" writes: >>> +} else if (!av_strncasecmp(nptr, "0x", 2) || >>> + !av_strncasecmp(nptr, "-0x", 3) || >>> + !av_strncasecmp(nptr, "+0x", 3)) { >>> +

Re: [libav-devel] [PATCH] lavu: add snprintf(), vsnprint() and strtod() replacements on MSVC.

2012-08-03 Thread Ronald S. Bultje
Hi, On Fri, Aug 3, 2012 at 2:14 AM, Måns Rullgård wrote: > "Ronald S. Bultje" writes: >> +} else if (!av_strncasecmp(nptr, "0x", 2) || >> + !av_strncasecmp(nptr, "-0x", 3) || >> + !av_strncasecmp(nptr, "+0x", 3)) { >> +return strtol(nptr, endptr, 16); > >

Re: [libav-devel] [PATCH] lavu: add snprintf(), vsnprint() and strtod() replacements on MSVC.

2012-08-03 Thread Måns Rullgård
"Ronald S. Bultje" writes: > From: "Ronald S. Bultje" > > I'm adding this under _MSC_VER (rather than a configure check) because > I'm not quite sure how the configure check would work, so consider this > a RFC more than anything. The idea is to compile in os_support.c (or > maybe rename it to m

Re: [libav-devel] [PATCH] lavu: add snprintf(), vsnprint() and strtod() replacements on MSVC.

2012-08-02 Thread Luca Barbato
On 08/03/2012 01:37 AM, Ronald S. Bultje wrote: > I'm adding this under _MSC_VER (rather than a configure check) because > I'm not quite sure how the configure check would work, so consider this > a RFC more than anything. The idea is to compile in os_support.c (or > maybe rename it to msvc_compat.

[libav-devel] [PATCH] lavu: add snprintf(), vsnprint() and strtod() replacements on MSVC.

2012-08-02 Thread Ronald S. Bultje
From: "Ronald S. Bultje" I'm adding this under _MSC_VER (rather than a configure check) because I'm not quite sure how the configure check would work, so consider this a RFC more than anything. The idea is to compile in os_support.c (or maybe rename it to msvc_compat.c) only for MSVC, and force-i