Re: [RFC] extending ev++.h to add C++ loop wrappers.

2008-01-17 Thread Marc Lehmann
On Wed, Jan 16, 2008 at 05:20:06PM -0200, Leandro Lucarella <[EMAIL PROTECTED]> wrote: > > (like watchers? but since they are radically different methods, maybe the > > must be called otherwise). Maybe just loop -> do_loop? > > Even more, if we call it loop, then we can't name the internal base >

Re: [RFC] extending ev++.h to add C++ loop wrappers.

2008-01-17 Thread Leandro Lucarella
Marc Lehmann, el 17 de enero a las 08:57 me escribiste: > On Wed, Jan 16, 2008 at 04:12:02PM -0200, Leandro Lucarella <[EMAIL > PROTECTED]> wrote: > > Marc Lehmann, el 16 de enero a las 05:43 me escribiste: > > I'm trying to go back to this design, but I'm starting to need the loop to > > be virtu

Re: [RFC] extending ev++.h to add C++ loop wrappers.

2008-01-17 Thread Leandro Lucarella
Marc Lehmann, el 16 de enero a las 05:43 me escribiste: > Not if you are convinced its what people predominantly want. I have as > much data on that as you (i.e. mostly my own: I have more READ than write > watchers, but I don't see why it should be the default. Think readability: > >start (fd

New iteration over the ev++ improvement patch.

2008-01-17 Thread Leandro Lucarella
Well, after all the talking and thinking, this is what I came up with. Main changes: * The use of exceptions is now optional (configurable via EV_CXX_EXCEPTIONS). I don't know if: #define throw(exception) throw (exception) is valid preprocesor code though =) It could be easily changed to E

Re: New iteration over the ev++ improvement patch.

2008-01-17 Thread Leandro Lucarella
Leandro Lucarella, el 17 de enero a las 17:08 me escribiste: > Patch and example attached. Documentation still missing (I'll do that when > the patch gets a technical OK =). I'll probably split the patch in > smaller, incremental changes. I think not many people undestand the invisible diff format

Re: New iteration over the ev++ improvement patch.

2008-01-17 Thread Marc Lehmann
On Thu, Jan 17, 2008 at 05:08:16PM -0200, Leandro Lucarella <[EMAIL PROTECTED]> wrote: > Well, after all the talking and thinking, this is what I came up with. > > Main changes: > * The use of exceptions is now optional (configurable via > EV_CXX_EXCEPTIONS). I don't know if: > #define throw(

Re: [RFC] extending ev++.h to add C++ loop wrappers.

2008-01-17 Thread Marc Lehmann
On Wed, Jan 16, 2008 at 03:37:12PM -0200, Leandro Lucarella <[EMAIL PROTECTED]> wrote: > > Well, I think its a wonderful idea, its a loop, it should be called loop :) > > If we call it loop, then the loop() method has to be called other way, > that's why I didn't call it loop. Maybe loop -> start

Re: [RFC] extending ev++.h to add C++ loop wrappers.

2008-01-17 Thread Marc Lehmann
On Thu, Jan 17, 2008 at 10:28:16AM -0200, Leandro Lucarella <[EMAIL PROTECTED]> wrote: > > Bause I don't: I changed ->stat to ->update already and it sucks. The > > obvious method would be to call them ev_sleep etc. (haha). > > do_/get_xxx? do_fork, do_sleep, get_time? > > fix_fork? go_sleep? no