Seabios already added a new device type to halt booting.
Qemu can add "HALT" at the end of bootindex string, then
seabios will halt booting after trying to boot from all
selected devices.
This patch added a new boot option to configure if boot
from un-selected devices.
This option only effects wh
On 2013年03月19日 01:01, John Ferlan wrote:
On 03/18/2013 05:57 AM, Li Zhang wrote:
From: Li Zhang
Now that VCPU number are removed from qemu_monitor_text.c.
VCPU string checking also should be removed.
Report-by: John Ferlan
Signed-off-by: Li Zhang
---
src/qemu/qemu_monitor_text.c |9 +-
This patch adds cpuset cgroup support for LXC.
Signed-off-by: Gao feng
---
src/lxc/lxc_cgroup.c | 54 +++-
src/lxc/lxc_cgroup.h | 2 +-
src/lxc/lxc_controller.c | 2 +-
3 files changed, 55 insertions(+), 3 deletions(-)
diff --git a/src/lxc/l
Intend to reduce the redundant code,use virNumaSetupMemoryPolicy
to replace virLXCControllerSetupNUMAPolicy and
qemuProcessInitNumaMemoryPolicy.
This patch also moves the numa related codes to the
file virnuma.c and virnuma.h
Signed-off-by: Gao feng
---
src/conf/domain_conf.c | 17 ++-
s
On 2013/03/18 19:33, Osier Yang wrote:
> On 2013年03月18日 18:06, Gao feng wrote:
>> On 2013/03/18 17:34, Osier Yang wrote:
>>> On 2013年03月18日 17:04, Gao feng wrote:
Intend to reduce the redundant code,use virNumaSetupMemoryPolicy
to replace virLXCControllerSetupNUMAPolicy and
qemuProce
Hi Eric & Daniel,
Could you please help review these patches?
Best Regards,
Olivia
> -Original Message-
> From: Yin Olivia-R63875
> Sent: Thursday, March 14, 2013 12:50 PM
> To: libvir-list@redhat.com
> Cc: Yin Olivia-R63875
> Subject: [PATCH v5 0/3] qemu: -dtb option support
>
> Since
On 03/18/2013 04:07 PM, Laine Stump wrote:
> virStorageBackendRBDRefreshPool() first allocates an array big enough
> to hold 1024 names, then calls rbd_list(), which returns ERANGE if the
> array isn't big enough. When that happens, the VIR_ALLOC_N is called
> again with a larger size. Unfortunatel
On 03/18/2013 02:07 PM, Laine Stump wrote:
> virStorageBackendRBDRefreshPool() first allocates an array big enough
> to hold 1024 names, then calls rbd_list(), which returns ERANGE if the
> array isn't big enough. When that happens, the VIR_ALLOC_N is called
> again with a larger size. Unfortunatel
virStorageBackendRBDRefreshPool() first allocates an array big enough
to hold 1024 names, then calls rbd_list(), which returns ERANGE if the
array isn't big enough. When that happens, the VIR_ALLOC_N is called
again with a larger size. Unfortunately, the original array isn't
freed before allocating
Hello,
I'm part of the people developing the live system called Tails [1].
[1] https://tails.boum.org/
We are now preparing a bounties program to help developers work on
upstream software and fix bugs or implement features needed for Tails.
Daniel P. Berrange suggested we write to this list ab
Op maandag 18 maart 2013 18:19:51 schreef Jiri Denemark:
> On Thu, Mar 14, 2013 at 20:01:16 +0100, AL13N wrote:
> > Op maandag 11 maart 2013 12:59:08 schreef Eric Blake:
> > > On 03/10/2013 09:25 AM, AL13N wrote:
> > > > regarding
> > > >
> > > > http://www.redhat.com/archives/libvir-list/2012-Dec
> On 03/16/2013 11:08 PM, Eric Blake wrote:
> >> So, it appears the this version of gnulib fixes something
> >> important but
> >> also causes a segfault when ./configure is run with the new
> >> gnulib.
> >> What I do not know is if this segfault has any meaning.
> > The segfault DOES have meanin
On Thu, Mar 14, 2013 at 20:01:16 +0100, AL13N wrote:
> Op maandag 11 maart 2013 12:59:08 schreef Eric Blake:
> > On 03/10/2013 09:25 AM, AL13N wrote:
> > > regarding
> > >
> > > http://www.redhat.com/archives/libvir-list/2012-December/msg01365.html
> > >
> > > and
> > >
> > > https://www.redhat.
On 03/18/2013 05:57 AM, Li Zhang wrote:
> From: Li Zhang
>
> Now that VCPU number are removed from qemu_monitor_text.c.
> VCPU string checking also should be removed.
>
> Report-by: John Ferlan
> Signed-off-by: Li Zhang
> ---
> src/qemu/qemu_monitor_text.c |9 +
> 1 file changed,
I am pleased to announce that a new release of the libvirt-glib package,
version 0.1.6, is now available from
ftp://libvirt.org/libvirt/glib/
The packages are GPG signed with
Key fingerprint: DAF3 A6FD B26B 6291 2D0E 8E3F BE86 EBB4 1510 4FDF (4096R)
New in this release:
- Prefer g_strlc
Paolo Bonzini writes:
> Il 18/03/2013 15:24, Anthony Liguori ha scritto:
>> "Michael S. Tsirkin" writes:
>>
>>> We need to know the original path since unparenting loses this state.
>>>
>>> Signed-off-by: Michael S. Tsirkin
>>> ---
>>> hw/qdev.c| 4 ++--
>>> include/qom/object.h |
Il 18/03/2013 15:35, Michael S. Tsirkin ha scritto:
> > There's no harm AFAICT in doing this and it seems more logical to me to
> > have destruction flow start with the subclass and move up to the base
> > class.
>
> At Paolo's request children are intentionally reported before parents,
> shouldn'
Il 18/03/2013 15:24, Anthony Liguori ha scritto:
> "Michael S. Tsirkin" writes:
>
>> We need to know the original path since unparenting loses this state.
>>
>> Signed-off-by: Michael S. Tsirkin
>> ---
>> hw/qdev.c| 4 ++--
>> include/qom/object.h | 3 ++-
>> qom/object.c |
On Mon, Mar 18, 2013 at 05:39:25PM +0800, Alex Jia wrote:
>
> Signed-off-by: Alex Jia
> ---
> bin/virt-sandbox.c |4 ++--
> 1 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/bin/virt-sandbox.c b/bin/virt-sandbox.c
> index bd7ac49..654a205 100644
> --- a/bin/virt-sandbox.c
>
On Mon, Mar 18, 2013 at 05:10:17PM +0800, Guannan Ren wrote:
>
> The set of patches is trying to add 'startupPolicy' attribute support
> to the source element of hard disks. Policy levels are using the
> mandatory, requisite, optional levels as originally documented.
>
> For the 'optional' policy
> qemu: check backing chains even when cgroup is omitted
>
> added backing file checks just before the code that removes optional
> disks if they are not present. However, the backing chain code fails
> in
> case the disk file does not exist, which makes qemuProcessStart fail
> regardless on c
On Mon, Mar 18, 2013 at 05:04:03PM +0800, Gao feng wrote:
> Intend to reduce the redundant code,use virNumaSetupMemoryPolicy
> to replace virLXCControllerSetupNUMAPolicy and
> qemuProcessInitNumaMemoryPolicy.
>
> This patch also moves the numa related codes to the
> file virnuma.c and virnuma.h
>
On Mon, Mar 18, 2013 at 09:24:16AM -0500, Anthony Liguori wrote:
> "Michael S. Tsirkin" writes:
>
> > We need to know the original path since unparenting loses this state.
> >
> > Signed-off-by: Michael S. Tsirkin
> > ---
> > hw/qdev.c| 4 ++--
> > include/qom/object.h | 3 ++-
> >
On Mon, Mar 18, 2013 at 05:04:04PM +0800, Gao feng wrote:
> This patch adds cpuset cgroup support for LXC.
>
> Signed-off-by: Gao feng
> ---
> src/lxc/lxc_cgroup.c | 54
> +++-
> src/lxc/lxc_cgroup.h | 2 +-
> src/lxc/lxc_controller.c | 2 +-
On Mon, Mar 18, 2013 at 05:04:02PM +0800, Gao feng wrote:
> Allow lxc using the advisory nodeset from querying numad,
> this means if user doesn't specify the numa nodes that
> the lxc domain should assign to, libvirt will automatically
> bind the lxc domain to the advisory nodeset which queried fr
"Michael S. Tsirkin" writes:
> We need to know the original path since unparenting loses this state.
>
> Signed-off-by: Michael S. Tsirkin
> ---
> hw/qdev.c| 4 ++--
> include/qom/object.h | 3 ++-
> qom/object.c | 4 +++-
> 3 files changed, 7 insertions(+), 4 deletions(-)
>
On Mon, Mar 18, 2013 at 05:04:01PM +0800, Gao feng wrote:
> qemuGetNumadAdvice will be used by LXC driver,rename
> it to virNumaGetAutoPlacementAdvice and move it to virnuma.c
>
> Signed-off-by: Gao feng
> ---
> po/POTFILES.in | 1 +
> src/Makefile.am | 1 +
> src/libvirt_pr
On 2013年03月13日 15:52, Osier Yang wrote:
On 2013年03月13日 15:38, Osier Yang wrote:
On 2013年03月13日 15:20, yuxh wrote:
On 03/13/2013 11:33 AM, Osier Yang wrote:
On 2013年03月13日 11:04, yuxh wrote:
To Osier Yang
Sorry for disturbing you on the working time, but I really need your
help.
I met a probl
We should record the new disk src in the shared disk table for
updating disk (CD-ROM or Floppy) API. Fortunately, we only allow
to update the disk source now, otherwise we might also want to
set the unpriv_sgio setting.
---
src/qemu/qemu_driver.c |4
1 files changed, 4 insertions(+), 0 de
On Mon, Mar 18, 2013 at 21:33:04 +0800, Guannan Ren wrote:
> On 03/18/2013 09:18 PM, Jiri Denemark wrote:
> > Commit 82d5fe543720da6d83c1d6bfa1c347d7d9fda278
> >
> > qemu: check backing chains even when cgroup is omitted
> >
> > added backing file checks just before the code that removes optio
On 03/18/2013 09:18 PM, Jiri Denemark wrote:
Commit 82d5fe543720da6d83c1d6bfa1c347d7d9fda278
qemu: check backing chains even when cgroup is omitted
added backing file checks just before the code that removes optional
disks if they are not present. However, the backing chain code fails in
c
Commit 82d5fe543720da6d83c1d6bfa1c347d7d9fda278
qemu: check backing chains even when cgroup is omitted
added backing file checks just before the code that removes optional
disks if they are not present. However, the backing chain code fails in
case the disk file does not exist, which makes qe
On 03/01/2013 06:03 PM, Guannan Ren wrote:
For example:
>>> dom.memoryStats()
libvir: QEMU Driver error : Requested operation is not valid:\
domain is not running
There are six such python API functions like so.
The root reason is that generator.py script checks the type of return
On 2013年03月18日 18:06, Gao feng wrote:
On 2013/03/18 17:34, Osier Yang wrote:
On 2013年03月18日 17:04, Gao feng wrote:
Intend to reduce the redundant code,use virNumaSetupMemoryPolicy
to replace virLXCControllerSetupNUMAPolicy and
qemuProcessInitNumaMemoryPolicy.
This patch also moves the numa rel
On 2013/03/18 17:34, Osier Yang wrote:
> On 2013年03月18日 17:04, Gao feng wrote:
>> Intend to reduce the redundant code,use virNumaSetupMemoryPolicy
>> to replace virLXCControllerSetupNUMAPolicy and
>> qemuProcessInitNumaMemoryPolicy.
>>
>> This patch also moves the numa related codes to the
>> file
On 03/18/2013 06:40 PM, Osier Yang wrote:
On 2013年03月18日 17:10, Guannan Ren wrote:
The set of patches is trying to add 'startupPolicy' attribute support
to the source element of hard disks. Policy levels are using the
mandatory, requisite, optional levels as originally documented.
For the 'opt
On 2013年03月18日 17:10, Guannan Ren wrote:
The set of patches is trying to add 'startupPolicy' attribute support
to the source element of hard disks. Policy levels are using the
mandatory, requisite, optional levels as originally documented.
For the 'optional' policy, there is a little difference
On 2013年03月18日 17:10, Guannan Ren wrote:
Add startupPolicy attribute policy for harddisk with type "file",
"block" and "dir". The "network" type disk is still not supported.
---
docs/formatdomain.html.in | 9 ++---
src/conf/domain_conf.c| 19 +--
2 files changed, 19 i
On 03/18/2013 06:02 PM, Osier Yang wrote:
On 2013年03月18日 18:00, Alex Jia wrote:
Signed-off-by: Alex Jia
---
bin/virt-sandbox.c |2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/bin/virt-sandbox.c b/bin/virt-sandbox.c
index bd7ac49..257d6c2 100644
--- a/bin/virt-sandbo
On 03/18/2013 05:51 PM, Osier Yang wrote:
On 2013年03月18日 15:10, Alex Jia wrote:
Signed-off-by: Alex Jia
---
libvirt-sandbox/libvirt-sandbox-init-qemu.c |4
1 files changed, 4 insertions(+), 0 deletions(-)
diff --git a/libvirt-sandbox/libvirt-sandbox-init-qemu.c
b/libvirt-sandbox/l
On 2013年03月18日 18:00, Alex Jia wrote:
Signed-off-by: Alex Jia
---
bin/virt-sandbox.c |2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/bin/virt-sandbox.c b/bin/virt-sandbox.c
index bd7ac49..257d6c2 100644
--- a/bin/virt-sandbox.c
+++ b/bin/virt-sandbox.c
@@ -87,7 +87,7
Signed-off-by: Alex Jia
---
bin/virt-sandbox.c |2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/bin/virt-sandbox.c b/bin/virt-sandbox.c
index bd7ac49..257d6c2 100644
--- a/bin/virt-sandbox.c
+++ b/bin/virt-sandbox.c
@@ -87,7 +87,7 @@ int main(int argc, char **argv) {
On 03/18/2013 05:45 PM, Osier Yang wrote:
On 2013年03月18日 17:39, Alex Jia wrote:
Signed-off-by: Alex Jia
---
bin/virt-sandbox.c |4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/bin/virt-sandbox.c b/bin/virt-sandbox.c
index bd7ac49..654a205 100644
--- a/bin/virt-sand
From: Li Zhang
Now that VCPU number are removed from qemu_monitor_text.c.
VCPU string checking also should be removed.
Report-by: John Ferlan
Signed-off-by: Li Zhang
---
src/qemu/qemu_monitor_text.c |9 +
1 file changed, 1 insertion(+), 8 deletions(-)
diff --git a/src/qemu/qemu_m
On 2013年03月18日 14:54, hongming wrote:
Can you shorten the patch subject? And add the sentences in the commit
log instead?
---
cases/nwfilter.conf | 59 +
repos/nwfilter/nwfilter_check.py| 120 +++
repos/nwfilter/nwfilter
On 2013年03月18日 15:10, Alex Jia wrote:
Signed-off-by: Alex Jia
---
libvirt-sandbox/libvirt-sandbox-init-qemu.c |4
1 files changed, 4 insertions(+), 0 deletions(-)
diff --git a/libvirt-sandbox/libvirt-sandbox-init-qemu.c
b/libvirt-sandbox/libvirt-sandbox-init-qemu.c
index 38ed284..d
On 2013年03月18日 17:39, Alex Jia wrote:
Signed-off-by: Alex Jia
---
bin/virt-sandbox.c |4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/bin/virt-sandbox.c b/bin/virt-sandbox.c
index bd7ac49..654a205 100644
--- a/bin/virt-sandbox.c
+++ b/bin/virt-sandbox.c
@@ -87,10 +8
Signed-off-by: Alex Jia
---
bin/virt-sandbox.c |4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/bin/virt-sandbox.c b/bin/virt-sandbox.c
index bd7ac49..654a205 100644
--- a/bin/virt-sandbox.c
+++ b/bin/virt-sandbox.c
@@ -87,10 +87,10 @@ int main(int argc, char **argv) {
On 2013年03月18日 17:04, Gao feng wrote:
> This patch adds cpuset cgroup support for LXC.
>
> Signed-off-by: Gao feng
> ---
> src/lxc/lxc_cgroup.c | 54
> +++-
> src/lxc/lxc_cgroup.h | 2 +-
> src/lxc/lxc_controller.c | 2 +-
> 3 files chang
On 2013年03月18日 17:04, Gao feng wrote:
> Intend to reduce the redundant code,use virNumaSetupMemoryPolicy
> to replace virLXCControllerSetupNUMAPolicy and
> qemuProcessInitNumaMemoryPolicy.
>
> This patch also moves the numa related codes to the
> file virnuma.c and virnuma.h
>
> Signed-off-by: Ga
On 2013年03月18日 17:04, Gao feng wrote:
> Allow lxc using the advisory nodeset from querying numad,
> this means if user doesn't specify the numa nodes that
> the lxc domain should assign to, libvirt will automatically
> bind the lxc domain to the advisory nodeset which queried from
> numad.
>
> Sig
On 2013年03月18日 17:04, Gao feng wrote:
qemuGetNumadAdvice will be used by LXC driver,rename
it to virNumaGetAutoPlacementAdvice and move it to virnuma.c
Signed-off-by: Gao feng
---
po/POTFILES.in | 1 +
src/Makefile.am | 1 +
src/libvirt_private.syms | 3 +++
src/qemu/q
qemuGetNumadAdvice will be used by LXC driver,rename
it to virNumaGetAutoPlacementAdvice and move it to virnuma.c
Signed-off-by: Gao feng
---
po/POTFILES.in | 1 +
src/Makefile.am | 1 +
src/libvirt_private.syms | 3 +++
src/qemu/qemu_process.c | 34 +++
This patchset intend to add cpuset cgroup support for LXC.
in order to don't create too many redundant codes,
this patchset also rename some functions and structure.
Gao feng (4):
rename qemuGetNumadAdvice to virNumaGetAutoPlacementAdvice
LXC: allow uses advisory nodeset from querying numad
Intend to reduce the redundant code,use virNumaSetupMemoryPolicy
to replace virLXCControllerSetupNUMAPolicy and
qemuProcessInitNumaMemoryPolicy.
This patch also moves the numa related codes to the
file virnuma.c and virnuma.h
Signed-off-by: Gao feng
---
include/libvirt/libvirt.h.in | 15 --
virBitmapNextLastSetBit: Search for the last set bit before
certain position.
virBitmapNextLastSetBit: Search for the last clear bit before
certain position.
---
src/libvirt_private.syms | 2 +
src/util/virbitmap.c | 96
src/util/virbitmap.h
This patch adds cpuset cgroup support for LXC.
Signed-off-by: Gao feng
---
src/lxc/lxc_cgroup.c | 54 +++-
src/lxc/lxc_cgroup.h | 2 +-
src/lxc/lxc_controller.c | 2 +-
3 files changed, 55 insertions(+), 3 deletions(-)
diff --git PATCH v3src
With 'optional' startupPolicy set, when one or more disk are missing,
the qemu process drops their definitions and bootups the vm.
When the vm is using per-device boot elements, then we need to
reorder them in order to perform migrate successfully if necessary.
During the reordering, it uses virBi
Allow lxc using the advisory nodeset from querying numad,
this means if user doesn't specify the numa nodes that
the lxc domain should assign to, libvirt will automatically
bind the lxc domain to the advisory nodeset which queried from
numad.
Signed-off-by: Gao feng
---
src/lxc/lxc_controller.c
This patch makes preparations for disk droping if they are not accessable
when using startupPolicy "optional". That is to say, the patch aims to
perform the disk presense checking before making disk chain.
---
src/qemu/qemu_process.c | 7 ---
1 file changed, 4 insertions(+), 3 deletions(-)
di
VIR_DOMAIN_EVENT_DISK_CHANGE_MISSING_ON_START
---
include/libvirt/libvirt.h.in | 1 +
src/qemu/qemu_domain.c | 18 +-
2 files changed, 14 insertions(+), 5 deletions(-)
diff --git a/include/libvirt/libvirt.h.in b/include/libvirt/libvirt.h.in
index f6a7aff..72df5a2 100644
---
Add startupPolicy attribute policy for harddisk with type "file",
"block" and "dir". The "network" type disk is still not supported.
---
docs/formatdomain.html.in | 9 ++---
src/conf/domain_conf.c| 19 +--
2 files changed, 19 insertions(+), 9 deletions(-)
diff --git a/doc
The set of patches is trying to add 'startupPolicy' attribute support
to the source element of hard disks. Policy levels are using the
mandatory, requisite, optional levels as originally documented.
For the 'optional' policy, there is a little difference from CDROM and
Floppy which only drop its
On 2013/03/18 11:19, Osier Yang wrote:
> On 2013年03月18日 10:27, Gao feng wrote:
>> On 2013/03/15 17:24, Osier Yang wrote:
>>> On 2013年03月01日 14:52, Gao feng wrote:
This patch adds cpuset cgroup support for LXC.
also set cpuset cgroup before setting cpu
affinity and numa policy.
>>>
>>
Signed-off-by: Alex Jia
---
libvirt-sandbox/libvirt-sandbox-init-qemu.c |4
1 files changed, 4 insertions(+), 0 deletions(-)
diff --git a/libvirt-sandbox/libvirt-sandbox-init-qemu.c
b/libvirt-sandbox/libvirt-sandbox-init-qemu.c
index 38ed284..dfa1374 100644
--- a/libvirt-sandbox/libvi
65 matches
Mail list logo