[PATCH 0/6] input: cyapa: integrated with gen5 trackpad supported in one driver.

2014-04-14 Thread Dudley Du
This patch set is made based on kernel 3.14.0. It's aimed to re-architecture the cyapa driver to support the old gen3 trackpad device and new gen5 trackpad device in one cyapa driver for easily products support based on customers' requirements, and add sysfs functions and interfaces supported that

[PATCH 4/6] input: cyapa: enable/disable trackpad device based on LID state

2014-04-14 Thread Dudley Du
Rely on EV_SW and SW_LID bits to identify a LID device, and hook up our filter to listen for SW_LID events to enable/disable touchpad when LID is open/closed. TEST=test on Chomebooks. Signed-off-by: Du, Dudley d...@cypress.com --- diff --git a/drivers/input/mouse/cyapa.c

Re: [PATCH v4 7/9] ARM: sun7i/sun4i: dt: Add AXP209 support to various boards

2014-04-14 Thread Maxime Ripard
Hi Carlo, On Fri, Apr 11, 2014 at 11:38:11AM +0200, Carlo Caione wrote: Signed-off-by: Hans de Goede hdego...@redhat.com Signed-off-by: Carlo Caione ca...@caione.org --- In all the DTs the min and max microvolt allowed for each regulator are actually the min and max voltage possible for

Re: HID vendor access from user space

2014-04-14 Thread Nestor Lopez Casado
David, Jiri, After considering our discussion here, which is your position on extending the hidraw nodes to include separate nodes for top level vendor collections ? Cheers, -nestor On Tue, Apr 8, 2014 at 5:53 PM, Nestor Lopez Casado nlopezca...@logitech.com wrote: On Mon, Apr 7, 2014 at 6:27

Re: [linux-sunxi] Re: [PATCH v4 7/9] ARM: sun7i/sun4i: dt: Add AXP209 support to various boards

2014-04-14 Thread Carlo Caione
On Mon, Apr 14, 2014 at 11:52 AM, Maxime Ripard maxime.rip...@free-electrons.com wrote: Hi Carlo, Hi Maxime, On Fri, Apr 11, 2014 at 11:38:11AM +0200, Carlo Caione wrote: Signed-off-by: Hans de Goede hdego...@redhat.com Signed-off-by: Carlo Caione ca...@caione.org --- In all the DTs the

[PATCH v3 1/2] input/serio: Add a firmware_id sysfs attribute

2014-04-14 Thread Hans de Goede
serio devices exposed via platform firmware interfaces such as ACPI may provide additional identifying information of use to userspace. We don't associate the serio devices with the firmware device (we don't set it as parent), so there's no way for userspace to make use of this information. We

[PATCH v3 2/2] input/serio/8042: Add firmware_id support

2014-04-14 Thread Hans de Goede
Fill in the new serio firmware_id sysfs attribute for pnp instantiated 8042 serio ports. Signed-off-by: Hans de Goede hdego...@redhat.com Acked-by: Peter Hutterer peter.hutte...@who-t.net --- drivers/input/serio/i8042-x86ia64io.h | 15 +++ drivers/input/serio/i8042.c | 6

[PATCH v2 1/2] uapi/input.h: Add INPUT_PROP_TOPBUTTONPAD device property

2014-04-14 Thread Hans de Goede
On some newer laptops with a trackpoint the physical buttons for the trackpoint have been removed to allow for a larger touchpad. On these laptops the buttonpad has clearly marked areas on the top which are to be used as trackpad buttons. Users of the event device-node need to know about this, so

[PATCH v2 0/2] Add INPUT_PROP_TOPBUTTONPAD device property

2014-04-14 Thread Hans de Goede
Hi All, Here is v2 of my INPUT_PROP_TOPBUTTONPAD patch-set. Changes in v2: -Drop adding of pnp_id to struct serio (drop patches 2/4 and 3/4 of v1) -Modify the synaptics patch to use firmware_id instead of pnp_id Regards, Hans -- To unsubscribe from this list: send the line unsubscribe

[PATCH v2 2/2] synaptics: Report INPUT_PROP_TOPBUTTONPAD property for touchpads with top buttonareas

2014-04-14 Thread Hans de Goede
Signed-off-by: Hans de Goede hdego...@redhat.com --- drivers/input/mouse/synaptics.c | 46 +++-- 1 file changed, 44 insertions(+), 2 deletions(-) diff --git a/drivers/input/mouse/synaptics.c b/drivers/input/mouse/synaptics.c index d8d49d1..b9d2259 100644 ---

[PATCH] synaptics: Add min/max quirk for ThinkPad T431s, L440, S1 Yoga and X1

2014-04-14 Thread Hans de Goede
We expect that all the Haswell series will need such quirks, sigh. The T431s seems to be T430 hardware in a T440s case, using the T440s touchpad, with the same min/max issue. The X1 Carbon 3rd generation name says 2nd while it is a 3rd generation. The X1 and T431s share a PnPID with the T540p,

[PATCH v3 0/2] input/serio: Add a firmware_id sysfs attribute

2014-04-14 Thread Hans de Goede
Hi All, Here is v3 of my serio firmware_id sysfs attribute patch-set Changes in v2: -Add a helper function to avoid copy/pasting the code for building the firmware_id string from pnp_ids Changes in v3: -Prefix the firmware_id string for 8042-pnp devices which PNP: so that it will be easy to

Re: [linux-sunxi] Re: [PATCH v4 7/9] ARM: sun7i/sun4i: dt: Add AXP209 support to various boards

2014-04-14 Thread Hans de Goede
Hi, On 04/14/2014 12:02 PM, Carlo Caione wrote: On Mon, Apr 14, 2014 at 11:52 AM, Maxime Ripard maxime.rip...@free-electrons.com wrote: Hi Carlo, Hi Maxime, On Fri, Apr 11, 2014 at 11:38:11AM +0200, Carlo Caione wrote: Signed-off-by: Hans de Goede hdego...@redhat.com Signed-off-by:

Re: [linux-sunxi] Re: [PATCH v4 7/9] ARM: sun7i/sun4i: dt: Add AXP209 support to various boards

2014-04-14 Thread Mark Brown
On Mon, Apr 14, 2014 at 12:20:32PM +0200, Hans de Goede wrote: Please fix your mailer to word wrap at less than 80 columns. As Mark has also mentioned we should probably pin the regulators to a certain voltage, except for those which we expect to be controlled by a driver, so basically all of

Re: [PATCH] HID: add missing hid usages

2014-04-14 Thread Olivier Gay
On Mon, Apr 7, 2014 at 9:49 AM, Jiri Kosina jkos...@suse.cz wrote: [ adding Dmitry to CC ] On Fri, 4 Apr 2014, Olivier Gay wrote: with this patch we add some missing hid usages to the hid system. Those missing hid usages are already used by some Logitech products as well as some future

[PATCH v5 2/7] HID: sony: Use a struct for the Sixaxis output report.

2014-04-14 Thread Frank Praznik
Use a struct for the Sixaxis output report that uses named members to set the report fields. Signed-off-by: Frank Praznik frank.praz...@oh.rr.com --- drivers/hid/hid-sony.c | 66 +- 1 file changed, 49 insertions(+), 17 deletions(-) diff --git

[PATCH v5 3/7] HID: sony: Convert startup and shutdown functions to use a uniform parameter type

2014-04-14 Thread Frank Praznik
Convert all of the local initialization and shutdown functions to take a parameter type of struct sony_sc* instead of using a mix of struct sony_sc* and struct hid_device*. Allows for the removal of some calls to hid_get_drvdata(). Signed-off-by: Frank Praznik frank.praz...@oh.rr.com ---

[PATCH v5 4/7] HID: sony: Use the controller Bluetooth MAC address as the unique value in the battery name string

2014-04-14 Thread Frank Praznik
Use the controller Bluetooth MAC address as the unique identifier in the battery name string instead of the atomic integer that was used before. Signed-off-by: Frank Praznik frank.praz...@oh.rr.com --- drivers/hid/hid-sony.c | 8 ++-- 1 file changed, 2 insertions(+), 6 deletions(-) diff

[PATCH v5 7/7] HID: hid-sony - allow 3rd party INTEC controller to turn off all leds

2014-04-14 Thread Frank Praznik
From: Simon Wood si...@mungewell.org Without this patch the 3rd party INTEC (PS3) controller will blink all leds when user turns them off, it appears to require an extra flag set. Signed-off-by: Simon Wood si...@mungewell.org Signed-off-by: Frank Praznik frank.praz...@oh.rr.com ---

[PATCH v5 6/7] HID: sony: Add blink support to the Sixaxis and DualShock 4 LEDs

2014-04-14 Thread Frank Praznik
Add support for setting the blink rate of the LEDs. The Sixaxis allows control over each individual LED, but the Dualshock 4 only has one global control for controlling the hardware blink rate so individual colors will fall back to software timers. Setting the brightness cancels the blinking as

[PATCH v5 5/7] HID: sony: Initialize the controller LEDs with a device ID value

2014-04-14 Thread Frank Praznik
Add an IDA id allocator to assign unique, sequential device ids to Sixaxis and DualShock 4 controllers. Use the device ID to initialize the Sixaxis and DualShock 4 controller LEDs to default values. The number or color of the controller is set relative to other connected Sony controllers. Set

[PATCH v5 0/7] HID: sony: More Sony controller fixes and improvements.

2014-04-14 Thread Frank Praznik
v5 has the following changes: -Addresses some usability issues with the hardware blink support in the LED code. The Sixaxis has some odd behavior where, on USB, the controller overrides user LED settings and blinks the whole light bar until the PS button is pushed. The new patch doesn't

[PATCH v2] synaptics: Add min/max quirk for ThinkPad T431s, L440, S1 Yoga and X1

2014-04-14 Thread Hans de Goede
Hi All, This v2 is an unchanges resend of v1 with Cc: stable added, as I should have done for v1 already. Regards, Hans -- To unsubscribe from this list: send the line unsubscribe linux-input in the body of a message to majord...@vger.kernel.org More majordomo info at

[PATCH v5 1/7] HID: sony: Use inliners for work queue initialization and cancellation

2014-04-14 Thread Frank Praznik
Use inliners to make sure that the work queue initialization flag is always checked and set correctly when initializing or cancelling the work queue. Signed-off-by: Frank Praznik frank.praz...@oh.rr.com --- drivers/hid/hid-sony.c | 29 +++-- 1 file changed, 19

Re: [patch]GPIO button is supposed to wake the system up if the wakeup attribute is set

2014-04-14 Thread Li, Aubrey
ping... On 2014/4/10 18:48, One Thousand Gnomes wrote: On Thu, 10 Apr 2014 10:11:09 +0800 Li, Aubrey aubrey...@linux.intel.com wrote: When the wakeup attribute is set, GPIO button is supposed to set irqflag - IRQF_NO_SUSPEND to request irq. So when the system enters the suspend sleep mode,

[PATCH 4/4] HID: (thingm) add support for blink(1) mk2

2014-04-14 Thread Vivien Didelot
The blink(1) mk2 is a new version of the blink(1) USB RGB LED. The new generation has 2 individually-controllable RGB chips. This patch adds support for this device to the thingm driver, which registers 3 new standard LED class instances for the second RGB chip. Note that the 'n' (set) command

[PATCH 3/4] HID: (thingm) refactor blink(1) support

2014-04-14 Thread Vivien Didelot
This patch refactors the way the thingm driver registers a blink(1) LED. In order to make the driver simpler and more standard, drop the rgb sysfs attribute and create one instance of LED class per RGB channel. Actually, the name of the LED class instance registered for a blink(1) device is

[PATCH 0/4] HID: (thingm) introduces blink(1) mk2

2014-04-14 Thread Vivien Didelot
This patchset introduces the support of the blink(1) mk2 device, after a refactoring of the thingm driver. It removes non-standard sysfs attributes and uses work queues to fix the usage of triggers with this device. Vivien Didelot (4): HID: (thingm) remove the play sysfs attribute HID:

[PATCH 2/4] HID: (thingm) remove the fade sysfs attribute

2014-04-14 Thread Vivien Didelot
As for the play sysfs attribute, remove this other non-standard attribute, so the driver only implements what is required to switch the LED on and off. Thus, a fade time won't be ideal for some fast-changing triggers. Signed-off-by: Vivien Didelot vivien.dide...@savoirfairelinux.com ---

[PATCH 1/4] HID: (thingm) remove the play sysfs attribute

2014-04-14 Thread Vivien Didelot
When the thingm driver registers an instance of LED class, it creates a play sysfs attribute for this blink(1) specific feature. Since this feature is not specific to the RGB chip but to the HID device itself, let's remove this attribute from the LED instance and only implement what is useful to

Re: HID vendor access from user space

2014-04-14 Thread David Herrmann
Hi On Mon, Apr 14, 2014 at 12:00 PM, Nestor Lopez Casado nlopezca...@logitech.com wrote: David, Jiri, After considering our discussion here, which is your position on extending the hidraw nodes to include separate nodes for top level vendor collections ? Patches, patches, patches! I am