Re: Bug in i2c-core?

2015-03-04 Thread Wolfram Sang
> > > I am writing an I2C touchscreen driver for an i.MX6 based board. I > > > compiled it as a module and when I unload it, I get the following warning: > > > > > > # modprobe sx8654 > > > [ 46.261494] input: SX8654 I2C Touchscreen as > > > /devices/soc0/soc/210.aips-bus/21a.i2c/i2c-0/

[PATCH 0/2] Add device tree support for Goodix GT9xx series touchscreen controller

2015-03-04 Thread Aleksei Mamlin
This patch set adds device tree support and binding information for Goodix GT9xx series touchscreen controller. It also adds support for 5-finger chips, like GT911 and GT912, which can be found on ARM tablets, like Wexler TAB7200 and MSI Primo73. Aleksei Mamlin (2): input: goodix: Add device tre

[PATCH 1/2] input: goodix: Add device tree support

2015-03-04 Thread Aleksei Mamlin
This patch adds device tree support for Goodix GT9xx series touchscreen controller. Signed-off-by: Aleksei Mamlin Acked-by: Hans de Goede --- .../bindings/input/touchscreen/goodix.txt | 27 ++ .../devicetree/bindings/vendor-prefixes.txt| 1 + drivers/input/

[PATCH 2/2] input: goodix: Add device tree support for 5-finger chips

2015-03-04 Thread Aleksei Mamlin
This patch adds device tree support for 5-finger chips, like GT911 and GT912. Signed-off-by: Aleksei Mamlin Acked-by: Hans de Goede --- .../bindings/input/touchscreen/goodix.txt | 4 ++- drivers/input/touchscreen/goodix.c | 40 +- 2 files changed, 3

Re: [PATCH 2/2] input: goodix: Add device tree support for 5-finger chips

2015-03-04 Thread Bastien Nocera
On Wed, 2015-03-04 at 11:34 +0300, Aleksei Mamlin wrote: > This patch adds device tree support for 5-finger chips, like GT911 > and GT912. You should add the same support to the ACPI matching. > #ifdef CONFIG_OF > static struct of_device_id goodix_of_match[] = { > - { .compatible = "goo

Re: [PATCH 1/2] input: goodix: Add device tree support

2015-03-04 Thread Bastien Nocera
On Wed, 2015-03-04 at 11:33 +0300, Aleksei Mamlin wrote: > This patch adds device tree support for Goodix GT9xx series > touchscreen controller. > diff --git a/drivers/input/touchscreen/Kconfig > b/drivers/input/touchscreen/Kconfig > index 5891752..7a6ab8c 100644 > --- a/drivers/input/touchscre

Re: [PATCH 2/2] input: goodix: Add device tree support for 5-finger chips

2015-03-04 Thread Antonio Ospite
On Wed, 4 Mar 2015 11:34:13 +0300 Aleksei Mamlin wrote: > This patch adds device tree support for 5-finger chips, like GT911 and GT912. > Hi Aleksei, from a datasheet I found[1](Pag. 11) I see that some devices provide the information about the max number of touch points in register 0x804C. H

Re: [PATCH 2/2] input: goodix: Add device tree support for 5-finger chips

2015-03-04 Thread Aleksei Mamlin
On Wed, 4 Mar 2015 11:30:40 +0100 Antonio Ospite wrote: > On Wed, 4 Mar 2015 11:34:13 +0300 > Aleksei Mamlin wrote: > > > This patch adds device tree support for 5-finger chips, like GT911 and > > GT912. > > > > Hi Aleksei, > > from a datasheet I found[1](Pag. 11) I see that some devices pr

[PATCH v2] input: driver for microcontroller keys on the iPaq h3xxx

2015-03-04 Thread Linus Walleij
This adds a key input driver for the keys found on the h3xxx iPAQ series. Based on a driver from handhelds.org 2.6.21 kernel, written by Alessandro GARDICH. Signed-off-by: Alessandro GARDICH Signed-off-by: Dmitry Artamonow Signed-off-by: Linus Walleij --- ChangeLog v1->v2: - Improve KConfig he

Re: [PATCH v2 2/4] gpio: add parameter to allow the use named gpios

2015-03-04 Thread Linus Walleij
On Wed, Jan 21, 2015 at 10:33 PM, Olliver Schinagl wrote: > From: Olliver Schinagl > > The gpio binding document says that new code should always use named > gpios. Patch 40b73183 added support to parse a list of gpios from child > nodes, but does not make it possible to use named gpios. This pa

Re: [PATCH v3 2/6] HID: uclogic: merge hid-huion driver in hid-uclogic

2015-03-04 Thread Jiri Kosina
On Tue, 3 Mar 2015, Benjamin Tissoires wrote: > From: Nikolai Kondrashov > > Merge the hid-huion driver into hid-uclogic as all the devices supported > by hid-huion are in fact UC-Logic devices. > > Signed-off-by: Nikolai Kondrashov > Signed-off-by: Benjamin Tissoires > --- > > no changes in

Re: [PATCH] HID: wacom: ask for a in-prox report when it was missed

2015-03-04 Thread Benjamin Tissoires
On Mar 03 2015 or thereabouts, Jason Gerecke wrote: > On 3/3/2015 9:20 AM, Benjamin Tissoires wrote: > >If noone listens to the input device when a tool comes in proximity, > >the tablet does not send the in-prox event when a client becomes available. > >That means that no events will be sent until

Re: [PATCH v3 2/6] HID: uclogic: merge hid-huion driver in hid-uclogic

2015-03-04 Thread Benjamin Tissoires
On Mar 04 2015 or thereabouts, Jiri Kosina wrote: > On Tue, 3 Mar 2015, Benjamin Tissoires wrote: > > > From: Nikolai Kondrashov > > > > Merge the hid-huion driver into hid-uclogic as all the devices supported > > by hid-huion are in fact UC-Logic devices. > > > > Signed-off-by: Nikolai Kondras

[PATCH] HID: Kconfig: add USB_HID dependency to UC-LOGIC

2015-03-04 Thread Benjamin Tissoires
In commit 08177f4 (HID: uclogic: merge hid-huion driver in hid-uclogic) HID_HUION depends explicitely on USB_HID because it contained quite some USB-isms. Now that hid-uclogic is the new home of Huion tablets, we need to also add the dependency on USB_HID to this driver. Reported-by: Jiri Kosina

Re: [PATCH] HID: Kconfig: add USB_HID dependency to UC-LOGIC

2015-03-04 Thread Nikolai Kondrashov
On 03/04/2015 06:24 PM, Benjamin Tissoires wrote: In commit 08177f4 (HID: uclogic: merge hid-huion driver in hid-uclogic) HID_HUION depends explicitely on USB_HID because it contained quite some USB-isms. Now that hid-uclogic is the new home of Huion tablets, we need to also add the dependency o

Re: [PATCH] HID: Kconfig: add USB_HID dependency to UC-LOGIC

2015-03-04 Thread Jiri Kosina
On Wed, 4 Mar 2015, Benjamin Tissoires wrote: > In commit 08177f4 (HID: uclogic: merge hid-huion driver in hid-uclogic) > HID_HUION depends explicitely on USB_HID because it contained quite some > USB-isms. > > Now that hid-uclogic is the new home of Huion tablets, we need to also > add the depen

Re: [PATCH 1/2] input: goodix: Add device tree support

2015-03-04 Thread Antonio Ospite
On Wed, 04 Mar 2015 10:21:26 +0100 Bastien Nocera wrote: > On Wed, 2015-03-04 at 11:33 +0300, Aleksei Mamlin wrote: > > This patch adds device tree support for Goodix GT9xx series > > touchscreen controller. > > > > diff --git a/drivers/input/touchscreen/Kconfig > > b/drivers/input/touchscree

Re: [PATCH 2/2] input: goodix: Add device tree support for 5-finger chips

2015-03-04 Thread Aleksei Mamlin
On Wed, 04 Mar 2015 10:19:08 +0100 Bastien Nocera wrote: > On Wed, 2015-03-04 at 11:34 +0300, Aleksei Mamlin wrote: > > This patch adds device tree support for 5-finger chips, like GT911 > > and GT912. > > You should add the same support to the ACPI matching. Hi Bastien, I never seen ACPI ids

[PATCH] Add short KEY_DIRECTION description

2015-03-04 Thread Stefan Brüns
Signed-off-by: Stefan Brüns --- Requested 5 years ago: https://lkml.org/lkml/2010/2/27/36 See also http://comments.gmane.org/gmane.linux.kernel.input/11175 include/uapi/linux/input.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/include/uapi/linux/input.h b/include/uapi/lin

Re: [PATCH] Add short KEY_DIRECTION description

2015-03-04 Thread Bastien Nocera
I need the same key in my Thinkpad patch. But could you use a more descriptive name, such as KEY_ROTATE_DISPLAY? > On 4 Mar 2015, at 22:42, Stefan Brüns wrote: > > Signed-off-by: Stefan Brüns > --- > Requested 5 years ago: https://lkml.org/lkml/2010/2/27/36 > See also http://comments.gmane.o

[PATCH] HID: map telephony usage page

2015-03-04 Thread Dmitry Torokhov
Currently HID code maps usages from telephony page into BTN_0, BTN_1, etc keys which get interpreted by mousedev and userspace as left/right/middle button clicks, which is not really helpful. This change adds mappings for usages that have corresponding input event definitions, and leaves the rest

Re: [PATCH] HID: map telephony usage page

2015-03-04 Thread Jiri Kosina
On Wed, 4 Mar 2015, Dmitry Torokhov wrote: > Currently HID code maps usages from telephony page into BTN_0, BTN_1, etc > keys which get interpreted by mousedev and userspace as left/right/middle > button clicks, which is not really helpful. > > This change adds mappings for usages that have corre

Re: [PATCH v7 4/5] Input: add haptic drvier on max77843

2015-03-04 Thread Dmitry Torokhov
On Tue, Mar 03, 2015 at 10:35:33AM +0900, Jaewon Kim wrote: > Hi Dmitry, > > On 03/03/2015 02:32, Dmitry Torokhov wrote: > >On Mon, Mar 02, 2015 at 07:10:37PM +0900, Jaewon Kim wrote: > >>This patch adds support for haptic driver on max77843 > >>MFD(Multi Function Device) with PMIC, MUIC, LED, CHA

Re: [PATCH v2] input: driver for microcontroller keys on the iPaq h3xxx

2015-03-04 Thread Dmitry Torokhov
On Wed, Mar 04, 2015 at 01:45:27PM +0100, Linus Walleij wrote: > This adds a key input driver for the keys found on the h3xxx > iPAQ series. > > Based on a driver from handhelds.org 2.6.21 kernel, written > by Alessandro GARDICH. > > Signed-off-by: Alessandro GARDICH > Signed-off-by: Dmitry Arta

Re: [PATCH] keyboard/tc3589x-keypad.c: set IRQF_ONESHOT flag to ensure IRQ request

2015-03-04 Thread Dmitry Torokhov
On Mon, Mar 02, 2015 at 04:21:06PM +0100, Valentin Rothberg wrote: > Since commit 1c6c69525b40eb76de8adf039409722015927dc3 ("genirq: Reject > bogus threaded irq requests") threaded IRQs without a primary handler > need to be requested with IRQF_ONESHOT, otherwise the request will fail. > > Current

[PATCH v2 1/2] Add alias KEY_ROTATE_DISPLAY for KEY_DIRECTION, add description

2015-03-04 Thread Stefan Brüns
Signed-off-by: Stefan Brüns --- include/uapi/linux/input.h | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/include/uapi/linux/input.h b/include/uapi/linux/input.h index a1d7e93..47b0138 100644 --- a/include/uapi/linux/input.h +++ b/include/uapi/linux/input.h @@ -368,7 +368,8

[PATCH 2/2] use more descriptive KEY_ROTATE_DISPLAY instead of KEY_DIRECTION

2015-03-04 Thread Stefan Brüns
Signed-off-by: Stefan Brüns --- drivers/hid/hid-debug.c | 2 +- drivers/platform/x86/fujitsu-tablet.c | 6 +++--- drivers/platform/x86/hp-wmi.c | 2 +- 3 files changed, 5 insertions(+), 5 deletions(-) diff --git a/drivers/hid/hid-debug.c b/drivers/hid/hid-debug.c index 8bf6

[PATCH 0/2] Replace KEY_DIRECTION with KEY_ROTATE_DISPLAY

2015-03-04 Thread Stefan Brüns
The description was requested 5 years ago: https://lkml.org/lkml/2010/2/27/36 See also http://comments.gmane.org/gmane.linux.kernel.input/11175 Stefan Brüns (2): Add alias KEY_ROTATE_DISPLAY for KEY_DIRECTION, add description use more descriptive KEY_ROTATE_DISPLAY instead of KEY_DIRECTION d

Re: [PATCH 2/2] HID: wacom: rely on actual touch down count to decide touch_down

2015-03-04 Thread Jason Gerecke
On 2/20/2015 2:27 PM, Ping Cheng wrote: touch_down is a flag to indicate if there are touches on tablet or not. Since one set of touch events may be posted over more than one data packet/touch frame, and pen may come in proximity while touch events are partially sent, counting all touch events fo

Re: [PATCH 1/2] HID: wacom: do not send pen events before touch is up/forced out

2015-03-04 Thread Jason Gerecke
On 2/20/2015 2:25 PM, Ping Cheng wrote: If pen comes in proximity while touch is down, we force touch up before sending pen events. Otherwise, there can be unfinished touch events compete with pen events. This idea has been fully implemented for Tablet PCs. But other tablets that support both pen

Re: [PATCH v7 1/8] ARM: dt: Binding documentation for imx25 ADC/TSC

2015-03-04 Thread Markus Pargmann
Hi, On Tue, Mar 03, 2015 at 10:02:12AM +0100, Arnd Bergmann wrote: > On Tuesday 03 March 2015 08:58:11 Markus Pargmann wrote: > > +Example: > > + tscadc: tscadc@5003 { > > + compatible = "fsl,imx25-tsadc"; > > + reg = <0x5003 0xc>; > > + inte