[PATCH 4/7] perf tools: Move init_have_children field to struct hist_entry_tui

2015-04-18 Thread Namhyung Kim
The init_have_children is used to init callchain info only for TUI. So it'd be better to move it to the hist_entry_tui struct. Signed-off-by: Namhyung Kim namhy...@kernel.org --- tools/perf/ui/browsers/hists.c | 4 ++-- tools/perf/util/sort.h | 2 +- 2 files changed, 3 insertions(+), 3

[PATCH 7/7] perf hists browser: Simplify zooming code a bit

2015-04-18 Thread Namhyung Kim
Introduce pstack_peek() and reuse do_zoom_dso/thread() function. Signed-off-by: Namhyung Kim namhy...@kernel.org --- tools/perf/ui/browsers/hists.c | 16 +--- tools/perf/util/pstack.c | 7 +++ tools/perf/util/pstack.h | 1 + 3 files changed, 13 insertions(+), 11

Re: sparc64: Build failure due to commit f1600e549b94 (sparc: Make sparc64 use scalable lib/iommu-common.c functions)

2015-04-18 Thread Guenter Roeck
On 04/18/2015 02:41 PM, David Miller wrote: From: Sowmini Varadhan sowmini.varad...@oracle.com Date: Sat, 18 Apr 2015 15:55:14 -0400 Sowmini, I think I sorted this out in the 'sparc' GIT tree. Can you take a look? The patches look right now. These are the commit-ids I checked

Re: sparc64: Build failure due to commit f1600e549b94 (sparc: Make sparc64 use scalable lib/iommu-common.c functions)

2015-04-18 Thread Guenter Roeck
On 04/18/2015 09:13 PM, Guenter Roeck wrote: On 04/18/2015 02:41 PM, David Miller wrote: From: Sowmini Varadhan sowmini.varad...@oracle.com Date: Sat, 18 Apr 2015 15:55:14 -0400 Sowmini, I think I sorted this out in the 'sparc' GIT tree. Can you take a look? The patches look right now.

Re: [Adi-buildroot-devel] [Consult] blackfin: About one building break issue for STACKTRACE

2015-04-18 Thread Chen Gang
On 4/18/15 06:20, Chen Gang wrote: On 4/17/15 22:02, Chen Gang wrote: On 4/17/15 11:02, Zhang, Sonic wrote: Hi Gang, Please only use the GCC for Blackfin 2013R1 or 2014R1 from https://sourceforge.net/projects/adi-buildroot/files/ . Upstream GCC5 isn't ported to Blackfin properly. For

[PATCH] ocfs2: use retval instead of status for checking error

2015-04-18 Thread Daeseok Youn
The use of 'status' in __ocfs2_add_entry() can return wrong value. Some functions' return value in __ocfs2_add_entry(), i.e ocfs2_journal_access_di() is saved to 'status'. But 'status' is not used in 'bail' label for returning result of __ocfs2_add_entry(). So use retval instead of status.

Re: [PATCH v3 00/17] crypto: talitos - Add support for SEC1

2015-04-18 Thread Herbert Xu
On Fri, Apr 17, 2015 at 04:31:47PM +0200, Christophe Leroy wrote: The purpose of this set of patchs is to add to talitos crypto driver the support for the SEC1 version of the security engine, which is found in mpc885 and mpc8272 processors. v3 is a complete rework of the patchset. Since a

Re: [RFC PATCH 1/2] tee: generic TEE subsystem

2015-04-18 Thread Paul Bolle
On Fri, 2015-04-17 at 22:07 +0200, Arnd Bergmann wrote: On Friday 17 April 2015 09:50:56 Jens Wiklander wrote: +static const struct file_operations tee_fops = { + .owner = THIS_MODULE, + .open = tee_open, + .release = tee_release, + .unlocked_ioctl = tee_ioctl +}; Add a

[git pull] devicetree updates for v4.1

2015-04-18 Thread Grant Likely
Hi Linus, Here are the devicetree changes queued up for v4.1. Nothing really exciting here. Rob has another few commits for big-endian attached UARTs, but those will be sent in a separate merge request since they haven't been as thoroughly tested as this batch. Please merge Thanks, g. The

Re: [RESEND PATCH V2 1/2] input: misc: da9063: OnKey driver

2015-04-18 Thread Paul Bolle
There's still a license mismatch left (it probably got lost in the noise when I finally noticed that the header comment mentioned the LGPL in V1). On Fri, 2015-04-17 at 13:03 +0100, S Twiss wrote: --- /dev/null +++ b/drivers/input/misc/da9063-onkey.c + * This program is free software; you can

Re: [PATCH 06/21] nd: ndctl class device, and nd bus attributes

2015-04-18 Thread Greg KH
On Fri, Apr 17, 2015 at 09:35:46PM -0400, Dan Williams wrote: This is the position (device topology) independent method to find all the NFIT-defined buses in the system. The expectation is that there will only ever be one nd bus discovered via /sys/class/nd/ndctl0. However, we allow for the

Re: [PATCH 07/21] nd: dimm devices (nfit memory-devices)

2015-04-18 Thread Greg KH
On Fri, Apr 17, 2015 at 09:35:52PM -0400, Dan Williams wrote: Register the dimms described in the nfit as devices on a nd_bus, named dimmN where N is a global ida index. The dimm numbering per-bus may appear contiguous, since we only allow a single nd_bus to be registered at at a time.

Re: [PATCH 14/20] VFS/namei: add 'inode' arg to put_link().

2015-04-18 Thread Al Viro
On Fri, Apr 17, 2015 at 08:09:10PM +0100, Al Viro wrote: On Fri, Apr 17, 2015 at 05:25:36PM +0100, Al Viro wrote: On Mon, Mar 23, 2015 at 01:37:40PM +1100, NeilBrown wrote: @@ -1669,13 +1669,14 @@ static inline int nested_symlink(struct path *path, struct nameidata *nd) do {

Re: [PATCH 12/21] nd_pmem: add NFIT support to the pmem driver

2015-04-18 Thread Christoph Hellwig
On Fri, Apr 17, 2015 at 09:36:18PM -0400, Dan Williams wrote: nd_pmem attaches to persistent memory regions and namespaces emitted by the nd subsystem, and, same as the original pmem driver, presents the system-physical-address range as a block device. I don't think there is any need to move

Re: [PATCH 1/5 v2] blk-mq: Add prep/unprep support

2015-04-18 Thread Matias Bjorling
Den 17-04-2015 kl. 19:46 skrev Christoph Hellwig: On Fri, Apr 17, 2015 at 10:15:46AM +0200, Matias Bj?rling wrote: Just the prep/unprep, or other pieces as well? All of it - it's functionality that lies logically below the block layer, so that's where it should be handled. In fact it should

Re: [PATCH] sound/oss: fix deadlock in sequencer_ioctl(SNDCTL_SEQ_OUTOFBAND)

2015-04-18 Thread Takashi Iwai
At Sat, 18 Apr 2015 02:53:25 +0300, Alexey Khoroshilov wrote: A deadlock can be initiated by userspace via ioctl(SNDCTL_SEQ_OUTOFBAND) on /dev/sequencer with TMR_ECHO midi event. In this case the control flow is: sound_ioctl() - case SND_DEV_SEQ: case SND_DEV_SEQ2:

Re: [PATCH 02/14] MIPS: ath79: Add basic device tree support

2015-04-18 Thread Paul Bolle
On Fri, 2015-04-17 at 16:24 +0200, Alban Bedel wrote: --- a/arch/mips/ath79/Kconfig +++ b/arch/mips/ath79/Kconfig +choice + prompt Builtin devicetree selection + default DTB_ATH79_NONE + help + Select the devicetree. + + config DTB_ATH79_NONE + bool

Re: [PATCH V1 1/6] mfd: da9062: DA9062 MFD core driver

2015-04-18 Thread Paul Bolle
On Fri, 2015-04-17 at 15:23 +0100, S Twiss wrote: --- a/drivers/mfd/Kconfig +++ b/drivers/mfd/Kconfig +config MFD_DA9062 + bool Dialog Semiconductor DA9062 PMIC Support + select MFD_CORE + select REGMAP_I2C + select REGMAP_IRQ + depends on I2C=y + help +

Re: [PATCH V1 2/6] regulator: da9062: DA9062 regulator driver

2015-04-18 Thread Paul Bolle
I spotted only a license mismatch. On Fri, 2015-04-17 at 15:23 +0100, S Twiss wrote: + * This program is free software; you can redistribute it and/or + * modify it under the terms of the GNU General Public License + * as published by the Free Software Foundation; either version 2 + * of the

Re: [RFC PATCH 1/2] tee: generic TEE subsystem

2015-04-18 Thread Greg Kroah-Hartman
On Fri, Apr 17, 2015 at 09:50:56AM +0200, Jens Wiklander wrote: +/** + * struct tee_cmd_data - Opaque command argument + * @buf_ptr: [in] A __user pointer to a command buffer + * @buf_len: [in] Length of the buffer above + * + * Opaque command data which is passed on to the specific driver.

Re: [RFC PATCH 1/2] tee: generic TEE subsystem

2015-04-18 Thread Greg Kroah-Hartman
On Fri, Apr 17, 2015 at 09:50:56AM +0200, Jens Wiklander wrote: +struct tee_device { + char name[TEE_MAX_DEV_NAME_LEN]; + const struct tee_desc *desc; + struct device *dev; No, please embed the device in your structure, don't have a pointer to it. + struct miscdevice

Re: [RFC PATCH 2/2] tee: add OP-TEE driver

2015-04-18 Thread Greg Kroah-Hartman
On Fri, Apr 17, 2015 at 09:50:57AM +0200, Jens Wiklander wrote: Adds mostly stubbed OP-TEE driver which also can be compiled as a loadable module. Please provide a real driver, so that we can see how this is all going to work. Otherwise it's not really that useful to create some framework that

Re: [PATCH 3.10 00/34] 3.10.75-stable review

2015-04-18 Thread Greg Kroah-Hartman
On Fri, Apr 17, 2015 at 01:00:10PM -0700, Guenter Roeck wrote: On Fri, Apr 17, 2015 at 03:28:32PM +0200, Greg Kroah-Hartman wrote: This is the start of the stable review cycle for the 3.10.75 release. There are 34 patches in this series, all will be posted as a response to this one. If

Re: [tpmdd-devel] [RFC PATCH 1/2] tee: generic TEE subsystem

2015-04-18 Thread Russell King - ARM Linux
On Fri, Apr 17, 2015 at 10:30:54AM -0600, Jason Gunthorpe wrote: On Fri, Apr 17, 2015 at 09:50:56AM +0200, Jens Wiklander wrote: + teedev = devm_kzalloc(dev, sizeof(*teedev), GFP_KERNEL); [..] + rc = misc_register(teedev-miscdev); [..] +void tee_unregister(struct tee_device *teedev)

Re: [RFC PATCH 1/2] tee: generic TEE subsystem

2015-04-18 Thread Russell King - ARM Linux
On Sat, Apr 18, 2015 at 10:57:12AM +0200, Greg Kroah-Hartman wrote: On Fri, Apr 17, 2015 at 09:50:56AM +0200, Jens Wiklander wrote: +struct tee_device { + char name[TEE_MAX_DEV_NAME_LEN]; + const struct tee_desc *desc; + struct device *dev; No, please embed the device in your

[PATCH] mm/slab_common: Support the slub_debug boot option on specific object size

2015-04-18 Thread Gavin Guo
The slub_debug=PU,kmalloc-xx cannot work because in the create_kmalloc_caches() the s-name is created after the create_kmalloc_cache() is called. The name is NULL in the create_kmalloc_cache() so the kmem_cache_flags() would not set the slub_debug flags to the s-flags. The fix here set up a

[PATCH 1/2] f2fs: support FALLOC_FL_COLLAPSE_RANGE

2015-04-18 Thread Chao Yu
Now, FALLOC_FL_COLLAPSE_RANGE flag in -fallocate is supported in ext4/xfs. In commit, the semantics of this flag is descripted as following: 1) It collapses the range lying between offset and length by removing any data blocks which are present in this range and than updates all the logical

[PATCH 1/3] f2fs: make posix_acl_create() safer and cleaner

2015-04-18 Thread Chao Yu
Our f2fs_acl_create is copied from posix_acl_create in ./fs/posix_acl.c and modified to avoid deadlock bug when inline_dentry feature is enabled. Dan Carpenter rewrites posix_acl_create in commit 2799563b281f (fs/posix_acl.c: make posix_acl_create() safer and cleaner) to make this function more

[PATCH 2/3] f2fs: use is_valid_blkaddr to verify blkaddr for readability

2015-04-18 Thread Chao Yu
Export is_valid_blkaddr() and use it to replace some codes for readability. Signed-off-by: Chao Yu chao2...@samsung.com --- fs/f2fs/checkpoint.c | 3 +-- fs/f2fs/f2fs.h | 1 + fs/f2fs/recovery.c | 6 +++--- 3 files changed, 5 insertions(+), 5 deletions(-) diff --git

[PATCH 3/3] f2fs: make has_fsynced_inode static

2015-04-18 Thread Chao Yu
has_fsynced_inode() has no other caller out of node.c, make it static. Signed-off-by: Chao Yu chao2...@samsung.com --- fs/f2fs/f2fs.h | 1 - fs/f2fs/node.c | 2 +- 2 files changed, 1 insertion(+), 2 deletions(-) diff --git a/fs/f2fs/f2fs.h b/fs/f2fs/f2fs.h index 5cf7e9f..9fd730a 100644 ---

Re: Error: DMA: Out of SW-IOMMU space [was: External USB drives become unresponsive after few hours.]

2015-04-18 Thread Dorian Gray
On 17 April 2015 at 22:06, Konrad Rzeszutek Wilk konrad.w...@oracle.com wrote: On Fri, Apr 17, 2015 at 05:14:20PM +0200, Dorian Gray wrote: On 16 April 2015 at 20:42, Konrad Rzeszutek Wilk konrad.w...@oracle.com wrote: And easier way is to compile the kernel with CONFIG_DMA_API_DEBUG and

[tip:perf/urgent] perf/x86/intel: Add Broadwell support for the LBR callstack

2015-04-18 Thread tip-bot for Kan Liang
Commit-ID: 78d504bcd769cc496f63b626f507039eab2316b7 Gitweb: http://git.kernel.org/tip/78d504bcd769cc496f63b626f507039eab2316b7 Author: Kan Liang kan.li...@intel.com AuthorDate: Thu, 2 Apr 2015 04:12:57 -0400 Committer: Ingo Molnar mi...@kernel.org CommitDate: Fri, 17 Apr 2015 09:59:07

[tip:perf/urgent] perf/x86/intel/rapl: Fix energy counter measurements but supporing per domain energy units

2015-04-18 Thread tip-bot for Jacob Pan
Commit-ID: 645523960102fa0ac0578d070630e49ab05f06d1 Gitweb: http://git.kernel.org/tip/645523960102fa0ac0578d070630e49ab05f06d1 Author: Jacob Pan jacob.jun@linux.intel.com AuthorDate: Thu, 26 Mar 2015 14:28:45 -0700 Committer: Ingo Molnar mi...@kernel.org CommitDate: Fri, 17 Apr 2015

[tip:locking/urgent] smp: Fix smp_call_function_single_async() locking

2015-04-18 Thread tip-bot for Linus Torvalds
Commit-ID: 8053871d0f7f67c7efb7f226ef031f78877d6625 Gitweb: http://git.kernel.org/tip/8053871d0f7f67c7efb7f226ef031f78877d6625 Author: Linus Torvalds torva...@linux-foundation.org AuthorDate: Wed, 11 Feb 2015 12:42:10 -0800 Committer: Ingo Molnar mi...@kernel.org CommitDate: Fri, 17 Apr

[tip:x86/urgent] x86/fpu: Load xsave pointer *after* initialization

2015-04-18 Thread tip-bot for Borislav Petkov
Commit-ID: 18ecb3bfa5a9f6fffbb3eeb4369f0b9463438ec0 Gitweb: http://git.kernel.org/tip/18ecb3bfa5a9f6fffbb3eeb4369f0b9463438ec0 Author: Borislav Petkov b...@suse.de AuthorDate: Thu, 16 Apr 2015 20:41:37 +0200 Committer: Ingo Molnar mi...@kernel.org CommitDate: Fri, 17 Apr 2015 10:15:47

Re: [V4.1] Regression: Bluetooth mouse not working.

2015-04-18 Thread Jörg Otte
What this patch tried to do is to limit it to what userspace is currently actually using. My mistake was to look only at BlueZ 5.x userspace and not at BlueZ 4.x userspace. The fix to not break existing userspace is essentially this: diff --git a/net/bluetooth/hidp/core.c

<    1   2   3   4   5