[tip:x86/mm] x86/mm: Drop WARN from multi-BAR check

2015-12-29 Thread tip-bot for Laura Abbott
Commit-ID: 9abb0ecdee69a2577560cc283368e490da974934 Gitweb: http://git.kernel.org/tip/9abb0ecdee69a2577560cc283368e490da974934 Author: Laura Abbott AuthorDate: Mon, 21 Dec 2015 12:01:14 -0800 Committer: Thomas Gleixner CommitDate: Tue, 29

[PATCH v1 2/3] ARM64 LPC: LPC driver implementation

2015-12-29 Thread Rongrong Zou
We only implement io cycles here, we hook the lpc_io_write_byte and lpc_io_read_byte to inb/outb. So the drivers(ipmi/uart) which access the legacy ISA I/O port need no modification. The low pin count specification is at http://www.intel.com/design/chipsets/industry/lpc.htm Signed-off-by:

Re: [PATCH v2 5/5] x86: ftrace: fix the comments for ftrace_modify_code_direct

2015-12-29 Thread Thomas Gleixner
On Wed, 23 Dec 2015, Steven Rostedt wrote: > On Sun, 6 Dec 2015 10:02:58 +0800 > Li Bin wrote: > > diff --git a/arch/x86/kernel/ftrace.c b/arch/x86/kernel/ftrace.c > > index 311bcf3..db0f6b1 100644 > > --- a/arch/x86/kernel/ftrace.c > > +++ b/arch/x86/kernel/ftrace.c > >

Re: [PATCH] crypto: hifn_795x, picoxcell - use ablkcipher_request_cast

2015-12-29 Thread Herbert Xu
On Mon, Dec 28, 2015 at 09:53:07PM +0800, Geliang Tang wrote: > Use ablkcipher_request_cast() instead of open-coding it. > > Signed-off-by: Geliang Tang Applied. -- Email: Herbert Xu Home Page: http://gondor.apana.org.au/~herbert/ PGP Key:

Re: [PATCH] resources: Remove unneeded initialization of local variable

2015-12-29 Thread Laurent Navet
why not directly ? struct region_devres *dr = devres_alloc(devm_region_release, sizeof(struct region_devres),.. 2015-12-29 14:24 UTC+01:00, Bojan Prtvar : > Few lines below dr is reinitialized by devres_alloc() > so we don't need to init it by NULL in the beginning of >

Re: [PATCH v1 1/3] ARM64 LPC: indirect ISA PORT IO introduced

2015-12-29 Thread Arnd Bergmann
On Tuesday 29 December 2015 21:33:50 Rongrong Zou wrote: > Indirect ISA port I/O accessing introduced, vendors can hook > their own in/out function to general inb/outb. Drivers can access > legacy ISA I/O port by inb/outb as it is done in x86 platform. > > Signed-off-by: Rongrong Zou

[PATCH v2 0/3] bpf: hash: use per-bucket spinlock

2015-12-29 Thread Ming Lei
Hi, This patchset tries to optimize ebpf hash map, and follows the idea: Both htab_map_update_elem() and htab_map_delete_elem() can be called from eBPF program, and they may be in kernel hot path, it isn't efficient to use a per-hashtable lock in this two helpers,

[PATCH v2 2/3] bpf: hash: move select_bucket() out of htab's spinlock

2015-12-29 Thread Ming Lei
The spinlock is just used for protecting the per-bucket hlist, so it isn't needed for selecting bucket. Acked-by: Daniel Borkmann Signed-off-by: Ming Lei --- kernel/bpf/hashtab.c | 6 ++ 1 file changed, 2 insertions(+), 4 deletions(-) diff

Re: use-after-free in hash_sock_destruct

2015-12-29 Thread Herbert Xu
On Thu, Dec 17, 2015 at 01:59:50PM +0100, Dmitry Vyukov wrote: > > The following program causes use-after-free in hash_sock_destruct: This patch should fix the problem. AFAIK everything that you have reported should now be fixed. If you still have issues please resubmit them (and please cc

[PATCH v2 1/3] bpf: hash: use atomic count

2015-12-29 Thread Ming Lei
Preparing for removing global per-hashtable lock, so the counter need to be defined as aotmic_t first. Acked-by: Daniel Borkmann Signed-off-by: Ming Lei --- kernel/bpf/hashtab.c | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-)

Re: [PATCH 08/13] IB/srpt: chain RDMA READ/WRITE requests

2015-12-29 Thread Bart Van Assche
On 12/07/2015 09:51 PM, Christoph Hellwig wrote: > Remove struct rdma_iu and instead allocate the struct ib_rdma_wr array > early and fill out directly. This allows us to chain the WRs, and thus > archive both less lock contention on the HCA workqueue as well as much > simpler error handling.

[PATCH] drivers: power: fix typo in documentation

2015-12-29 Thread Manuel Pégourié-Gonnard
The documentation for detach() said attach. Signed-off-by: Manuel Pégourié-Gonnard Cc: triv...@kernel.org --- drivers/base/power/common.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/base/power/common.c b/drivers/base/power/common.c index

[SUSPECTED SPAM] hi Tux

2015-12-29 Thread wsonguci
hey Tux http://pinewoodaccounting.ca/freedom.php?silver=k1e13tzhma16pt Yours Truly wsonguci -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: [RFD] CAT user space interface revisited

2015-12-29 Thread Thomas Gleixner
Marcelo, On Wed, 23 Dec 2015, Marcelo Tosatti wrote: > On Tue, Dec 22, 2015 at 06:12:05PM +, Yu, Fenghua wrote: > > > From: Thomas Gleixner [mailto:t...@linutronix.de] > > > > > > I was not able to identify any existing infrastructure where this really > > > fits in. I > > > chose a

[PATCH] mfd-dm355evm_msp: One function call less in add_child() after error detection

2015-12-29 Thread SF Markus Elfring
From: Markus Elfring Date: Tue, 29 Dec 2015 13:56:42 +0100 The platform_device_put() function was called in one case by the add_child() function during error handling even if the passed variable "pdev" contained a null pointer. Implementation details could be

Re: [PATCH RFC 1/3] x86/pvclock: add setter for pvclock_pvti_cpu0_va

2015-12-29 Thread Andy Lutomirski
On Tue, Dec 29, 2015 at 4:50 AM, Joao Martins wrote: > On 12/28/2015 11:45 PM, Andy Lutomirski wrote: >> On Mon, Dec 28, 2015 at 1:52 PM, Joao Martins >> wrote: >>> Right now there is only a pvclock_pvti_cpu0_va() which is defined on >>>

[PATCH v1 3/3] ARM64 LPC: update binding doc

2015-12-29 Thread Rongrong Zou
Signed-off-by: Rongrong Zou --- .../devicetree/bindings/arm64/low-pin-count.txt | 20 1 file changed, 20 insertions(+) create mode 100644 Documentation/devicetree/bindings/arm64/low-pin-count.txt diff --git

[PATCH v1 1/3] ARM64 LPC: indirect ISA PORT IO introduced

2015-12-29 Thread Rongrong Zou
Indirect ISA port I/O accessing introduced, vendors can hook their own in/out function to general inb/outb. Drivers can access legacy ISA I/O port by inb/outb as it is done in x86 platform. Signed-off-by: Rongrong Zou --- arch/arm64/Kconfig.platforms | 5 ++-

[PATCH v1 0/3] ARM64 LPC: legacy ISA I/O support

2015-12-29 Thread Rongrong Zou
The Low Pin Count bus, is used on IBM-compatible personal computers to connect low-bandwidth devices to the CPU, such as the boot ROM, "legacy" I/O devices (integrated into a super I/O chip), and Trusted Platform Module (TPM)."Legacy" I/O devices usually include serial and parallel ports, PS/2

Re: [PATCH v1 2/3] ARM64 LPC: LPC driver implementation

2015-12-29 Thread Arnd Bergmann
On Tuesday 29 December 2015 21:33:51 Rongrong Zou wrote: > We only implement io cycles here, we hook the lpc_io_write_byte > and lpc_io_read_byte to inb/outb. So the drivers(ipmi/uart) which access > the legacy ISA I/O port need no modification. > > The low pin count specification is at >

Re: [PATCH v1 1/3] ARM64 LPC: indirect ISA PORT IO introduced

2015-12-29 Thread Rongrong Zou
Hi Arnd, Thanks for your comment. 在 2015/12/29 21:47, Arnd Bergmann 写道: On Tuesday 29 December 2015 21:33:50 Rongrong Zou wrote: Indirect ISA port I/O accessing introduced, vendors can hook their own in/out function to general inb/outb. Drivers can access legacy ISA I/O port by inb/outb as it

Re: [PATCH] unix: properly account for FDs passed over unix sockets

2015-12-29 Thread Hannes Frederic Sowa
On 28.12.2015 15:14, Willy Tarreau wrote: It is possible for a process to allocate and accumulate far more FDs than the process' limit by sending them over a unix socket then closing them to keep the process' fd count low. This change addresses this problem by keeping track of the number of FDs

Re: [PATCH v1 1/1] lib/vsprintf: refactor duplicate code to xnumber()

2015-12-29 Thread Andy Shevchenko
On Tue, 2015-12-29 at 00:20 +0200, Andy Shevchenko wrote: > On Mon, Dec 28, 2015 at 11:42 PM, Rasmus Villemoes > wrote: > > On Mon, Dec 28 2015, Joe Perches wrote: > > > > > On Mon, 2015-12-28 at 20:18 +0200, Andy Shevchenko wrote: > > > > xnumber()

[tip:timers/urgent] posix-clock: Fix return code on the poll method's error path

2015-12-29 Thread tip-bot for Richard Cochran
Commit-ID: 1b9f23727abb92c5e58f139e7d180befcaa06fe0 Gitweb: http://git.kernel.org/tip/1b9f23727abb92c5e58f139e7d180befcaa06fe0 Author: Richard Cochran AuthorDate: Tue, 22 Dec 2015 22:19:58 +0100 Committer: Thomas Gleixner CommitDate: Tue,

[tip:irq/core] irqchip/gicv2m: Miscellaneous fixes for v2m resources and SPI ranges

2015-12-29 Thread tip-bot for Suravee Suthikulpanit
Commit-ID: 5a1ff480f4ec40ace313c16b0543c7c6af09e227 Gitweb: http://git.kernel.org/tip/5a1ff480f4ec40ace313c16b0543c7c6af09e227 Author: Suravee Suthikulpanit AuthorDate: Tue, 22 Dec 2015 16:24:23 -0800 Committer: Thomas Gleixner

Re: [PATCH 2/2] 32-bit ABI: introduce ARCH_32BIT_OFF_T config option

2015-12-29 Thread Arnd Bergmann
On Tuesday 29 December 2015 12:26:35 Yury Norov wrote: > All new 32-bit architectures should have 64-bit off_t type, but existing > architectures has 32-bit ones. > > To handle it, new config option is added to arch/Kconfig that defaults > ARCH_32BIT_OFF_T to be disabled for non-64 bit

[memdup_user_nul] BUG: unable to handle kernel NULL pointer dereference at 00000100

2015-12-29 Thread Fengguang Wu
https://git.kernel.org/pub/scm/linux/kernel/git/viro/vfs.git work.misc commit c7af9d5728bed29ef614324e67e066896d087c8f Author: Al Viro AuthorDate: Thu Dec 24 00:13:10 2015 -0500 Commit: Al Viro CommitDate: Thu Dec 24 10:52:16 2015 -0500

[memdup_user_nul] kernel BUG at mm/slab.c:2735!

2015-12-29 Thread Fengguang Wu
Hi Al, It looks this patch has various impacts. Here are some more bug messages. https://git.kernel.org/pub/scm/linux/kernel/git/viro/vfs.git work.misc commit c7af9d5728bed29ef614324e67e066896d087c8f Author: Al Viro AuthorDate: Thu Dec 24 00:13:10 2015 -0500

Re: [PATCH 1/1] usb: cdc-acm: handle unlinked urb in acm read callback

2015-12-29 Thread Oliver Neukum
On Tue, 2015-12-29 at 13:46 +0800, Lu Baolu wrote: > In current acm driver, the bulk-in callback function ignores the > URBs unlinked in usb core. > > This causes unexpected data loss in some cases. For example, > runtime suspend entry will unlinked all urbs and set urb->status > to -ENOENT even

Re: [PATCH 2/2] 32-bit ABI: introduce ARCH_32BIT_OFF_T config option

2015-12-29 Thread Arnd Bergmann
On Tuesday 29 December 2015 14:43:41 Yury Norov wrote: > On Tue, Dec 29, 2015 at 12:02:33PM +0100, Arnd Bergmann wrote: > > On Tuesday 29 December 2015 12:26:35 Yury Norov wrote: > > > > Acked-by: Arnd Bergmann > > > > Should we merge the two patches through my asm-generic tree

Re: [PATCH] arm: kernel: utilize hrtimer based broadcast

2015-12-29 Thread Thomas Gleixner
On Mon, 28 Dec 2015, Arnd Bergmann wrote: > On Monday 28 December 2015 07:18:58 Huan Wang wrote: > > Hi, Arnd, > > > > Could you help to review the following patch? Thanks. > > > > Hi Alison, > > I'm sorry but I understand very little of this particular area of the kernel. > > I've added

[PATCH net-next 1/3] r8169:Fix typo in setting RTL8168EP and RTL8168H D3cold PFM mode

2015-12-29 Thread Chunhao Lin
The register for setting D3code PFM mode is MISC_1, not DLLPR. Signed-off-by: Chunhao Lin --- drivers/net/ethernet/realtek/r8169.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/net/ethernet/realtek/r8169.c

[PATCH net-next 0/3] Fix some typos in setting hardware parameter

2015-12-29 Thread Chunhao Lin
The typos are in setting RTL8168DP, RTL8168EP and RTL8168H hardware parameters. This series of patch fix these typos. Chunhao Lin (3): r8169:Fix typo in setting RTL8168EP and RTL8168H D3cold PFM mode r8169:Fix typo in setting RTL8168H PHY PFM mode. r8169:Correct the way of setting RTL8168DP

[PATCH net-next 3/3] r8169:Correct the way of setting RTL8168DP ephy

2015-12-29 Thread Chunhao Lin
The original way is wrong, it always writes ephy reg 0x03. Signed-off-by: Chunhao Lin --- drivers/net/ethernet/realtek/r8169.c | 17 + 1 file changed, 5 insertions(+), 12 deletions(-) diff --git a/drivers/net/ethernet/realtek/r8169.c

Re: [PATCH v1 1/3] ARM64 LPC: indirect ISA PORT IO introduced

2015-12-29 Thread Arnd Bergmann
On Tuesday 29 December 2015 22:26:27 Rongrong Zou wrote: > 在 2015/12/29 21:47, Arnd Bergmann 写道: > > On Tuesday 29 December 2015 21:33:50 Rongrong Zou wrote: > >> Indirect ISA port I/O accessing introduced, vendors can hook > >> their own in/out function to general inb/outb. Drivers can access >

Re: [PATCH] unix: properly account for FDs passed over unix sockets

2015-12-29 Thread Hannes Frederic Sowa
On 28.12.2015 15:14, Willy Tarreau wrote: @@ -1528,10 +1546,8 @@ static int unix_attach_fds(struct scm_cookie *scm, struct sk_buff *skb) if (!UNIXCB(skb).fp) return -ENOMEM; - if (unix_sock_count) { - for (i = scm->fp->count - 1; i >= 0; i--) -

<    3   4   5   6   7   8