[PATCH v7 15/18] perf ftrace: add option -D/--delay to delay tracing

2020-07-18 Thread Changbin Du
This adds an option '-D/--delay' to allow us to start tracing some times later after workload is launched. Signed-off-by: Changbin Du --- tools/perf/Documentation/perf-ftrace.txt | 4 tools/perf/builtin-ftrace.c | 19 --- 2 files changed, 20 insertions(+), 3

[PATCH v7 14/18] perf: ftrace: allow set graph depth by '--graph-opts'

2020-07-18 Thread Changbin Du
This is to have a consistent view of all graph tracer options. The original option '--graph-depth' is marked as deprecated. Signed-off-by: Changbin Du --- tools/perf/Documentation/perf-ftrace.txt | 5 + tools/perf/builtin-ftrace.c | 5 ++--- 2 files changed, 3 insertions(+), 7

[PATCH v7 06/18] perf ftrace: add option '--inherit' to trace children processes

2020-07-18 Thread Changbin Du
This adds an option '--inherit' to allow us trace children processes spawned by our target. Signed-off-by: Changbin Du --- v2: option name '--trace-children' -> '--inherit'. --- tools/perf/Documentation/perf-ftrace.txt | 3 ++ tools/perf/builtin-ftrace.c | 38

[PATCH v7 07/18] perf: util: add general function to parse sublevel options

2020-07-18 Thread Changbin Du
This factors out a general function perf_parse_sublevel_options() to parse sublevel options. The 'sublevel' options is something like the '--debug' options which allow more sublevel options. Signed-off-by: Changbin Du --- v2: add util/parse-sublevel-options.c --- tools/perf/util/Build

[PATCH v7 08/18] perf ftrace: add support for tracing option 'func_stack_trace'

2020-07-18 Thread Changbin Du
This adds support to display call trace for function tracer. To do this, just specify a '--func-opts call-graph' option. $ sudo perf ftrace -T vfs_read --func-opts call-graph iio-sensor-prox-855 [003] 6168.369657: vfs_read <-ksys_read iio-sensor-prox-855 [003] 6168.369677: => vfs_read

[PATCH v7 11/18] perf ftrace: add support for tracing option 'irq-info'

2020-07-18 Thread Changbin Du
This adds support to display irq context info for function tracer. To do this, just specify a '--func-opts irq-info' option. Signed-off-by: Changbin Du --- tools/perf/Documentation/perf-ftrace.txt | 1 + tools/perf/builtin-ftrace.c | 21 - 2 files changed, 21

[PATCH v7 09/18] perf ftrace: add support for trace option sleep-time

2020-07-18 Thread Changbin Du
This adds an option '--graph-opts nosleep-time' which allow us only to measure on-CPU time. This option is function_graph tracer only. Signed-off-by: Changbin Du --- v3: switch to uniform option --graph-opts. v2: option name '--nosleep-time' -> '--graph-nosleep-time'. ---

[PATCH v7 10/18] perf ftrace: add support for trace option funcgraph-irqs

2020-07-18 Thread Changbin Du
This adds an option '--graph-opts noirqs' to filter out functions executed in irq context. Signed-off-by: Changbin Du --- v2: option name '--nofuncgraph-irqs' -> '--graph-noirqs'. --- tools/perf/Documentation/perf-ftrace.txt | 1 + tools/perf/builtin-ftrace.c | 21

[PATCH v7 03/18] perf ftrace: factor out function write_tracing_file_int()

2020-07-18 Thread Changbin Du
We will reuse this function later. Signed-off-by: Changbin Du --- tools/perf/builtin-ftrace.c | 17 - 1 file changed, 12 insertions(+), 5 deletions(-) diff --git a/tools/perf/builtin-ftrace.c b/tools/perf/builtin-ftrace.c index 3c0e60fdfe0f..9abf97c29cb6 100644 ---

[PATCH v7 04/18] perf ftrace: add option '-m/--buffer-size' to set per-cpu buffer size

2020-07-18 Thread Changbin Du
This adds an option '-m/--buffer-size' to allow us set the size of per-cpu tracing buffer. Signed-off-by: Changbin Du --- v2: support units as a suffix. --- tools/perf/Documentation/perf-ftrace.txt | 5 +++ tools/perf/builtin-ftrace.c | 56 +++- 2 files

[PATCH v7 02/18] perf ftrace: add option '-F/--funcs' to list available functions

2020-07-18 Thread Changbin Du
This adds an option '-F/--funcs' to list all available functions to trace, which is read from tracing file 'available_filter_functions'. $ sudo ./perf ftrace -F | head trace_initcall_finish_cb initcall_blacklisted do_one_initcall do_one_initcall trace_initcall_start_cb run_init_process

[PATCH v7 05/18] perf ftrace: show trace column header

2020-07-18 Thread Changbin Du
This makes perf-ftrace display column header before printing trace. $ sudo perf ftrace # tracer: function # # entries-in-buffer/entries-written: 0/0 #P:8 # #TASK-PID CPU# TIMESTAMP FUNCTION # | | | | | <...>-9246

[PATCH v7 01/18] perf ftrace: select function/function_graph tracer automatically

2020-07-18 Thread Changbin Du
The '-g/-G' options have already implied function_graph tracer should be used instead of function tracer. So the extra option '--tracer' can be killed. This patch changes the behavior as below: - By default, function tracer is used. - If '-g' or '-G' option is on, then function_graph tracer

[PATCH v7 00/18] perf: ftrace enhancement

2020-07-18 Thread Changbin Du
The perf has basic kernel ftrace support but lack support of most tracing options. This serias is target to enhance the perf ftrace functionality so that we can make full use of kernel ftrace with perf. In general, this serias be cataloged into two main changes: 1) Improve usability of existing

Re: [PATCH 04/20] dlb2: add device ioctl layer and first 4 ioctls

2020-07-18 Thread gregkh
On Fri, Jul 17, 2020 at 08:05:08PM +, Eads, Gage wrote: > > > > -Original Message- > > From: Arnd Bergmann > > Sent: Friday, July 17, 2020 1:57 PM > > To: Eads, Gage > > Cc: linux-kernel@vger.kernel.org; gregkh ; > > Karlsson, Magnus ; Topel, Bjorn > > > > Subject: Re: [PATCH

Re: [PATCH 01/20] dlb2: add skeleton for DLB 2.0 driver

2020-07-18 Thread Greg KH
On Fri, Jul 17, 2020 at 06:19:14PM +, Eads, Gage wrote: > > > > -Original Message- > > From: Greg KH > > Sent: Sunday, July 12, 2020 10:57 AM > > To: Eads, Gage > > Cc: linux-kernel@vger.kernel.org; a...@arndb.de; Karlsson, Magnus > > ; Topel, Bjorn > > Subject: Re: [PATCH 01/20]

Re: [PATCH 01/20] dlb2: add skeleton for DLB 2.0 driver

2020-07-18 Thread Greg KH
On Fri, Jul 17, 2020 at 06:18:46PM +, Eads, Gage wrote: > > > > -Original Message- > > From: Greg KH > > Sent: Sunday, July 12, 2020 10:58 AM > > To: Eads, Gage > > Cc: linux-kernel@vger.kernel.org; a...@arndb.de; Karlsson, Magnus > > ; Topel, Bjorn > > Subject: Re: [PATCH 01/20]

Re: [v2 1/4] coccinelle: api: extend memdup_user transformation with GFP_USER

2020-07-18 Thread Julia Lawall
On Sat, 18 Jul 2020, Markus Elfring wrote: > > Applied. > > Do you care for patch review concerns according to this SmPL script > adjustment? > > * https://lore.kernel.org/cocci/5c0dae88-e172-3ba6-f86c-d1a6238bb...@web.de/ > https://lkml.org/lkml/2020/6/9/568 This one it complete nonsense.

[PATCH 4/7] KVM: x86: Add intr/vectoring info and error code to kvm_exit tracepoint

2020-07-18 Thread Sean Christopherson
Extend the kvm_exit tracepoint to align it with kvm_nested_vmexit in terms of what information is captured. On SVM, this means adding interrupt info and error code, and on VMX it means adding ITD vectoring and error code. This sets the stage for macrofying the kvm_exit tracepoint definition so

[PATCH 1/7] KVM: x86: Add RIP to the kvm_entry, i.e. VM-Enter, tracepoint

2020-07-18 Thread Sean Christopherson
Add RIP to the kvm_entry tracepoint to help debug if the kvm_exit tracepoint is disable or if VM-Enter fails, in which case the kvm_exit tracepoint won't be hit. Read RIP from within the tracepoint itself to avoid a potential VMREAD and retpoline if the guest's RIP isn't available.

[PATCH 5/7] KVM: x86: Add macro wrapper for defining kvm_exit tracepoint

2020-07-18 Thread Sean Christopherson
Macrofy the definition of kvm_exit so that the definition can be reused verbatim by kvm_nested_vmexit. No functional change intended. Signed-off-by: Sean Christopherson --- arch/x86/kvm/trace.h | 69 +++- 1 file changed, 36 insertions(+), 33 deletions(-)

[PATCH 0/7] KVM: x86: Tracepoint improvements and fixes

2020-07-18 Thread Sean Christopherson
Various improvements and fixes for the kvm_entry, kvm_exit and kvm_nested_vmexit tracepoints. 1. Capture the guest's RIP during kvm_entry for obvious reasons. 2. Extend kvm_exit to report the same info as kvm_nested_vmexit, and macrofy its definition to reuse it verbatim for nested

[PATCH] kconfig: constify XPM data

2020-07-18 Thread Masahiro Yamada
Constify arrays as well as strings. Signed-off-by: Masahiro Yamada --- scripts/kconfig/images.c | 30 +++--- scripts/kconfig/images.h | 30 +++--- 2 files changed, 30 insertions(+), 30 deletions(-) diff --git a/scripts/kconfig/images.c

[PATCH 6/7] KVM: x86: Use common definition for kvm_nested_vmexit tracepoint

2020-07-18 Thread Sean Christopherson
Use the newly introduced TRACE_EVENT_KVM_EXIT to define the guts of kvm_nested_vmexit so that it captures and prints the same information as with kvm_exit. This has the bonus side effect of fixing the interrupt info and error code printing for the case where they're invalid, e.g. if the exit was

[PATCH 7/7] KVM: nVMX: Read EXIT_QUAL and INTR_INFO only when needed for nested exit

2020-07-18 Thread Sean Christopherson
Read vmcs.EXIT_QUALIFICATION and vmcs.VM_EXIT_INTR_INFO only when the VM-Exit is being reflected to L1 now that they are no longer passed directly to the kvm_nested_vmexit tracepoint. No functional change intended. Signed-off-by: Sean Christopherson --- arch/x86/kvm/vmx/nested.c | 5 ++--- 1

[PATCH 3/7] KVM: VMX: Add a helper to test for a valid error code given an intr info

2020-07-18 Thread Sean Christopherson
Add a helper, is_exception_with_error_code(), to provide the simple but difficult to read code of checking for a valid exception with an error code given a vmcs.VM_EXIT_INTR_INFO value. The helper will gain another user, vmx_get_exit_info(), in a future patch. Signed-off-by: Sean Christopherson

[PATCH 2/7] KVM: x86: Read guest RIP from within the kvm_nested_vmexit tracepoint

2020-07-18 Thread Sean Christopherson
Use kvm_rip_read() to read the guest's RIP for the nested VM-Exit tracepoint instead of having the caller pass in the tracepoint. Params that are passed into a tracepoint are evaluated even if the tracepoint is disabled, i.e. passing in RIP for VMX incurs a VMREAD and retpoline to retrieve a

[PATCH V1] arm64: dts: qcom: Add bandwidth votes for eMMC and SDcard

2020-07-18 Thread Shaik Sajida Bhanu
From: Pradeep P V K Add the bandwidth domain supporting performance state and the corresponding OPP tables for the sdhc device on sc7180. Signed-off-by: Shaik Sajida Bhanu --- This change is depends on the patch series https://lkml.org/lkml/2020/6/30/1280 Also depends on documentation commit

[PATCH V1] arm64: dts: qcom: SD-card GPIO pin set bias-pull up

2020-07-18 Thread Shaik Sajida Bhanu
From: Veerabhadrarao Badiganti On some sc7180 based platforms where external pull is not present on cd-gpio, this gpio state is getting read as HIGH when sleep config is applied on it. This is resulting in SDcard rescan after suspend-resume even though SDcard is not present. Update cd-gpio

[tip:master] BUILD SUCCESS 01634f2bd42e6fdd2d2959d97c26fcfab36be02a

2020-07-18 Thread kernel test robot
tree/branch: https://git.kernel.org/pub/scm/linux/kernel/git/tip/tip.git master branch HEAD: 01634f2bd42e6fdd2d2959d97c26fcfab36be02a Merge branch 'x86/urgent' elapsed time: 1074m configs tested: 100 configs skipped: 1 The following configs have been built successfully. More configs may be

[PATCH v2] f2fs: add F2FS_IOC_SEC_TRIM_FILE ioctl

2020-07-18 Thread Daeho Jeong
From: Daeho Jeong Added a new ioctl to send discard commands or/and zero out to selected data area of a regular file for security reason. The way of handling range.len of F2FS_IOC_SEC_TRIM_FILE: 1. Added -1 value support for range.len to secure trim the whole blocks starting from range.start

[PATCH v2] smp: Fix a potential usage of stale nr_cpus

2020-07-18 Thread Muchun Song
When the cmdline of "nr_cpus" is not valid, the @nr_cpu_ids is assigned a stale value. The nr_cpus is only valid when get_option() return 1. So check the return value to prevent this. Signed-off-by: Muchun Song --- changelog in v2: 1) Rework the commit log. 2) Rework the return value check.

Re: [PATCH] libbpf bpf_helpers: Use __builtin_offsetof for offsetof if available

2020-07-18 Thread Yonghong Song
On 7/17/20 12:23 AM, Ian Rogers wrote: The non-builtin route for offsetof has a dependency on size_t from stdlib.h/stdint.h that is undeclared and may break targets. The offsetof macro in bpf_helpers may disable the same macro in other headers that have a #ifdef offsetof guard. Rather than

<    1   2   3   4   5   6