[PATCH 2/3] dyndbg: in dynamic_emit_prefix, change inter-field separator

2012-07-19 Thread Jim Cromie
, but doesnt solve it entirely; if dyndbg==p is used, the callsite is enabled but no prefix is added, so theres one less ':' in the message. Changing the terminator to ',' would fix this, and might be warranted. pr_fmt(fmt) KBUILD_MODNAME : fmt, also adds another ':'. Signed-off-by: Jim Cromie

[PATCH 3/3] dyndbg: change varname verbose_bytes to sz_used

2012-07-19 Thread Jim Cromie
New name reflects purpose (count mem used), verbose is just print condition, and bytes is too generic. Signed-off-by: Jim Cromie jim.cro...@gmail.com --- lib/dynamic_debug.c |6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/lib/dynamic_debug.c b/lib/dynamic_debug.c

[ patch .24-rc0 5/5 ] SuperIO locks coordinator - use in other hwmon/*.c

2007-10-14 Thread Jim Cromie
05 - use superio-locks in rest of drivers/hwmon/*.c this patch is compile-tested only, please review for sanity before you try running them. Things to look for - missing superio_release(), opportunities to use superio_devid(), superio_inw(), etc. Signed-off-by: Jim Cromie <[EMAIL PROTEC

[ patch .24-rc0 3/5 ] SuperIO locks coordinator - use in hwmon/pc87360

2007-10-14 Thread Jim Cromie
03 - use superio-locks in drivers/hwmon/pc87360 this driver keeps the slot for only during __init, since it only needs the sio-port to read the ISA addresses of the Logical Devices in the chip, which are then used exclusively. Signed-off-by: Jim Cromie <[EMAIL PROTECTED]> --- hwmon-s

[ patch .24-rc0 4/5 ] SuperIO locks coordinator - use in drivers/char/pc8736x-gpio

2007-10-14 Thread Jim Cromie
they sanity-test the sharing of a reservation with 2 different life-cycles. Signed-off-by: Jim Cromie <[EMAIL PROTECTED]> --- hwmon-superio-pc8736x-gpio Kconfig|1 pc8736x_gpio.c | 83 ++--- 2 files changed, 34 insertions(

[ patch .24-rc0 2/5 ] SuperIO locks coordinator - use in hwmon/w83627hf

2007-10-14 Thread Jim Cromie
02 - use superio-locks in drivers/hwmon/w83627hf.c tested on an AMD-Barton mobo. Signed-off-by: Jim Cromie <[EMAIL PROTECTED]> --- hwmon-superio-w83627hf Kconfig|1 w83627hf.c | 140 - 2 files changed, 58 insertions(

[ patch .24-rc0 1/5 ] SuperIO locks coordinator - add the module

2007-10-14 Thread Jim Cromie
ind etc) were chosen to fit the idiom used in hwmon/*.c, patches 2-5 remove the per-user-driver copies of the superio_*() fns. I added the module to /drivers/hwmon, mostly cuz thats where Ive used it - perhaps drivers/isa is better ? Signed-off-by: Jim Cromie <[EMAIL PROTECTED]> ---

[ patch .24-rc0 0/5 ] SuperIO locks coordinator

2007-10-14 Thread Jim Cromie
d all your suggestions, thanks. Signed-off-by: Jim Cromie <[EMAIL PROTECTED]> --- - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Pl

[ patch .24-rc0 0/5 ] SuperIO locks coordinator

2007-10-14 Thread Jim Cromie
suggestions, thanks. Signed-off-by: Jim Cromie [EMAIL PROTECTED] --- - To unsubscribe from this list: send the line unsubscribe linux-kernel in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org

[ patch .24-rc0 1/5 ] SuperIO locks coordinator - add the module

2007-10-14 Thread Jim Cromie
) were chosen to fit the idiom used in hwmon/*.c, patches 2-5 remove the per-user-driver copies of the superio_*() fns. I added the module to /drivers/hwmon, mostly cuz thats where Ive used it - perhaps drivers/isa is better ? Signed-off-by: Jim Cromie [EMAIL PROTECTED] --- hwmon-superio-module

[ patch .24-rc0 2/5 ] SuperIO locks coordinator - use in hwmon/w83627hf

2007-10-14 Thread Jim Cromie
02 - use superio-locks in drivers/hwmon/w83627hf.c tested on an AMD-Barton mobo. Signed-off-by: Jim Cromie [EMAIL PROTECTED] --- hwmon-superio-w83627hf Kconfig|1 w83627hf.c | 140 - 2 files changed, 58 insertions(+), 83

[ patch .24-rc0 3/5 ] SuperIO locks coordinator - use in hwmon/pc87360

2007-10-14 Thread Jim Cromie
03 - use superio-locks in drivers/hwmon/pc87360 this driver keeps the slot for only during __init, since it only needs the sio-port to read the ISA addresses of the Logical Devices in the chip, which are then used exclusively. Signed-off-by: Jim Cromie [EMAIL PROTECTED] --- hwmon-superio

[ patch .24-rc0 4/5 ] SuperIO locks coordinator - use in drivers/char/pc8736x-gpio

2007-10-14 Thread Jim Cromie
they sanity-test the sharing of a reservation with 2 different life-cycles. Signed-off-by: Jim Cromie [EMAIL PROTECTED] --- hwmon-superio-pc8736x-gpio Kconfig|1 pc8736x_gpio.c | 83 ++--- 2 files changed, 34 insertions(+), 50

[ patch .24-rc0 5/5 ] SuperIO locks coordinator - use in other hwmon/*.c

2007-10-14 Thread Jim Cromie
05 - use superio-locks in rest of drivers/hwmon/*.c this patch is compile-tested only, please review for sanity before you try running them. Things to look for - missing superio_release(), opportunities to use superio_devid(), superio_inw(), etc. Signed-off-by: Jim Cromie [EMAIL PROTECTED

(no subject)

2007-09-07 Thread Jim Cromie
auth 2efbb938 subscribe linux-kernel [EMAIL PROTECTED] auth a339d34a subscribe linux-net [EMAIL PROTECTED] - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at

(no subject)

2007-09-07 Thread Jim Cromie
auth 2efbb938 subscribe linux-kernel [EMAIL PROTECTED] auth a339d34a subscribe linux-net [EMAIL PROTECTED] - To unsubscribe from this list: send the line unsubscribe linux-kernel in the body of a message to [EMAIL PROTECTED] More majordomo info at

Coding style on function signatures (was: Convert tasklets to work queues )

2007-07-07 Thread Jim Cromie
Linus Torvalds wrote: Yes, code should be less than 80 characters wide. But hey, sometimes it's just more readable to have one line that is slightly longer than it should be, than to split something that is awkward to split. < cc-list heavily trimmed > could you speak to the

Coding style on function signatures (was: Convert tasklets to work queues )

2007-07-07 Thread Jim Cromie
Linus Torvalds wrote: Yes, code should be less than 80 characters wide. But hey, sometimes it's just more readable to have one line that is slightly longer than it should be, than to split something that is awkward to split. cc-list heavily trimmed could you speak to the

13-mm1: firmware_loading_store goes berserk on boot.

2005-09-02 Thread Jim Cromie
during boot, kernel get caught in a hi-speed loop, issuing these msgs. from the logs, it appears that the 'repeated' catcher is getting overwhelmed, perhaps by message trucation which breaks the pattern. Ive edited large chunks of repeats that made it into the log. Sep 2 07:59:36 harpo

<    1   2   3   4