.
But, if mirrored regions are existed, bootmem allocator tries to
allocate from mirrored region independently of "kerenelcore=mirror" option.
So, IMHO, kernel text is important, so putting it to mirrored (more reliable)
region is reasonable whether or not "kernel
e motherboard resources through system.c
> driver.
>
> @David Miller, what is your opinion about this?
> I think this driver should be reverted...
I'm willing to revise my driver if it's something wrong.
I can't reproduce this problem. Could you please show me how to reproduce
problem ?
Sincerely,
Taku Izumi
Dear Bhaktipriya,
Thanks. Looks good to me.
Sincerely,
Taku Izumi
> -Original Message-
> From: Bhaktipriya Shridhar [mailto:bhaktipriy...@gmail.com]
> Sent: Thursday, June 02, 2016 6:31 PM
> To: David S. Miller; Izumi, Taku/泉 拓; Florian Westphal; Bhaktipriya Shridhar
>
Dear Xishi,
Sorry for late.
> -Original Message-
> From: Xishi Qiu [mailto:qiuxi...@huawei.com]
> Sent: Friday, December 11, 2015 6:44 PM
> To: Izumi, Taku/泉 拓
> Cc: Luck, Tony; linux-kernel@vger.kernel.org; linux...@kvack.org;
> a...@linux-foundation.org; Kamezawa,
provides a new way to create ZONE_MOVABLE.
Sincerely,
Taku Izumi
>
> It seems something like that we add a new zone but the name is zone_movable,
> not zone_mirror. And the prerequisite is that we won't enable these two
> features(movable memory and mirrored memory) at the sam
cated from ZONE_MOVABLE.
In this case administrator must review and reconfigure the mirror ratio via
"MirrorRequest" EFI variable.
Sincerely,
Taku Izumi
>
> > --
> > To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> > the body of
Dear Xishi,
Thanks for reviewing.
> -Original Message-
> From: Xishi Qiu [mailto:qiuxi...@huawei.com]
> Sent: Wednesday, December 09, 2015 11:26 AM
> To: Izumi, Taku/泉 拓
> Cc: linux-kernel@vger.kernel.org; linux...@kvack.org; tony.l...@intel.com;
> Kamezawa,
|ooxx| ZONE_MOVABLE
(legend) o: present x: absent
v2 -> v3:
- change the option name from kernelcore=reliable
into kernelcore=mirror
- documentation fix so that users can understand
nn[KMS] and mirror are exclusive
Signed-off-by: Taku Izumi
---
Documentation/kernel-par
Currently each zone's zone_start_pfn is calculated at
free_area_init_core(). However zone's range is fixed at
the time when invoking zone_spanned_pages_in_node().
This patch changes each zone->zone_start_pfn is
calculated at zone_spanned_pages_in_node().
Signed-off-by: Taku I
ages, and vice versa.
v1 -> v2:
Refine so that the above example case also can be
handled properly:
v2 -> v3:
Change the option name from kernelcore=reliable
into kernelcore=mirror and some documentation fix
according to Andrew Morton's point
Taku Izumi (2):
than mirror.
>
Okay, I'll change the option name into kernelcore=mirror.
Sincerely,
Taku Izumi
>>20);
}
Which do you think is beter ?
- change into kernelcore="mirrored"
- keep kernelcore="reliable" and minmal printk fix
>
> Secondly, does this patchset mean that kernelcore=reliable and
> kernelcore=100M are exclusive? Or can the user specif
the above example case also can be
handled properly:
Taku Izumi (2):
mm: Calculate zone_start_pfn at zone_spanned_pages_in_node()
mm: Introduce kernelcore=reliable option
Documentation/kernel-parameters.txt | 9 ++-
mm/page_alloc.c | 140 ++
Currently each zone's zone_start_pfn is calculated at
free_area_init_core(). However zone's range is fixed at
the time when invoking zone_spanned_pages_in_node().
This patch changes each zone->zone_start_pfn is
calculated at zone_spanned_pages_in_node().
Signed-off-by: Taku I
x| ZONE_MOVABLE
(legend) o: present x: absent
Signed-off-by: Taku Izumi
---
Documentation/kernel-parameters.txt | 9 ++-
mm/page_alloc.c | 110 ++--
2 files changed, 112 insertions(+), 7 deletions(-)
diff --git a/Documentation/k
Thanks, Colin.
Signed-off-by: Taku Izumi
> -Original Message-
> From: Colin King [mailto:colin.k...@canonical.com]
> Sent: Thursday, November 12, 2015 12:23 AM
> To: David S. Miller; Izumi, Taku/泉 拓; Markus Elfring; net...@vger.kernel.org
> Cc: linux-kernel@vger.kerne
Commit-ID: 78b9bc947b18ed16b6c2c573d774e6d54ad9452d
Gitweb: http://git.kernel.org/tip/78b9bc947b18ed16b6c2c573d774e6d54ad9452d
Author: Taku Izumi
AuthorDate: Fri, 23 Oct 2015 11:48:17 +0200
Committer: Ingo Molnar
CommitDate: Wed, 28 Oct 2015 12:28:06 +0100
efi: Fix warning of int-to
Dear Tony,
> -Original Message-
> From: Luck, Tony [mailto:tony.l...@intel.com]
> Sent: Friday, October 23, 2015 8:27 AM
> To: Kamezawa, Hiroyuki/亀澤 寛之; Izumi, Taku/泉 拓; linux-kernel@vger.kernel.org;
> linux...@kvack.org
> Cc: qiuxi...@huawei.com; m...@csn
32-bit
environment.
This patch changes the type of "new_memmap_phy" variable
from "u64" into "ulong" to avoid it.
v1 -> v2:
- change the type of "new_memmap_phy" from phys_addr_t
into ulong according to Ard's comment
Reported-by: Ingo Molnar
void*) == sizeof(phys_addr_t), which is not always true,
> e.g., on 32-bit ARM (whose UEFI support is
> in development but not yet merged) with LPAE enabled.
>
> Could we use unsigned long instead?
Okay. I'll update my patch.
Sincerely,
Taku Izumi
--
To unsubscribe from this l
32-bit
environment.
This patch changes the type of "new_memmap_phy" variable
from "u64" into "phys_addr_t" to avoid it.
Reported-by: Ingo Molnar
Signed-off-by: Taku Izumi
---
drivers/firmware/efi/fake_mem.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
dif
Hi Xishi,
> On 2015/10/15 21:32, Taku Izumi wrote:
>
> > Xeon E7 v3 based systems supports Address Range Mirroring
> > and UEFI BIOS complied with UEFI spec 2.5 can notify which
> > ranges are reliable (mirrored) via EFI memory map.
> > Now Linux kernel utilize
,2G@0x10a000:0x1,2G@4G:0x1
efi_fake_mem is found at:
git://git.kernel.org/pub/scm/linux/kernel/git/mfleming/efi.git
tags/efi-next
Signed-off-by: Taku Izumi
---
Documentation/kernel-parameters.txt | 9 -
mm/page_alloc.c | 26 +++
; term solution. But this looks like a very clever was to try out the
> feature with a minimally invasive patch.
Yes. I agree creating a new zone is the right solution for long term.
I believe this approach using MOVABLE_ZONE is good and reasonable
for short-term solution.
Sincerely,
Tak
option and
introduces kernelcore=reliable option. By specifying
"reliable" instead of specifying the amount of memory,
non-reliable region will be arranged into ZONE_MOVABLE.
Signed-off-by: Taku Izumi
---
Documentation/kernel-parameters.txt | 9 -
mm/page_alloc.c
Commit-ID: 712df65ccb63da08a484bf57c40b250dfd4103a7
Gitweb: http://git.kernel.org/tip/712df65ccb63da08a484bf57c40b250dfd4103a7
Author: Taku Izumi
AuthorDate: Thu, 24 Sep 2015 21:10:21 +0900
Committer: Ingo Molnar
CommitDate: Tue, 6 Oct 2015 17:31:51 +0200
perf/x86/intel/uncore: Fix
emory
Signed-off-by: Taku Izumi
---
Documentation/kernel-parameters.txt | 15 +++
arch/x86/kernel/setup.c | 4 +-
drivers/firmware/efi/Kconfig| 22
drivers/firmware/efi/Makefile | 1 +
drivers/firmware/efi/fake_mem.c | 238
I've missed git-format-patch after rebasing.
I'll resend right one..
> -Original Message-
> From: kbuild test robot [mailto:l...@intel.com]
> Sent: Wednesday, September 30, 2015 10:37 AM
> To: Izumi, Taku/泉 拓
> Cc: kbuild-...@01.org; linux-kernel@
emory
Signed-off-by: Taku Izumi
---
Documentation/kernel-parameters.txt | 15 +++
arch/x86/kernel/setup.c | 4 +-
drivers/firmware/efi/Kconfig| 22
drivers/firmware/efi/Makefile | 1 +
drivers/firmware/efi/fake_mem.c | 238
_MAX_FAKE_MEM
- and some fix pointed by Matt Flemming
Taku Izumi (2):
x86, efi: rename print_efi_memmap() to efi_print_memmap()
x86, efi: Add "efi_fake_mem" boot option
Documentation/kernel-parameters.txt | 15 +++
arch/x86/include/asm/efi.h | 1 +
arch/x86/kernel/se
This patch renames print_efi_memmap() to efi_print_memmap() and
make it global function so that we can invoke it outside of
arch/x86/platform/efi/efi.c
Signed-off-by: Taku Izumi
---
arch/x86/include/asm/efi.h | 1 +
arch/x86/platform/efi/efi.c | 4 ++--
2 files changed, 3 insertions(+), 2
lock at snbep_pci2phy_map_init()
Signed-off-by: Taku Izumi
---
arch/x86/kernel/cpu/perf_event_intel_uncore.c | 61 --
arch/x86/kernel/cpu/perf_event_intel_uncore.h | 12 -
arch/x86/kernel/cpu/perf_event_intel_uncore_snb.c | 16 --
.../x86/kernel/cpu/perf_event_
oducing segment-aware pci2phy_map instead.
v3 -> v4:
- avoid GFP_ATOMIC allocation at __find_pci2phy_map()
- Add missing pci_dev_put at snb_pci2phy_map_init()
- Add missing raw_spin_unlock at snbep_pci2phy_map_init()
Signed-off-by: Taku Izumi
---
arch/x86/ke
oducing segment-aware pci2phy_map instead.
v2 -> v3:
- fix up according to Peter's comment
- introduce __find_pci2phy_map() to avert repetition
Signed-off-by: Taku Izumi
---
arch/x86/kernel/cpu/perf_event_intel_uncore.c | 45 --
arch/x86/kernel/cpu/perf_event
oducing segment-aware pci2phy_map instead.
v1 -> v2:
- Extract method named uncore_pcibus_to_physid to avoid repetetion of
retrieving phys_id code
Signed-off-by: Taku Izumi
---
arch/x86/kernel/cpu/perf_event_intel_uncore.c | 25 --
arch/x86/kernel/cpu/perf_event_intel_u
Dear Matt,
Thank you for reviewing.
I updated my patchset.
I'm happy if you review new one.
Sincerely,
Taku Izumi
> -Original Message-
> From: Matt Fleming [mailto:m...@codeblueprint.co.uk]
> Sent: Wednesday, August 26, 2015 8:46 AM
> To: Izumi, Taku/泉 拓
&
UEFI spec 2.5 introduces new Memory Attribute Definition named
EFI_MEMORY_MORE_RELIABLE. This patch adds this new attribute
support to efi_md_typeattr_format().
Signed-off-by: Taku Izumi
---
drivers/firmware/efi/efi.c | 6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a
breviation of EFI_MEMORY_MORE_RELIABLE from "RELY" to "MR"
- add patch (2/3) for changing abbreviation of EFI_MEMORY_RUNTIME
- migrate some code from arch/x86/platform/efi/quirks to
drivers/firmware/efi/fake_mem.c and create config EFI_FAKE_MEMMAP
Taku Izumi (3):
efi: Add EF
Now efi_md_typeattr_format() outputs "RUN" if passed EFI memory
descriptor has EFI_MEMORY_RUNTIME attribute. But "RT" is preferer
because it is shorter and clearer.
This patch changes abbreviation of EFI_MEMORY_RUNTIME from "RUN"
to "RT".
Suggested-by: A
ng message is output:
efi: Memory: 4096M/131455M mirrored memory
Signed-off-by: Taku Izumi
---
Documentation/kernel-parameters.txt | 8 ++
arch/x86/include/asm/efi.h | 1 +
arch/x86/kernel/setup.c | 4 +-
arch/x86/platform/efi/efi.c | 2 +-
drivers/
with UEFI spec 2.5 complied
firmware.
This patchset introduces new boot option named "efi_fake_mem_mirror".
By specifying this parameter, you can mark specific memory as
mirrored memory. This is useful for debugging of Memory Address Range
Mirroring feature.
Taku Izumi (2):
UEFI spec 2.5 introduces new Memory Attribute Definition named
EFI_MEMORY_MORE_RELIABLE. This patch adds this new attribute
support to efi_md_typeattr_format().
Signed-off-by: Taku Izumi
---
drivers/firmware/efi/efi.c | 6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a
)
And you will find that the following message is output:
efi: Memory: 4096M/131455M mirrored memory
Signed-off-by: Taku Izumi
---
Documentation/kernel-parameters.txt | 8 ++
arch/x86/include/asm/efi.h | 2 +
arch/x86/kernel/setup.c | 4 +-
arch/x86/platform/efi
oducing segment-aware pci2phy_map instead.
v1->v2:
- Extract method named uncore_pcibus_to_physid to avoid repetetion of
retrieving phys_id code
Signed-off-by: Taku Izumi
---
arch/x86/kernel/cpu/perf_event_intel_uncore.c | 25 --
arch/x86/kernel/cpu/perf_event_intel_u
oducing segment-aware pci2phy_map instead.
Signed-off-by: Taku Izumi
---
arch/x86/kernel/cpu/perf_event_intel_uncore.c | 27 +++---
arch/x86/kernel/cpu/perf_event_intel_uncore.h | 9 -
arch/x86/kernel/cpu/perf_event_intel_uncore_snb.c | 23 +++-
.../x86/kernel
8b 45 00 4d 39 c4 75 6c 4c 39 e3
[0.189000] RIP [] __list_add+0x16/0xc0
[0.189000] RSP
[0.189000] CR2: 0008
[0.189000] ---[ end trace 58feee6875cf67cf ]---
[0.189000] Kernel panic - not syncing: Fatal exception
[0.189000] ---[ end Kernel panic - not synci
ce, not depending on acpi_device
> struct.
How about squashing patch #2 into patch #1 ?
The caller and callee should be the same place in my mind.
Best regards,
Taku Izumi
> Signed-off-by: Tang Chen
> Signed-off-by: Liu Jiang
> ---
> drivers/acpi/pci_root.c | 19 ++
hild devices connecting to it.
> + */
> +static enum acpihp_slot_type __init acpihp_enum_get_slot_type(u32 dev_types)
> +{
> + BUG_ON(dev_types > 15);
> +
> + switch (dev_types) {
> + case 0:
> + /* Generic CONTAINER */
> +
> struct pci_driver *driver; /* which driver has allocated this
> device */
> u64 dma_mask; /* Mask of the bits of bus address this
> --
> 1.7.9.5
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-pci" in
&g
if "blank_state", which is intended to
reflect the state of timer, was shuffled arround.
This revised patch reflects his pointed out. I confirmed this also fixed
the problem.
Regards,
Taku Izumi <[EMAIL PROTECTED]>
Fix the graphic corruption issue on IA64 machines.
VGA co
without changing "blank_state", and when "blank_state" is
"blank_off",
"do_blank_screen() function returns without invoking sw->con_blank()
function.
That's why VGA console driver can misunderstand the current mode.
--
.
Is the original patch sufficient? or is there anything we should
correct?
Taku Izumi <[EMAIL PROTECTED]>
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at http://vger.kernel.org/maj
0 bsp=e37b0e30
[] sys_read+0x70/0xe0
sp=e37b7e20 bsp=e37b0db0
[] ia64_ret_from_syscall+0x0/0x20
sp=e37b7e30 bsp=e37b0db0
[] __kernel_syscall_via_break+0x0/0x20
sp=e37b8000 bsp=e37b0db0
Thanks,
Taku Izumi
Fix the possible NULL pointer acce
FIFO at
serial8250_console_write function like transmit_chars function. Where
should I correct in order to use FIFO?
Taku Izumi <[EMAIL PROTECTED]>
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More maj
higher than that of real serial port, this problem is exposed.
The output performance via virtual serial port is still low by using original
serial driver. I think original serial driver becomes bottoleneck.
Taku Izumi <[EMAIL PROTECTED]>
--patch
55 matches
Mail list logo