Fw: RE: [PATCH 2/3] exfat: remove useless check in exfat_move_file()

2020-10-14 Thread kohada.tetsuh...@dc.mitsubishielectric.co.jp
Thank you for continuing the discussion. The reply was delayed to summarize the arguing points. > I already gave my comment on previous thread, and I prefer de array handling > I sent instead of only two entries. We haven't discussed enough yet and I have some questions. I still don't understand

RE: [PATCH 1/2] exfat: add NameLength check when extracting name

2020-08-17 Thread kohada.tetsuh...@dc.mitsubishielectric.co.jp
Thank you for your reply. > > >> -static void exfat_get_uniname_from_ext_entry(struct super_block *sb, > > >> -struct exfat_chain *p_dir, int entry, unsigned short > > >> *uniname) > > >> +static int exfat_get_uniname_from_name_entries(struct > > >> exfat_entry_set_cache *es, >

RE: [PATCH v2] exfat: integrates dir-entry getting and validation

2020-08-03 Thread kohada.tetsuh...@dc.mitsubishielectric.co.jp
Thank you for your reply. > > diff --git a/fs/exfat/dir.c b/fs/exfat/dir.c index > > 573659bfbc55..09b85746e760 100644 > > --- a/fs/exfat/dir.c > > +++ b/fs/exfat/dir.c > > @@ -33,6 +33,7 @@ static void exfat_get_uniname_from_ext_entry(struct > > super_block *sb, { > > int i; > > struct

RE: [RFC]PATCH] exfat: integrates dir-entry getting and validation

2020-07-13 Thread kohada.tetsuh...@dc.mitsubishielectric.co.jp
Thanks for your reply. > > > > /* validiate cached dentries */ > > - for (i = 1; i < num_entries; i++) { > > - ep = exfat_get_dentry_cached(es, i); > > - if (!exfat_validate_entry(exfat_get_entry_type(ep), )) > > > + for (i = 1; i < es->num_entries; i++) { > > +

RE: [PATCH] exfat: retain 'VolumeFlags' properly

2020-07-13 Thread kohada.tetsuh...@dc.mitsubishielectric.co.jp
Thanks for your reply. > > Also, rename ERR_MEDIUM to MED_FAILURE. > I think that MEDIA_FAILURE looks better. I think so too. If so, should I change VOL_DIRTY to VOLUME_DIRTY? > > -int exfat_set_vol_flags(struct super_block *sb, unsigned short > > new_flag) > > +int exfat_set_vol_flags(struct

RE: [PATCH 1/2 v4] exfat: write multiple sectors at once

2020-06-21 Thread kohada.tetsuh...@dc.mitsubishielectric.co.jp
> 2020-06-19 17:38 GMT+09:00, Tetsuhiro Kohada : > > Write multiple sectors at once when updating dir-entries. > > Add exfat_update_bhs() for that. It wait for write completion once > > instead of sector by sector. > > It's only effective if sync enabled. > > > > Reviewed-by: Christoph Hellwig >

RE: [PATCH] exfat: remove EXFAT_SB_DIRTY flag

2020-06-15 Thread kohada.tetsuh...@dc.mitsubishielectric.co.jp
> > On 2020/06/12 17:34, Sungjong Seo wrote: > > >> remove EXFAT_SB_DIRTY flag and related codes. > > >> > > >> This flag is set/reset in exfat_put_super()/exfat_sync_fs() to > > >> avoid sync_blockdev(). > > >> However ... > > >> - exfat_put_super(): > > >> Before calling this, the VFS has

RE: [PATCH 3/3] exfat: set EXFAT_SB_DIRTY and VOL_DIRTY at the same timing

2020-06-07 Thread kohada.tetsuh...@dc.mitsubishielectric.co.jp
Thank you for your comment. > >> Can you split this patch into two? (Don't set VOL_DIRTY on -ENOTEMPTY and > >> Setting EXFAT_SB_DIRTY is > >> merged into exfat_set_vol_flag). I need to check the second one more. > > > > Can't do that. > > > > exfat_set_vol_flag() is called when rmdir processing

Re: [PATCH] exfat: optimize dir-cache

2020-05-27 Thread kohada.tetsuh...@dc.mitsubishielectric.co.jp
Thank you for your comment. >> +for (i = 0; i < es->num_bh; i++) { >> +if (es->modified) >> +exfat_update_bh(es->sb, es->bh[i], sync); > > Overall, it looks good to me. > However, if "sync" is set, it looks better to return the result of >