Re: [PATCH 6/8] mmc: dw_mmc: Generic MMC tuning with the clock phase framework

2015-09-15 Thread Jaehoon Chung
Hi, On 09/16/2015 07:09 AM, Heiko Stübner wrote: > Hi, > > Am Dienstag, 15. September 2015, 17:25:38 schrieb Jaehoon Chung: >> On 09/01/2015 03:24 AM, Heiko Stuebner wrote: >>> From: Alexandru M Stan >>> >>> This algorithm will try 1 degree increments, since there's no way

Re: [PATCH 2/3] mmc: sd: Allow calling sd mode switch with retries

2015-09-15 Thread Jaehoon Chung
Hi, On 09/10/2015 12:02 PM, Yousong Zhou wrote: > On 10 September 2015 at 08:33, Shawn Lin wrote: >> On 2015/9/10 0:33, Yousong Zhou wrote: >>> >>> This will allow retrying access mode switch to High-Speed in the >>> following commit. Well, it's not solution. (It's my

Re: [PATCH 2/3] mmc: sd: Allow calling sd mode switch with retries

2015-09-15 Thread Yousong Zhou
Hi, On 16 September 2015 at 10:36, Jaehoon Chung wrote: > Hi, > > On 09/10/2015 12:02 PM, Yousong Zhou wrote: >> On 10 September 2015 at 08:33, Shawn Lin wrote: >>> On 2015/9/10 0:33, Yousong Zhou wrote: This will allow retrying access

Re: [PATCH 6/8] mmc: dw_mmc: Generic MMC tuning with the clock phase framework

2015-09-15 Thread Heiko Stübner
Hi, Am Dienstag, 15. September 2015, 17:25:38 schrieb Jaehoon Chung: > On 09/01/2015 03:24 AM, Heiko Stuebner wrote: > > From: Alexandru M Stan > > > > This algorithm will try 1 degree increments, since there's no way to tell > > what resolution the underlying phase code

Re: [RFC PATCH v7 01/10] mmc: dw_mmc: Add external dma interface support

2015-09-15 Thread Jaehoon Chung
Hi, Shawn. Sorry for late review. On 08/24/2015 10:25 AM, Shawn Lin wrote: > DesignWare MMC Controller can supports two types of DMA > mode: external dma and internal dma. We get a RK312x platform > integrated dw_mmc and ARM pl330 dma controller. This patch add > edmac ops to support these

Re: [PATCH 1/2] mmc: core: enable CMD19 tuning for DDR50 mode

2015-09-15 Thread Barry Song
2015-08-25 20:05 GMT+08:00 Ulf Hansson : > On 20 August 2015 at 02:16, Barry Song <21cn...@gmail.com> wrote: >> 2015-08-18 1:11 GMT+08:00 Ulf Hansson : >>> On 11 August 2015 at 10:41, Barry Song <21cn...@gmail.com> wrote: From: Weijun Yang

Re: [RFC PATCH v7 02/10] mmc: dw_mmc: use macro for HCON register operations

2015-09-15 Thread Jaehoon Chung
Hi, Shawn. Looks good to me. Acked-by: Jaehoon Chung Best Regards, Jaehoon Chung On 08/24/2015 10:25 AM, Shawn Lin wrote: > This patch add some macros for HCON register operations > to make code more readable. > > Signed-off-by: Shawn Lin >

Re: [PATCH 6/8] mmc: dw_mmc: Generic MMC tuning with the clock phase framework

2015-09-15 Thread Jaehoon Chung
Dear, Heiko. On 09/01/2015 03:24 AM, Heiko Stuebner wrote: > From: Alexandru M Stan > > This algorithm will try 1 degree increments, since there's no way to tell > what resolution the underlying phase code uses. As an added bonus, doing > many tunings yields better results

Re: [PATCH 1/3] mmc: sd: Remove superfluous error code assignment

2015-09-15 Thread Ulf Hansson
On 9 September 2015 at 18:33, Yousong Zhou wrote: > Signed-off-by: Yousong Zhou Thanks, applied for next! I will comment on patch2 and patch3 separately. Kind regards Uffe > --- > drivers/mmc/core/sd.c |2 -- > 1 file changed, 2 deletions(-)

Re: [PATCH] mmc: sdhci-acpi: detect sd card reader on asus x205ta

2015-09-15 Thread Ulf Hansson
On 5 September 2015 at 08:49, Michele Curti wrote: > Add an entry to the sdhci_acpi_uids list to detect the SD card > reader on the Asus X205Ta laptop. > > dstd table: > > Device (SDHC) > { > Name (_ADR, Zero) // _ADR: Address > Name (_HID, "PNP0FFF") // _HID:

[PATCH] mmc: sdhci: call sdhci_init() before request irq

2015-09-15 Thread Haibo Chen
sdhci_init() will clear all irqs and set the needed irqs. So logically sdhci_init() should be called before request irq. If not, some irqs may be triggled and handled wrongly. Take the following into consideration, after request irq, if SDIO card interrupt enabled, a sd card in the sd slot will

Re: [PATCH 2/2] mmc: sdhci-pxav3: Print ret value on error from sdhci_add_host() fn

2015-09-15 Thread Ulf Hansson
On 2 September 2015 at 17:16, Vaibhav Hiremath wrote: > > > On Wednesday 02 September 2015 08:37 PM, Joe Perches wrote: >> >> On Wed, 2015-09-02 at 18:37 +0530, Vaibhav Hiremath wrote: >>> >>> On Wednesday 02 September 2015 02:07 AM, Joe Perches wrote: On

Re: Initial signal voltage ?

2015-09-15 Thread Fabio Estevam
On Thu, Aug 27, 2015 at 2:16 PM, Joakim Tjernlund wrote: > > None the less, the info is there in the host caps so why not use it? > If caps say 1.8V only why insist on trying 3/3.3 Volt? Yes, it seems this is similar to the issue I tried to solve before:

Re: [PATCH-v2 0/3] mmc: sdhci-pxav3: Fix tabbing issue

2015-09-15 Thread Vaibhav Hiremath
On Tuesday 15 September 2015 05:58 PM, Ulf Hansson wrote: On 7 September 2015 at 13:31, Vaibhav Hiremath wrote: Trivial patch-series, which fixes the tabbing issue in the driver, uses the BIT macro for bit fields and prints notice on -EPROBE_DEFER in

Re: [PATCH-v2 0/3] mmc: sdhci-pxav3: Fix tabbing issue

2015-09-15 Thread Ulf Hansson
On 7 September 2015 at 13:31, Vaibhav Hiremath wrote: > Trivial patch-series, which fixes the tabbing issue in the driver, > uses the BIT macro for bit fields and prints notice on -EPROBE_DEFER > in sdhci_add_host() function on regulator unavailability. > > V1 => V2 >

[PATCH] mmc: core: Convert __mmc_switch() into an internal core function

2015-09-15 Thread Ulf Hansson
As there are no users of the __mmc_switch() API, except for the mmc core itself, let's convert it from an exported function into an internal. Signed-off-by: Ulf Hansson --- drivers/mmc/core/mmc_ops.c | 1 - drivers/mmc/core/mmc_ops.h | 3 +++ include/linux/mmc/core.h |