Re: [RFC 1/3 v3] mm: iommu: An API to unify IOMMU, CPU and device memory management

2010-07-21 Thread Russell King - ARM Linux
On Wed, Jul 21, 2010 at 11:19:58AM +0530, Shilimkar, Santosh wrote: > > -Original Message- > > From: linux-arm-kernel-boun...@lists.infradead.org [mailto:linux-arm- > > kernel-boun...@lists.infradead.org] On Behalf Of Russell King - ARM Linux > > Sent: Wednesday, July 21, 2010 4:00 AM > > T

RE: [RFC 1/3 v3] mm: iommu: An API to unify IOMMU, CPU and device memory management

2010-07-21 Thread Shilimkar, Santosh
> -Original Message- > From: Russell King - ARM Linux [mailto:li...@arm.linux.org.uk] > Sent: Wednesday, July 21, 2010 12:59 PM > To: Shilimkar, Santosh > Cc: step...@codeaurora.org; linux-a...@vger.kernel.org; > dwal...@codeaurora.org; m...@csn.ul.ie; linux-arm-...@vger.kernel.org; > linux

RE: [PATCH 2/2] omap:mailbox-provide multiple reader support

2010-07-21 Thread ext-phil.2.carmody
Apologies - top posting and not quoting properly due to having to use MS's braindead OWA. It appears that most of the "changes" are simply indentation changes caused by the inclusion of a new inner block here: + if (atomic_inc_return(&mbox->use_count) == 1) { rather than just using a goto

RE: [PATCH] omap4: fb: Adds missing display update call when panning

2010-07-21 Thread Janorkar, Mayuresh
> -Original Message- > From: Shilimkar, Santosh > Sent: Thursday, July 15, 2010 6:19 PM > To: Janorkar, Mayuresh; tomi.valkei...@nokia.com > Cc: linux-omap@vger.kernel.org; Diaz Prado, Gustavo > Subject: RE: [PATCH] omap4: fb: Adds missing display update call when > panning > > > -Orig

RE: [PATCH 1/3] OMAP: DSS2: Zorder enum in display.h

2010-07-21 Thread Premi, Sanjeev
> -Original Message- > From: linux-omap-ow...@vger.kernel.org > [mailto:linux-omap-ow...@vger.kernel.org] On Behalf Of Archit Taneja > Sent: Monday, July 19, 2010 5:40 PM > To: tomi.valkei...@nokia.com > Cc: linux-omap@vger.kernel.org; Semwal, Sumit; Nilofer, > Samreen; Taneja, Archit > S

Re: [PATCH] [ARM] video/omap2/tdo35s: fix visual artefacts

2010-07-21 Thread Igor Grinberg
ping! > TDO35S samples the data on the falling adge of the pixel clock, > therefore the data strobe should be on the raising edge. > > Signed-off-by: Igor Grinberg > Signed-off-by: Mike Rapoport > --- > .../video/omap2/displays/panel-toppoly-tdo35s.c|8 ++-- > 1 files changed, 6 inse

RE: [PATCH 08/11] staging: tidspbridge: remove IN modifier

2010-07-21 Thread Ramirez Luna, Omar
Hi, >From: Menon, Nishanth > >IN modifier does not exist. remove it > >Signed-off-by: Nishanth Menon >--- [...] >diff --git a/drivers/staging/tidspbridge/include/dspbridge/drv.h >b/drivers/staging/tidspbridge/include/dspbridge/drv.h >index 020bed0..753a317 100644 >--- a/drivers/staging/tidspbridg

Re: [PATCH 08/11] staging: tidspbridge: remove IN modifier

2010-07-21 Thread Nishanth Menon
On Wed, Jul 21, 2010 at 9:59 AM, Ramirez Luna, Omar wrote: > Hi, > >>From: Menon, Nishanth >> >>IN modifier does not exist. remove it >> >>Signed-off-by: Nishanth Menon >>--- > [...] >>diff --git a/drivers/staging/tidspbridge/include/dspbridge/drv.h >>b/drivers/staging/tidspbridge/include/dspbrid

[PATCH] omap: Add macros to evaluate cpu revision

2010-07-21 Thread Sanjeev Premi
This patch adds macros to evaluate the cpu revision. These macros increase readability by reducing the repetitive code when multiple silicon and their revisions have to be tested. Example usage would be: if (cpu_rev_eq(omap34xx, ES_1_0)) Signed-off-by: Sanjeev Premi --- arch/arm/plat-omap/inc

Re: [PATCH] omap: Add macros to evaluate cpu revision

2010-07-21 Thread Nishanth Menon
Premi, Sanjeev had written, on 07/21/2010 10:12 AM, the following: This patch adds macros to evaluate the cpu revision. These macros increase readability by reducing the repetitive code when multiple silicon and their revisions have to be tested. Example usage would be: if (cpu_rev_eq(omap34xx

Re: Buffer overrun in the TWL4030 keypad driver with Nokia RX51

2010-07-21 Thread Laurent Pinchart
Hi Dmitry, On Tuesday 20 July 2010 20:07:45 Dmitry Torokhov wrote: > On Tuesday, July 20, 2010 04:06:08 am Laurent Pinchart wrote: > > On Saturday 17 July 2010 23:37:05 Dmitry Torokhov wrote: > > > On Fri, Jul 16, 2010 at 05:28:43PM +0200, Laurent Pinchart wrote: > > > > I've spent the day debuggi

[PATCH] omap3: Prevent SDRC deadlock when L3 is changing frequency

2010-07-21 Thread Jon Hunter
From: Jon Hunter When changing the L3 clock frequency, the CPU is executing from internal RAM and the SDRC clock is disabled. During this time accesses made to external DDR are stalled. If the ARM subsystem attempts to access the DDR while the SDRC clock is disabled this will stall the CPU until

[PATCH v2 00/20] native support for wl1271 on ZOOM

2010-07-21 Thread Ohad Ben-Cohen
This patch series adds native support for wl1271 on ZOOM. Changes since v1: - introduce a fixed regulator device to control the power of wl1271 - allow to propagate private board-specific data to SDIO function drivers - allow SDIO function driver to control the card's power via new API - make it

[PATCH v2 01/20] sdio: add TI + wl1271 ids

2010-07-21 Thread Ohad Ben-Cohen
Add SDIO IDs for TI and for TI's wl1271 wlan device. Signed-off-by: Ohad Ben-Cohen --- include/linux/mmc/sdio_ids.h |3 +++ 1 files changed, 3 insertions(+), 0 deletions(-) diff --git a/include/linux/mmc/sdio_ids.h b/include/linux/mmc/sdio_ids.h index 33b2ea0..0d313c6 100644 --- a/include/l

[PATCH v2 02/20] wireless: wl1271: remove SDIO IDs from driver

2010-07-21 Thread Ohad Ben-Cohen
Remove SDIO IDs from the driver code since now it is included in linux/mmc/sdio_ids.h. Signed-off-by: Ohad Ben-Cohen --- drivers/net/wireless/wl12xx/wl1271_sdio.c |8 1 files changed, 0 insertions(+), 8 deletions(-) diff --git a/drivers/net/wireless/wl12xx/wl1271_sdio.c b/drivers/

[PATCH v2 03/20] mmc: support embedded data field in mmc_host

2010-07-21 Thread Ohad Ben-Cohen
Add support to set/get mmc_host private embedded data. This is needed to allow software to dynamically create (and remove) SDIO functions which represents embedded SDIO devices. Typically, it will be used to set the context of a driver that is creating a new SDIO function (and would then expect t

[PATCH v2 04/20] omap zoom2: wlan board muxing

2010-07-21 Thread Ohad Ben-Cohen
Add board muxing to support the wlan wl1271 chip that is hardwired to mmc2 (third mmc controller) on the ZOOM2. Signed-off-by: Ohad Ben-Cohen --- arch/arm/mach-omap2/board-zoom2.c | 13 + 1 files changed, 13 insertions(+), 0 deletions(-) diff --git a/arch/arm/mach-omap2/board-zoom

[PATCH v2 05/20] omap zoom3: wlan board muxing

2010-07-21 Thread Ohad Ben-Cohen
Add board muxing to support the wlan wl1271 chip that is hardwired to mmc2 (third mmc controller) on the ZOOM3. Signed-off-by: Ohad Ben-Cohen --- arch/arm/mach-omap2/board-zoom3.c | 13 + 1 files changed, 13 insertions(+), 0 deletions(-) diff --git a/arch/arm/mach-omap2/board-zoom

[PATCH v2 06/20] wireless: wl1271: make wl12xx.h common to both spi and sdio

2010-07-21 Thread Ohad Ben-Cohen
Move wl12xx.h outside of the spi-specific location, so it can be shared with both spi and sdio solutions. Signed-off-by: Ohad Ben-Cohen --- drivers/net/wireless/wl12xx/wl1251_sdio.c |2 +- drivers/net/wireless/wl12xx/wl1251_spi.c |2 +- drivers/net/wireless/wl12xx/wl1271_spi.c |2 +

[PATCH v2 07/20] wireless: wl1271: support return value for the set power func

2010-07-21 Thread Ohad Ben-Cohen
Make it possible for the set power method to indicate a success/failure return value. This is needed to support more complex power on/off operations such as bringing up (and down) sdio functions. Signed-off-by: Ohad Ben-Cohen --- drivers/net/wireless/wl12xx/wl1271.h |2 +- drivers/net/w

[PATCH v2 08/20] wireless: wl1271: take irq info from private board data

2010-07-21 Thread Ohad Ben-Cohen
Remove the hard coded irq information, and instead take the irq information from the board private data which is supplied by the sdio function. Signed-off-by: Ohad Ben-Cohen --- drivers/net/wireless/wl12xx/wl1271_sdio.c | 14 -- 1 files changed, 8 insertions(+), 6 deletions(-) dif

[PATCH v2 09/20] wireless: wl1271: make ref_clock configurable by board

2010-07-21 Thread Ohad Ben-Cohen
The wl1271 device is using a reference clock that may change between board to board. Make the ref_clock parameter configurable by the board files that set up the device, instead of having a hard coded value in the driver source itself. Signed-off-by: Ohad Ben-Cohen --- drivers/net/wireless/wl12

[PATCH v2 10/20] omap: zoom: add fixed regulator device for wlan

2010-07-21 Thread Ohad Ben-Cohen
Add a fixed regulator vmmc device to enable power control of the wl1271 wlan device. Signed-off-by: Ohad Ben-Cohen --- arch/arm/mach-omap2/board-zoom-peripherals.c | 34 ++ 1 files changed, 34 insertions(+), 0 deletions(-) diff --git a/arch/arm/mach-omap2/board-zoom-pe

[PATCH v2 11/20] omap: hsmmc: support mmc3 regulator power control

2010-07-21 Thread Ohad Ben-Cohen
Prepare for mmc3 regulator power control by splitting the power control functions of mmc2 and mmc3, and expecting mmc3 to have a single, dedicated, regulator support. Signed-off-by: Ohad Ben-Cohen --- arch/arm/mach-omap2/hsmmc.c | 10 -- drivers/mmc/host/omap_hsmmc.c | 67 +

[PATCH v2 13/20] omap: zoom: add mmc3/wl1271 device support

2010-07-21 Thread Ohad Ben-Cohen
Add MMC3 support on ZOOM, which has the wl1271 device hardwired to. The wl1271 is a 4-wire, 1.8V, embedded SDIO WLAN device with an external IRQ line, and power-controlled by a GPIO-based fixed regulator. Signed-off-by: Ohad Ben-Cohen --- arch/arm/mach-omap2/board-zoom-peripherals.c | 19

[PATCH v2 12/20] omap: hsmmc: allow board-specific settings of private mmc data

2010-07-21 Thread Ohad Ben-Cohen
Allow board-specific settings of private mmc data, in order to allow embedded SDIO devices to communicate board-specific parameters to the SDIO function driver (e.g., the external IRQ line of the wl1271). Signed-off-by: Ohad Ben-Cohen --- arch/arm/mach-omap2/hsmmc.c |2 ++ arch/arm

[PATCH v2 14/20] mmc: sdio: fully reconfigure oldcard on resume

2010-07-21 Thread Ohad Ben-Cohen
On resume, let mmc_sdio_init_card go all the way, instead of skipping the reconfiguration of the card's speed and width. This is needed to ensure cards wake up with their clock reconfigured (otherwise it's kept low). This patch also removes the explicit bus width reconfiguration on resume, since

[PATCH v2 15/20] mmc: sdio: verify existence of resume handler

2010-07-21 Thread Ohad Ben-Cohen
Before invoking a card's resume handler, verify one exists. Signed-off-by: Ohad Ben-Cohen --- drivers/mmc/core/sdio.c |4 +++- 1 files changed, 3 insertions(+), 1 deletions(-) diff --git a/drivers/mmc/core/sdio.c b/drivers/mmc/core/sdio.c index 645f173..37739f5 100644 --- a/drivers/mmc/core

[PATCH v2 16/20] mmc: introduce API to control the card's power

2010-07-21 Thread Ohad Ben-Cohen
Introduce the sdio_claim_power/sdio_release_power API (with correspoding mmc_claim_power/mmc_release_power) that controls the power of the card. A reference count scheme is employed, to allow SDIO function voting. Signed-off-by: Ohad Ben-Cohen --- drivers/mmc/core/bus.c|3 ++ drivers

[PATCH v2 17/20] mmc: sdio: relocate sdio_set_block_size call

2010-07-21 Thread Ohad Ben-Cohen
To support probing of SDIO function driver while the device is powered off, we need to relocate the sdio_set_block_size call from the bus probe to an earlier point where we know the device is still powered. In addition, we want the block size set also when cards are resumed. Signed-off-by: Ohad Be

[PATCH v2 20/20] wireless: wl1271: call SDIO claim/release power API

2010-07-21 Thread Ohad Ben-Cohen
call SDIO claim/release power API to turn the wl1271 power on and off Signed-off-by: Ohad Ben-Cohen --- drivers/net/wireless/wl12xx/wl1271_sdio.c |2 ++ 1 files changed, 2 insertions(+), 0 deletions(-) diff --git a/drivers/net/wireless/wl12xx/wl1271_sdio.c b/drivers/net/wireless/wl12xx/wl1

[PATCH v2 18/20] mmc: sdio: enable a default power off mode of the card

2010-07-21 Thread Ohad Ben-Cohen
Add support for an SDIO device to stay powered off even without the presence of an SDIO function driver. A host should explicitly ask for it by means of MMC_CAP_DONT_POWER_CARD, and the SDIO function driver should know it needs to call sdio_claim_power before accessing the device. Signed-off-by: O

[PATCH v2 19/20] omap: zoom: keep the MMC3 wl1271 device powered off

2010-07-21 Thread Ohad Ben-Cohen
Keep the MMC3 wl1271 WLAN device powered off until its SDIO function driver requests otherwise. Signed-off-by: Ohad Ben-Cohen --- arch/arm/mach-omap2/board-zoom-peripherals.c |1 + arch/arm/mach-omap2/hsmmc.c |3 +++ arch/arm/mach-omap2/hsmmc.h |1 +

Re: [PATCH v2 01/20] sdio: add TI + wl1271 ids

2010-07-21 Thread Marcel Holtmann
Hi Ohad, > Add SDIO IDs for TI and for TI's wl1271 wlan device. > > Signed-off-by: Ohad Ben-Cohen > --- > include/linux/mmc/sdio_ids.h |3 +++ > 1 files changed, 3 insertions(+), 0 deletions(-) > > diff --git a/include/linux/mmc/sdio_ids.h b/include/linux/mmc/sdio_ids.h > index 33b2ea0..0d

Re: [PATCH v2 10/20] omap: zoom: add fixed regulator device for wlan

2010-07-21 Thread Mark Brown
On Wed, Jul 21, 2010 at 08:33:44PM +0300, Ohad Ben-Cohen wrote: > +static struct regulator_consumer_supply zoom_vmmc3_supply = { > + .supply = "vmmc", > +}; This looks like a misconfiguration on the consumer - I'd strongly expect the consumer to have a dev_name specified also with the

Re: [RFC 1/3 v3] mm: iommu: An API to unify IOMMU, CPU and device memory management

2010-07-21 Thread stepanm
> * >> > This is difficult to achieve without remapping kernel memory using L2 >> > page tables, so we can unmap pages on 4K page granularity. That's >> > going to increase TLB overhead and result in lower system performance >

RE: [PATCH v2 19/20] omap: zoom: keep the MMC3 wl1271 device powered off

2010-07-21 Thread Gabay, Benzy
Ohad, -Original Message- From: Ohad Ben-Cohen [mailto:o...@wizery.com] Sent: Wednesday, July 21, 2010 12:34 PM To: linux-wirel...@vger.kernel.org; linux-...@vger.kernel.org; linux-omap@vger.kernel.org Cc: linux-arm-ker...@lists.infradead.org; li...@arm.linux.org.uk; Chikkature Rajashek

[PATCH] OMAP2: OMAPFB: Fix invalid bpp for PAL and NTSC modes

2010-07-21 Thread Maurus Cuelenaere
omapfb_mode_to_timings() sets the bpp to 0 when bootarg omapfb.mode is set to either "pal" or "ntsc". This patch corrects this by setting the bpp to 24, as would be done if omapdss_default_get_recommended_bpp() would be called Signed-off-by: Maurus Cuelenaere --- drivers/video/omap2/omapfb/omapf

Question about armv7(cortex-a9) dcache initialization.

2010-07-21 Thread ikjn
In the ARM Cortex-A9 TRM, I found a note in chapter 6.1 Note: You must invalidate the instruction cache, the data cache, and BTAC before using them. You are not required to invalidate the main TLB, even though it is recommended for safety reasons. This ensures compatibility with future revisions o

Re: [RFC 3/3] mm: iommu: The Virtual Contiguous Memory Manager

2010-07-21 Thread Zach Pfeffer
On Wed, Jul 14, 2010 at 10:59:43AM +0900, FUJITA Tomonori wrote: > On Tue, 13 Jul 2010 10:02:23 +0100 > > Zach Pfeffer said this new VCM infrastructure can be useful for > video4linux. However, I don't think we need 3,000-lines another > abstraction layer to solve video4linux's issue nicely. Its

Re: [RFC 1/3 v3] mm: iommu: An API to unify IOMMU, CPU and device memory management

2010-07-21 Thread Zach Pfeffer
On Tue, Jul 20, 2010 at 09:44:12PM -0400, Timothy Meade wrote: > On Tue, Jul 20, 2010 at 8:44 PM, Zach Pfeffer wrote: > > On Mon, Jul 19, 2010 at 05:21:35AM -0400, Tim HRM wrote: > >> On Fri, Jul 16, 2010 at 8:01 PM, Larry Bassel > >> wrote: > >> > On 16 Jul 10 08:58, Russell King - ARM Linux wr

RE: [PATCH 1/3] OMAP: DSS2: Zorder enum in display.h

2010-07-21 Thread Taneja, Archit
> -Original Message- > From: Premi, Sanjeev > Sent: Wednesday, July 21, 2010 7:47 PM > To: Taneja, Archit; tomi.valkei...@nokia.com > Cc: linux-omap@vger.kernel.org; Semwal, Sumit; Nilofer, > Samreen; Taneja, Archit > Subject: RE: [PATCH 1/3] OMAP: DSS2: Zorder enum in display.h > > >

Re: [RFC 1/3 v3] mm: iommu: An API to unify IOMMU, CPU and device memory management

2010-07-21 Thread Zach Pfeffer
On Mon, Jul 19, 2010 at 12:44:49AM -0700, Eric W. Biederman wrote: > Zach Pfeffer writes: > > > On Thu, Jul 15, 2010 at 09:55:35AM +0100, Russell King - ARM Linux wrote: > >> On Wed, Jul 14, 2010 at 06:29:58PM -0700, Zach Pfeffer wrote: > >> > The VCM ensures that all mappings that map a given ph

Re: [RFC 1/3 v3] mm: iommu: An API to unify IOMMU, CPU and device memory management

2010-07-21 Thread Zach Pfeffer
On Wed, Jul 21, 2010 at 10:44:37AM +0900, FUJITA Tomonori wrote: > On Tue, 20 Jul 2010 15:20:01 -0700 > Zach Pfeffer wrote: > > > > I'm not saying that it's reasonable to pass (or even allocate) a 1MB > > > buffer via the DMA API. > > > > But given a bunch of large chunks of memory, is there any

Re: [RFC 1/3 v3] mm: iommu: An API to unify IOMMU, CPU and device memory management

2010-07-21 Thread FUJITA Tomonori
On Wed, 21 Jul 2010 21:30:34 -0700 Zach Pfeffer wrote: > On Wed, Jul 21, 2010 at 10:44:37AM +0900, FUJITA Tomonori wrote: > > On Tue, 20 Jul 2010 15:20:01 -0700 > > Zach Pfeffer wrote: > > > > > > I'm not saying that it's reasonable to pass (or even allocate) a 1MB > > > > buffer via the DMA AP

Re: [RFC 3/3] mm: iommu: The Virtual Contiguous Memory Manager

2010-07-21 Thread FUJITA Tomonori
On Wed, 21 Jul 2010 20:50:26 -0700 Zach Pfeffer wrote: > On Wed, Jul 14, 2010 at 10:59:43AM +0900, FUJITA Tomonori wrote: > > On Tue, 13 Jul 2010 10:02:23 +0100 > > > > Zach Pfeffer said this new VCM infrastructure can be useful for > > video4linux. However, I don't think we need 3,000-lines ano

RE: [PATCH] omap: Add macros to evaluate cpu revision

2010-07-21 Thread Gadiyar, Anand
> > @@ -460,4 +461,35 @@ OMAP3_HAS_FEATURE(isp, ISP) > > OMAP3_HAS_FEATURE(192mhz_clk, 192MHZ_CLK) > > OMAP3_HAS_FEATURE(io_wakeup, IO_WAKEUP) > > > > +/* > > + * Map revision bits to silicon specific revisions > > + */ > > +#define ES_1_0 OMAP_REVBITS_00 > probably need ES_1_1, 1_2