Hi Rajendra,
On 03/14/2014 04:20 AM, Nayak, Rajendra wrote:
The only difference from the dra75x devices is the missing .smp entry.
Signed-off-by: Rajendra Nayak
---
arch/arm/mach-omap2/board-generic.c | 18 ++
1 file changed, 18 insertions(+)
diff --git a/arch/arm/mach-om
Hi Santosh, Laurent, Russell, Arnd,
On 03/14/2014 12:51 PM, Santosh Shilimkar wrote:
On Friday 14 March 2014 12:38 PM, Laurent Pinchart wrote:
Hi Santosh,
On Friday 14 March 2014 12:15:11 Santosh Shilimkar wrote:
+ Russell, Arnd
On Thursday 13 March 2014 10:47 PM, Anna, Suman wrote:
On 03/0
On 03/14/2014 07:13 PM, Suman Anna wrote:
> Hi Joel,
>
> On 03/13/2014 03:35 PM, Joel Fernandes wrote:
>> We introduce functions to initialize clocksource and clockevent, use
>> CLOCKSOURCE_OF_DECLARE to declare the clocksource, and handle the
>> clocksource
>> selection on a per-SoC basis (Curren
Hi Laurent,
>>
On 03/07/2014 06:46 PM, Laurent Pinchart wrote:
Flushing the TLB before updating translation entries creates a race
condition and can lead to stale TLB entries if a translation request
arrives between flushing the TLB and updating the translation entries.
As there's no requiremen
Hi Laurent,
On 03/14/2014 04:46 AM, Laurent Pinchart wrote:
Hi Suman,
Thank you for the review.
On Thursday 13 March 2014 19:07:33 Suman Anna wrote:
On 03/07/2014 06:46 PM, Laurent Pinchart wrote:
The prot flags passed to the IOMMU map handler are defined in
include/linux/iommu.h as IOMMU_(R
Hi Joel,
On 03/13/2014 03:35 PM, Joel Fernandes wrote:
We introduce functions to initialize clocksource and clockevent, use
CLOCKSOURCE_OF_DECLARE to declare the clocksource, and handle the clocksource
selection on a per-SoC basis (Currently only AM335x is supported). Powering up
of the timer wi
Hi Ohad,
On 03/14/2014 03:10 PM, Ohad Ben-Cohen wrote:
Hi Suman, Mark,
On Mon, Feb 24, 2014 at 8:14 PM, Suman Anna wrote:
Mark, Ohad,
...
Gentle reminder, can you provide your acks/comments?
Sorry for the late jump in.
I have a few comments:
Thanks for the comments. It probably covers
On Fri, Mar 14, 2014 at 4:09 PM, Kevin Hilman wrote:
> Joel Fernandes writes:
>
>> On 03/13/2014 04:52 PM, Rob Herring wrote:
>>> On Thu, Mar 13, 2014 at 3:35 PM, Joel Fernandes wrote:
Introduce a generic omap timer initialization function that can
be used by all SoCs for which support
Joel Fernandes writes:
> On 03/13/2014 04:52 PM, Rob Herring wrote:
>> On Thu, Mar 13, 2014 at 3:35 PM, Joel Fernandes wrote:
>>> Introduce a generic omap timer initialization function that can
>>> be used by all SoCs for which support is available in the clocksource
>>> driver introduced in the
On Fri, Mar 14, 2014 at 2:25 PM, Dave Gerlach wrote:
> Driver to read from a register and depending on either set bits or
> a specific known selectively enable or disable OPPs based on DT node.
>
> Can support opp-modifier-reg-bit where single bits within the register
> determine the availability
Hi Suman, Mark,
On Mon, Feb 24, 2014 at 8:14 PM, Suman Anna wrote:
> Mark, Ohad,
...
> Gentle reminder, can you provide your acks/comments?
Sorry for the late jump in.
I have a few comments:
- Hardware spinlocks must have global and system-wide id numbers;
these numbers cannot be maintained in
On Fri, Mar 14, 2014 at 05:34:29PM +0200, Roger Quadros wrote:
> On 03/14/2014 04:54 PM, Kishon Vijay Abraham I wrote:
> >
> >
> > On Friday 14 March 2014 05:41 PM, Roger Quadros wrote:
> >> On 03/14/2014 12:38 PM, Kishon Vijay Abraham I wrote:
> >>> Hi Roger,
> >>>
> >>> On Friday 07 March 2014
On Fri, Mar 14, 2014 at 11:36:40AM +0100, Linus Walleij wrote:
> On Thu, Mar 13, 2014 at 10:12 AM, Pavel Machek wrote:
> > But... what would actually help: I believe we should introduce
> > milivolt_t, miliamp_t, milisec_t etc... types. Storing milivolts in
> > int, then having comment saying "mi
On 03/14/2014 02:32 PM, Joel Fernandes wrote:
> On 03/14/2014 10:52 AM, Tony Lindgren wrote:
>> * Joel Fernandes [140313 16:52]:
>>> On 03/13/2014 03:48 PM, Tony Lindgren wrote:
* Joel Fernandes [140313 13:43]:
> We introduce functions to initialize clocksource and clockevent, use
>
On 03/14/2014 10:52 AM, Tony Lindgren wrote:
> * Joel Fernandes [140313 16:52]:
>> On 03/13/2014 03:48 PM, Tony Lindgren wrote:
>>> * Joel Fernandes [140313 13:43]:
We introduce functions to initialize clocksource and clockevent, use
CLOCKSOURCE_OF_DECLARE to declare the clocksource, an
Add an entry for opp_modifier which configures OPPs on am33xx. Within this
nodes are defined with opp-modifier propety that are defined as a list
of frequency, offset from base register, and efuse value. The CPU node
passes a phandle to the appropriate child node of the efuse node.
This patch also
Add an entry for opp_modifier which configures OPPs on omap443x. Within
this, nodes are defined with the opp-modifier propety that are defined as
a list of frequency, offset from base register, and register value. The
CPU node passes a phandle to the appropriate child node to get the correct
table.
Introduce framework to allow an OPP modifier driver to selectively
determine which possible OPPs for an SoC are available based on
register values found in SoC through a common API.
Three functions are exported, a register and unregister function for
the opp modifier drivers to notify the API of t
Add an entry for opp_modifier which configures OPPs on imx6q. Within
this nodes are defined with opp-modifier propety that are defined as a list
of frequency, offset from base register, and efuse value.
This is an untested example patch to show how opp-modifier could be used
for this platform.
Si
Driver to read from a register and depending on either set bits or
a specific known selectively enable or disable OPPs based on DT node.
Can support opp-modifier-reg-bit where single bits within the register
determine the availability of an OPP or opp-modifier-reg-val where a
certain value inside
Add an entry for opp_modifier which configures OPPs on AM4372. Within
this, nodes are defined with the opp-modifier propety that are defined as
a list of frequency, offset from base register, and efuse value.
The CPU node passes a phandle to the appropriate child node to get the
correct table.
Thi
There are many SoCs that can have different operating points supported
depending on different conditions even for otherwise identical parts.
It does not make sense to define many different iterations of a device tree
file for each possible permutation of the same device especially when this data
m
Add an entry for opp_modifier which configures OPPs on omap4460. Within
this, nodes are defined with the opp-modifier propety that are defined
as a list of frequency, offset from base register, and register value.
The CPU node passes a phandle to the appropriate child node to get the
correct table.
Add an entry for opp-modifier which configures OPPs on 43xx. Within
this, nodes are defined with the opp-modifier propety that are defined as
a list of frequency, offset from base register, and efuse value.
The CPU node passes a phandle to the appropriate child node to get the
correct table.
This
Add a hook inside opp_init_cpufreq_table to allow all cpufreq drivers
to utilize OPP modifier functionality. Hook will return success if no
phandle is present for devices that do not use opp-modifier.
Signed-off-by: Dave Gerlach
---
drivers/base/power/opp.c | 8
1 file changed, 8 insert
On Fri, Mar 14, 2014 at 04:34:19PM +, Tomi Valkeinen wrote:
> On 14/03/14 18:04, Felipe Balbi wrote:
> > On Fri, Mar 14, 2014 at 02:07:45PM +, Mark Rutland wrote:
> >> On Fri, Mar 14, 2014 at 11:07:05AM +, Tomi Valkeinen wrote:
> >>> On 14/03/14 12:19, Tomi Valkeinen wrote:
> On 14
On Friday 14 March 2014 12:57 PM, Arnd Bergmann wrote:
> On Friday 14 March 2014, Santosh Shilimkar wrote:
>> I remember NAKing this approach in past and my stand remains same.
>> The cache APIs which you are trying to use here are not suppose
>> to be used outside.
>>
>> I think the right way to f
On Friday 14 March 2014 12:38 PM, Laurent Pinchart wrote:
> Hi Santosh,
>
> On Friday 14 March 2014 12:15:11 Santosh Shilimkar wrote:
>> + Russell, Arnd
>>
>> On Thursday 13 March 2014 10:47 PM, Anna, Suman wrote:
>>> On 03/07/2014 06:46 PM, Laurent Pinchart wrote:
The page table entries must
On Friday 14 March 2014, Santosh Shilimkar wrote:
> I remember NAKing this approach in past and my stand remains same.
> The cache APIs which you are trying to use here are not suppose
> to be used outside.
>
> I think the right way to fix this is to make use of streaming APIs.
> If needed, IOMMU
Hi Santosh,
On Friday 14 March 2014 12:15:11 Santosh Shilimkar wrote:
> + Russell, Arnd
>
> On Thursday 13 March 2014 10:47 PM, Anna, Suman wrote:
> > On 03/07/2014 06:46 PM, Laurent Pinchart wrote:
> >> The page table entries must be cleaned from the cache before being
> >> accessed by the IOMMU
On 14/03/14 18:04, Felipe Balbi wrote:
> On Fri, Mar 14, 2014 at 02:07:45PM +, Mark Rutland wrote:
>> On Fri, Mar 14, 2014 at 11:07:05AM +, Tomi Valkeinen wrote:
>>> On 14/03/14 12:19, Tomi Valkeinen wrote:
On 14/03/14 12:14, Mark Rutland wrote:
> I can't see anything obviousl
+ Russell, Arnd
On Thursday 13 March 2014 10:47 PM, Anna, Suman wrote:
> Hi Laurent,
>
> On 03/07/2014 06:46 PM, Laurent Pinchart wrote:
>> The page table entries must be cleaned from the cache before being
>> accessed by the IOMMU. Instead of implementing cache management manually
>> (and ignori
On Fri, Mar 14, 2014 at 02:07:45PM +, Mark Rutland wrote:
> On Fri, Mar 14, 2014 at 11:07:05AM +, Tomi Valkeinen wrote:
> > On 14/03/14 12:19, Tomi Valkeinen wrote:
> > > On 14/03/14 12:14, Mark Rutland wrote:
> > >
> > >> I can't see anything obviously wrong in platform_device_del. Do you
* Joel Fernandes [140313 16:52]:
> On 03/13/2014 03:48 PM, Tony Lindgren wrote:
> > * Joel Fernandes [140313 13:43]:
> >> We introduce functions to initialize clocksource and clockevent, use
> >> CLOCKSOURCE_OF_DECLARE to declare the clocksource, and handle the
> >> clocksource
> >> selection on
On 03/14/2014 04:54 PM, Kishon Vijay Abraham I wrote:
>
>
> On Friday 14 March 2014 05:41 PM, Roger Quadros wrote:
>> On 03/14/2014 12:38 PM, Kishon Vijay Abraham I wrote:
>>> Hi Roger,
>>>
>>> On Friday 07 March 2014 06:39 PM, Roger Quadros wrote:
Add nodes for the Super Speed USB controlle
On Fri, Mar 14, 2014 at 03:12:26PM +0200, Ohad Ben-Cohen wrote:
> On Sun, Mar 2, 2014 at 10:19 PM, Bjorn Andersson wrote:
> > When introducing the ability to reference a hwspin lock via a phandle
> > in device tree it makes a big difference to be able to differ between
> > the case of "initializat
On Friday 14 March 2014 05:41 PM, Roger Quadros wrote:
On 03/14/2014 12:38 PM, Kishon Vijay Abraham I wrote:
Hi Roger,
On Friday 07 March 2014 06:39 PM, Roger Quadros wrote:
Add nodes for the Super Speed USB controllers, omap-control-usb,
USB2 PHY and USB3 PHY devices.
Remove ocp2scp1 addre
On Fri, Mar 14, 2014 at 11:07:05AM +, Tomi Valkeinen wrote:
> On 14/03/14 12:19, Tomi Valkeinen wrote:
> > On 14/03/14 12:14, Mark Rutland wrote:
> >
> >> I can't see anything obviously wrong in platform_device_del. Do you have
> >> a backtrace?
> >
> > Yes, below.
> >
> > I can see at least
On Sun, Mar 2, 2014 at 10:19 PM, Bjorn Andersson wrote:
> When introducing the ability to reference a hwspin lock via a phandle
> in device tree it makes a big difference to be able to differ between
> the case of "initialization failed" or "device not yet probed"; so
> that the client knows if it
On 03/14/2014 12:38 PM, Kishon Vijay Abraham I wrote:
> Hi Roger,
>
> On Friday 07 March 2014 06:39 PM, Roger Quadros wrote:
>> Add nodes for the Super Speed USB controllers, omap-control-usb,
>> USB2 PHY and USB3 PHY devices.
>>
>> Remove ocp2scp1 address space from hwmod data as it is
>> now pro
I have proposal for you.
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
On 14/03/14 12:19, Tomi Valkeinen wrote:
> On 14/03/14 12:14, Mark Rutland wrote:
>
>> I can't see anything obviously wrong in platform_device_del. Do you have
>> a backtrace?
>
> Yes, below.
>
> I can see at least drivers/usb/dwc3/dwc3-exynos.c doing the exact same thing
> I do, so maybe I've g
Hi Suman,
(CC'ing Joerg Roedel and Marek Szyprowski for the core IOMMU discussion)
On Thursday 13 March 2014 21:33:37 Suman Anna wrote:
> On 03/07/2014 06:46 PM, Laurent Pinchart wrote:
> > Hello,
> >
> > This patch set fixes miscellaneous issues with the OMAP IOMMU driver,
> > found when trying
Hi Roger,
On Friday 07 March 2014 06:39 PM, Roger Quadros wrote:
Add nodes for the Super Speed USB controllers, omap-control-usb,
USB2 PHY and USB3 PHY devices.
Remove ocp2scp1 address space from hwmod data as it is
now provided via device tree.
Signed-off-by: Roger Quadros
---
arch/arm/boo
On Thu, Mar 13, 2014 at 10:12 AM, Pavel Machek wrote:
> Hi!
>
>> > 30*HZ means 30 seconds in the kernel... what is hard to understand
>> > about it?
>>
>> Well I might be picky, but since it is a charging algorithm dealing with
>> ampères, volts, constant-current/constant-voltage, watchdogs and
>>
On 14/03/14 12:14, Mark Rutland wrote:
> I can't see anything obviously wrong in platform_device_del. Do you have
> a backtrace?
Yes, below.
I can see at least drivers/usb/dwc3/dwc3-exynos.c doing the exact same thing
I do, so maybe I've got something wrong with the omapdss driver.
Tomi
[ 6
On Fri, Mar 14, 2014 at 09:42:26AM +, Tomi Valkeinen wrote:
> On 14/03/14 11:10, Mark Rutland wrote:
>
> > The "simple-bus" compatible string is intended for busses which are
> > transparent (bar some address remapping expressed via ranges), and is
> > not intended as an annotation to get Linu
On Fri, Mar 14, 2014 at 11:38:58AM +0200, Peter Ujfalusi wrote:
> The only thing I'm afraid off is that it is going to take two release cycle to
> get this in: first cycle edma part, next cycle for the ASoC to switch to use
> the edma-pcm.
We can do a cross tree merge, or the EDMA code can be app
Hi Suman,
On Thursday 13 March 2014 17:27:38 Suman Anna wrote:
> Hi Laurent,
>
> On 03/07/2014 06:46 PM, Laurent Pinchart wrote:
> > Flushing the TLB before updating translation entries creates a race
> > condition and can lead to stale TLB entries if a translation request
> > arrives between flu
Hi,
On Thursday 13 March 2014 07:59 PM, Kamil Debski wrote:
Hi,
From: Archit Taneja [mailto:arc...@ti.com]
Sent: Thursday, March 13, 2014 1:09 PM
Hi Kamil,
On Thursday 13 March 2014 05:18 PM, Kamil Debski wrote:
Hi Archit,
From: Archit Taneja [mailto:arc...@ti.com]
Sent: Tuesday, March 11
Hi Suman,
On Thursday 13 March 2014 17:16:07 Suman Anna wrote:
> On 03/07/2014 06:46 PM, Laurent Pinchart wrote:
> > The flush_iotlb_page() function prints a debug message when no
> > corresponding page was found in the TLB. That condition is incorrectly
> > checked and always resolves to true, gi
Hi Suman,
Thank you for the review.
On Thursday 13 March 2014 19:07:33 Suman Anna wrote:
> On 03/07/2014 06:46 PM, Laurent Pinchart wrote:
> > The prot flags passed to the IOMMU map handler are defined in
> > include/linux/iommu.h as IOMMU_(READ|WRITE|CACHE|EXEC). However, the
> > driver expects
On 14/03/14 11:10, Mark Rutland wrote:
> The "simple-bus" compatible string is intended for busses which are
> transparent (bar some address remapping expressed via ranges), and is
> not intended as an annotation to get Linux to probe child nodes.
>
> Any node with a "simple-bus" entry in the com
On 03/13/2014 03:46 PM, Mark Brown wrote:
> On Thu, Mar 13, 2014 at 11:18:22AM +0200, Peter Ujfalusi wrote:
>
>> With this series AM335x and AM447x will use the dmaengine PCM for audio. The
>> daVinci devices will keep using the davinci-pcm for now since I do not have
>> means to test them but the
The only difference from the dra75x devices is the missing .smp entry.
Signed-off-by: Rajendra Nayak
---
arch/arm/mach-omap2/board-generic.c | 18 ++
1 file changed, 18 insertions(+)
diff --git a/arch/arm/mach-omap2/board-generic.c
b/arch/arm/mach-omap2/board-generic.c
index
DRA72x is a single core cortex A15 device with most infrastructure IPs otherwise
same as whats on the DRA75x devices.
So move the cpu nodes into dra75x.dtsi and dra72x.dtsi respectively.
Also add a minimal dra72-evm dts file.
Signed-off-by: Rajendra Nayak
---
.../devicetree/bindings/arm/omap/o
DRA72x devices are single core Cortex A15 devices belonging to the
DRA7 family (Similar to the DRA75x devices which are dual core Cortex
A15 based)
The patches add minimal DT/kernel modifications to add boot support for
DRA72x devices resuing all the kernel data for DRA75x devices.
Rajendra Nayak
DRA752 device is wrongly documented as DRA742 device. Fix the typo.
Signed-off-by: Rajendra Nayak
---
.../devicetree/bindings/arm/omap/omap.txt |4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/Documentation/devicetree/bindings/arm/omap/omap.txt
b/Documentation
From: Suman Anna
Bug was introduced by commit 'f92d959: ARM: OMAP2+: hwmod:
Extract no-idle and no-reset info from DT'
There were 2 versions of the patch posted which resulted in the above
commit. While v1 [1] had the bug, v2 [2] had it fixed.
However v1 apparently seemed to have been pulled in
On Thu, Mar 13, 2014 at 06:22:54PM +, Tomi Valkeinen wrote:
> On 13/03/14 19:46, Mark Rutland wrote:
> > On Thu, Mar 13, 2014 at 08:58:29AM +, Sathya Prakash M R wrote:
> >> Add device node for DSS module for AM4372. Both the
> >> AM437x-Gp evm and Am43x-Epos evm use the same LCD panel.
> >
Hi Suman,
On Tue, Mar 4, 2014 at 7:38 PM, Suman Anna wrote:
Do you have any objections to the return code convention change?
>>>
>>> Unless strictly needed, I prefer we don't switch to the ERR_PTR code
>>> convention, as it reduces code readability and increases chances of
>>> user bugs.
>>>
On 03/13/2014 10:35 PM, Joel Fernandes wrote:
Signed-off-by: Joel Fernandes
---
arch/arm/boot/dts/am33xx.dtsi |2 ++
1 file changed, 2 insertions(+)
diff --git a/arch/arm/boot/dts/am33xx.dtsi b/arch/arm/boot/dts/am33xx.dtsi
index 4e6c959..51b7008 100644
--- a/arch/arm/boot/dts/am33xx.dts
On 03/14/2014 01:36 AM, Joel Fernandes wrote:
On 03/13/2014 04:52 PM, Rob Herring wrote:
On Thu, Mar 13, 2014 at 3:35 PM, Joel Fernandes wrote:
Introduce a generic omap timer initialization function that can
be used by all SoCs for which support is available in the clocksource
driver introduce
63 matches
Mail list logo