On Thu, Jun 20, 2013 at 08:31:07PM -0400, Doug Ledford wrote:
> > The new transports have new requirements, and the apps have new
> > required behaviors - the API simply can't hide all this in every
> > case. The changes before had nothing to do with MTU, FWIW.
>
> It demonstrates what I would ca
On Thu, Jun 20, 2013 at 7:48 AM, Christoph Lameter wrote:
> There is no way that user space can initiate a page pin right now. Perf is
> pinning the page from the kernel. Similarly the IB subsystem pins memory
> meeded for device I/O.
Christoph, your argument would be a lot more convincing if you
On Thu, Jun 20, 2013 at 5:09 PM, Stephen Rothwell wrote:
> I noticed that the infiniband tree is now based on the net-next tree. I
> assume that is deliberate? I do have to question how much testing that
> tree has had since it is now based on a tree that Dave only released in
> the last 24 hour
Fix to return -ENOMEM in the add_port() error handling
case instead of 0, as done elsewhere in this function.
Signed-off-by: Wei Yongjun
---
v1 -> v2: change patch description
---
drivers/infiniband/core/sysfs.c | 8 ++--
1 file changed, 6 insertions(+), 2 deletions(-)
diff --git a/drivers/
> Subject: [PATCH] IB/core: Fix error return code in add_port()
>
> From: Wei Yongjun
>
> Fix to return -ENOMEM in the alloc_group_attrs() error handling
Patch itself looks fine, but please change alloc_group_attrs() -> add_port() in
the description.
- Sean
--
To unsubscribe from this list: s
From: Wei Yongjun
Fix to return -ENOMEM in the alloc_group_attrs() error handling
case instead of 0, as done elsewhere in this function.
Signed-off-by: Wei Yongjun
---
drivers/infiniband/core/sysfs.c | 8 ++--
1 file changed, 6 insertions(+), 2 deletions(-)
diff --git a/drivers/infiniband
> I would argue that this is because the libraries are so disjoint (that
> librdmacm needs the deep internal knowledge it needs of libibverbs
> indicates that maybe these two shouldn't be separate from each other for
> example, or that maybe libibverbs should provide a unified connection
> API to t
On 06/20/2013 05:14 PM, Jason Gunthorpe wrote:
> On Thu, Jun 20, 2013 at 04:31:14PM -0400, Doug Ledford wrote:
>>> happened for iwarp, rocee, etc.
>>
>> If it happened once, then I would agree with you above. That it *keeps*
>> happening is the issue. To me, that's a clear indication that instead
Hi all,
I noticed that the infiniband tree is now based on the net-next tree. I
assume that is deliberate? I do have to question how much testing that
tree has had since it is now based on a tree that Dave only released in
the last 24 hours ...
--
Cheers,
Stephen Rothwells.
On Thu, Jun 20, 2013 at 04:31:14PM -0400, Doug Ledford wrote:
> > happened for iwarp, rocee, etc.
>
> If it happened once, then I would agree with you above. That it *keeps*
> happening is the issue. To me, that's a clear indication that instead
> of fixing the shortcomings of the current API pr
On Jun 20, 2013, at 4:40 PM, Doug Ledford wrote:
>> {
>> static char str[16];
>> snprintf(str, sizeof(str), "%d", ibv_mtu_to_num(max_mtu));
>>return str;
>> }
>
> That is not, however, multi-thread safe nor advisable unless you clearly
> indicate in the man page to the function
On 06/18/2013 02:49 PM, Jason Gunthorpe wrote:
> This is simpler:
>
> {
> static char str[16];
> snprintf(str, sizeof(str), "%d", ibv_mtu_to_num(max_mtu));
> return str;
> }
That is not, however, multi-thread safe nor advisable unless you clearly
indicate in the man page to th
On 06/20/2013 12:53 PM, Jason Gunthorpe wrote:
> On Thu, Jun 20, 2013 at 12:34:04PM -0400, Doug Ledford wrote:
>> On 06/20/2013 10:21 AM, Jeff Squyres wrote:
>>> Keep IBV_MTU_* enums values as they are, but pass MTU values around as
>>> int's. This is an ABI-compatible change; legacy applications
On Jun 20, 2013, at 1:09 PM, "Hefty, Sean" wrote:
>> int ibv_rate_to_mult(enum ibv_rate rate);
>> enum ibv_rate mult_to_ibv_rate(int mult);
>>
>> int ibv_rate_to_mbps(enum ibv_rate rate);
>> enum ibv_rate mbps_to_ibv_rate(int mbps);
>
> libibverbs uses the "ibv_" prefix for pretty much everythi
> I used the name "num_to_ibv_mtu" because it is in the spirit of the other
> enum-
> to-int/int-to-enum function pair naming conventions:
>
> int ibv_rate_to_mult(enum ibv_rate rate);
> enum ibv_rate mult_to_ibv_rate(int mult);
>
> int ibv_rate_to_mbps(enum ibv_rate rate);
> enum ibv_rate mbps_
On Thu, Jun 20, 2013 at 12:34:04PM -0400, Doug Ledford wrote:
> On 06/20/2013 10:21 AM, Jeff Squyres wrote:
> > Keep IBV_MTU_* enums values as they are, but pass MTU values around as
> > int's. This is an ABI-compatible change; legacy applications will use
> > the enum values,
>
> I'm not really
On 06/20/2013 12:34 PM, Doug Ledford wrote:
> On 06/20/2013 10:21 AM, Jeff Squyres wrote:
>> Keep IBV_MTU_* enums values as they are, but pass MTU values around as
>> int's. This is an ABI-compatible change; legacy applications will use
>> the enum values,
>
> I'm not really concerned with what t
On 06/20/2013 10:21 AM, Jeff Squyres wrote:
> Keep IBV_MTU_* enums values as they are, but pass MTU values around as
> int's. This is an ABI-compatible change; legacy applications will use
> the enum values,
I'm not really concerned with what the legacy apps use so much as what
they are presented
On 6/20/2013 3:44 AM, Line Holen wrote:
> Signed-off-by: Line Holen
Thanks. Applied.
-- Hal
--
To unsubscribe from this list: send the line "unsubscribe linux-rdma" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
On 19/06/2013 18:47, Wendy Cheng wrote:
what kind of HW I would need to run it ?
The mlx4 driver supports memory windows as of kernel 3.9
Or.
--
To unsubscribe from this list: send the line "unsubscribe linux-rdma" in
the body of a message to majord...@vger.kernel.org
More majordomo info at h
On Thu, 20 Jun 2013, Ingo Molnar wrote:
> Peter clearly pointed it out that in the perf case it's user-space that
> initiates the pinned memory mapping which is resource-controlled via
> RLIMIT_MEMLOCK - and this was implemented that way before your commit
> broke the code.
There is no way that u
On 16/06/2013 15:02, Eli Cohen wrote:
From: Eli Cohen
The patches that follow constitute the driver for Mellanox's 5th generation
of HCAs named Connect-IB.
The driver is comprised of two kernel modules: mlx5_ib and mlx5_core. This
partitioning resembles what we have for mlx4 with the substanti
Keep IBV_MTU_* enums values as they are, but pass MTU values around as
int's. This is an ABI-compatible change; legacy applications will use
the enum values, but newer applications can use an int for values that
do not currently exist in the enum set (e.g., 1500, 9000).
(if people like the idea o
On Jun 18, 2013, at 2:49 PM, Jason Gunthorpe
wrote:
>> +int num_to_ibv_mtu(int num);
>
> Probably should be ibv_num_to_mtu() to keep with the naming pattern..
New patch coming momentarily, but I wanted to comment on this one:
I used the name "num_to_ibv_mtu" because it is in the spirit of t
On 20-06-2013 09:38, David Miller wrote:
> From: Steve Wise
> Date: Wed, 19 Jun 2013 21:19:13 -0500
>
>> On 6/19/2013 8:01 PM, David Miller wrote:
>>> From: Vipul Pandya
>>> Date: Wed, 12 Jun 2013 17:11:38 +0530
>>>
We have included all the maintainers of respective drivers. Kindly
r
On 6/19/2013 11:08 PM, David Miller wrote:
From: Steve Wise
Date: Wed, 19 Jun 2013 21:19:13 -0500
On 6/19/2013 8:01 PM, David Miller wrote:
From: Vipul Pandya
Date: Wed, 12 Jun 2013 17:11:38 +0530
We have included all the maintainers of respective drivers. Kindly
review the change and let
* Christoph Lameter wrote:
> On Mon, 17 Jun 2013, Peter Zijlstra wrote:
>
> > They did no such thing; being one of those who wrote such code. I
> > expressly used RLIMIT_MEMLOCK for its the one limit userspace has to
> > limit pages that are exempt from paging.
>
> Dont remember reviewing that
* Thomas Gleixner wrote:
> On Thu, 13 Jun 2013, Andrew Morton wrote:
> > Let's try to get this wrapped up?
> >
> > On Thu, 6 Jun 2013 14:43:51 +0200 Peter Zijlstra
> > wrote:
> >
> > >
> > > Patch bc3e53f682 ("mm: distinguish between mlocked and pinned pages")
> > > broke RLIMIT_MEMLOCK.
>
Signed-off-by: Line Holen
---
diff --git a/opensm/osm_sm_state_mgr.c b/opensm/osm_sm_state_mgr.c
index 11defdd..5d4b651 100644
--- a/opensm/osm_sm_state_mgr.c
+++ b/opensm/osm_sm_state_mgr.c
@@ -157,7 +157,7 @@ static void sm_state_mgr_start_polling(osm_sm_t * sm)
cl_status = cl_timer_st
29 matches
Mail list logo