Re: [PATCH v2 for-next 1/7] IB/core: Extend ib_uverbs_create_qp

2015-10-21 Thread Sagi Grimberg
On 10/21/2015 1:04 PM, Or Gerlitz wrote: On 10/21/2015 12:53 PM, Sagi Grimberg wrote: On 10/15/2015 2:44 PM, Eran Ben Elisha wrote: +struct ib_uverbs_ex_create_qp { +__u64 user_handle; +__u32 pd_handle; +__u32 send_cq_handle; +__u32 recv_cq_handle; +__u32 srq_handle; +

[PATCH v3 for-next 1/7] IB/core: Extend ib_uverbs_create_qp

2015-10-21 Thread Eran Ben Elisha
ib_uverbs_ex_create_qp follows the extension verbs mechanism. New features (for example, QP creation flags field which is added in a downstream patch) could used via user-space libraries without breaking the ABI. Signed-off-by: Eran Ben Elisha --- Hi Doug, This is a fix for

Re: [PATCH v2 07/22] staging/rdma/hfi1: Fix sparse error in sdma.h file

2015-10-21 Thread Dan Carpenter
On Mon, Oct 19, 2015 at 10:11:22PM -0400, ira.we...@intel.com wrote: > From: Niranjana Vishwanathapura > > Use NULL instead of 0 for pointer argument to fix the sparse error. > > Reviewed-by: Mike Marciniszyn > Reviewed-by: Mitko

Re: [PATCH v3 for-next 1/7] IB/core: Extend ib_uverbs_create_qp

2015-10-21 Thread Haggai Eran
On 21/10/2015 17:00, Eran Ben Elisha wrote: > ib_uverbs_ex_create_qp follows the extension verbs > mechanism. New features (for example, QP creation flags > field which is added in a downstream patch) could used > via user-space libraries without breaking the ABI. > > Signed-off-by: Eran Ben

Re: [PATCH v2 for-next 1/7] IB/core: Extend ib_uverbs_create_qp

2015-10-21 Thread eran ben elisha
On Wed, Oct 21, 2015 at 11:34 AM, Haggai Eran wrote: > On 15/10/2015 14:44, Eran Ben Elisha wrote: >> ib_uverbs_ex_create_qp follows the extension verbs >> mechanism. New features (for example, QP creation flags >> field which is added in a downstream patch) could used >>

Re: [PATCH v2 for-next 1/7] IB/core: Extend ib_uverbs_create_qp

2015-10-21 Thread Haggai Eran
On 21/10/2015 16:46, eran ben elisha wrote: >>> +ssize_t ib_uverbs_create_qp(struct ib_uverbs_file *file, >>> >> + struct ib_device *ib_dev, >>> >> + const char __user *buf, int in_len, >>> >> + int out_len) >>> >> +{ >>> >> +

Re: merge struct ib_device_attr into struct ib_device V2

2015-10-21 Thread Bart Van Assche
On 10/21/2015 12:11 AM, Or Gerlitz wrote: haven't found any review or ack to your giant patch that touches the > whole subsystem (drivers, core and ULPs) expect from Sagi's -- lets > hear more opinions. Although I have not yet had the time to review the entire patch, removing

RE: [PATCH v2 07/22] staging/rdma/hfi1: Fix sparse error in sdma.h file

2015-10-21 Thread Weiny, Ira
> > On Mon, Oct 19, 2015 at 10:11:22PM -0400, ira.we...@intel.com wrote: > > From: Niranjana Vishwanathapura > > > > Use NULL instead of 0 for pointer argument to fix the sparse error. > > > > Reviewed-by: Mike Marciniszyn > >

Re: merge struct ib_device_attr into struct ib_device V2

2015-10-21 Thread Jason Gunthorpe
On Wed, Oct 21, 2015 at 08:48:10AM -0700, Bart Van Assche wrote: > On 10/21/2015 12:11 AM, Or Gerlitz wrote: > >haven't found any review or ack to your giant patch that touches the > > whole subsystem (drivers, core and ULPs) expect from Sagi's -- lets > > hear more opinions. > > Although I have

Re: merge struct ib_device_attr into struct ib_device V2

2015-10-21 Thread Steve Wise
On 10/21/2015 11:43 AM, Jason Gunthorpe wrote: On Wed, Oct 21, 2015 at 08:48:10AM -0700, Bart Van Assche wrote: On 10/21/2015 12:11 AM, Or Gerlitz wrote: haven't found any review or ack to your giant patch that touches the whole subsystem (drivers, core and ULPs) expect from Sagi's -- lets

Re: merge struct ib_device_attr into struct ib_device V2

2015-10-21 Thread Or Gerlitz
On Wed, Oct 21, 2015 at 6:48 PM, Bart Van Assche wrote: > On 10/21/2015 12:11 AM, Or Gerlitz wrote: >> >> haven't found any review or ack to your giant patch that touches the > >> whole subsystem (drivers, core and ULPs) expect from Sagi's -- lets >> hear more

Re: [PATCH v2 for-next 1/7] IB/core: Extend ib_uverbs_create_qp

2015-10-21 Thread Or Gerlitz
On Wed, Oct 21, 2015 at 9:21 PM, Christoph Lameter wrote: > Hmmm... We are running out of dev_cap flags on mlx4 already. They are 32 > bits. Christoph, These are QP creation flags (IB_QP_CREATE_XXX) not device capability flags (IB_DEVICE_YYY) Or. -- To unsubscribe from this

Re: [PATCH v2 for-next 1/7] IB/core: Extend ib_uverbs_create_qp

2015-10-21 Thread Christoph Lameter
On Wed, 21 Oct 2015, Or Gerlitz wrote: > Again, the kernel stack consuming rate here was < 1 bit a year when > averaging over time since this was introduced. So we should be doing > well for the coming ~10-20 years with this 32 bit field, and we can > easily extend it later, I verified that with

Re: merge struct ib_device_attr into struct ib_device V2

2015-10-21 Thread Or Gerlitz
On Wed, Oct 21, 2015 at 9:20 PM, Jason Gunthorpe wrote: > No to the pointer idea. can you spare few words why? And if you have a valid argument, as Christoph said they teach in cache 101 course which he's pretty sure I skipped as twenty other courses taken by

Re: merge struct ib_device_attr into struct ib_device V2

2015-10-21 Thread Jason Gunthorpe
On Wed, Oct 21, 2015 at 09:08:31PM +0300, Or Gerlitz wrote: > The alternative approach to address this which was also running here > in the form of a patch from Ira following a reviewer comment from me, > is the have struct ib_device to contain a struct ib_device_attr member > (potentially a

Re: [PATCH rdma-RC] IB/cm: Fix rb-tree duplicate free and use-after-free

2015-10-21 Thread Doug Ledford
On 10/20/2015 04:27 PM, Doug Ledford wrote: > On 10/15/2015 11:15 AM, Matan Barak wrote: >> >> >> On 10/12/2015 7:37 PM, Hefty, Sean wrote: ib_send_cm_sidr_rep could sometimes erase the node from the sidr (depending on errors in the process). Since ib_send_cm_sidr_rep is called both

Re: [PATCH] usnic: correctly check failed allocation

2015-10-21 Thread Doug Ledford
On 10/15/2015 05:15 PM, Insu Yun wrote: > Since ib_alloc_device returns allocated memory address, not error, > it should be checked as IS_NULL, not IS_ERR_OR_NULL. > > Signed-off-by: Insu Yun Thanks, applied. > --- > drivers/infiniband/hw/usnic/usnic_ib_main.c | 9 -

Re: [PATCH] usnix: correctly handle kzalloc return value

2015-10-21 Thread Doug Ledford
On 10/17/2015 03:06 PM, Insu Yun wrote: > Since kzalloc returns memory address, not error code, > it should be checked whether it is null or not. > > Signed-off-by: Insu Yun Thanks, applied. > --- > drivers/infiniband/hw/usnic/usnic_ib_qp_grp.c | 8 > 1 file

Re: [PATCH] MAINTAINERS: update usnic maintainer contacts

2015-10-21 Thread Doug Ledford
On 10/15/2015 11:01 PM, Dave Goodell wrote: > Upinder hasn't worked for Cisco for a little while now, updating to more > active maintainers. > > Signed-off-by: Dave Goodell Thanks, applied. > --- > MAINTAINERS | 5 +++-- > 1 file changed, 3 insertions(+), 2 deletions(-) >

Re: [PATCH for-next 0/5] RDMA/ocrdma: bug fixes

2015-10-21 Thread Doug Ledford
On 10/20/2015 04:47 AM, Selvin Xavier wrote: > This patch series includs fix in CQ door bell logic, check to prevent > driver crash and code cleanup. > Please apply. > > Devesh Sharma (1): > RDMA/ocrdma: Prevent CQ-Doorbell floods > > Naga Irrinki (1): > RDMA/ocrdma: Check resource ids

Re: [PATCH] RDMA/cxgb4: re-fix 32-bit build warning

2015-10-21 Thread Doug Ledford
On 10/07/2015 08:10 AM, Arnd Bergmann wrote: > Casting a pointer to __be64 produces a warning on 32-bit architectures: > > drivers/infiniband/hw/cxgb4/mem.c:147:20: warning: cast from pointer to > integer of different size [-Wpointer-to-int-cast] > req->wr.wr_lo = (__force __be64)_wait; > >

Re: [PATCH] IB/core: avoid 32-bit warning

2015-10-21 Thread Doug Ledford
On 10/07/2015 09:46 AM, Yann Droneaud wrote: > Hi, > > Le mercredi 07 octobre 2015 à 16:19 +0300, Sagi Grimberg a écrit : >> On 10/7/2015 3:29 PM, Arnd Bergmann wrote: >>> The INIT_UDATA() macro requires a pointer or unsigned long argument >>> for >>> both input and output buffer, and all callers

Re: [PATCH for-next 0/2] RDMA/cxgb4: Add iWARP support for T6 adapter

2015-10-21 Thread Doug Ledford
On 10/12/2015 01:01 PM, Steve Wise wrote: > > >> -Original Message- >> From: netdev-ow...@vger.kernel.org [mailto:netdev-ow...@vger.kernel.org] On >> Behalf Of Hariprasad Shenai >> Sent: Wednesday, September 23, 2015 6:49 AM >> To: linux-rdma@vger.kernel.org; net...@vger.kernel.org >>

Re: [PATCH for-next 0/5] set MPA revision to 2 and misc. fixes for iw_cxgb4

2015-10-21 Thread Doug Ledford
On 09/08/2015 12:26 AM, Hariprasad Shenai wrote: > Hi, > > This patch series adds the following. > Detect errors while creating listening servers, pass ird/ord info in > connect reply events, fix misuse of ord for ird calculation and for the > ESTABLISHED event we should have the peer's ord/ird

VMware Users List

2015-10-21 Thread Michael Thompson
Hi, Hope this email finds you well! Would you be interested in reaching out to "VMware Users List” for across USA with opt-in verified contact information? We also have the list of VMware Clusters, VMware Distributed Resource Scheduler (DRS), VMware ESX Server, VMware Fusion, VMware GSX

Re: [PATCH v2 for-next 1/7] IB/core: Extend ib_uverbs_create_qp

2015-10-21 Thread Or Gerlitz
On Wed, Oct 21, 2015 at 5:09 PM, Sagi Grimberg wrote: > On 10/21/2015 1:04 PM, Or Gerlitz wrote: >> On 10/21/2015 12:53 PM, Sagi Grimberg wrote: >>> On 10/15/2015 2:44 PM, Eran Ben Elisha wrote: +struct ib_uverbs_ex_create_qp { +__u64 user_handle; +__u32 pd_handle; +

Re: [PATCH for-next 0/2] RDMA/cxgb4: Add iWARP support for T6 adapter

2015-10-21 Thread David Miller
From: Doug Ledford Date: Wed, 21 Oct 2015 16:58:50 -0400 > Probably. Unless David objects, I'll queue them up. No objection from me. -- To unsubscribe from this list: send the line "unsubscribe linux-rdma" in the body of a message to majord...@vger.kernel.org More

Re: [PATCH v2 01/22] staging/rdma/hfi1: Fix regression in send performance

2015-10-21 Thread Dan Carpenter
On Mon, Oct 19, 2015 at 10:11:16PM -0400, ira.we...@intel.com wrote: > From: Mike Marciniszyn > > This additional call is a regression from qib. For small messages the > progress > routine always builds one and clears out the ahg state when the queue has gone > to

Re: [PATCH v3 for-next 1/7] IB/core: Extend ib_uverbs_create_qp

2015-10-21 Thread Doug Ledford
On 10/21/2015 10:00 AM, Eran Ben Elisha wrote: > ib_uverbs_ex_create_qp follows the extension verbs > mechanism. New features (for example, QP creation flags > field which is added in a downstream patch) could used > via user-space libraries without breaking the ABI. > > Signed-off-by: Eran Ben

Re: [PATCH v6 0/4] Add network namespace support in the RDMA-CM

2015-10-21 Thread Doug Ledford
On 08/27/2015 10:29 AM, Haggai Eran wrote: > Hi, > > Now that the code for demuxing requests is inside rdma_cm, here are the > patches > to add InfiniBand network namespace again. > > Changes from v5: > - removed patches that got in as part of the cleanup series. Hi Haggai, This series no

Re: [PATCH for-next v2 00/10] Add RoCE GID cache usage in verbs/cma

2015-10-21 Thread Doug Ledford
On 10/15/2015 11:38 AM, Matan Barak wrote: > Hi Doug, > > This purpose of this series is to add usage of the GID cache to > the CMA and IB stack. Instead of passing Ethernet L2 attributes > via QP attributes, we could just use the GID cache that's already > points to a ndev and thus to all

Re: [PATCH 00/23] Update driver to 0.9-294

2015-10-21 Thread Moni Shoua
> Understood, however, unlike SoftRoCE, qib and hfi currently share a lot of > code > to drive the hardware. > > The underlying reason for the TODO item "Remove software processing of IB > protocol..." is because we have a large amount of duplicated code between > these > drivers. _Some_ of

Re: merge struct ib_device_attr into struct ib_device V2

2015-10-21 Thread Christoph Hellwig
On Tue, Oct 20, 2015 at 06:07:31PM +0300, Or Gerlitz wrote: > But this makes struct ib_device much much bigger, and this structure > is used in **fast** path, > e.g the ULP traverses through a pointer from struct ib_device to > post_send/recv, poll_cq and friends. But it doesn't get near the end

Re: merge struct ib_device_attr into struct ib_device V2

2015-10-21 Thread Christoph Hellwig
On Tue, Oct 20, 2015 at 06:13:35PM +0300, Sagi Grimberg wrote: >> The networking community will let you work for 10y before they add a >> field to struct net_device exactly b/c >> of the reason I brought. Why here we can come out of the blue and add >> tens if not hundreds of fields to our device

Re: merge struct ib_device_attr into struct ib_device V2

2015-10-21 Thread Or Gerlitz
On 10/21/2015 9:38 AM, Christoph Hellwig wrote: On Tue, Oct 20, 2015 at 06:07:31PM +0300, Or Gerlitz wrote: >But this makes struct ib_device much much bigger, and this structure >is used in **fast** path, >e.g the ULP traverses through a pointer from struct ib_device to >post_send/recv, poll_cq

Re: merge struct ib_device_attr into struct ib_device V2

2015-10-21 Thread Christoph Hellwig
On Wed, Oct 21, 2015 at 09:44:41AM +0300, Or Gerlitz wrote: > Fact is that for struct net_device you will not add 333 new fields over > night in the coming 33 years, for sure. That's because they never had this split and added fields to struct netdev as required. One interesting difference in

Re: merge struct ib_device_attr into struct ib_device V2

2015-10-21 Thread Or Gerlitz
On 10/21/2015 9:51 AM, Christoph Hellwig wrote: We have a UAPI that requires us to keep the device query verb for ever, and hence the returned device attr struct, it would be a much smaller and noisy patch pointer to cache an device attr on the device structure. Take a look at the code. The

Re: [PATCH v2 for-next 1/7] IB/core: Extend ib_uverbs_create_qp

2015-10-21 Thread Sagi Grimberg
On 10/15/2015 2:44 PM, Eran Ben Elisha wrote: ib_uverbs_ex_create_qp follows the extension verbs mechanism. New features (for example, QP creation flags field which is added in a downstream patch) could used via user-space libraries without breaking the ABI. This is an important addition, I'll

Re: [PATCH] IB/cma: Use inner P_Key to determine netdev

2015-10-21 Thread Haggai Eran
On 20/10/2015 19:44, Jason Gunthorpe wrote: > On Tue, Oct 20, 2015 at 09:45:27AM +0300, Haggai Eran wrote: >> On 19/10/2015 21:19, Jason Gunthorpe wrote: >>> On Mon, Oct 19, 2015 at 09:09:25PM +0300, Haggai Eran wrote: When discussing the patches to demux ids in rdma_cm instead of ib_cm, it

Re: [PATCH v2 for-next 1/7] IB/core: Extend ib_uverbs_create_qp

2015-10-21 Thread Or Gerlitz
On 10/21/2015 12:53 PM, Sagi Grimberg wrote: On 10/15/2015 2:44 PM, Eran Ben Elisha wrote: +struct ib_uverbs_ex_create_qp { +__u64 user_handle; +__u32 pd_handle; +__u32 send_cq_handle; +__u32 recv_cq_handle; +__u32 srq_handle; +__u32 max_send_wr; +__u32

Re: [PATCH v2 for-next 1/7] IB/core: Extend ib_uverbs_create_qp

2015-10-21 Thread Haggai Eran
On 21/10/2015 12:53, Sagi Grimberg wrote: > On 10/15/2015 2:44 PM, Eran Ben Elisha wrote: >> ib_uverbs_ex_create_qp follows the extension verbs >> mechanism. New features (for example, QP creation flags >> field which is added in a downstream patch) could used >> via user-space libraries without

[PATCH] IB/mlx5: Postpone remove_keys under knowledge of coming preemption

2015-10-21 Thread Leon Romanovsky
From: Leon Romanovsky The remove_keys() logic is performed as garbage collection task. Such task is intended to be run when no other active processes are running. The need_resched() will return TRUE if there are user tasks to be activated in near future. In such case, we

Re: [PATCH v2 for-next 1/7] IB/core: Extend ib_uverbs_create_qp

2015-10-21 Thread Haggai Eran
On 15/10/2015 14:44, Eran Ben Elisha wrote: > ib_uverbs_ex_create_qp follows the extension verbs > mechanism. New features (for example, QP creation flags > field which is added in a downstream patch) could used > via user-space libraries without breaking the ABI. > > Signed-off-by: Eran Ben

Re: merge struct ib_device_attr into struct ib_device V2

2015-10-21 Thread Christoph Hellwig
On Wed, Oct 21, 2015 at 10:11:29AM +0300, Or Gerlitz wrote: > > We will have many more device query extensions, None of which use struct ib_device_attr I hope! > but the point I tried to > make here is a bit different -- > we do need to keep the user/kernel device attr struct as part of the

Re: merge struct ib_device_attr into struct ib_device V2

2015-10-21 Thread Or Gerlitz
On 10/21/2015 10:33 AM, Christoph Hellwig wrote: For anything you want to add you need to touch_a_ struct. It's not any difference in efforts if it's ib_device_attr or ib_device. You're not even saving much memory if at all as every driver caches at least some fields of it in their own device

Re: merge struct ib_device_attr into struct ib_device V2

2015-10-21 Thread Christoph Hellwig
On Wed, Oct 21, 2015 at 10:41:13AM +0300, Or Gerlitz wrote: > I know, but a patch that adds caching an attr pointer on the device will > remove these local caches, > we actually had that/similar patch posted here and it was dropped/forgotten. > >> so if you use one of those you're >> already

Re: [PATCH v2 for-next 2/7] IB/core: Allow setting create flags in QP init attribute

2015-10-21 Thread Haggai Eran
On 15/10/2015 14:44, Eran Ben Elisha wrote: > Allow setting IB_QP_CREATE_BLOCK_MULTICAST_LOOPBACK at create_flags in > ib_uverbs_create_qp_ex. > > Signed-off-by: Eran Ben Elisha > --- > drivers/infiniband/core/uverbs_cmd.c | 2 +- > 1 file changed, 1 insertion(+), 1