Pull Requeset: Exynos4 Register Address Update for Devfreq Drivers.

2011-12-20 Thread MyungJoo Ham
Hello, Please pull the patches for Exynos4 SoCs that support devfreq device drivers for Exynos4210/4212/4412. The patches are: ARM: EXYNOS4: Add DMC1, allow PPMU access for DMC. ARM: EXYNOS4: Add clock register addresses for Exynos4x12 bus devfreq driver ARM Exynos4210-Nuri: support Exynos4210-bu

RE: [PATCH v2 0/4] Implement RTC support for S3C2443/S3C2416/S3C2450

2011-12-20 Thread Kukjin Kim
Heiko Stübner wrote: > > Similar to the ADC the RTC of S3C2443 and S3C2416/2450 has some slight > variances when compared to the existing types. > > This series adds support for those SoCs. > > As with the ADC patches, these changes where tested on S3C2416 hardware. > The S3C2443 quirks are a su

RE: [PATCH 1/4] ARM: SAMSUNG: cleanup of rtc register definitions

2011-12-20 Thread Kukjin Kim
Heiko Stübner wrote: > > regs-rtc.h uses a mixture of tabs and spaces and also (x< to format bits. So, before adding new stuff clean up the formatting > and also add spaces to the bit definitions (i.e. (x << y) ) > > Signed-off-by: Heiko Stuebner > --- > arch/arm/plat-samsung/include/plat/regs-

RE: [PATCH V2] ARM: EXYNOS: Use gpio_request_one

2011-12-20 Thread Kukjin Kim
Jingoo Han wrote: > > By using gpio_request_one it is possible to set the direction > and initial value in one shot. Thus, using gpio_request_one can > make the code simpler. > > Signed-off-by: Jingoo Han > --- > arch/arm/mach-exynos/mach-nuri.c |9 ++--- > arch/arm/mach-exyno

RE: [PATCHv2 resend] Fix compilation error when CONFIG_CPU_FREQ_S3C24XX_DEBUGFS selected.

2011-12-20 Thread Kukjin Kim
Denis Kuzmenko wrote: > > Fix compilation error when CONFIG_CPU_FREQ_S3C24XX_DEBUGFS selected. > > Signed-off-by: Denis Kuzmenko > --- > > Patch is against 3.2-rc4. > CONFIG_S3C2410_IOTIMING is not selected for MACH_MINI2440. Because of this > the > file s3c2410-iotiming.c is not ever compiled

RE: [PATCH v4] s3c/s3c24xx: arm: leds: Make s3c24xx LEDS driver use gpiolib. Fix error disabling pull during probe.

2011-12-20 Thread Kukjin Kim
Denis Kuzmenko wrote: > > Make s3c24xx LEDS driver use gpiolib. Fix error disabling pull during > probe. > > Signed-off-by: Denis Kuzmenko Acked-by: Kukjin Kim Richard, I think, this should be handled in your tree. Thanks. Best regards, Kgene. -- Kukjin Kim , Senior Engineer, SW Solution De

RE: [PATCH V7 1/2] mmc: core: HS200 mode support for eMMC 4.5

2011-12-20 Thread Subhash Jadavani
> -Original Message- > From: linux-mmc-ow...@vger.kernel.org [mailto:linux-mmc- > ow...@vger.kernel.org] On Behalf Of Girish K S > Sent: Wednesday, December 21, 2011 9:43 AM > To: linux-...@vger.kernel.org > Cc: patc...@linaro.org; linux-samsung-soc@vger.kernel.org; Girish K S; > Chris Ba

[PATCH V2] ARM: EXYNOS: Use gpio_request_one

2011-12-20 Thread Jingoo Han
By using gpio_request_one it is possible to set the direction and initial value in one shot. Thus, using gpio_request_one can make the code simpler. Signed-off-by: Jingoo Han --- arch/arm/mach-exynos/mach-nuri.c |9 ++--- arch/arm/mach-exynos/mach-smdkv310.c |4 +---

RE: [PATCH] ARM: EXYNOS: Use gpio_request_one

2011-12-20 Thread Jingoo Han
Kukjin Kim wrote: > -Original Message- > Subject: RE: [PATCH] ARM: EXYNOS: Use gpio_request_one > > Jingoo Han wrote: > > > > By using gpio_request_one it is possible to set the direction > > and initial value in one shot. Thus, using gpio_request_one can > > make the code simpler. > > > >

Re: [PATCH V7 1/2] mmc: core: HS200 mode support for eMMC 4.5

2011-12-20 Thread Philip Rakity
On Dec 20, 2011, at 8:12 PM, Girish K S wrote: > This patch adds the support of the HS200 bus speed for eMMC 4.5 devices. > The eMMC 4.5 devices have support for 200MHz bus speed. The function > prototype of the tuning function is modified to handle the tuning command > number which is different

RE: Re: [PATCH 0/3] Support Samsung S5P OHCI device and driver

2011-12-20 Thread Kukjin Kim
> -Original Message- > From: Greg KH [mailto:g...@kroah.com] > Sent: Saturday, December 10, 2011 8:58 AM > To: Kukjin Kim > Cc: 'Jingoo Han'; linux-arm-ker...@lists.infradead.org; linux- > u...@vger.kernel.org; linux-samsung-soc@vger.kernel.org; gre...@suse.de; > st...@rowland.harvard.edu

RE: [PATCH] ARM: SAMSUNG: Add a callback 'notify_after' for PWM backlight control

2011-12-20 Thread Kukjin Kim
Jingoo Han wrote: > > The callback 'notify_after' was added to struct > platform_pwm_backlight_data > provided by PWM backlight driver. Therefore, this patch adds a callback > 'notify_after' which can be called after pwm_enable, pwm_disable and > pwm_config. > > Signed-off-by: Jingoo Han > --- >

RE: [PATCH] ARM: S5PV210: Use gpio_request_one

2011-12-20 Thread Kukjin Kim
Jingoo Han wrote: > > By using gpio_request_one it is possible to set the direction > and initial value in one shot. Thus, using gpio_request_one can > make the code simpler. > > Signed-off-by: Jingoo Han > --- > arch/arm/mach-s5pv210/mach-aquila.c |3 +-- > arch/arm/mach-s5pv210/mach-gon

RE: [PATCH] ARM: EXYNOS: Use gpio_request_one

2011-12-20 Thread Kukjin Kim
Jingoo Han wrote: > > By using gpio_request_one it is possible to set the direction > and initial value in one shot. Thus, using gpio_request_one can > make the code simpler. > > Signed-off-by: Jingoo Han > --- > arch/arm/mach-exynos/mach-nuri.c |4 +--- > arch/arm/mach-exynos/mac

RE: [PATCH] ARM: S5PV210: Set 1000ns as PWM backlight period on SMDKV210

2011-12-20 Thread Kukjin Kim
Mark Brown wrote: > > On Wed, Dec 07, 2011 at 04:21:20PM +0900, Kukjin Kim wrote: > > > If switch frequency is 1kHz, the value of pwm_period_ns should be > 100 at > > mach-crag6410.c not 10? > > I guess so, please go ahead and make the change - we can always revert > if it doesn't work.

[PATCH V7 2/2] mmc: host: Adds support for eMMC 4.5 HS200 mode

2011-12-20 Thread Girish K S
This patch adds support for the HS200 mode on the host side. Also enables the tuning feature required when the HS200 mode is selected. cc: Chris Ball Signed-off-by: Girish K S --- drivers/mmc/host/sdhci.c | 45 ++--- drivers/mmc/host/sdhci.h |1 +

[PATCH V7 1/2] mmc: core: HS200 mode support for eMMC 4.5

2011-12-20 Thread Girish K S
This patch adds the support of the HS200 bus speed for eMMC 4.5 devices. The eMMC 4.5 devices have support for 200MHz bus speed. The function prototype of the tuning function is modified to handle the tuning command number which is different in sd and mmc case. cc: Chris Ball Signed-off-by: Giris

[PATCH V7 0/2] HS200 Mode support for device and host

2011-12-20 Thread Girish K S
changes in v7: Updated with review comments for minor changes in host conditional handling. added the handling for 4 bit bus width. Changes in v6: split the patch into 2 and classified them as a patch for device and host. Modified to include the review comments. Chang

RE: [PATCH 1/8] s3c-hsudc: move platform_data struct to global header

2011-12-20 Thread Kukjin Kim
Heiko Stübner wrote: > > Am Dienstag, 20. Dezember 2011, 12:25:00 schrieb Felipe Balbi: > > Hi, > > > > On Mon, Dec 19, 2011 at 07:39:15PM +0100, Heiko Stübner wrote: > > > Gadget drivers should be compilable on all architectures. > > > This patch removes one dependency on architecture-specific co

RE: [PATCH 02/12] ARM: restart: S3C64XX: use new restart hook

2011-12-20 Thread Kukjin Kim
Kukjin Kim wrote: > > Hook these platforms restart code into the new restart hook rather > than using arch_reset(). > > Cc: Ben Dooks > Cc: Russell King > Signed-off-by: Kukjin Kim > --- > arch/arm/mach-s3c64xx/common.c | 10 ++ > arch/arm/mach-s3c64xx/common.h

RE: [PATCH 12/12] ARM: restart: S3C24XX: use new restart hook

2011-12-20 Thread Kukjin Kim
Kukjin Kim wrote: > > Hook these platforms restart code into the new restart hook rather > than using arch_reset(). > And adds local header file, common.h in arch/arm/mach-s3c2410/ and > arch/arm/mach-s3c2440/ directories. > > Cc: Ben Dooks > Cc: Russell King > Signed-off-by: Kukjin Kim > ---

RE: [PATCH 10/12] ARM: restart: EXYNOS: use new restart hook

2011-12-20 Thread Kukjin Kim
Kukjin Kim wrote: > > From: Russell King > > Hook these platforms restart code into the new restart hook rather > than using arch_reset(). > > Signed-off-by: Russell King > [kgene@samsung.com: according to local header, updated] > Signed-off-by: Kukjin Kim > --- > arch/arm/mach-exynos/co

RE: [PATCH 08/12] ARM: restart: S5PV210: use new restart hook

2011-12-20 Thread Kukjin Kim
Kukjin Kim wrote: > > From: Russell King > > Hook these platforms restart code into the new restart hook rather > than using arch_reset(). > > Signed-off-by: Russell King > [kgene@samsung.com: according to local header, updated] > Signed-off-by: Kukjin Kim > --- > arch/arm/mach-s5pv210/c

RE: [PATCH 06/12] ARM: restart: S5PC100: use new restart hook

2011-12-20 Thread Kukjin Kim
Kukjin Kim wrote: > > Hook these platforms restart code into the new restart hook rather > than using arch_reset(). > > Cc: Ben Dooks > Cc: Russell King > Signed-off-by: Kukjin Kim > --- > arch/arm/mach-s5pc100/common.c |9 + > arch/arm/mach-s5pc100/common.h

RE: [PATCH 04/12] ARM: restart: S5P64X0: use new restart hook

2011-12-20 Thread Kukjin Kim
Kukjin Kim wrote: > > Hook these platforms restart code into the new restart hook rather > than using arch_reset(). > > Cc: Ben Dooks > Cc: Russell King > Signed-off-by: Kukjin Kim > --- > arch/arm/mach-s5p64x0/common.c |9 + > arch/arm/mach-s5p64x0/common.h

RE: [PATCH 00/12] ARM: restart: SAMSUNG: use new restart hook

2011-12-20 Thread Kukjin Kim
Russell King - ARM Linux wrote: > > On Tue, Dec 20, 2011 at 09:48:24PM +0900, Kukjin Kim wrote: > > This patch introduces common.[ch] in each SAMSUNG mach- directories > > and implements using new restart hook for Samsung stuff. > > > > This is against on rmk/devel-stable branch. > > > > [PATCH 01

Re: [PATCH 7/8] s3c-hsudc: use release_mem_region instead of release_resource

2011-12-20 Thread Russell King - ARM Linux
On Tue, Dec 20, 2011 at 11:09:48PM +0200, Felipe Balbi wrote: > On Tue, Dec 20, 2011 at 08:10:49PM +, Russell King - ARM Linux wrote: > > On Mon, Dec 19, 2011 at 07:42:52PM +0100, Heiko Stübner wrote: > > > As the memory region is requested through request_mem_region > > > use the correct paire

Re: [PATCH 7/8] s3c-hsudc: use release_mem_region instead of release_resource

2011-12-20 Thread Felipe Balbi
On Tue, Dec 20, 2011 at 08:10:49PM +, Russell King - ARM Linux wrote: > On Mon, Dec 19, 2011 at 07:42:52PM +0100, Heiko Stübner wrote: > > As the memory region is requested through request_mem_region > > use the correct paired method to release it in the error path > > and don't go "beneath the

Re: [PATCH 00/12] ARM: restart: SAMSUNG: use new restart hook

2011-12-20 Thread Russell King - ARM Linux
On Tue, Dec 20, 2011 at 09:48:24PM +0900, Kukjin Kim wrote: > This patch introduces common.[ch] in each SAMSUNG mach- directories > and implements using new restart hook for Samsung stuff. > > This is against on rmk/devel-stable branch. > > [PATCH 01/12] ARM: S3C64XX: introduce arch/arm/mach-s3c6

Re: [PATCH 7/8] s3c-hsudc: use release_mem_region instead of release_resource

2011-12-20 Thread Russell King - ARM Linux
On Mon, Dec 19, 2011 at 07:42:52PM +0100, Heiko Stübner wrote: > As the memory region is requested through request_mem_region > use the correct paired method to release it in the error path > and don't go "beneath the API" as pointed out by Russel King. Please correct the spelling, thanks. -- To u

Re: [PATCH 6/7] s3c-hsudc: Add regulator handling

2011-12-20 Thread Mark Brown
On Mon, Dec 19, 2011 at 02:27:07PM +0100, Heiko St?bner wrote: > The udc has three supplies: vdda (3.3V), vddi (1.2V) and vddosc (1.8-3.3V). > Turn these on and off on start and stop calls. > > Signed-off-by: Heiko Stuebner Reviewed-by: Mark Brown -- To unsubscribe from this list: send the line

Re: [PATCH 12/12] ARM: restart: S3C24XX: use new restart hook

2011-12-20 Thread Kukjin Kim
On 12/20/11 22:18, Heiko Stübner wrote: Am Dienstag, 20. Dezember 2011, 13:48:36 schrieb Kukjin Kim: Hook these platforms restart code into the new restart hook rather than using arch_reset(). And adds local header file, common.h in arch/arm/mach-s3c2410/ and arch/arm/mach-s3c2440/ directories.

Re: [PATCH 12/12] ARM: restart: S3C24XX: use new restart hook

2011-12-20 Thread Heiko Stübner
Am Dienstag, 20. Dezember 2011, 13:48:36 schrieb Kukjin Kim: > Hook these platforms restart code into the new restart hook rather > than using arch_reset(). > And adds local header file, common.h in arch/arm/mach-s3c2410/ and > arch/arm/mach-s3c2440/ directories. > > Cc: Ben Dooks > Cc: Russell K

[PATCH 12/12] ARM: restart: S3C24XX: use new restart hook

2011-12-20 Thread Kukjin Kim
Hook these platforms restart code into the new restart hook rather than using arch_reset(). And adds local header file, common.h in arch/arm/mach-s3c2410/ and arch/arm/mach-s3c2440/ directories. Cc: Ben Dooks Cc: Russell King Signed-off-by: Kukjin Kim --- arch/arm/mach-s3c2410/common.h

[PATCH 11/12] ARM: restart: S3C24XX: move SWRST based S3C platforms to machine_desc hook

2011-12-20 Thread Kukjin Kim
From: Heiko Stuebner S3C2412/S3C2416/S3C2443 use a special register to signal the reset to the processor and used therefore the s3c24xx_reset_hook mechanism in the s3c24xx-specific arch reset. This patch introduces restart functions for these architectures, moves the board files to them and remo

[PATCH 10/12] ARM: restart: EXYNOS: use new restart hook

2011-12-20 Thread Kukjin Kim
From: Russell King Hook these platforms restart code into the new restart hook rather than using arch_reset(). Signed-off-by: Russell King [kgene@samsung.com: according to local header, updated] Signed-off-by: Kukjin Kim --- arch/arm/mach-exynos/common.c |7 +

[PATCH 09/12] ARM: EXYNOS: introduce arch/arm/mach-exynos/common.[ch]

2011-12-20 Thread Kukjin Kim
This patch introduces common.[ch] which are used only in the arch/arm/mach-exynos/ directory. The common.c file merges the cpu.c, init.c, irq-combiner.c and irq-eint.c files which are used commonly on EXYNOS SoCs and the common.h file replaces with plat/exynos4.h file. Cc: Ben Dooks Cc: Russell K

[PATCH 08/12] ARM: restart: S5PV210: use new restart hook

2011-12-20 Thread Kukjin Kim
From: Russell King Hook these platforms restart code into the new restart hook rather than using arch_reset(). Signed-off-by: Russell King [kgene@samsung.com: according to local header, updated] Signed-off-by: Kukjin Kim --- arch/arm/mach-s5pv210/common.c |6 +- arch/

[PATCH 07/12] ARM: S5PV210: introduce arch/arm/mach-s5pv210/common.[ch]

2011-12-20 Thread Kukjin Kim
This patch introduces common.[ch] which are used only in the arch/arm/mach-s5pv210/ directory. The common.c file merges the cpu.c and init.c which are used commonly on S5PCV210/S5PC100 SoC and the common.h local header file replaces with plat/s5pv210.h file. Cc: Ben Dooks Cc: Russell King Signed

[PATCH 06/12] ARM: restart: S5PC100: use new restart hook

2011-12-20 Thread Kukjin Kim
Hook these platforms restart code into the new restart hook rather than using arch_reset(). Cc: Ben Dooks Cc: Russell King Signed-off-by: Kukjin Kim --- arch/arm/mach-s5pc100/common.c |9 + arch/arm/mach-s5pc100/common.h |2 ++ arch/arm/mach-s5pc100/in

[PATCH 05/12] ARM: S5PC100: introduce arch/arm/mach-s5pc100/common.[ch]

2011-12-20 Thread Kukjin Kim
This patch introduces common.[ch] which are used only in the arch/arm/mach-s5pc100/ directory. The common.c file merges the cpu.c and init.c which are used commonly on S5PC100 SoC and the common.h local header file replaces with plat/s5pc100.h file. Cc: Ben Dooks Cc: Russell King Signed-off-by:

[PATCH 04/12] ARM: restart: S5P64X0: use new restart hook

2011-12-20 Thread Kukjin Kim
Hook these platforms restart code into the new restart hook rather than using arch_reset(). Cc: Ben Dooks Cc: Russell King Signed-off-by: Kukjin Kim --- arch/arm/mach-s5p64x0/common.c |9 + arch/arm/mach-s5p64x0/common.h |2 ++ arch/arm/mach-s5p64x0/in

[PATCH 03/12] ARM: S5P64X0: introduce arch/arm/mach-s5p64x0/common.[ch]

2011-12-20 Thread Kukjin Kim
This patch introduces common.[ch] which are used only in the arch/arm/mach-s5p64x0/ directory. The common.c file merges the cpu.c, init.c and irq-eint.c files which are used commonly on S5P64X0 SoCs and the common.h local header file replaces with plat/s5p6440.h and plat/s5p6450.h files. Cc: Ben D

[PATCH 02/12] ARM: restart: S3C64XX: use new restart hook

2011-12-20 Thread Kukjin Kim
Hook these platforms restart code into the new restart hook rather than using arch_reset(). Cc: Ben Dooks Cc: Russell King Signed-off-by: Kukjin Kim --- arch/arm/mach-s3c64xx/common.c | 10 ++ arch/arm/mach-s3c64xx/common.h |2 ++ arch/arm/

[PATCH 01/12] ARM: S3C64XX: introduce arch/arm/mach-s3c64xx/common.[ch]

2011-12-20 Thread Kukjin Kim
This patch introduces common.[ch] which are used only in the arch/arm/mach-s3c64xx/ directory. The common.c file merges the cpu.c, irq.c and irq-eint.c which are used commonly on S3C64XX SoCs and the common.h file replaces with plat/s3c6400.h and plat/s3c6410.h files. Cc: Ben Dooks Cc: Russell Ki

[PATCH 00/12] ARM: restart: SAMSUNG: use new restart hook

2011-12-20 Thread Kukjin Kim
This patch introduces common.[ch] in each SAMSUNG mach- directories and implements using new restart hook for Samsung stuff. This is against on rmk/devel-stable branch. [PATCH 01/12] ARM: S3C64XX: introduce arch/arm/mach-s3c64xx/common.[ch] [PATCH 02/12] ARM: restart: S3C64XX: use new restart hoo

Re: [PATCH 1/8] s3c-hsudc: move platform_data struct to global header

2011-12-20 Thread Heiko Stübner
Am Dienstag, 20. Dezember 2011, 12:25:00 schrieb Felipe Balbi: > Hi, > > On Mon, Dec 19, 2011 at 07:39:15PM +0100, Heiko Stübner wrote: > > Gadget drivers should be compilable on all architectures. > > This patch removes one dependency on architecture-specific code. > > > > Signed-off-by: Heiko S

Re: [PATCH 8/8] s3c-hsudc: remove the_controller global

2011-12-20 Thread Felipe Balbi
On Mon, Dec 19, 2011 at 07:43:35PM +0100, Heiko Stübner wrote: > Instead use container_of to retrieve the s3c_hsudc from the > struct usb_gadget pointer. > > Signed-off-by: Heiko Stuebner > --- > drivers/usb/gadget/s3c-hsudc.c | 11 ++- > 1 files changed, 6 insertions(+), 5 deletions(-

Re: [PATCH 8/8] s3c-hsudc: remove the_controller global

2011-12-20 Thread Felipe Balbi
Hi, On Mon, Dec 19, 2011 at 07:43:35PM +0100, Heiko Stübner wrote: > Instead use container_of to retrieve the s3c_hsudc from the > struct usb_gadget pointer. > > Signed-off-by: Heiko Stuebner aha, it's here. So I replied too fast. Sorry about that and thanks for doing this. -- balbi signatu

Re: [PATCH 1/8] s3c-hsudc: move platform_data struct to global header

2011-12-20 Thread Felipe Balbi
Hi, On Mon, Dec 19, 2011 at 07:39:15PM +0100, Heiko Stübner wrote: > Gadget drivers should be compilable on all architectures. > This patch removes one dependency on architecture-specific code. > > Signed-off-by: Heiko Stuebner > --- > arch/arm/mach-s3c2416/mach-smdk2416.c|1 + > arch/a

Re: [PATCH 5/8] s3c-hsudc: use udc_start and udc_stop functions

2011-12-20 Thread Felipe Balbi
Hi, On Mon, Dec 19, 2011 at 07:41:45PM +0100, Heiko Stübner wrote: > udc_start and udc_stop reduce code duplication in comparison to > start and stop generalising calls done by all drivers > (i.e. bind and unbind) and moving these calls to common code. > > Signed-off-by: Heiko Stuebner > --- >