[PATCH V2 05/41] staging: wilc1000: remove bool bRespRequired from send_config_pkt

2015-10-12 Thread Tony Cho
This patch removes 4th parameter, bool bRespRequired from the send_config_pkt function because it is not used inside the funcntion. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/coreconfigurator.c | 2 +- drivers/staging/wilc1000/coreconfigurator.h | 2 +-

[PATCH V2 06/41] staging: wilc1000: change parameter names in send_config_pkt

2015-10-12 Thread Tony Cho
This patch changes the parameter names in send_config_pkt function as the followings: - u8Mode to mode - pstrWIDs to wids - u32WIDsCount to count - drvHandler to drv Signed-off-by: Tony Cho --- drivers/staging/wilc1000/coreconfigurator.c | 41 ++---

[PATCH V2 09/41] staging: wilc1000: rename the member variable, enuWIDtype of wid

2015-10-12 Thread Tony Cho
From: Leo Kim This patch renames enuWIDtype of struct wid to type. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/coreconfigurator.h | 2 +- drivers/staging/wilc1000/host_interface.c | 184

[PATCH V2 04/41] staging: wilc1000: wilc_wfi_cfgoperations.c : removes unused local variables

2015-10-12 Thread Tony Cho
From: Leo Kim This patch removes useless local variable, s32Error and returns directly zero from wilc_wfi_cfgoperations.c and also removes incorrect break in switch-case statement. The break is not useless which is being called right after return statement. Signed-off-by: Leo

[PATCH V2 07/41] staging: wilc1000: remove typedef from tstrWID

2015-10-12 Thread Tony Cho
From: Leo Kim This patch removes typedef from the struct tstrWID and rename it to wid. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/coreconfigurator.c | 2 +- drivers/staging/wilc1000/coreconfigurator.h

[PATCH] iw: Fix return values when parameters are wrong

2015-10-12 Thread Ola Olsson
According to header file, wrong parameters yield 1 as return value. Also tried to fix the comments since one part of it was unreadable. Signed-off-by: Ola Olsson --- interface.c |6 ++ iw.h|4 ++-- ps.c|6 ++ 3 files changed, 6

[PATCH] ocb: use correct "MHz" instead of "MHZ"

2015-10-12 Thread Ola Olsson
Fixes the last typos of MHZ to MHz Signed-off-by: Ola Olsson --- ocb.c |6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/ocb.c b/ocb.c index fc48ecf..c60591c 100644 --- a/ocb.c +++ b/ocb.c @@ -18,9 +18,9 @@ static int join_ocb(struct

[PATCH v2 1/2] cfg80211: Add multiple scan plans for scheduled scan

2015-10-12 Thread Luca Coelho
From: Avraham Stern Add the option to configure multiple 'scan plans' for scheduled scan. Each 'scan plan' defines the number of scan cycles and the interval between scans. The scan plans are executed in the order they were configured. The last scan plan will always run

[PATCH v2 2/2] mac80211: Do not restart scheduled scan if multiple scan plans are set

2015-10-12 Thread Luca Coelho
From: Avraham Stern If multiple scan plans were set for scheduled scan, do not restart scheduled scan on reconfig because it is possible that some scan plans were already completed and there is no need to run them all over again. Instead, notify userspace that scheduled

[PATCH V2 19/41] staging: wilc1000: remove typedef from tenuHostIFstate

2015-10-12 Thread Tony Cho
From: Leo Kim This patch removes typedef from the enum tenuHostIFstate and rename it to host_if_state. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.h | 7 +++ 1 file changed, 3

[PATCH V2 11/41] staging: wilc1000: rename the member variable, s32ValueSize of wid

2015-10-12 Thread Tony Cho
From: Leo Kim This patch renames s32ValueSize of struct wid to size. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/coreconfigurator.c | 6 +- drivers/staging/wilc1000/coreconfigurator.h | 2 +-

[PATCH V2 14/41] staging: wilc1000: remove unused struct tstrBssTable

2015-10-12 Thread Tony Cho
From: Leo Kim This patch removes struct tstrBssTable with related comment. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 6 -- 1 file changed, 6 deletions(-) diff --git

[PATCH V2 12/41] staging: wilc1000: rename the member variable, ps8WidVal of wid

2015-10-12 Thread Tony Cho
From: Leo Kim This patch renames ps8WidVal of struct wid to val. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/coreconfigurator.c | 4 +- drivers/staging/wilc1000/coreconfigurator.h | 2 +-

[PATCH V2 08/41] staging: wilc1000: remove typedef from tenuWIDtype

2015-10-12 Thread Tony Cho
From: Leo Kim This patch remove typedef from the enum tenuWIDtype and rename it to WID_TYPE. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/coreconfigurator.h | 2 +-

[PATCH V2 16/41] staging: wilc1000: remove _tstrJoinParam from join_bss_param

2015-10-12 Thread Tony Cho
From: Leo Kim This patch removes struct _tstrJoinParam from the struct join_bss_param because it is not used inside the struct. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 1 - 1 file

[PATCH V2 30/41] staging: wilc1000: remove wilc_wlan.c included in wilc_wfi_cfgoperations.c

2015-10-12 Thread Tony Cho
This patch removes "wilc_wlan.c" from the wilc_wfi_cfgoperation.c file and adds wilc_wlan.o into Makefile to compile it because there is few benefits. This patch also adds "wilc_wfi_netdevice.h" in the wilc_wlan.c file to avoid the compile errors. Signed-off-by: Tony Cho ---

[PATCH V2 02/41] staging: wilc1000: rename the member variable, drvHandler of host_if_msg

2015-10-12 Thread Tony Cho
From: Leo Kim This patch renames drvHandler of struct host_if_msg to drv. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 168 +++--- 1 file changed, 84

[PATCH V2 03/41] staging: wilc1000: host_interface.c : removes unused local variables

2015-10-12 Thread Tony Cho
From: Leo Kim This patch removes unused local variables from host_interface.c. The unused local variable, s32Error is used just to return zero, so this patch calls "returns 0" instead of "return s32Error" after removing s32Error. Signed-off-by: Leo Kim

[PATCH V2 13/41] staging: wilc1000: remove unused struct tstrWidJoinReqExt

2015-10-12 Thread Tony Cho
From: Leo Kim This patch removes struct tstrWidJoinReqExt because it's not used. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 6 -- 1 file changed, 6 deletions(-) diff --git

[PATCH V2 17/41] staging: wilc1000: remove typedef from tstrWILC_UsrScanReq

2015-10-12 Thread Tony Cho
From: Leo Kim This patch removes typedef from the struct tstrWILC_UsrScanReq with related comments and renames it to user_scan_req. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.h | 7

[PATCH V2 10/41] staging: wilc1000: rename the member variable, u16WIDid of wid

2015-10-12 Thread Tony Cho
From: Leo Kim This patch renames u16WIDid of struct wid to id. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/coreconfigurator.c | 8 +- drivers/staging/wilc1000/coreconfigurator.h | 2 +-

[PATCH V2 20/41] staging: wilc1000: remove typedef from tstrFoundNetworkInfo

2015-10-12 Thread Tony Cho
From: Leo Kim This patch removes typedef from the struct tstrFoundNetworkInfo and rename it to found_net_info. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.h | 6 +++--- 1 file changed, 3

[PATCH V2 22/41] staging: wilc1000: remove unused struct WILC_WFIDrvHandle

2015-10-12 Thread Tony Cho
From: Leo Kim This patch removes unused the struct WILC_WFIDrvHandle with related commnets. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.h | 5 - 1 file changed, 5 deletions(-) diff

[PATCH V2 21/41] staging: wilc1000: remove typedef from tstrHiddenNetworkInfo

2015-10-12 Thread Tony Cho
From: Leo Kim This patch removes typedef from the struct tstrHiddenNetworkInfo with related comments and renames it to hidden_net_info. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.h | 8

[PATCH V2 29/41] staging: wilc1000: host_infterface.h: remove unused enum tenuWILC_StaFlag

2015-10-12 Thread Tony Cho
This patch removes unused enum tenuWILC_StaFlag from the host_interface.h. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.h | 20 1 file changed, 20 deletions(-) diff --git a/drivers/staging/wilc1000/host_interface.h

[PATCH V2 25/41] staging: wilc1000: remove typedef from tenuScanEvent

2015-10-12 Thread Tony Cho
From: Leo Kim This patch removes typedef from the enum tenuScanEvent and rename it to scan_event. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 2 +-

[PATCH V2 24/41] staging: wilc1000: remove typedef from tstrStatistics

2015-10-12 Thread Tony Cho
From: Leo Kim This patch removes typedef from the struct tstrStatistics and rename it to rf_info. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 6 +++---

[PATCH V2 26/41] staging: wilc1000: rename typedef from tenuCfgParam

2015-10-12 Thread Tony Cho
From: Leo Kim This patch rename typedef from the enum tenuCfgParamand rename it to cfg_param. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.h | 4 ++-- 1 file changed, 2 insertions(+), 2

[PATCH V2 23/41] staging: wilc1000: remove unused struct cfg_param_t

2015-10-12 Thread Tony Cho
From: Leo Kim This patch removes unused the struct cfg_param_t. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.h | 6 -- 1 file changed, 6 deletions(-) diff --git

[PATCH V2 27/41] staging: wilc1000: remove typedef from tenuConnDisconnEvent

2015-10-12 Thread Tony Cho
From: Leo Kim This patch removes typedef from the enum tenuConnDisconnEvent and renames it to conn_event. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.h | 6 +++---

[PATCH V2 28/41] staging: wilc1000: remove typedef from tenuScanConnTimer

2015-10-12 Thread Tony Cho
From: Leo Kim This patch removes typedef from the enum tenuScanConnTimer and renames it to scan_conn_timer. Signed-off-by: Leo Kim Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 8 1 file changed, 4

Re: [PATCH 01/11] brcmfmac: expose device memory to devcoredump subsystem

2015-10-12 Thread Kalle Valo
kbuild test robot writes: > Hi Arend, > > [auto build test ERROR on next-20151008 -- if it's inappropriate base, please > ignore] > > config: x86_64-randconfig-x011-201540 (attached as .config) > reproduce: > # save the attached .config to linux build tree > make

Re: [PATCH] iw: Fix memory leak in error path

2015-10-12 Thread Johannes Berg
On Fri, 2015-10-09 at 16:52 +0200, Ola Olsson wrote: > The leak is present if malloc fails after requesting > a scan with ies or meshid as input. > Applied, thanks! johannes -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to

[PATCH V2 35/41] staging: wilc1000: rename strHostIFwpaAttr of union host_if_key_attr

2015-10-12 Thread Tony Cho
This patch renames strHostIFwpaAttr of union host_if_key_attr to wpa to avoid CamelCase naming convention. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 95 ++- 1 file changed, 44 insertions(+), 51 deletions(-) diff

[PATCH V2 31/41] staging: wilc1000: replace drvHandler and hWFIDrv with hif_drv

2015-10-12 Thread Tony Cho
This patch replaces the variable names of struct host_if_drv used as the functions' input parameter, drvHandler and hWFIDrv with hif_drv. In addition, the local variable declared in many functions, pstrWFIDrv is removed and hif_drv is directly used. A debug message printing pstrWFIDrv is deleted

[PATCH V2 39/41] staging: wilc1000: rename u8Wepidx of struct host_if_wep_attr

2015-10-12 Thread Tony Cho
This patch renames u8Wepidx of struct host_if_wep_attr to index to avoid CamelCase naming convention. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 20 ++-- 1 file changed, 10 insertions(+), 10 deletions(-) diff --git

[PATCH V2 32/41] staging: wilc1000: rename pstrCfgParamVal in struct cfg_param_attr

2015-10-12 Thread Tony Cho
This patch renames a variable of struct cfg_param_val in struct cfg_param_attr, pstrCfgParamVal to cfg_attr_info to avoid CamelCase naming convention. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 144 +++--- 1 file changed,

[PATCH V2 38/41] staging: wilc1000: rename u8WepKeylen of struct host_if_wep_attr

2015-10-12 Thread Tony Cho
This patch renames u8WepKeylen of struct host_if_wep_attr to key_len to avoid CamelCase naming convention. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 20 ++-- 1 file changed, 10 insertions(+), 10 deletions(-) diff --git

[PATCH V2 40/41] staging: wilc1000: rename u8mode of struct host_if_wep_attr

2015-10-12 Thread Tony Cho
This patch renames u8mode of struct host_if_wep_attr to mode to avoid CamelCase naming convention. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git

[PATCH V2 33/41] staging: wilc1000: rename u32SetCfgFlag of struct cfg_param_val

2015-10-12 Thread Tony Cho
This patch renames u32SetCfgFlag of struct cfg_param_val to flag to avoid CamelCase naming convention. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 36 +++ drivers/staging/wilc1000/host_interface.h | 2 +-

[PATCH V2 34/41] staging: wilc1000: rename strHostIFwepAttr of union host_if_key_attr

2015-10-12 Thread Tony Cho
This patch renames strHostIFwepAttr of union host_if_key_attr to wep to avoid CamelCase naming convention. Signed-off-by: Tony Cho --- drivers/staging/wilc1000/host_interface.c | 71 ++- 1 file changed, 31 insertions(+), 40 deletions(-) diff

[PATCH v2 6/7] ath10k: remove unused dl_is_polled

2015-10-12 Thread Rajkumar Manoharan
Since polling for received messages not supported, remove unused dl_is_polled. Reviewed-by: Michal Kazior Signed-off-by: Rajkumar Manoharan --- drivers/net/wireless/ath/ath10k/hif.h | 7 +++ drivers/net/wireless/ath/ath10k/htc.c | 7

[PATCH v2 2/7] ath10k: register per copy engine send completion callbacks

2015-10-12 Thread Rajkumar Manoharan
Register send completion callbacks for every copy engines (CE) separately instead of having common completion handler. Since some of the copy engines delivers different type of messages, per-CE callbacks help to service them differently. Reviewed-by: Michal Kazior

[PATCH v2 3/7] ath10k: register per copy engine receive callbacks

2015-10-12 Thread Rajkumar Manoharan
Register receive callbacks for every copy engines (CE) separately instead of having common receive handler. Some of the copy engines receives different type of messages (i.e HTT/HTC/pktlog) from target. Hence to service them accordingly, register per copy engine receive callbacks. Reviewed-by:

[PATCH v2 0/7] ath10k: add copy engine fast path support

2015-10-12 Thread Rajkumar Manoharan
Below patchset adds fast path support for uplink traffic by bypassing HTC layer processing. This is enabled by making use of unused copy engine 5 to receive HTT messages directly from HIF layer. From initial validation in VHT80/5G mode TCP UL is improved to 900Mbps from ~840Mbps in conducted test.

[PATCH v2 1/7] ath10k: export htc tx rx handlers

2015-10-12 Thread Rajkumar Manoharan
Export HTC layer tx and rx handlers. This will be used by HIF layer for per-CE data processing. Instead of callback mechanism, HIF will call appropriate upper layers API directly. Reviewed-by: Michal Kazior Signed-off-by: Rajkumar Manoharan

[PATCH] iw: Adding helpful hints for vendor cmd

2015-10-12 Thread Ola Olsson
Without having access to the source, it was hard to know the format of vendor oui and sub cmd. This commit fixes that. Signed-off-by: Ola Olsson --- vendor.c | 14 +- 1 file changed, 9 insertions(+), 5 deletions(-) diff --git a/vendor.c b/vendor.c index

[PATCH] iw: Fixes help text for event

2015-10-12 Thread Ola Olsson
According to source, the -t and -r options are mutually exclusive. This commit fixes the help text accordingly. Signed-off-by: Ola Olsson --- event.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/event.c b/event.c index 5d0bfde..a342dc4 100644

Re: [PATCH 01/11] brcmfmac: expose device memory to devcoredump subsystem

2015-10-12 Thread Arend van Spriel
On 10/12/2015 10:59 AM, Kalle Valo wrote: kbuild test robot writes: Hi Arend, [auto build test ERROR on next-20151008 -- if it's inappropriate base, please ignore] config: x86_64-randconfig-x011-201540 (attached as .config) reproduce: # save the attached .config to

Re: [PATCH] iw: Adding helpful hints for vendor cmd

2015-10-12 Thread Julian Calaby
Hi Ola, On Tue, Oct 13, 2015 at 7:32 AM, Ola Olsson wrote: > Without having access to the source, it was > hard to know the format of vendor oui and sub > cmd. This commit fixes that. > > Signed-off-by: Ola Olsson > --- > vendor.c | 14

Re: pull-request: wireless-drivers-next 2015-10-09

2015-10-12 Thread David Miller
From: Kalle Valo Date: Fri, 09 Oct 2015 18:13:22 +0300 > here's first wireless-drivers pull request for 4.4. New features and > bugfixes but not really anything out of ordinary. Please let me know if > there are any problems. Pulled, thanks Kalle. -- To unsubscribe from

Amministratore di sistema

2015-10-12 Thread ADMIN
La cassetta postale ha superato il limite di archiviazione, che è 20 GB come set del amministratore, si sta attualmente eseguendo il 20,9 GB, si potrebbe non essere in grado di inviare o ricevere nuovi messaggi fino a quando è convalidare nuovamente la cassetta postale. A riconvalidare la

Re: [PATCH] staging: wilc1000: remove WILC1000_DYNAMICALLY_ALLOCATE_MEMROY

2015-10-12 Thread Greg KH
On Sat, Oct 10, 2015 at 03:41:54PM +0300, Stanislav Kholmanskikh wrote: > The config option in the subject may be removed, because, > indeed, it only serves as the 'n' value for > CONFIG_WILC1000_PREALLOCATE_AT_LOADING_DRIVER > > Signed-off-by: Stanislav Kholmanskikh