Re: [PATCH] mac80211_hwsim: Added vendor echo command

2016-06-24 Thread Jouni Malinen
On Fri, Jun 24, 2016 at 10:13:54AM +0200, Erik Stromdahl wrote: > The purpose of the echo command is to provide a test > facility for user space programs. > diff --git a/drivers/net/wireless/mac80211_hwsim.c > b/drivers/net/wireless/mac80211_hwsim.c > @@ -332,14 +332,16 @@ static const struct

Re: [PATCH 3/8] wireless: ipw2200: fix old-style declaration

2016-06-24 Thread Stanislav Yakovlev
On 16 June 2016 at 17:52, Arnd Bergmann wrote: > Modern C standards expect the 'inline' keyword to come before the return > type in a declaration, and we get a warning for this with "make W=1": > > drivers/net/wireless/intel/ipw2x00/ipw2200.c:4096:1: error: 'inline' is not > at

Re: [ldv-project] [net] rtl8188ee: a potential race condition

2016-06-24 Thread Larry Finger
On 06/24/2016 09:17 AM, Vaishali Thakkar wrote: On Friday 10 June 2016 01:51 PM, Pavel Andrianov wrote: Hi! There is a potential data race in drivers/net/wireless/realtek/rtlwifi/rtl8188ee/rtl8188ee.ko. In the function rtl88ee_gpio_radio_on_off_checking the flag ppsc->rfchange_inprogress

Re: [ldv-project] [net] rtl8188ee: a potential race condition

2016-06-24 Thread Vaishali Thakkar
On Friday 10 June 2016 01:51 PM, Pavel Andrianov wrote: > Hi! > > There is a potential data race in > drivers/net/wireless/realtek/rtlwifi/rtl8188ee/rtl8188ee.ko. > > In the function rtl88ee_gpio_radio_on_off_checking the flag > ppsc->rfchange_inprogress is set with a spinlock protection. In

[PATCH v3 2/3] ath9k: add a helper to get the string representation of ath_bus_type

2016-06-24 Thread Martin Blumenstingl
Signed-off-by: Martin Blumenstingl --- this is a new patch which didn't exist in v2 yet, it prepares the new function ath_bus_type_to_string which will be used in patch #3 drivers/net/wireless/ath/ath.h | 2 ++ drivers/net/wireless/ath/main.c | 15

[PATCH RFC v3 3/3] ath9k: parse the device configuration from an OF node

2016-06-24 Thread Martin Blumenstingl
This makes it possible to configure ath9k based devices using devicetree. That makes some out-of-tree "convert devicetree to ath9k_platform_data glue"-code obsolete. Signed-off-by: Martin Blumenstingl --- changes in v2 -> v3: - replaced qca,eeprom-name with a

[PATCH RFC v3 1/3] Documentation: dt: net: add ath9k wireless device binding

2016-06-24 Thread Martin Blumenstingl
Add documentation how devicetree can be used to configure ath9k based devices. Signed-off-by: Martin Blumenstingl --- changes in v2 -> v3: - improved wording of the qca,disable-2ghz and qca,disable-5ghz properties - replaced qca,eeprom-name with qca,no-eeprom

[RFC v3] ath9k: add devicetree support to ath9k

2016-06-24 Thread Martin Blumenstingl
This series adds support for configuring ath9k based devices via devicetree. This was tested on PCI(e) based devices. This should work for AHB based devices as well as soon as the ath79 platform is ready to populate the ath9k wmac via devicetree. This series depends on my previous series: "ath9k:

[PATCH] mac80211_hwsim: Added vendor echo command

2016-06-24 Thread Erik Stromdahl
The purpose of the echo command is to provide a test facility for user space programs. Signed-off-by: Erik Stromdahl --- drivers/net/wireless/mac80211_hwsim.c | 27 +-- 1 file changed, 25 insertions(+), 2 deletions(-) diff --git

Re: [PATCH] mwifiex: Fixed endianness for event TLV type TLV_BTCOEX_WL_SCANTIME

2016-06-24 Thread Prasun Maiti
On Thu, Jun 16, 2016 at 9:49 AM, Prasun Maiti wrote: > The two members min_scan_time and max_scan_time of structure > "mwifiex_ie_types_btcoex_scan_time" are of two bytes each. The values > are assigned directtly from firmware without endian conversion handling. > So,