Re: [PATCH 2/3] gianfar: Magic Packet and suspend/resume support.

2008-08-07 Thread Jeff Garzik
Scott Wood wrote: Signed-off-by: Scott Wood <[EMAIL PROTECTED]> --- Documentation/powerpc/booting-without-of.txt |5 +- arch/powerpc/sysdev/fsl_soc.c|3 + drivers/net/gianfar.c| 118 +- drivers/net/gianfar.h

Re: [PATCH] i2c-mpc: suppress I2C device probing

2008-08-07 Thread Jean Delvare
Hi Grant, Wolgang, On Thu, 17 Jul 2008 12:02:50 -0600, Grant Likely wrote: > On Thu, Jul 17, 2008 at 4:37 AM, Wolfgang Grandegger <[EMAIL PROTECTED]> > wrote: > > This patch suppresses I2C device probing by clearing the class field > > of the "struct i2c_adapter" for the MPC I2C bus adapters. Som

Re: [PATCH 5/6] powerpc: add USB peripheral support to MPC836xMDS

2008-08-07 Thread Li Yang
Hi Anton, On Wed, 2008-08-06 at 16:07 +0400, Anton Vorontsov wrote: > Hello Li, > > On Wed, Aug 06, 2008 at 03:04:44PM +0800, Li Yang wrote: > > Signed-off-by: Li Yang <[EMAIL PROTECTED]> > > --- > > arch/powerpc/boot/dts/mpc836x_mds.dts | 15 ++- > > arch/powerpc/platforms/83xx/mpc836

Powerpc and ioremap

2008-08-07 Thread Sébastien Chrétien
Hello, I am trying to port linux on my Powerpc Board. I have used Linux 2.6.26 and gcc 3.4.5. I have used Uboot 1.2. Linux seems running from _start to udbg_early_init(). That's why I develloped a udbg_driver. It must write in a register which is located at 0x2001b044. So I wrote : void __iomem *

Re: [PATCH 2/6] powerpc: export cpm2_immr symbol for CPM2 drivers to compile as module

2008-08-07 Thread Li Yang
On Wed, 2008-08-06 at 19:24 +0400, Anton Vorontsov wrote: > On Wed, Aug 06, 2008 at 03:04:41PM +0800, Li Yang wrote: > > Signed-off-by: Li Yang <[EMAIL PROTECTED]> > > --- > > arch/powerpc/sysdev/cpm2.c |1 + > > 1 files changed, 1 insertions(+), 0 deletions(-) > > > > diff --git a/arch/power

Re: [PATCH] i2c-mpc: suppress I2C device probing

2008-08-07 Thread Wolfgang Grandegger
Jean Delvare wrote: Hi Grant, Wolgang, On Thu, 17 Jul 2008 12:02:50 -0600, Grant Likely wrote: On Thu, Jul 17, 2008 at 4:37 AM, Wolfgang Grandegger <[EMAIL PROTECTED]> wrote: This patch suppresses I2C device probing by clearing the class field of the "struct i2c_adapter" for the MPC I2C bus ad

Re: [PATCH 7/8] powerpc: implement crash_setup_regs for ppc32

2008-08-07 Thread Michael Ellerman
On Fri, 2008-08-01 at 18:14 +0400, Anton Vorontsov wrote: > From: Dale Farnsworth <[EMAIL PROTECTED]> > > Signed-off-by: Dale Farnsworth <[EMAIL PROTECTED]> > Signed-off-by: Anton Vorontsov <[EMAIL PROTECTED]> > @@ -51,6 +50,7 @@ static inline void crash_setup_regs(struct pt_regs *newregs, >

Re: [PATCH 1/8] powerpc: set up OF properties for ppc32 kexec

2008-08-07 Thread Michael Ellerman
On Fri, 2008-08-01 at 18:14 +0400, Anton Vorontsov wrote: > From: Dale Farnsworth <[EMAIL PROTECTED]> > > Refactor the setting of kexec OF properties, moving the common code > from machine_kexec_64.c to machine_kexec.c where it can be used on > both ppc64 and ppc32. This is needed for kexec to wo

Re: [PATCH 6/8] powerpc: set up OF properties for ppc32 kdump

2008-08-07 Thread Michael Ellerman
On Fri, 2008-08-01 at 18:14 +0400, Anton Vorontsov wrote: > From: Dale Farnsworth <[EMAIL PROTECTED]> > > Refactor the setting of kexec OF properties, moving the common code > from machine_kexec_64.c to machine_kexec.c where it can be used on > both ppc64 and ppc32. This will be needed for kdump

Re: [PATCH] i2c-mpc: suppress I2C device probing

2008-08-07 Thread Jochen Friedrich
Hi Wolfgang, > $ grep I2C_CLASS_HWMON * > i2c-cpm.c: .class = I2C_CLASS_HWMON | I2C_CLASS_SPD, > i2c-mpc.c: .class = I2C_CLASS_HWMON | I2C_CLASS_SPD, > i2c-ibm_iic.c: adap->class = I2C_CLASS_HWMON | I2C_CLASS_SPD; > i2c-pasemi.c: smbus->adapter.class = I2C_CLASS_HWM

Re: [PATCH] i2c-mpc: suppress I2C device probing

2008-08-07 Thread Jean Delvare
On Thu, 07 Aug 2008 12:50:11 +0200, Jochen Friedrich wrote: > Hi Wolfgang, > > > $ grep I2C_CLASS_HWMON * > > i2c-cpm.c:.class = I2C_CLASS_HWMON | I2C_CLASS_SPD, > > i2c-mpc.c:.class = I2C_CLASS_HWMON | I2C_CLASS_SPD, > > i2c-ibm_iic.c:adap->class = I2C_CLASS_H

Re: [PATCH 6/8] powerpc: set up OF properties for ppc32 kdump

2008-08-07 Thread Anton Vorontsov
On Thu, Aug 07, 2008 at 08:47:31PM +1000, Michael Ellerman wrote: > On Fri, 2008-08-01 at 18:14 +0400, Anton Vorontsov wrote: > > From: Dale Farnsworth <[EMAIL PROTECTED]> > > > > Refactor the setting of kexec OF properties, moving the common code > > from machine_kexec_64.c to machine_kexec.c whe

Re: [PATCH 2/6] powerpc: export cpm2_immr symbol for CPM2 drivers to compile as module

2008-08-07 Thread Anton Vorontsov
On Thu, Aug 07, 2008 at 06:19:22PM +0800, Li Yang wrote: > On Wed, 2008-08-06 at 19:24 +0400, Anton Vorontsov wrote: > > On Wed, Aug 06, 2008 at 03:04:41PM +0800, Li Yang wrote: > > > Signed-off-by: Li Yang <[EMAIL PROTECTED]> > > > --- > > > arch/powerpc/sysdev/cpm2.c |1 + > > > 1 files chan

Re: Powerpc and ioremap

2008-08-07 Thread Juergen Beisert
Am Donnerstag, 7. August 2008 11:54 schrieb Sébastien Chrétien: > Hello, > > I am trying to port linux on my Powerpc Board. I have used Linux 2.6.26 and > gcc 3.4.5. > I have used Uboot 1.2. > Linux seems running from _start to udbg_early_init(). That's why I > develloped a udbg_driver. > It must w

Re: Powerpc and ioremap

2008-08-07 Thread Sébastien Chrétien
Thanks for your answer. But it doesn't work. I think ioremap create a kernel panic. But I can't see because i have no UART ready. Is there a way in order to trace the failure ? 2008/8/7, Juergen Beisert <[EMAIL PROTECTED]>: > > Am Donnerstag, 7. August 2008 11:54 schrieb Sébastien Chrétien: > > >

[PATCH] powerpc: Fix Book-E watchdog timer interval setting

2008-08-07 Thread Matthias Fuchs
This patch fixes the setting of the Book-E watchdog timer interval setup on initialization and by ioctl(). Tested on PPC440EPx sequoia evaluation board. Signed-off-by: Matthias Fuchs <[EMAIL PROTECTED]> --- drivers/watchdog/booke_wdt.c |6 +- 1 files changed, 5 insertions(+), 1 deletions

Re: Powerpc and ioremap

2008-08-07 Thread Sébastien Chrétien
Can we call ioremap() during udbg_early_init ? 2008/8/7, Sébastien Chrétien <[EMAIL PROTECTED]>: > > Thanks for your answer. > But it doesn't work. > I think ioremap create a kernel panic. But I can't see because i have no > UART ready. > Is there a way in order to trace the failure ? > > 2008/8/7

Re: [PATCH 2/3] gianfar: Magic Packet and suspend/resume support.

2008-08-07 Thread Kumar Gala
On Aug 7, 2008, at 2:58 AM, Jeff Garzik wrote: Scott Wood wrote: Signed-off-by: Scott Wood <[EMAIL PROTECTED]> --- Documentation/powerpc/booting-without-of.txt |5 +- arch/powerpc/sysdev/fsl_soc.c|3 + drivers/net/gianfar.c| 118

Re: [PATCH] powerpc: Fix Book-E watchdog timer interval setting

2008-08-07 Thread Kumar Gala
On Aug 7, 2008, at 7:48 AM, Matthias Fuchs wrote: This patch fixes the setting of the Book-E watchdog timer interval setup on initialization and by ioctl(). Tested on PPC440EPx sequoia evaluation board. Signed-off-by: Matthias Fuchs <[EMAIL PROTECTED]> --- drivers/watchdog/booke_wdt.c |

Re: [PATCH 5/6] powerpc: add USB peripheral support to MPC836xMDS

2008-08-07 Thread Anton Vorontsov
On Thu, Aug 07, 2008 at 05:31:44PM +0800, Li Yang wrote: [...] > > > > > reg = <0x6c0 0x40 0x8b00 0x100>; > > > interrupts = <11>; > > > interrupt-parent = <&qeic>; > > > mode = "slave"; > > > > I'd suggest to rename this to

Re: [PATCH] powerpc: Fix Book-E watchdog timer interval setting

2008-08-07 Thread Matthias Fuchs
Sure, the former line: mtspr(SPRN_TCR, (mfspr(SPRN_TCR)&~WDTP(0))|WDTP(booke_wdt_period)); tries to mask the wdt interval period bits by and'ing with ~WDTP(0) which is 0x. So no bits are cleared and or'ing a new value does not change anything. The default interval is '3' which is the m

Re: [PATCH 4/6] powerpc: add USB peripheral support to MPC8272ADS

2008-08-07 Thread Scott Wood
On Thu, Aug 07, 2008 at 11:50:14AM +0800, Li Yang wrote: > udc is a common name for USB device mode drivers to work with Linux > gadget. We will have two separate drivers for USB host and device. > Probably we can have two compatibles "fsl,qe_udc" and "fsl,qe-usb-host" 1. If you have separate com

Re: [PATCH] i2c-mpc: suppress I2C device probing

2008-08-07 Thread Grant Likely
On Thu, Aug 7, 2008 at 5:07 AM, Jean Delvare <[EMAIL PROTECTED]> wrote: > On Thu, 07 Aug 2008 12:50:11 +0200, Jochen Friedrich wrote: >> Hi Wolfgang, >> >> > $ grep I2C_CLASS_HWMON * >> > i2c-cpm.c:.class = I2C_CLASS_HWMON | I2C_CLASS_SPD, >> > i2c-mpc.c:.class = I2C_

Re: [RFC] [PATCH 0/5 V2] Huge page backed user-space stacks

2008-08-07 Thread Mel Gorman
On (06/08/08 12:50), Dave Hansen didst pronounce: > On Wed, 2008-08-06 at 10:02 +0100, Mel Gorman wrote: > > > That said, this particular patch doesn't appear *too* bound to hugetlb > > > itself. But, some of its limitations *do* come from the filesystem, > > > like its inability to handle VM_GROW

[RFC] Driver helper functions.....

2008-08-07 Thread Sean MacLennan
The design of the warp is basically a processor, an FPGA, some RAM, some flash, and some glue logic. As the number of drivers rapidly expands... we are starting to hit inter-driver conflicts with a select few FPGA registers. So we need a few "helper" functions to handle locking. Basically somethin

Re: [RFC/PATCH 1/3] powerpc: add ioremap_bat() function for setting up BAT translated IO regions.

2008-08-07 Thread Scott Wood
On Wed, Aug 06, 2008 at 05:11:08PM -0600, Grant Likely wrote: > I do this particular test to make absolute sure that the caller > absolutely understands the limitations of the block mapping. If they > call this with something that isn't 128k aligned, then I make it fail > immediately so the coder

RE: [RFC/PATCH 2/3] of: add of_lookup_stdout() utility function

2008-08-07 Thread Yoder Stuart
> -Original Message- > From: [EMAIL PROTECTED] > [mailto:[EMAIL PROTECTED] > On Behalf Of David Gibson > Sent: Thursday, August 07, 2008 1:13 AM > To: Tabi Timur > Cc: linuxppc-dev@ozlabs.org; [EMAIL PROTECTED]; [EMAIL PROTECTED] > Subject: Re: [RFC/PATCH 2/3] of: add of_lookup_stdout(

Re: [RFC] [PATCH 0/5 V2] Huge page backed user-space stacks

2008-08-07 Thread Dave Hansen
On Thu, 2008-08-07 at 17:06 +0100, Mel Gorman wrote: > On (06/08/08 12:50), Dave Hansen didst pronounce: > > The main thing this set of patches does that I care about is take an > > anonymous VMA and replace it with a hugetlb VMA. It does this on a > > special cue, but does it nonetheless. > > Th

[PATCH 5121 pci 1/3] powerpc: 83xx: pci: Remove need for get_immrbase from mpc83xx_add_bridge.

2008-08-07 Thread John Rigby
Modify mpc83xx_add_bridge to get config space register base address from the device tree instead of immr + hardcoded offset. 83xx pci nodes have these changes: register properties now contain two address length tuples: First is the pci bridge register base, this has always been there.

[PATCH 5121 pci 2/3] powerpc: 5121: Add PCI support.

2008-08-07 Thread John Rigby
Uses mpc83xx_add_bridge in fsl_pci.c Adds second register tuple to pci node register property as previously done for 83xx device trees in a previous patch. Signed-off-by: John Rigby <[EMAIL PROTECTED]> --- arch/powerpc/boot/dts/mpc5121ads.dts |4 +++- arch/powerpc/platforms/512x/Kconfig

[PATCH 5121 pci 3/3] powerpc: pci: 5121: Hide pci bridge.

2008-08-07 Thread John Rigby
The class of the MPC5121 pci host bridge is PCI_CLASS_BRIDGE_OTHER while other freescale host bridges have class set to PCI_CLASS_PROCESSOR_POWERPC. This patch makes fixup_hide_host_resource_fsl match PCI_CLASS_BRIDGE_OTHER in addition to PCI_CLASS_PROCESSOR_POWERPC. Signed-off-by: John Rigby <[E

Re: [RFC/PATCH 2/3] of: add of_lookup_stdout() utility function

2008-08-07 Thread Timur Tabi
Yoder Stuart wrote: > The second was the idea that we may need a /aliases/stdin as well. > You could conceptually have stdout be a monitor and a stdin > be a keyboard. I don't think the hypervisor console subsystem supports this. I don't see any way of registering separate clients for input vs.

Re: [RFC/PATCH 1/3] powerpc: add ioremap_bat() function for setting up BAT translated IO regions.

2008-08-07 Thread Kumar Gala
On Aug 7, 2008, at 11:45 AM, Scott Wood wrote: On Wed, Aug 06, 2008 at 05:11:08PM -0600, Grant Likely wrote: I do this particular test to make absolute sure that the caller absolutely understands the limitations of the block mapping. If they call this with something that isn't 128k aligned, t

Re: [RFC/PATCH 2/3] of: add of_lookup_stdout() utility function

2008-08-07 Thread Milton Miller
TimurTabi wrote: > Yoder Stuart wrote: > > > The second was the idea that we may need a > > /aliases/stdin as well. You could conceptually have > > stdout be a monitor and a stdin be a keyboard. > > I don't think the hypervisor console subsystem supports > this. I don't see any way of registerin

Re: [RFC/PATCH 2/3] of: add of_lookup_stdout() utility function

2008-08-07 Thread Timur Tabi
Milton Miller wrote: > Why should what the hvc driver support have any effect on > what the binding should be? Because my hypervisor console driver uses the hypervisor console/tty subsystem. If the subsystem assumes one stdout/stdin device, then I must abide by that. -- Timur Tabi Linux kernel

Re: [RFC/PATCH 2/3] of: add of_lookup_stdout() utility function

2008-08-07 Thread Scott Wood
Timur Tabi wrote: Milton Miller wrote: Why should what the hvc driver support have any effect on what the binding should be? Because my hypervisor console driver uses the hypervisor console/tty subsystem. If the subsystem assumes one stdout/stdin device, then I must abide by that. So fix t

Device tree question

2008-08-07 Thread Steven A. Falco
I have added a compact flash to the external bus of a Sequoia (PPC440EPx) evaluation board. It is wired to CS1, and U-boot is set to configure CS1 to be at address 0xc100. U-boot can access the device, and reports the correct partition table, etc. so I believe the hardware is ok. I've create

Re: [RFC/PATCH 1/3] powerpc: add ioremap_bat() function for setting up BAT translated IO regions.

2008-08-07 Thread Benjamin Herrenschmidt
On Wed, 2008-08-06 at 20:49 -0500, Kumar Gala wrote: > On Aug 6, 2008, at 5:28 PM, Benjamin Herrenschmidt wrote: > > > > >> there is a bunch of error checking and difference in semantics that > >> you need to fix. I think introduce a new API for this is silly, > >> especially since we expect ther

Re: [RFC/PATCH 1/3] powerpc: add ioremap_bat() function for setting up BAT translated IO regions.

2008-08-07 Thread Benjamin Herrenschmidt
On Wed, 2008-08-06 at 17:11 -0600, Grant Likely wrote: > I'm not sure what you're asking. Are you asking about this particular > test, or are you asking why I don't also test the size? Badly worded. I meant BAT sizes are masks of bits. IE, they are power of 2 and the BAT address must be aligned

Re: [RFC/PATCH 2/3] of: add of_lookup_stdout() utility function

2008-08-07 Thread Benjamin Herrenschmidt
On Wed, 2008-08-06 at 00:35 -0600, Grant Likely wrote: > On Wed, Aug 6, 2008 at 12:32 AM, David Miller <[EMAIL PROTECTED]> wrote: > > From: Grant Likely <[EMAIL PROTECTED]> > > Date: Wed, 06 Aug 2008 00:02:44 -0600 > > > >> of_lookup_stdout() is useful for figuring out what device to use as output

Re: [RFC/PATCH 2/3] of: add of_lookup_stdout() utility function

2008-08-07 Thread Benjamin Herrenschmidt
> It's not what we do with flattened device trees blobs though. In the > flattened tree we're not using a /chosen/stdout property, just the > linux,stdout-path one. > > The question that remains is; should there be? Should the dt blobs > use /chosen/stdout also? (I'm not familiar enough with r

Re: [RFC/PATCH 2/3] of: add of_lookup_stdout() utility function

2008-08-07 Thread Benjamin Herrenschmidt
On Wed, 2008-08-06 at 11:46 -0500, Timur Tabi wrote: > On Wed, Aug 6, 2008 at 1:02 AM, Grant Likely <[EMAIL PROTECTED]> wrote: > > From: Grant Likely <[EMAIL PROTECTED]> > > > > of_lookup_stdout() is useful for figuring out what device to use as output > > for early boot progress messages. It retu

Re: [RFC/PATCH 1/3] powerpc: add ioremap_bat() function for setting up BAT translated IO regions.

2008-08-07 Thread Kumar Gala
On Aug 7, 2008, at 5:13 PM, Benjamin Herrenschmidt wrote: On Wed, 2008-08-06 at 20:49 -0500, Kumar Gala wrote: On Aug 6, 2008, at 5:28 PM, Benjamin Herrenschmidt wrote: there is a bunch of error checking and difference in semantics that you need to fix. I think introduce a new API for thi

Re: problem in booting kernel with mpc836x_mds.dtb

2008-08-07 Thread Jerry Van Baren
[EMAIL PROTECTED] wrote: Hi, I have the following problem, when i am trying to boot linux on MPC8360E MDS board with the mpc836x_mds.dtb created using dtc and mpc836x_mds.dts in from /arch/powerpc/boot/platforms/dts/ directory of linux-2.6.22 version. fdt_chosen: FDT_ERR_BADMAGIC after this