When enabling the debug-printouts, it came to me that I forgot to
mention something kind of important. Using the standard mpc52xx_pci.c,
even the memory resources are mapped to zero.
After disabling this code block, the memory regions are mapped out
fine (but still no IO):
static void
mpc52xx_pci
On Wed, 2009-02-04 at 23:53 -0600, Kumar Gala wrote:
>
> Are you going to ask "test" get pulled into Stephen's -next tree?
No, I don't intend to let things stage long enough in "test" for that to
matter and I asked Stephen, he isn't hot about it. Hopefully the max
lifetime for something in "test"
2009-02-05
03212009
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev
On Feb 4, 2009, at 5:45 PM, Madhulika Madishetty wrote:
diff --git a/arch/powerpc/kernel/cputable.c b/arch/powerpc/kernel/
cputable.c
index 923f87a..5c40da4 100644
--- a/arch/powerpc/kernel/cputable.c
+++ b/arch/powerpc/kernel/cputable.c
@@ -43,6 +43,7 @@ extern void __setup_cpu_440spe(unsigne
On Feb 4, 2009, at 10:01 PM, Benjamin Herrenschmidt wrote:
Hoy !
So I've been annoyed for some time by the way we do our preparation
for
the next merge window. The "next" branch is defined as not being
rebased
ever (well, as much as possible), which makes it impossible to just
stash thing
I've pushed these commits to the test branch. This include the next
branches from Kumar and Grant, which I'll move over to my "next" branch
soon, probably tomorrow, if the world doesn't end in the meantime.
The rest is picked up from patchwork, and will trickle up to "next" as I
see fit unless som
> Right, but then you need to set that in the VMA's, and thus gone is your
> nice fast g_u_p() that doesn't touch VMAs :-)
Registering memory is a slow path thing in the RDMA world. Speeding it
up is nice, so we make userspace do the madvise(VM_DONTCOPY) if it cares
but if it doesn't it can lea
On Wed, 2009-02-04 at 21:10 -0800, Roland Dreier wrote:
> > Note that g_u_p() has all sort of shortcommings... we were discussing
> > some of that recently due to bugs reported from the field.
> >
> > The problem mostly is that you cannot guarantee that the physical page
> > will remain mapped
On Wed, Jan 28, 2009 at 02:53:05PM -0800, James Hsiao wrote:
> This patch adds support for AMCC ppc4xx security device driver. This is the
> initial release that includes the driver framework with AES and SHA1
> algorithms
> support.
> The remaining algorithms will be released in the near future.
> Note that g_u_p() has all sort of shortcommings... we were discussing
> some of that recently due to bugs reported from the field.
>
> The problem mostly is that you cannot guarantee that the physical page
> will remain mapped to that virtual address in the process. For example,
> if your
On Wed, Feb 4, 2009 at 9:01 PM, Benjamin Herrenschmidt
wrote:
> [...]
> Now, one important rule is: test will be reset at the beginning of every
> merge window. I will not let it degenerate into the old linuxppc-dev bk
> tree that drifted for years and had things that never got merged.
>
> I'm als
Hoy !
So I've been annoyed for some time by the way we do our preparation for
the next merge window. The "next" branch is defined as not being rebased
ever (well, as much as possible), which makes it impossible to just
stash things early in there and rebase if needed, which is a useful
exercise in
Benjamin Herrenschmidt wrote:
> On Wed, 2009-02-04 at 18:44 -0500, Oren Laadan wrote:
>> * Anything that is decided at compiled time should probably go to the arch-
>> dependent header.
>>
>> * Anything that can change at boot time (e.g., for x86 that would include
>> the capabilities of the FPU)
On Thu, Feb 05, 2009 at 12:15:31PM +1100, Benjamin Herrenschmidt wrote:
> On Wed, 2009-02-04 at 19:35 -0500, Steven Rostedt wrote:
> > On Thu, 2009-02-05 at 11:31 +1100, Benjamin Herrenschmidt wrote:
> > > On Wed, 2009-02-04 at 18:08 +0300, Anton Vorontsov wrote:
> > > > Remove -fno-omit-frame-poin
On Wed, 2009-02-04 at 19:35 -0500, Steven Rostedt wrote:
> On Thu, 2009-02-05 at 11:31 +1100, Benjamin Herrenschmidt wrote:
> > On Wed, 2009-02-04 at 18:08 +0300, Anton Vorontsov wrote:
> > > Remove -fno-omit-frame-pointer flag from CFLAGS.
> > > Remove -fno-omit-frame-pointer workarounds.
> >
> >
On Wed, Feb 04, 2009 at 07:35:54PM -0500, Steven Rostedt wrote:
>
> On Thu, 2009-02-05 at 11:31 +1100, Benjamin Herrenschmidt wrote:
> > On Wed, 2009-02-04 at 18:08 +0300, Anton Vorontsov wrote:
> > > Remove -fno-omit-frame-pointer flag from CFLAGS.
> > > Remove -fno-omit-frame-pointer workarounds
On Thu, 2009-02-05 at 11:31 +1100, Benjamin Herrenschmidt wrote:
> On Wed, 2009-02-04 at 18:08 +0300, Anton Vorontsov wrote:
> > Remove -fno-omit-frame-pointer flag from CFLAGS.
> > Remove -fno-omit-frame-pointer workarounds.
>
> But what about -pg -requires -fno-omit-frame-pointer ?
I don't thi
On Wed, 2009-02-04 at 18:08 +0300, Anton Vorontsov wrote:
> Remove -fno-omit-frame-pointer flag from CFLAGS.
> Remove -fno-omit-frame-pointer workarounds.
But what about -pg -requires -fno-omit-frame-pointer ?
Ben.
> Signed-off-by: Anton Vorontsov
> ---
> arch/powerpc/Makefile
On Wed, 2009-02-04 at 18:44 -0500, Oren Laadan wrote:
> * Anything that is decided at compiled time should probably go to the arch-
> dependent header.
>
> * Anything that can change at boot time (e.g., for x86 that would include
> the capabilities of the FPU), or even run time (is there any ?) sh
> get_user_pages() also gives us the vma back, and we can see from
> is_vm_hugetlb_page() (-- BTW can I just say that a function
> is_xxx_page() that operates on vmas is horribly misnamed --) that these
> pages all come from a hugetlb mapping, but figuring out the size of that
> mapping is I guess
From: Madhulika Madishetty
This patch contains initial framework for the AMCC Redwood board.
Signed-off-by: Madhulika Madishetty
Signed-off-by: Tirumala Marri
Signed-off-by: Feng Kan
Signed-off-by: Vidhyananth Venkatasamy
Signed-off-by: Preetesh Parekh
Acked-by: Loc Ho
Acked-by: Feng Kan
Benjamin Herrenschmidt wrote:
> On Wed, 2009-02-04 at 09:54 -0600, Serge E. Hallyn wrote:
>> Quoting Benjamin Herrenschmidt (b...@kernel.crashing.org):
+struct cr_hdr_cpu {
+ struct pt_regs pt_regs;
+ /* relevant fields from thread_struct */
+ double fpr[32][TS_FPRWIDTH];
>
> OK, I've been able to reproduce it. It looks like the assumptions of the
> trampoline that I've made is not correct if the size of the module is over
> some limit. I had to make usb-core into a module, and I see the same
> bug.
>
> I'll take a deeper look into it.
Thanks ! I've been a bit
Julia Lawall wrote:
Signed-off-by: Julia Lawall
---
arch/powerpc/platforms/82xx/pq2ads-pci-pic.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff -u -p a/arch/powerpc/platforms/82xx/pq2ads-pci-pic.c
b/arch/powerpc/platforms/82xx/pq2ads-pci-pic.c
--- a/arch/powerpc/platforms/82xx/
From: Julia Lawall
Taking sizeof the result of sizeof is quite strange and does not seem to be
what is wanted here.
This was fixed using the following semantic patch.
(http://www.emn.fr/x-info/coccinelle/)
//
@@
expression E;
@@
- sizeof (
sizeof (E)
- )
@@
type T;
@@
- sizeof (
sizeof
On Sat, 31 Jan 2009, Arnd Bergmann wrote:
> On Saturday 31 January 2009, Geoff Levand wrote:
> > >
> > > So I take it that the above showed that the code worked for some?
> >
> > In my trials it blows up on the first load_module() call, and for my
> > config that was usbcore:
>
> I looked into
On Wed, Feb 04, 2009 at 10:35:31PM +0100, Gerhard Pircher wrote:
>
> Original-Nachricht
> > Datum: Wed, 4 Feb 2009 21:59:41 +0100
> > Von: Gabriel Paubert
> > An: Benjamin Herrenschmidt
> > CC: Gerhard Pircher , linuxppc-dev list
> >
> > Betreff: Re: [PATCH v2 1/4] Add platfo
Original-Nachricht
> Datum: Wed, 4 Feb 2009 21:59:41 +0100
> Von: Gabriel Paubert
> An: Benjamin Herrenschmidt
> CC: Gerhard Pircher , linuxppc-dev list
>
> Betreff: Re: [PATCH v2 1/4] Add platform support for AmigaOne
> On Wed, Feb 04, 2009 at 02:50:07PM +1100, Benjamin Her
> You should be able to find the head of a compound page using the
> compound_head() inline, so try
> PAGE_SIZE << compound_order(compound_head(page))
Thanks! Looks like that should be exactly what we need.
- R.
___
Linuxppc-dev mailing list
* Anton Vorontsov wrote:
> This patch gives arches more freedom on overwriting CFLAGS, specifically
> on PowerPC we want to remove -fno-omit-frame-pointer flag.
>
> Signed-off-by: Anton Vorontsov
> ---
> Makefile |4 ++--
> 1 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git
On Wed, 04 Feb 2009 11:11:22 -0800
Roland Dreier wrote:
> > > > huge_page_size(page_hstate(page))
>
> > > That would suit. I assume the intention is for that to be usable by
> > > driver modules on any architecture?
>
> > erm, you overestimate the amount of planning and forethought
On Wed, Feb 04, 2009 at 11:11:22AM -0800, Roland Dreier wrote:
> Heh. Looking into the implementation, it seems that I could actually do
> PAGE_SIZE << compound_order(page)
> directly (since there's no reason to go from size to hstate and back to
> size. I don't know all the details of thes
On Wed, Feb 04, 2009 at 02:50:07PM +1100, Benjamin Herrenschmidt wrote:
>
> > + hose->first_busno = bus_range ? bus_range[0] : 0;
> > + hose->last_busno = bus_range ? bus_range[1] : 0xff;
> > +
> > + setup_indirect_pci(hose, 0xfec00cf8, 0xfee00cfc, 0);
>
> Minor in the context of amigaone but sti
On Wed, 2009-02-04 at 09:54 -0600, Serge E. Hallyn wrote:
> Quoting Benjamin Herrenschmidt (b...@kernel.crashing.org):
> >
> > > +struct cr_hdr_cpu {
> > > + struct pt_regs pt_regs;
> > > + /* relevant fields from thread_struct */
> > > + double fpr[32][TS_FPRWIDTH];
> > > + unsigned int fpscr;
>
And I really mean -next this time. :-)
The following changes since commit b1792e367053968f2ddb48bc911d314143ce6242:
Linus Torvalds (1):
Merge branch 'for-linus' of git://git.kernel.org/.../jbarnes/pci-2.6
are available in the git repository at:
git://git.secretlab.ca/git/linux-2.6-m
On Wed, 2009-02-04 at 13:09 +0100, Gerhard Pircher wrote:
> I agree that these addresses should come from the device-tree, but these
> two config registers are not located within the normal PCI I/O address
> space (0xfe00-0xfec0).
> Maybe I should add a "reg" property to the PHB node, but I
Hey Wolfram, thanks for the review.
On Wed, Feb 4, 2009 at 12:55 PM, Wolfram Sang wrote:
>
> I have been told to move such a changelog below the dashed lines,
> because it is not so important for the git-history.
This is only in my email for review purposes. It won't be in the git commit.
>> +
On Wed, Feb 4, 2009 at 2:14 PM, Alan Nishioka wrote:
> request_firmware uses the hotplug code so the kernel doesn't have any
> sourceless binaries compiled into it. on init, the driver requests the
> firmware, user mode hotplug daemon loads the firmware from disk and gives
> the driver a pointer
Timur Tabi wrote:
> However, it appears that this is not common behavior for I2C driver. In
> fact, only these six drivers ever call wait_event_interruptible_timeout():
>
> i2c-cpm.c
I don't know about the others, but in i2c-cpm.c the use of interruptible
wait seems incorrect. Maybe it could be
Hello Grant,
On Wed, Feb 04, 2009 at 11:23:05AM -0700, Grant Likely wrote:
> From: Grant Likely
>
> This patch adds IRQ controller support to the MPC5200 General
> Purpose Timer (GPT) device driver. With this patch the mpc5200-gpt
> driver supports both GPIO and IRQ functions.
>
> The GPT driv
request_firmware uses the hotplug code so the kernel doesn't have any
sourceless binaries compiled into it. on init, the driver requests the
firmware, user mode hotplug daemon loads the firmware from disk and
gives the driver a pointer to it.
since this is a short term problem, i would sugges
> > > huge_page_size(page_hstate(page))
> > That would suit. I assume the intention is for that to be usable by
> > driver modules on any architecture?
> erm, you overestimate the amount of planning and forethought which goes
> into these things ;)
> The lack of any EXPORT_SYMBOL
I am currently trying to get an MPC5200-based board to run Linux
2.6.28. Most of the devices are working, however i have some issues
with the PCI-bus. More precisely, the issue is that all of
the cards' IO-regions are mapped to address 0x0.
In my device tree I have the following:
p...@f000
Hi Milton,
I've tracked it down to the device tree passed to the second kernel being
screwed-up when patched by kexec-tools. Namely, it was creating
linux,usable-memory entries that were wrong, and the MMU initialization hung
when it failed allocating for the page tables. I hacked the tool, and go
From: Grant Likely
This patch adds IRQ controller support to the MPC5200 General
Purpose Timer (GPT) device driver. With this patch the mpc5200-gpt
driver supports both GPIO and IRQ functions.
The GPT driver was contained within the mpc52xx_gpio.c file, but this
patch moves it out into a new fi
On Wed, Feb 4, 2009 at 9:53 AM, Tobias Knutsson
wrote:
> clock-frequency = <0x1e84800>; //<0>; // From boot loader
> interrupts = <2 8 0 2 9 0 2 10 0>;
> interrupt-parent = <&mpc5200_pic>;
> bus-range = <0 0>;
> ranges = <0x020
2009/2/4 Steven Rostedt :
>
> >From ftrace.h:
>
> #ifdef CONFIG_FRAME_POINTER
> /* TODO: need to fix this for ARM */
> # define CALLER_ADDR0 ((unsigned long)__builtin_return_address(0))
> # define CALLER_ADDR1 ((unsigned long)__builtin_return_address(1))
> # define CALLER_ADDR2 ((unsigned long)__bu
I received great help last week in getting a USB wi fi device working.
Thanks again, but can someone read below and advise me on kernel 2.6.24?
The best out-of-the box solution for me was 2.6.27.8, for which I needed
a Denx eldx toolchain in place of the toolchain I was using to compile
2.6.24.
Quoting Benjamin Herrenschmidt (b...@kernel.crashing.org):
>
> > +struct cr_hdr_cpu {
> > + struct pt_regs pt_regs;
> > + /* relevant fields from thread_struct */
> > + double fpr[32][TS_FPRWIDTH];
> > + unsigned int fpscr;
> > + int fpexc_mode;
> > + /* unsigned int align_ctl; this is
On Wed, Feb 04, 2009 at 04:26:15PM +0100, Frédéric Weisbecker wrote:
[...]
> > @@ -136,6 +138,7 @@ config SCHED_TRACER
> >select TRACING
> >select CONTEXT_SWITCH_TRACER
> >select TRACER_MAX_TRACE
> > + select FRAME_POINTER
> >help
> > This tracer track
2009/2/4 Anton Vorontsov :
> Irqsoff, switch and preempt tracers use CALLER_ADDR macros, so they
> should select FRAME_POINTER. Otherwise traces are meaningless.
>
> Signed-off-by: Anton Vorontsov
> ---
> kernel/trace/Kconfig |3 +++
> 1 files changed, 3 insertions(+), 0 deletions(-)
>
> diff
On Wed, 2009-02-04 at 16:26 +0100, Frédéric Weisbecker wrote:
> 2009/2/4 Anton Vorontsov :
> > Irqsoff, switch and preempt tracers use CALLER_ADDR macros, so they
> > should select FRAME_POINTER. Otherwise traces are meaningless.
> >
> > Signed-off-by: Anton Vorontsov
> > ---
> > kernel/trace/Kc
Irqsoff, switch and preempt tracers use CALLER_ADDR macros, so they
should select FRAME_POINTER. Otherwise traces are meaningless.
Signed-off-by: Anton Vorontsov
---
kernel/trace/Kconfig |3 +++
1 files changed, 3 insertions(+), 0 deletions(-)
diff --git a/kernel/trace/Kconfig b/kernel/trac
Remove -fno-omit-frame-pointer flag from CFLAGS.
Remove -fno-omit-frame-pointer workarounds.
Signed-off-by: Anton Vorontsov
---
arch/powerpc/Makefile| 10 ++
arch/powerpc/kernel/Makefile | 10 +-
arch/powerpc/platforms/powermac/Makefile |2
This patch gives arches more freedom on overwriting CFLAGS, specifically
on PowerPC we want to remove -fno-omit-frame-pointer flag.
Signed-off-by: Anton Vorontsov
---
Makefile |4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
index 7715b2c..d1ba93f 1
On Tue, Feb 03, 2009 at 07:19:55PM +0300, Anton Vorontsov wrote:
> On Tue, Feb 03, 2009 at 05:06:45PM +0100, Ingo Molnar wrote:
> >
> > * Anton Vorontsov wrote:
> >
> > > According to this discussion:
> > >
> > > http://lkml.org/lkml/2008/7/25/338
> > > http://lkml.org/lkml/2008/7/26/72
> > >
Lixin Yao wrote:
> I redefined io functions in libata-sff.c, byte operations are converted
> to 16bit word operations. Maybe I should ask for HW changes in new
> revisions of the board.
>
I do recommend that. We got it wrong on our first board too. :-) It
is much better to get the hardware righ
Hi
I'm trying to get the audio interface working on my ADS5121 Rev4.0 and
have some questions.
I did manage to record and play audio files of type raw and format
S32_BE like this:
$ arecord -traw -c2 -fS32_BE -Dhw:0,0 testfile
$ aplay -traw -c2 -fS32_BE -Dhw:0,0 testfile
I am not able to get th
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev
Ravishankar Govindarao
RFL Electronics Inc.
E-mail : ravi@rflelect.com
Voice: 973.334.3100 Ext. 233
Fax: 973.334.3863
CONFIDENTIALITY NOTE
This e-mail, including any attachments, may contain confidential and/or
legally privileged information. The Information is intended only for the
use of
On Wed, 4 Feb 2009, Sachin P. Sant wrote:
> Hi Stephen,
>
> 20090204 randconfig build on powerpc fails with :
>
> CC arch/powerpc/kernel/ftrace.o
> arch/powerpc/kernel/ftrace.c: In function __ftrace_make_nop:
> arch/powerpc/kernel/ftrace.c:204: error: der
On Wed, 2009-02-04 at 11:47 +1100, Benjamin Herrenschmidt wrote:
> On Tue, 2009-02-03 at 15:50 +, Martyn Welch wrote:
> >
> > The primary CPU is spinning in smp_generic_give_timebase() waiting for
> > "!tbsync->ack". The secondary CPU has made it into
> > smp_generic_take_timebase() and has ap
Original-Nachricht
> Datum: Wed, 04 Feb 2009 14:50:07 +1100
> Von: Benjamin Herrenschmidt
> An: Gerhard Pircher
> CC: linuxppc-dev list
> Betreff: Re: [PATCH v2 1/4] Add platform support for AmigaOne
> > + hose->first_busno = bus_range ? bus_range[0] : 0;
> > + hose->last_bus
Hi Stephen,
20090204 randconfig build on powerpc fails with :
CC arch/powerpc/kernel/ftrace.o
arch/powerpc/kernel/ftrace.c: In function __ftrace_make_nop:
arch/powerpc/kernel/ftrace.c:204: error: dereferencing pointer to incomplete
type
arch/powerpc/kernel/ftrace.c: In function
unsubscribe linux-kernel
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev
unsubscribe linux-kernel
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev
___
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev
67 matches
Mail list logo