[PATCH 2/2 v2] powerpc/t1023rdb: add ina220 current sensor node

2015-07-06 Thread Shengzhou Liu
Add support for INA220 current sensor. Signed-off-by: Shengzhou Liu --- v2: rename node name to 'current-sensor' for generic. arch/powerpc/boot/dts/t1023rdb.dts | 11 +++ 1 file changed, 11 insertions(+) diff --git a/arch/powerpc/boot/dts/t1023rdb.dts b/arch/powerpc/boot/dts/t1023rdb.

[PATCH 1/2 v2] powerpc/t1024rdb: add ina220 current sensor node

2015-07-06 Thread Shengzhou Liu
Add support for INA220 current sensor. Signed-off-by: Shengzhou Liu --- v2: rename node name to 'current-sensor' for generic. arch/powerpc/boot/dts/t1024rdb.dts | 6 ++ 1 file changed, 6 insertions(+) diff --git a/arch/powerpc/boot/dts/t1024rdb.dts b/arch/powerpc/boot/dts/t1024rdb.dts ind

[PATCH 2/2] cxl: Fail mmap if requested mapping is larger than assigned problem state area

2015-07-06 Thread Ian Munsie
From: Ian Munsie This patch makes the mmap call fail outright if the requested region is larger than the problem state area assigned to the context so the error is reported immediately rather than waiting for an attempt to access an address out of bounds. Although we never expect users to map mo

[PATCH 1/2] cxl: Fix off by one error allowing subsequent mmap page to be accessed

2015-07-06 Thread Ian Munsie
From: Ian Munsie It was discovered that if a process mmaped their problem state area they were able to access one page more than expected, potentially allowing them to access the problem state area of an unrelated process. This was due to a simple off by one error in the mmap fault handler intro

[PATCH] powerpc: Remove mtmsrd(), use existing mtmsr()

2015-07-06 Thread Anton Blanchard
mtmsr() does the right thing on 32bit and 64bit, so use it everywhere. Signed-off-by: Anton Blanchard --- arch/powerpc/include/asm/reg.h | 3 +-- arch/powerpc/oprofile/op_model_power4.c | 4 ++-- 2 files changed, 3 insertions(+), 4 deletions(-) diff --git a/arch/powerpc/include/asm/reg

Re: [alsa-devel][PATCH 1/2] ASoC: fsl_ssi: Add driver suspend and resume to support MEGA Fast

2015-07-06 Thread Timur Tabi
On Jul 6, 2015, at 4:49 AM, Zidan Wang wrote: > +static bool fsl_ssi_readable_reg(struct device *dev, unsigned int reg) > +{ > + switch (reg) { > + case CCSR_SSI_STX0: > + case CCSR_SSI_STX1: > + case CCSR_SSI_SRX0: > + case CCSR_SSI_SRX1: > + case CCSR_SSI_SCR: > + ca

Re: [alsa-devel][PATCH 2/2] ASoC: fsl_ssi: sound is wrong after suspend/resume

2015-07-06 Thread Timur Tabi
On Jul 6, 2015, at 4:49 AM, Zidan Wang wrote: > The register SFCSR is volatile, but some bits in it need to be > recovered after suspend/resume. > > Signed-off-by: Zidan Wang Shouldn't this be part of patch #1? ___ Linuxppc-dev mailing list Linuxppc-d

Re: [PATCH v2] powerpc/powernv: Fix race in updating core_idle_state

2015-07-06 Thread Shreyas B Prabhu
On 07/07/2015 05:52 AM, Michael Ellerman wrote: > On Tue, 2015-07-07 at 01:39 +0530, Shreyas B. Prabhu wrote: >> Signed-off-by: Shreyas B. Prabhu >> Fixes: 7b54e9f213f76 'powernv/powerpc: Add winkle support for offline >> cpus' > > The sha is wrong, it should be 77b54e9f213f. > Argh! Sorry > A

Re: [PATCH] cxl: Fix refcounting in kernel API

2015-07-06 Thread Ian Munsie
Acked-by: Ian Munsie ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

[PATCH] cxl: Fix refcounting in kernel API

2015-07-06 Thread Michael Neuling
Currently the kernel API AFU dev refcounting is done on context start and stop. This patch moves this refcounting to context init and release, bringing it inline with how the userspace API does it. Without this we've seen the refcounting on the AFU get out of whack between the user and kernel API

Re: [PATCH v2] powerpc/powernv: Fix race in updating core_idle_state

2015-07-06 Thread Michael Ellerman
On Tue, 2015-07-07 at 01:39 +0530, Shreyas B. Prabhu wrote: > core_idle_state is maintained for each core. It uses 0-7 bits to track > whether a thread in the core has entered fastsleep or winkle. 8th bit is > used as a lock bit. ... > This patch fixes the above race by looping on the lock bit even

Re: [PATCH] Doc: powerpc: Fix typos in Documentation/powerpc

2015-07-06 Thread Ian Munsie
Acked-by: Ian Munsie ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

[PATCH 28/36] powerpc/PCI: Add IORESOURCE_MEM_64 for 64-bit resource in of parsing

2015-07-06 Thread Yinghai Lu
For device resource PREF bit setting under bridge 64-bit pref resource, we need to make sure only set PREF for 64bit resource, so set IORESOUCE_MEM_64 for 64bit resource during of device resource flags parsing. Link: https://bugzilla.kernel.org/show_bug.cgi?id=96261 Link: https://bugzilla.kernel.o

Re: [PATCH 1/2] powerpc/t1024rdb: add ina220 current sense node

2015-07-06 Thread Scott Wood
On Fri, 2015-07-03 at 17:50 +0800, Shengzhou Liu wrote: > Add support for INA220 current sense. > > Signed-off-by: Shengzhou Liu > --- > arch/powerpc/boot/dts/t1024rdb.dts | 7 +++ > 1 file changed, 7 insertions(+) > > diff --git a/arch/powerpc/boot/dts/t1024rdb.dts > b/arch/powerpc/boot/d

Re: [RFC PATCH 6/6] powerpc/kvm: change the condition of identifying hugetlb vm

2015-07-06 Thread Scott Wood
On Fri, 2015-07-03 at 16:47 +0800, wenwei tao wrote: > Hi Scott > > Thank you for your comments. > > Kernel already has that function: is_vm_hugetlb_page() , but the > original code didn't use it, > in order to keep the coding style of the original code, I didn't use it > either. > > For the sen

[PATCH v2] powerpc/powernv: Fix race in updating core_idle_state

2015-07-06 Thread Shreyas B. Prabhu
core_idle_state is maintained for each core. It uses 0-7 bits to track whether a thread in the core has entered fastsleep or winkle. 8th bit is used as a lock bit. The lock bit is set in these 2 scenarios- - The thread is first in subcore to wakeup from sleep/winkle. - If its the last thread in t

Re: [PATCH 6/6] nx-842-platform: if NX842 platform drivers are not modules, don't try to load them

2015-07-06 Thread Nishanth Aravamudan
On 06.07.2015 [16:13:07 +0800], Herbert Xu wrote: > On Thu, Jul 02, 2015 at 03:42:26PM -0700, Nishanth Aravamudan wrote: > > Based off the CONFIG_SPU_FS_MODULE code, only attempt to load platform > > modules if the nx-842 pseries/powernv drivers are built as modules. > > > > Otherwise, if CONFIG_D

[PATCH v2] crypto/nx-842-{powerpc,pseries}: reduce chattiness of platform drivers

2015-07-06 Thread Nishanth Aravamudan
On 03.07.2015 [11:30:32 +1000], Michael Ellerman wrote: > On Thu, 2015-07-02 at 15:40 -0700, Nishanth Aravamudan wrote: > > While we never would successfully load on the wrong machine type, there > > is extra output by default regardless of machine type. > > > > For instance, on a PowerVM LPAR, we

[PATCH] Doc: powerpc: Fix typos in Documentation/powerpc

2015-07-06 Thread Masanari Iida
This patch fix some spelling typo found in Documentation/powerpc. Signed-off-by: Masanari Iida --- Documentation/powerpc/cxl.txt | 2 +- Documentation/powerpc/dscr.txt| 6 +++--- Documentation/powerpc/qe_firmware.txt | 2 +- 3 files changed, 5 insertions(+), 5 deletions(-) diff

Re: [alsa-devel] [PATCH 2/3] ASoC: fsl_spdif: Add driver suspend and resume to support MEGA Fast

2015-07-06 Thread Fabio Estevam
On Mon, Jul 6, 2015 at 6:50 AM, Zidan Wang wrote: > For i.MX6 SoloX, there is a mode of the SoC to shutdown all power source of > modules during system suspend and resume procedure. Thus, SAI needs to save s/SAI/SPDIF ___ Linuxppc-dev mailing list Linux

[PATCH] powerpc/tm: Drop tm_orig_msr from thread_struct

2015-07-06 Thread Anshuman Khandual
Currently tm_orig_msr is getting used during process context switch only. Then there is ckpt_regs which saves the checkpointed userspace context The MSR slot contained in ckpt_regs structure can be used during process context switch instead of tm_orig_msr, thus allowing us to drop it from thread_st

[PATCH 2/2] powerpc/signal: Add helper function to fetch quad word aligned pointer

2015-07-06 Thread Anshuman Khandual
This patch adds one helper function 'vmx_reserve_addr' which computes quad word aligned pointer for vmx_reserve array element in sigcontext structure making the code more readable. Signed-off-by: Anshuman Khandual --- arch/powerpc/kernel/signal_64.c | 14 +- 1 file changed, 9 inserti

Re: [alsa-devel] [PATCH 1/3] ASoC: fsl_esai: Add driver suspend and resume to support MEGA Fast

2015-07-06 Thread Fabio Estevam
On Mon, Jul 6, 2015 at 6:50 AM, Zidan Wang wrote: > For i.MX6 SoloX, there is a mode of the SoC to shutdown all power source of > modules during system suspend and resume procedure. Thus, SAI needs to save You meant ESAI, not SAI. ___ Linuxppc-dev maili

[PATCH 1/2] powerpc/signal: Fix confusing header documentation in sigcontext.h

2015-07-06 Thread Anshuman Khandual
As 'vmx_reserve' array element had been expanded to contain 101 double words, the comment block above that needs to be updated. Also changed the array size declaration to reflect the logic mentioned in the comment block above. This change helps in explaining how the HW registers are represented in

[alsa-devel][PATCH 3/3] ASoC: fsl_sai: Add driver suspend and resume to support MEGA Fast

2015-07-06 Thread Zidan Wang
For i.MX6 SoloX, there is a mode of the SoC to shutdown all power source of modules during system suspend and resume procedure. Thus, SAI needs to save all the values of registers before the system suspend and restore them after the system resume. Signed-off-by: Zidan Wang --- sound/soc/fsl/fsl_

[alsa-devel][PATCH 2/3] ASoC: fsl_spdif: Add driver suspend and resume to support MEGA Fast

2015-07-06 Thread Zidan Wang
For i.MX6 SoloX, there is a mode of the SoC to shutdown all power source of modules during system suspend and resume procedure. Thus, SAI needs to save all the values of registers before the system suspend and restore them after the system resume. Signed-off-by: Zidan Wang --- sound/soc/fsl/fsl_

[alsa-devel][PATCH 1/3] ASoC: fsl_esai: Add driver suspend and resume to support MEGA Fast

2015-07-06 Thread Zidan Wang
For i.MX6 SoloX, there is a mode of the SoC to shutdown all power source of modules during system suspend and resume procedure. Thus, SAI needs to save all the values of registers before the system suspend and restore them after the system resume. Signed-off-by: Zidan Wang --- sound/soc/fsl/fsl_

[alsa-devel][PATCH 2/2] ASoC: fsl_ssi: sound is wrong after suspend/resume

2015-07-06 Thread Zidan Wang
The register SFCSR is volatile, but some bits in it need to be recovered after suspend/resume. Signed-off-by: Zidan Wang --- sound/soc/fsl/fsl_ssi.c | 12 1 file changed, 12 insertions(+) diff --git a/sound/soc/fsl/fsl_ssi.c b/sound/soc/fsl/fsl_ssi.c index 52b894f..e414f18 100644 -

[alsa-devel][PATCH 1/2] ASoC: fsl_ssi: Add driver suspend and resume to support MEGA Fast

2015-07-06 Thread Zidan Wang
For i.MX6 SoloX, there is a mode of the SoC to shutdown all power source of modules during system suspend and resume procedure. Thus, SSI needs to save all the values of registers before the system suspend and restore them after the system resume. Signed-off-by: Zidan Wang --- sound/soc/fsl/fsl_

Re: [PATCH 0/6] drivers/nx-842: reduce verbosity of logging

2015-07-06 Thread Herbert Xu
On Thu, Jul 02, 2015 at 03:38:00PM -0700, Nishanth Aravamudan wrote: > Currently, on a LPAR with the nx-842 device disabled, the following > messages are emitted: Patches 1-3 applied. -- Email: Herbert Xu Home Page: http://gondor.apana.org.au/~herbert/ PGP Key: http://gondor.apana.org.au/~herber

Re: [PATCH slof] README: Update with patch submittion note

2015-07-06 Thread Nikunj A Dadhania
Thomas Huth writes: > On Mon, 6 Jul 2015 18:02:00 +1000 > Alexey Kardashevskiy wrote: > >> On 07/06/2015 05:22 PM, Thomas Huth wrote: >> > On Mon, 6 Jul 2015 14:09:10 +1000 >> > Alexey Kardashevskiy wrote: >> > >> >> This adds a maillist and emails to be used when posting a patch for SLOF. > .

Re: [PATCH slof] README: Update with patch submittion note

2015-07-06 Thread Thomas Huth
On Mon, 6 Jul 2015 18:02:00 +1000 Alexey Kardashevskiy wrote: > On 07/06/2015 05:22 PM, Thomas Huth wrote: > > On Mon, 6 Jul 2015 14:09:10 +1000 > > Alexey Kardashevskiy wrote: > > > >> This adds a maillist and emails to be used when posting a patch for SLOF. ... > >> I was asked to describe so

Re: [PATCH 6/6] nx-842-platform: if NX842 platform drivers are not modules, don't try to load them

2015-07-06 Thread Herbert Xu
On Thu, Jul 02, 2015 at 03:42:26PM -0700, Nishanth Aravamudan wrote: > Based off the CONFIG_SPU_FS_MODULE code, only attempt to load platform > modules if the nx-842 pseries/powernv drivers are built as modules. > > Otherwise, if CONFIG_DEV_NX_COMPRESS=y, > CONFIG_DEV_NX_COMPRESS_PSERIES=y, CONFIG

Re: [PATCH slof] README: Update with patch submittion note

2015-07-06 Thread Alexey Kardashevskiy
On 07/06/2015 05:22 PM, Thomas Huth wrote: On Mon, 6 Jul 2015 14:09:10 +1000 Alexey Kardashevskiy wrote: This adds a maillist and emails to be used when posting a patch for SLOF. Cc: Benjamin Herrenschmidt Cc: Thomas Huth Cc: Nikunj A Dadhania Signed-off-by: Alexey Kardashevskiy --- I w

Re: [PATCH] Fix function keys sequence on USB

2015-07-06 Thread Nikunj A Dadhania
Dinar valeev writes: > From: Dinar Valeev > > Original issue is home and end keys are not functional in grub2. > Later I've found other inconsistencies in f1-f12 keys. > > "Correct sequence" was crabbed by pressing key on cat running in > xterm. > > Tested with Home, End, F2, Del and F10 keys in

Re: [RESEND] powerpc/configs: enable RTC class support

2015-07-06 Thread Vaibhav
On Fri, 2015-07-03 at 16:59 +1000, Michael Ellerman wrote: > You still haven't told me what happens on a pseries machine when this is > applied. Was finally able to get my hand over a pseries guest lpar today so dumping the results below. I have aggregated results for each configuration namely hos

Re: [PATCH slof] README: Update with patch submittion note

2015-07-06 Thread Thomas Huth
On Mon, 6 Jul 2015 14:09:10 +1000 Alexey Kardashevskiy wrote: > This adds a maillist and emails to be used when posting a patch for SLOF. > > Cc: Benjamin Herrenschmidt > Cc: Thomas Huth > Cc: Nikunj A Dadhania > Signed-off-by: Alexey Kardashevskiy > --- > > I was asked to describe somewhe