[RFC Patch V1 03/12] PowerPC, PCI: Use for_pci_msi_entry() to access MSI device list

2015-07-09 Thread Jiang Liu
Use accessor for_pci_msi_entry() to access MSI device list, so we could easily move msi_list from struct pci_dev into struct device later. Signed-off-by: Jiang Liu --- arch/powerpc/platforms/cell/axon_msi.c |6 +++--- arch/powerpc/platforms/pasemi/msi.c|4 ++-- arch/powerpc

[RFT v2 38/48] genirq, powerpc: Kill the first parameter 'irq' of irq_flow_handler_t

2015-06-03 Thread Jiang Liu
split the changes into several parts, though they should be merge as one to support bisecting. Signed-off-by: Jiang Liu --- arch/powerpc/include/asm/qe_ic.h| 23 +-- arch/powerpc/include/asm/tsi108_pci.h |2 +- arch/powerpc/platforms/512x/mpc5121

[RFT v2 26/48] powerpc, irq: Prepare for killing the first parameter 'irq' of irq_flow_handler_t

2015-06-03 Thread Jiang Liu
Change irq flow handler to prepare for killing the first parameter 'irq' of irq_flow_handler_t. Signed-off-by: Jiang Liu --- arch/powerpc/platforms/512x/mpc5121_ads_cpld.c |4 +++- arch/powerpc/platforms/85xx/socrates_fpga_pic.c |2 +- arch/powerpc/platforms/cell/i

[RFT v2 04/48] powerpc, irq: Use irq_desc_get_xxx() to avoid redundant lookup of irq_desc

2015-06-03 Thread Jiang Liu
Use irq_desc_get_xxx() to avoid redundant lookup of irq_desc while we already have a pointer to corresponding irq_desc. Note: this patch has been queued for 4.2 by Michael Ellerman Signed-off-by: Jiang Liu --- arch/powerpc/platforms/52xx/mpc52xx_gpt.c |2 +- arch/powerpc/platforms

Re: [v3, 33/36] genirq: Use helper function to access irq_data->msi_desc

2015-06-01 Thread Jiang Liu
On 2015/6/2 11:45, Michael Ellerman wrote: > On Mon, 2015-01-06 at 08:05:42 UTC, Jiang Liu wrote: >> Use irq_data access helper to access irq_data->msi_desc, so we could >> move msi_desc from struct irq_data into struct irq_common_data later. >> >> Signed-off-by: Jian

[Patch v3 33/36] genirq: Use helper function to access irq_data->msi_desc

2015-06-01 Thread Jiang Liu
Use irq_data access helper to access irq_data->msi_desc, so we could move msi_desc from struct irq_data into struct irq_common_data later. Signed-off-by: Jiang Liu --- arch/ia64/kernel/msi_ia64.c |2 +- arch/ia64/sn/kernel/msi_sn.c|2 +- arch/powerpc/sysdev/xics/

[Patch v3 24/36] powerpc, irq: Use access helper irq_data_get_affinity_mask()

2015-06-01 Thread Jiang Liu
Use access helper irq_data_get_affinity_mask() to hide implementation details of struct irq_desc. Signed-off-by: Jiang Liu --- arch/powerpc/kernel/irq.c |2 +- arch/powerpc/sysdev/xics/ics-opal.c |2 +- arch/powerpc/sysdev/xics/ics-rtas.c |2 +- 3 files changed, 3

[Patch v2 08/14] genirq: Introduce helper function irq_data_get_affinity_mask()

2015-05-20 Thread Jiang Liu
Introduce helper function irq_data_get_affinity_mask() and irq_get_affinity_mask() to hide implementation details, so we could move field 'affinity' from struct irq_data into struct irq_common_data later. Signed-off-by: Jiang Liu --- arch/alpha/kernel/irq.c |2 +-

[RFC v1 16/25] genirq: Kill the first parameter 'irq' of irq_flow_handler_t

2015-05-20 Thread Jiang Liu
split the changes into several parts, though they should be merge as one to support bisecting. Signed-off-by: Jiang Liu --- arch/powerpc/include/asm/qe_ic.h| 23 +-- arch/powerpc/include/asm/tsi108_pci.h |2 +- arch/powerpc/platforms/512x/mpc5121_a

[RFC v1 04/25] powerpc, irq: Use irq_desc_get_xxx() to avoid redundant lookup of irq_desc

2015-05-20 Thread Jiang Liu
Use irq_desc_get_xxx() to avoid redundant lookup of irq_desc while we already have a pointer to corresponding irq_desc. Signed-off-by: Jiang Liu --- arch/powerpc/platforms/52xx/mpc52xx_gpt.c |2 +- arch/powerpc/platforms/cell/axon_msi.c|2 +- arch/powerpc/platforms

[Patch v2 12/14] genirq: Use helper function to access irq_data->msi_desc

2015-05-20 Thread Jiang Liu
Use irq_data access helper to access irq_data->msi_desc, so we could move msi_desc from struct irq_data into struct irq_common_data later. Signed-off-by: Jiang Liu --- arch/ia64/kernel/msi_ia64.c |2 +- arch/ia64/sn/kernel/msi_sn.c|2 +- arch/powerpc/sysdev/xics/

[RFC v1 06/11] genirq: Introduce helper function irq_data_get_affinity_mask()

2015-05-03 Thread Jiang Liu
Introduce helper function irq_data_get_affinity_mask() and irq_get_affinity_mask() to hide implementation details, so we could move field 'affinity' from struct irq_data into struct irq_common_data later. Signed-off-by: Jiang Liu --- arch/alpha/kernel/irq.c |2 +-

[RFC v1 09/11] genirq: Use helper function to access irq_data->msi_desc

2015-05-03 Thread Jiang Liu
Use helper function to access irq_data->msi_desc, so we could move msi_desc from struct irq_data into struct irq_common_data later. Signed-off-by: Jiang Liu --- arch/ia64/kernel/msi_ia64.c |2 +- arch/ia64/sn/kernel/msi_sn.c|2 +- arch/powerpc/sysdev/xics/ics-opa

Ask help about killing irqchip.irq_print_chip on PPC platforms

2014-12-22 Thread Jiang Liu
Hi Scott and Tudor, Sorry, resend and Ccing the list. We are trying to clean up some irqchip interfaces, and irqchip.irq_print_chip is a candidate for removal. After some changes on x86 side, arch/powerpc/sysdev/fsl_msi.c may be the last user of irqchip.irq_print_chip. So could you

[RFC Part4 v1 11/17] PCI, MSI: Rename __read_msi_msg() as __pci_read_msi_msg()

2014-11-09 Thread Jiang Liu
Rename __read_msi_msg() as __pci_read_msi_msg() and kill unused read_msi_msg(). It's a preparation to separate generic MSI code from PCI core. Signed-off-by: Jiang Liu --- arch/powerpc/platforms/pseries/msi.c |2 +- arch/x86/pci/xen.c |2 +- drivers/pci/

Re: [PATCH 1/2] pci: Fix root port bus->self is NULL

2014-01-07 Thread Jiang Liu
On 2014/1/7 17:51, dongsheng.w...@freescale.com wrote: diff --git a/drivers/pci/probe.c b/drivers/pci/probe.c index 38e403d..7f2d1ab 100644 --- a/drivers/pci/probe.c +++ b/drivers/pci/probe.c @@ -1472,6 +1472,9 @@ int pci_scan_slot(struct pci_bus *bus, int devfn)

Re: [PATCH 1/2] pci: Fix root port bus->self is NULL

2014-01-07 Thread Jiang Liu
On 2014/1/7 16:27, Yijing Wang wrote: > On 2014/1/7 16:04, Dongsheng Wang wrote: >> From: Wang Dongsheng >> >> the root port bus->self always NULL, so put root port pci device >> into root port bus->self. >> >> Signed-off-by: Wang Dongsheng >> >> diff --git a/drivers/pci/probe.c b/drivers/pci/p

Re: [RFC PATCH v2 15/25] smp, ppc: kill SMP single function call interrupt

2013-09-12 Thread Jiang Liu
On 09/12/2013 04:03 AM, Srivatsa S. Bhat wrote: > On 09/11/2013 09:37 PM, Jiang Liu wrote: >> From: Jiang Liu >> >> Commit 9a46ad6d6df3b54 "smp: make smp_call_function_many() use logic >> similar to smp_call_function_single()" has unified the way to ha

[RFC PATCH v2 15/25] smp, ppc: kill SMP single function call interrupt

2013-09-11 Thread Jiang Liu
From: Jiang Liu Commit 9a46ad6d6df3b54 "smp: make smp_call_function_many() use logic similar to smp_call_function_single()" has unified the way to handle single and multiple cross-CPU function calls. Now only one interrupt is needed for architecture specific code to support generic SM

Re: [PATCH v3, part1 03/10] PCI: Convert alloc_pci_dev(void) to pci_alloc_dev(bus) instead

2013-06-06 Thread Jiang Liu
On Thu 06 Jun 2013 04:07:18 AM CST, Bjorn Helgaas wrote: > On Sat, May 25, 2013 at 7:48 AM, Jiang Liu wrote: >> From: Gu Zheng >> >> Use the new pci_alloc_dev(bus) to replace the existing using of >> alloc_pci_dev(void). >> ... > >> diff --git a/drivers/

[PATCH, v2 09/13] mm/PPC: prepare for killing free_all_bootmem_node()

2013-05-29 Thread Jiang Liu
Prepare for killing free_all_bootmem_node() by using free_all_bootmem(). Signed-off-by: Jiang Liu Cc: Benjamin Herrenschmidt Cc: Paul Mackerras Cc: Alexander Graf Cc: "Suzuki K. Poulose" Cc: linuxppc-dev@lists.ozlabs.org Cc: linux-ker...@vger.kernel.org --- arch/powerpc/mm/

[PATCH v6, part4 31/41] mm/ppc: prepare for removing num_physpages and simplify mem_init()

2013-05-29 Thread Jiang Liu
Prepare for removing num_physpages and simplify mem_init(). Signed-off-by: Jiang Liu Cc: Benjamin Herrenschmidt Cc: Paul Mackerras Cc: linuxppc-dev@lists.ozlabs.org Cc: linux-ker...@vger.kernel.org --- arch/powerpc/mm/mem.c | 56 +++ 1 file

[PATCH v3, part2 10/20] PCI, PPC: use hotplug-safe iterators to walk PCI buses

2013-05-26 Thread Jiang Liu
Enhance PPC architecture specific code to use hotplug-safe iterators to walk PCI buses. Signed-off-by: Jiang Liu Cc: Benjamin Herrenschmidt Cc: Paul Mackerras Cc: Gavin Shan Cc: Greg Kroah-Hartman Cc: Grant Likely Cc: Bill Pemberton Cc: Yinghai Lu Cc: linuxppc-dev@lists.ozlabs.org Cc

[PATCH v3, part1 03/10] PCI: Convert alloc_pci_dev(void) to pci_alloc_dev(bus) instead

2013-05-25 Thread Jiang Liu
From: Gu Zheng Use the new pci_alloc_dev(bus) to replace the existing using of alloc_pci_dev(void). v2: Follow Bjorn's correction to move pci_bus_put() to pci_release_dev() instead. v3: release reference to bus on error recovery path Signed-off-by: Gu Zheng Signed-off-by: Jiang Li

PCI, PPC: use hotplug-safe iterators to walk PCI buses

2013-05-15 Thread Jiang Liu
Enhance PPC architecture specific code to use hotplug-safe iterators to walk PCI buses. Signed-off-by: Jiang Liu Cc: Benjamin Herrenschmidt Cc: Paul Mackerras Cc: Gavin Shan Cc: Greg Kroah-Hartman Cc: Grant Likely Cc: Bill Pemberton Cc: Yinghai Lu Cc: linuxppc-dev@lists.ozlabs.org Cc

[RFC PATCH v2, part 2 09/18] PCI, PPC: use hotplug-safe iterators to walk PCI buses

2013-05-14 Thread Jiang Liu
Enhance PPC architecture specific code to use hotplug-safe iterators to walk PCI buses. Signed-off-by: Jiang Liu Cc: Benjamin Herrenschmidt Cc: Paul Mackerras Bjorn Helgaas Cc: Gavin Shan Cc: Greg Kroah-Hartman Cc: Grant Likely Cc: Bill Pemberton Cc: Yinghai Lu Cc: linuxppc-dev

[PATCH v2, part 1 3/9] PCI: Convert alloc_pci_dev(void) to pci_alloc_dev(bus) instead

2013-05-13 Thread Jiang Liu
..@vger.kernel.org Signed-off-by: Jiang Liu --- arch/powerpc/kernel/pci_of_scan.c | 3 +-- arch/sparc/kernel/pci.c | 3 +-- drivers/char/agp/alpha-agp.c | 2 +- drivers/char/agp/parisc-agp.c | 2 +- drivers/pci/iov.c | 8 +--- drivers/pci/probe.c

[PATCH v5, part4 31/41] mm/ppc: prepare for removing num_physpages and simplify mem_init()

2013-05-08 Thread Jiang Liu
Prepare for removing num_physpages and simplify mem_init(). Signed-off-by: Jiang Liu Cc: Benjamin Herrenschmidt Cc: Paul Mackerras Cc: linuxppc-dev@lists.ozlabs.org Cc: linux-ker...@vger.kernel.org --- arch/powerpc/mm/mem.c | 56 +++-- 1 file

[RFC PATCH v1 09/19] mm/PPC: prepare for killing free_all_bootmem_node()

2013-04-13 Thread Jiang Liu
Prepare for killing free_all_bootmem_node() by using free_all_bootmem(). Signed-off-by: Jiang Liu Cc: Benjamin Herrenschmidt Cc: Paul Mackerras Cc: Alexander Graf Cc: "Suzuki K. Poulose" Cc: linuxppc-dev@lists.ozlabs.org Cc: linux-ker...@vger.kernel.org --- arch/powerpc/mm/me

[PATCH v4, part3 31/41] mm/ppc: prepare for removing num_physpages and simplify mem_init()

2013-04-06 Thread Jiang Liu
Prepare for removing num_physpages and simplify mem_init(). Signed-off-by: Jiang Liu Cc: Benjamin Herrenschmidt Cc: Paul Mackerras Cc: linuxppc-dev@lists.ozlabs.org Cc: linux-ker...@vger.kernel.org --- arch/powerpc/mm/mem.c | 56 +++-- 1 file

[PATCH v3, part4 28/39] mm/ppc: prepare for removing num_physpages and simplify mem_init()

2013-03-26 Thread Jiang Liu
Prepare for removing num_physpages and simplify mem_init(). Signed-off-by: Jiang Liu Cc: Benjamin Herrenschmidt Cc: Paul Mackerras Cc: linuxppc-dev@lists.ozlabs.org Cc: linux-ker...@vger.kernel.org --- Hi all, Sorry for my mistake that my previous patch series has been screwed up. So I

[RFC PATCH v2, part4 28/39] mm/ppc: prepare for removing num_physpages and simplify mem_init()

2013-03-24 Thread Jiang Liu
Prepare for removing num_physpages and simplify mem_init(). Signed-off-by: Jiang Liu Cc: Benjamin Herrenschmidt Cc: Paul Mackerras Cc: linuxppc-dev@lists.ozlabs.org Cc: linux-ker...@vger.kernel.org --- arch/powerpc/mm/mem.c | 56 +++-- 1 file

[RFC PATCH v2, part4 27/39] mm/ppc: prepare for removing num_physpages and simplify mem_init()

2013-03-24 Thread Jiang Liu
Prepare for removing num_physpages and simplify mem_init(). Signed-off-by: Jiang Liu Cc: Benjamin Herrenschmidt Cc: Paul Mackerras Cc: linuxppc-dev@lists.ozlabs.org Cc: linux-ker...@vger.kernel.org --- arch/powerpc/mm/mem.c | 56 +++-- 1 file

[PATCH v2, part2 07/10] mm/PPC: use free_highmem_page() to free highmem pages into buddy system

2013-03-10 Thread Jiang Liu
Use helper function free_highmem_page() to free highmem pages into the buddy system. Signed-off-by: Jiang Liu Cc: Benjamin Herrenschmidt Cc: Paul Mackerras Cc: Jiang Liu Cc: Andrew Morton Cc: Alexander Graf Cc: "Suzuki K. Poulose" Cc: linuxppc-dev@lists.ozlabs.org Cc:

Re: [RFC PATCH v3 0/13] memory-hotplug : hot-remove physical memory

2012-07-11 Thread Jiang Liu
On 07/11/2012 08:54 AM, Yasuaki Ishimatsu wrote: > Hi Jiang, > > 2012/07/11 9:21, Jiang Liu wrote: >> On 07/11/2012 08:09 AM, Yasuaki Ishimatsu wrote: >>> Hi Jiang, >>> >>> 2012/07/11 1:50, Jiang Liu wrote: >>>> On 07/10/2012 05:58 PM, Yasuaki

Re: [RFC PATCH v3 0/13] memory-hotplug : hot-remove physical memory

2012-07-10 Thread Jiang Liu
On 07/11/2012 08:09 AM, Yasuaki Ishimatsu wrote: > Hi Jiang, > > 2012/07/11 1:50, Jiang Liu wrote: >> On 07/10/2012 05:58 PM, Yasuaki Ishimatsu wrote: >>> Hi Christoph, >>> >>> 2012/07/10 0:18, Christoph Lameter wrote: >>>> >>>> O

Re: [RFC PATCH v3 0/13] memory-hotplug : hot-remove physical memory

2012-07-10 Thread Jiang Liu
On 07/10/2012 05:58 PM, Yasuaki Ishimatsu wrote: > Hi Christoph, > > 2012/07/10 0:18, Christoph Lameter wrote: >> >> On Mon, 9 Jul 2012, Yasuaki Ishimatsu wrote: >> >>> Even if you apply these patches, you cannot remove the physical memory >>> completely since these patches are still under develop

Re: [PATCH] mm: setup pageblock_order before it's used by sparse

2012-07-02 Thread Jiang Liu
>> Hi Yinghai, >> >> I'm afraid the v2 will break powerpc. Currently only IA64 and PowerPC >> supports variable hugetlb size. >> >> HPAGE_SHIFT is a variable default to 0 on powerpc. But seems PowerPC >> is doing something wrong here, according to it's mm initialization >> sequence as below: >> sta

Re: [PATCH] mm: setup pageblock_order before it's used by sparse

2012-07-02 Thread Jiang Liu
On 2012-7-3 4:43, Yinghai Lu wrote: > On Sun, Jul 1, 2012 at 7:01 PM, Jiang Liu wrote: >> Hi Yinghai, >> The patch fails compilation as below: >> mm/page_alloc.c:151: error: initializer element is not constant >> mm/page_alloc.c:151: error: expected ‘,’ o

Re: [RFC PATCH 10/12] memory-hotplug : free memmap of sparse-vmemmap

2012-06-30 Thread Jiang Liu
On 06/27/2012 01:56 PM, Yasuaki Ishimatsu wrote: > I don't think that all pages of virtual mapping in removed memory can be > freed, since page which type is MIX_SECTION_INFO is difficult to free. > So, the patch only frees page which type is SECTION_INFO at first. > > CC: Len Brown > CC: Benjami

Re: [RFC PATCH 2/12] memory-hogplug : check memory offline in offline_pages

2012-06-30 Thread Jiang Liu
On 06/27/2012 01:44 PM, Yasuaki Ishimatsu wrote: > When offline_pages() is called to offlined memory, the function fails since > all memory has been offlined. In this case, the function should succeed. > The patch adds the check function into offline_pages(). > > CC: Len Brown > CC: Benjamin Herr

Re: [RFC PATCH 2/12] memory-hogplug : check memory offline in offline_pages

2012-06-30 Thread Jiang Liu
On 06/27/2012 01:44 PM, Yasuaki Ishimatsu wrote: > When offline_pages() is called to offlined memory, the function fails since > all memory has been offlined. In this case, the function should succeed. > The patch adds the check function into offline_pages(). > > CC: Len Brown > CC: Benjamin Herr