[Lldb-commits] [PATCH] D63110: Fix a crash in option parsing.

2019-06-10 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere accepted this revision. JDevlieghere added a comment. This revision is now accepted and ready to land. LGTM! Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D63110/new/ https://reviews.llvm.org/D63110 __

[Lldb-commits] [PATCH] D62503: Add ReadCStringFromMemory for faster string reads

2019-06-10 Thread António Afonso via Phabricator via lldb-commits
aadsm updated this revision to Diff 203948. aadsm added a comment. Rebase Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D62503/new/ https://reviews.llvm.org/D62503 Files: lldb/include/lldb/Host/common/NativeProcessProtocol.h lldb/source/Host/co

[Lldb-commits] [PATCH] D62502: Implement xfer:libraries-svr4:read packet

2019-06-10 Thread António Afonso via Phabricator via lldb-commits
aadsm updated this revision to Diff 203947. aadsm added a comment. - Update test to just wait for the process to stop - Change ReadSVR4LibraryInfo signature to return an Expected to the list of libraries and stop taking params by ref. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST AC

[Lldb-commits] [PATCH] D63110: Fix a crash in option parsing.

2019-06-10 Thread Adrian Prantl via Phabricator via lldb-commits
aprantl created this revision. aprantl added a reviewer: JDevlieghere. Herald added a project: LLDB. The call to getopt_long didn't handle the case where the *last* option had an argument missing. Repository: rG LLVM Github Monorepo https://reviews.llvm.org/D63110 Files: lldb/lit/Driver/I

[Lldb-commits] [lldb] r362985 - [Target] Use llvm::scope_exit to restore m_suppress_stop_hooks value.

2019-06-10 Thread Tatyana Krasnukha via lldb-commits
Author: tkrasnukha Date: Mon Jun 10 14:13:37 2019 New Revision: 362985 URL: http://llvm.org/viewvc/llvm-project?rev=362985&view=rev Log: [Target] Use llvm::scope_exit to restore m_suppress_stop_hooks value. Modified: lldb/trunk/source/Target/Target.cpp Modified: lldb/trunk/source/Target/Targ

[Lldb-commits] [lldb] r362984 - [Target][NFC] Rename GetCPPLanguageRuntime to Get

2019-06-10 Thread Alex Langford via lldb-commits
Author: xiaobai Date: Mon Jun 10 14:04:31 2019 New Revision: 362984 URL: http://llvm.org/viewvc/llvm-project?rev=362984&view=rev Log: [Target][NFC] Rename GetCPPLanguageRuntime to Get This is a followup to rL362981, in which I moved GetObjCLanguageRuntime from Process to ObjCLanguageRuntime, rena

[Lldb-commits] [PATCH] D62499: Create a generic handler for Xfer packets

2019-06-10 Thread António Afonso via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL362982: Create a generic handler for Xfer packets (authored by aadsm, committed by ). Herald added a project: LLVM. Herald added a subscriber: llvm-commits. Changed prior to commit: https://reviews.llvm

[Lldb-commits] [PATCH] D63052: [Target] Remove Process::GetObjCLanguageRuntime

2019-06-10 Thread Alex Langford via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL362981: [Target] Remove Process::GetObjCLanguageRuntime (authored by xiaobai, committed by ). Herald added a project: LLVM. Herald added a subscriber: llvm-commits. Repository: rL LLVM CHANGES SINCE LA

[Lldb-commits] [lldb] r362981 - [Target] Remove Process::GetObjCLanguageRuntime

2019-06-10 Thread Alex Langford via lldb-commits
Author: xiaobai Date: Mon Jun 10 13:53:23 2019 New Revision: 362981 URL: http://llvm.org/viewvc/llvm-project?rev=362981&view=rev Log: [Target] Remove Process::GetObjCLanguageRuntime Summary: In an effort to make Process more language agnostic, I removed GetCPPLanguageRuntime from Process. I'm fol

[Lldb-commits] [PATCH] D63052: [Target] Remove Process::GetObjCLanguageRuntime

2019-06-10 Thread Alex Langford via Phabricator via lldb-commits
xiaobai updated this revision to Diff 203877. xiaobai added a comment. ObjCLanguageRuntime::GetObjCLanguageRuntime -> ObjCLanguageRuntime::Get CHANGES SINCE LAST ACTION https://reviews.llvm.org/D63052/new/ https://reviews.llvm.org/D63052 Files: include/lldb/Target/ObjCLanguageRuntime.h i

[Lldb-commits] [PATCH] D63052: [Target] Remove Process::GetObjCLanguageRuntime

2019-06-10 Thread Alex Langford via Phabricator via lldb-commits
xiaobai marked an inline comment as done. xiaobai added inline comments. Comment at: include/lldb/Target/ObjCLanguageRuntime.h:202 + static ObjCLanguageRuntime *GetObjCLanguageRuntime(Process &process) { +return llvm::cast_or_null( labath wrote: > xiaobai

[Lldb-commits] [PATCH] D63052: [Target] Remove Process::GetObjCLanguageRuntime

2019-06-10 Thread Pavel Labath via Phabricator via lldb-commits
labath added inline comments. Comment at: include/lldb/Target/ObjCLanguageRuntime.h:202 + static ObjCLanguageRuntime *GetObjCLanguageRuntime(Process &process) { +return llvm::cast_or_null( xiaobai wrote: > labath wrote: > > compnerd wrote: > > > I think it

[Lldb-commits] [PATCH] D63052: [Target] Remove Process::GetObjCLanguageRuntime

2019-06-10 Thread Alex Langford via Phabricator via lldb-commits
xiaobai updated this revision to Diff 203872. xiaobai added a comment. Simplify a change CHANGES SINCE LAST ACTION https://reviews.llvm.org/D63052/new/ https://reviews.llvm.org/D63052 Files: include/lldb/Target/ObjCLanguageRuntime.h include/lldb/Target/Process.h include/lldb/lldb-forwa

[Lldb-commits] [PATCH] D63052: [Target] Remove Process::GetObjCLanguageRuntime

2019-06-10 Thread Alex Langford via Phabricator via lldb-commits
xiaobai marked an inline comment as done. xiaobai added inline comments. Comment at: include/lldb/Target/ObjCLanguageRuntime.h:202 + static ObjCLanguageRuntime *GetObjCLanguageRuntime(Process &process) { +return llvm::cast_or_null( labath wrote: > compnerd

[Lldb-commits] [PATCH] D62502: Implement xfer:libraries-svr4:read packet

2019-06-10 Thread António Afonso via Phabricator via lldb-commits
aadsm marked an inline comment as done. aadsm added inline comments. Comment at: lldb/source/Plugins/Process/Linux/NativeProcessLinux.cpp:2181 +template +Status NativeProcessLinux::ReadSVR4LibraryInfo(lldb::addr_t link_map_addr, + SV

[Lldb-commits] [PATCH] D62894: DWARF: Share line tables of type units

2019-06-10 Thread Greg Clayton via Phabricator via lldb-commits
clayborg requested changes to this revision. clayborg added a comment. This revision now requires changes to proceed. Still want to resolve getting files from a DWARFUnit a bit better. See inlined comment. Comment at: source/Plugins/SymbolFile/DWARF/DWARFASTParserClang.cpp:309

[Lldb-commits] [PATCH] D62894: DWARF: Share line tables of type units

2019-06-10 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere accepted this revision. JDevlieghere added inline comments. This revision is now accepted and ready to land. Comment at: source/Plugins/SymbolFile/DWARF/SymbolFileDWARF.h:303 + lldb_private::FileSpec GetSupportFile(DWARFUnit &unit, size_t file_idx); +

[Lldb-commits] [PATCH] D63005: DWARF: Don't create lldb CompileUnits for DWARF type units

2019-06-10 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. In D63005#1536367 , @JDevlieghere wrote: > I saw some weird formatting, but I assume you run clang-format before landing > anyway. LGTM. Actually, I usually use it interactively while editing, and then do a final pass before cr

[Lldb-commits] [lldb] r362961 - ABI: reflow the table text (NFC)

2019-06-10 Thread Saleem Abdulrasool via lldb-commits
Author: compnerd Date: Mon Jun 10 09:32:33 2019 New Revision: 362961 URL: http://llvm.org/viewvc/llvm-project?rev=362961&view=rev Log: ABI: reflow the table text (NFC) Reflow the text for the table to make the table legible. This is purely cosmetic, but makes understanding the contents of the ta

[Lldb-commits] [PATCH] D62894: DWARF: Share line tables of type units

2019-06-10 Thread Pavel Labath via Phabricator via lldb-commits
labath updated this revision to Diff 203845. labath added a comment. - address code review comments CHANGES SINCE LAST ACTION https://reviews.llvm.org/D62894/new/ https://reviews.llvm.org/D62894 Files: lit/SymbolFile/DWARF/debug-types-line-tables.s lit/SymbolFile/DWARF/forward-declaratio

[Lldb-commits] [PATCH] D62894: DWARF: Share line tables of type units

2019-06-10 Thread Pavel Labath via Phabricator via lldb-commits
labath marked 5 inline comments as done. labath added inline comments. Comment at: source/Plugins/SymbolFile/DWARF/DWARFUnit.h:200 const lldb_private::FileSpec &GetCompilationDirectory(); + const lldb_private::FileSpec &GetFileSpec(); lldb_private::FileSpec::Style GetPathS

[Lldb-commits] [lldb] r362960 - Breakpad: Add support for the arm64e "architecture"

2019-06-10 Thread Pavel Labath via lldb-commits
Author: labath Date: Mon Jun 10 09:21:26 2019 New Revision: 362960 URL: http://llvm.org/viewvc/llvm-project?rev=362960&view=rev Log: Breakpad: Add support for the arm64e "architecture" Added: lldb/trunk/lit/Modules/Breakpad/Inputs/identification-macosx-arm64e.syms Modified: lldb/trunk/lit

[Lldb-commits] [PATCH] D62501: Implement GetSharedLibraryInfoAddress

2019-06-10 Thread António Afonso via Phabricator via lldb-commits
aadsm added a comment. Initially one at a time but then thought it might be better to do it as a batch because I was afraid I was missing some dependency and would brake something unexpectedly. But I guess that since I've already landed D62168 it's probably fin

[Lldb-commits] [PATCH] D63005: DWARF: Don't create lldb CompileUnits for DWARF type units

2019-06-10 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere accepted this revision. JDevlieghere added a comment. I saw some weird formatting, but I assume you run clang-format before landing anyway. LGTM. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D63005/new/ https://reviews.llvm.org/D63005 ___

[Lldb-commits] [PATCH] D62502: Implement xfer:libraries-svr4:read packet

2019-06-10 Thread António Afonso via Phabricator via lldb-commits
aadsm marked an inline comment as done. aadsm added a comment. It's the same for freebsd https://github.com/freebsd/freebsd/blob/master/sys/kern/link_elf.c#L291 although behind a GDB flag (which NetBSD doesn't seem to be: https://nxr.netbsd.org/xref/src/libexec/ld.elf_so/rtld.c#1040). ==

[Lldb-commits] [PATCH] D62894: DWARF: Share line tables of type units

2019-06-10 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere added inline comments. Comment at: source/Plugins/SymbolFile/DWARF/DWARFUnit.h:148 dw_addr_t GetStrOffsetsBase() const { return m_str_offsets_base; } + dw_offset_t GetLineTableOffset(); void SetAddrBase(dw_addr_t addr_base); Nit: move this nex

[Lldb-commits] [PATCH] D62502: Implement xfer:libraries-svr4:read packet

2019-06-10 Thread Kamil Rytarowski via Phabricator via lldb-commits
krytarowski added a comment. https://nxr.netbsd.org/xref/src/include/link_elf.h#9 In general this code should be close to functional on NetBSD (if not already compatible). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D62502/new/ https://reviews.l

[Lldb-commits] [lldb] r362948 - Add "REQUIRES: x86" to DWARF assembly tests

2019-06-10 Thread Pavel Labath via lldb-commits
Author: labath Date: Mon Jun 10 08:08:00 2019 New Revision: 362948 URL: http://llvm.org/viewvc/llvm-project?rev=362948&view=rev Log: Add "REQUIRES: x86" to DWARF assembly tests These tests don't require an x86 host, but they do require that we build the x86 llvm target. Modified: lldb/trunk/

[Lldb-commits] [PATCH] D63054: [lldb] [Process/NetBSD] Fix error handling in register operations

2019-06-10 Thread Michał Górny via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL362946: [lldb] [Process/NetBSD] Fix error handling in register operations (authored by mgorny, committed by ). Herald added a project: LLVM. Herald added a subscriber: llvm-commits. Changed prior to commi

[Lldb-commits] [lldb] r362946 - [lldb] [Process/NetBSD] Fix error handling in register operations

2019-06-10 Thread Michal Gorny via lldb-commits
Author: mgorny Date: Mon Jun 10 08:03:49 2019 New Revision: 362946 URL: http://llvm.org/viewvc/llvm-project?rev=362946&view=rev Log: [lldb] [Process/NetBSD] Fix error handling in register operations Ensure that errors are passed through correctly when performing register read/write operations. C

[Lldb-commits] [PATCH] D63005: DWARF: Don't create lldb CompileUnits for DWARF type units

2019-06-10 Thread Pavel Labath via Phabricator via lldb-commits
labath updated this revision to Diff 203820. labath added a comment. - Also implement Adrians suggestion. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D63005/new/ https://reviews.llvm.org/D63005 Files: lit/SymbolFile/DWARF/debug-types-dwarf5.s lit/SymbolFile/DWARF/debug-types-line-

[Lldb-commits] [PATCH] D63005: DWARF: Don't create lldb CompileUnits for DWARF type units

2019-06-10 Thread Pavel Labath via Phabricator via lldb-commits
labath updated this revision to Diff 203816. labath added a comment. - account for the fact that D62943 was a dud. Instead, set the correct ID of the compile unit so that the DWARF unit can be found via the regular logic. - add a test for the situation where the

[Lldb-commits] [PATCH] D62894: DWARF: Share line tables of type units

2019-06-10 Thread Pavel Labath via Phabricator via lldb-commits
labath updated this revision to Diff 203790. labath marked 13 inline comments as done. labath added a comment. - Implement code review suggestions (except the Die::GetName, and return {}) - Add a test for the error message which is printed when we encounter an incomplete class (this is motivated

[Lldb-commits] [PATCH] D62894: DWARF: Share line tables of type units

2019-06-10 Thread Pavel Labath via Phabricator via lldb-commits
labath added inline comments. Comment at: source/Plugins/SymbolFile/DWARF/DWARFASTParserClang.cpp:309 + decl.SetFile( + die.GetDWARF()->GetSupportFile(*die.GetCU(), form_value.Unsigned())); break; clayborg wrote: > Maybe make a "FileSpec DWAR

[Lldb-commits] [PATCH] D62943: DWARF: Simplify SymbolFileDWARF::GetDWARFCompileUnit

2019-06-10 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. Thanks for reverting this. It seems I did not take into account here the fact that SymbolFileDWARFDebugMap creates CompileUnits without setting the the UserData to point to the relevant dwarf compile unit. I'll drop this patch and implement the thing I needed this for in

[Lldb-commits] [PATCH] D63052: [Target] Remove Process::GetObjCLanguageRuntime

2019-06-10 Thread Pavel Labath via Phabricator via lldb-commits
labath added inline comments. Comment at: include/lldb/Target/ObjCLanguageRuntime.h:202 + static ObjCLanguageRuntime *GetObjCLanguageRuntime(Process &process) { +return llvm::cast_or_null( compnerd wrote: > I think it would be nice to just call this `Get`