[Lldb-commits] [PATCH] D70796: [LLDB] Always interpret arm instructions as thumb on windows

2019-11-27 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo added a comment. In D70796#1762491 , @labath wrote: > Seems reasonable. Just out of curiosity, is this restriction enforced in some > way? E.g., if I manually do a `bx` to an arm address, will the system kill me? No, such simple cases do work

[Lldb-commits] [PATCH] D70797: [LLDB] Use r11 as frame pointer on Windows on ARM

2019-11-27 Thread Pavel Labath via Phabricator via lldb-commits
labath added a reviewer: jasonmolenda. labath added a comment. Presumably, this should change how unwind plans are computed. The unwind machinery will treat a `mov %sp, %fp`(whatever is the arm equivalent) as a signal that it should switch to an frame-pointer based unwind. This logic should

[Lldb-commits] [PATCH] D70778: [LLDB] [PECOFF] Factorize mapping section names to types using StringSwitch. NFCI.

2019-11-27 Thread Pavel Labath via Phabricator via lldb-commits
labath accepted this revision. labath added a comment. This revision is now accepted and ready to land. Thanks for taking the time to do this. Just get rid of the `else`s and this is good to go. Comment at: lldb/source/Plugins/ObjectFile/PECOFF/ObjectFilePECOFF.cpp:803-804 +

[Lldb-commits] [PATCH] D70796: [LLDB] Always interpret arm instructions as thumb on windows

2019-11-27 Thread Pavel Labath via Phabricator via lldb-commits
labath accepted this revision. labath added a comment. This revision is now accepted and ready to land. Seems reasonable. Just out of curiosity, is this restriction enforced in some way? E.g., if I manually do a `bx` to an arm address, will the system kill me? Repository: rG LLVM Github

[Lldb-commits] [PATCH] D70764: build: reduce CMake handling for zlib

2019-11-27 Thread Saleem Abdulrasool via Phabricator via lldb-commits
compnerd added a comment. @labath I think you are misunderstanding the patch. This is not autoselecting the dependencies. It is simply doing that based on an existing option that we have - `LLVM_ENABLE_ZLIB`. We could always search for zlib and override the results with `LLVM_ENABLE_ZLIB`

[Lldb-commits] [PATCH] D49466: Initial implementation of -fmacro-prefix-map and -ffile-prefix-map

2019-11-27 Thread Paul Robinson via Phabricator via lldb-commits
probinson added a comment. In D49466#1761156 , @MaskRay wrote: > The ugly path separator pattern `{{(/|)}}` appears in 60+ tests. Can we > teach clang and other tools to > > 1. accept both `/` and `\` input In general they do, AFAIK, although it's

[Lldb-commits] [PATCH] D70797: [LLDB] Use r11 as frame pointer on Windows on ARM

2019-11-27 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo created this revision. mstorsjo added reviewers: labath, amccarth. Herald added a subscriber: kristof.beyls. Herald added a project: LLDB. The change in itself is straightforward based on reading the code, but I don't have a real world case where I know this made a difference, so I

[Lldb-commits] [PATCH] D70796: [LLDB] Always interpret arm instructions as thumb on windows

2019-11-27 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo created this revision. mstorsjo added reviewers: labath, amccarth. Herald added a subscriber: kristof.beyls. Herald added a project: LLDB. Windows on arm always uses thumb mode, and doesn't have most of the mechanisms that are used in e.g. ELF for distinguishing between arm and thumb.

[Lldb-commits] [PATCH] D70778: [LLDB] [PECOFF] Factorize mapping section names to types using StringSwitch. NFCI.

2019-11-27 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo updated this revision to Diff 231318. mstorsjo added a comment. Split the code into a separate function as suggested. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D70778/new/ https://reviews.llvm.org/D70778 Files: lldb/source/Plugins/ObjectFile/PECOFF/ObjectFilePECOFF.cpp

[Lldb-commits] [PATCH] D70772: I implemented the features listed in this document: http://www.open-std.org/jtc1/sc22/wg21/docs/papers/2017/p0616r0.pdf and built libc++ using ninja without any errors/w

2019-11-27 Thread Marshall Clow via Phabricator via lldb-commits
mclow.lists requested changes to this revision. mclow.lists added a comment. This revision now requires changes to proceed. This is a mess. The changes in `libcxx/CMakeLists.txt` are unrelated to P0616. The changes in `algorithm` are also unrelated to P0616. The changes in `forward_list` are

[Lldb-commits] [PATCH] D70778: [LLDB] [PECOFF] Factorize mapping section names to types using StringSwitch. NFCI.

2019-11-27 Thread Adrian McCarthy via Phabricator via lldb-commits
amccarth added inline comments. Comment at: lldb/source/Plugins/ObjectFile/PECOFF/ObjectFilePECOFF.cpp:864-866 +// If the StringSwitch above picked any type, including +// eSectionTypeOther, accept that instead of the generic mappings +// based on flags

[Lldb-commits] [PATCH] D70775: [lldb] Add MockTypeSystem and some basic unit test for CompilerType

2019-11-27 Thread Pavel Labath via Phabricator via lldb-commits
labath accepted this revision. labath added a comment. This revision is now accepted and ready to land. In D70775#1761597 , @teemperor wrote: > I tried moving this to gmock, but after an hour of not being able to even > declare a simple virtual method

[Lldb-commits] [PATCH] D70745: [LLDB] [PECOFF] Look for the truncated ".eh_fram" section name

2019-11-27 Thread Pavel Labath via Phabricator via lldb-commits
labath accepted this revision. labath added a comment. In D70745#1761544 , @mstorsjo wrote: > In D70745#1761421 , @labath wrote: > > > In D70745#1761392 , @mstorsjo > >

[Lldb-commits] [PATCH] D70745: [LLDB] [PECOFF] Look for the truncated ".eh_fram" section name

2019-11-27 Thread Adrian McCarthy via Phabricator via lldb-commits
amccarth accepted this revision. amccarth added a comment. This revision is now accepted and ready to land. Nice. LGTM. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D70745/new/ https://reviews.llvm.org/D70745 ___ lldb-commits mailing list

[Lldb-commits] [PATCH] D70778: [LLDB] [PECOFF] Factorize mapping section names to types using StringSwitch. NFCI.

2019-11-27 Thread Pavel Labath via Phabricator via lldb-commits
labath added inline comments. Comment at: lldb/source/Plugins/ObjectFile/PECOFF/ObjectFilePECOFF.cpp:864-866 +// If the StringSwitch above picked any type, including +// eSectionTypeOther, accept that instead of the generic mappings +// based on flags

[Lldb-commits] [PATCH] D70775: [lldb] Add MockTypeSystem and some basic unit test for CompilerType

2019-11-27 Thread Raphael Isemann via Phabricator via lldb-commits
teemperor updated this revision to Diff 231226. teemperor added a comment. I tried moving this to gmock, but after an hour of not being able to even declare a simple virtual method due to issues like this I don't think this approach is really

[Lldb-commits] [PATCH] D70745: [LLDB] [PECOFF] Look for the truncated ".eh_fram" section name

2019-11-27 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo added a comment. In D70745#1761421 , @labath wrote: > In D70745#1761392 , @mstorsjo wrote: > > > > As for the long if-else cascade, the equivalent elf code was recently > > > refactored to use

[Lldb-commits] [PATCH] D70745: [LLDB] [PECOFF] Look for the truncated ".eh_fram" section name

2019-11-27 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo updated this revision to Diff 231212. mstorsjo edited the summary of this revision. mstorsjo added a comment. Updated on top of D70778 , added a testcase. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D70745/new/ https://reviews.llvm.org/D70745

[Lldb-commits] [PATCH] D70778: [LLDB] [PECOFF] Factorize mapping section names to types using StringSwitch. NFCI.

2019-11-27 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo created this revision. mstorsjo added reviewers: labath, amccarth. Herald added a project: LLDB. Keep the existing special cases based on combinations of section name, flags and sizes/offsets. Some of those special cases have been added intentionally, with test cases, rather recently,

[Lldb-commits] [PATCH] D70775: [lldb] Add MockTypeSystem and some basic unit test for CompilerType

2019-11-27 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. I think this should go into `TestingSupport/Symbol` (new folder) similar to how NativeProcessUtils.h is in `TestingSupport/Host` (to avoid the basic testing support functionality depending on the whole world). It's not obvious how you intend to use this class, but

[Lldb-commits] [PATCH] D70775: [lldb] Add MockTypeSystem and some basic unit test for CompilerType

2019-11-27 Thread Raphael Isemann via Phabricator via lldb-commits
teemperor created this revision. teemperor added a reviewer: labath. Herald added subscribers: lldb-commits, JDevlieghere, mgorny. Herald added a project: LLDB. There are a lot of classes using TypeSystem in some way (mostly indirectly through CompilerType) and we can't really unittest this code

[Lldb-commits] [PATCH] D70774: [lldb] NFC: refactor CompileUnit::ResolveSymbolContext

2019-11-27 Thread Konrad Wilhelm Kleine via Phabricator via lldb-commits
kwk updated this revision to Diff 231201. kwk added a comment. Small changes Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D70774/new/ https://reviews.llvm.org/D70774 Files: lldb/source/Symbol/CompileUnit.cpp Index:

[Lldb-commits] [PATCH] D70774: [lldb] NFC: refactor CompileUnit::ResolveSymbolContext

2019-11-27 Thread Konrad Wilhelm Kleine via Phabricator via lldb-commits
kwk added a comment. In D70774#1761444 , @teemperor wrote: > Let's just remove that return value. It's anyway only used in one place or so > where we can just call GetSize() manually. Then we also don't need the > lambda. Otherwise this LGTM, thanks!

[Lldb-commits] [PATCH] D70774: [lldb] NFC: refactor CompileUnit::ResolveSymbolContext

2019-11-27 Thread Raphael Isemann via Phabricator via lldb-commits
teemperor requested changes to this revision. teemperor added a comment. This revision now requires changes to proceed. Let's just remove that return value. It's anyway only used in one place or so where we can just call GetSize() manually. Then we also don't need the lambda. Otherwise this

[Lldb-commits] [PATCH] D70774: [lldb] NFC: refactor CompileUnit::ResolveSymbolContext

2019-11-27 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. What we've started doing these days is to just remove the "number of things appended" return value from these kinds of functions, as they make it very easy to introduce bugs. (And most callers don't care about those, and those that do, can implement this easily on their

[Lldb-commits] [PATCH] D70774: [lldb] NFC: refactor CompileUnit::ResolveSymbolContext

2019-11-27 Thread Konrad Wilhelm Kleine via Phabricator via lldb-commits
kwk created this revision. Herald added a reviewer: jdoerfert. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. kwk planned changes to this revision. I found the above named method hard to read because it had a) many nested blocks and b) one return statement at the end with

[Lldb-commits] [PATCH] D70745: [LLDB] [PECOFF] Look for the truncated ".eh_fram" section name

2019-11-27 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. In D70745#1761392 , @mstorsjo wrote: > > As for the long if-else cascade, the equivalent elf code was recently > > refactored to use llvm::StringSwitch. Doing the same here would be nice. > > A StringSwitch sounds nice. Some of

[Lldb-commits] [lldb] 92d5ea5 - [lldb][NFC] Move TypeSystem RTTI to static variable to remove swift reference

2019-11-27 Thread Raphael Isemann via lldb-commits
Author: Raphael Isemann Date: 2019-11-27T10:28:02+01:00 New Revision: 92d5ea5d1674c38e03d130c6b04afa118e94ef4a URL: https://github.com/llvm/llvm-project/commit/92d5ea5d1674c38e03d130c6b04afa118e94ef4a DIFF:

[Lldb-commits] [PATCH] D70745: [LLDB] [PECOFF] Look for the truncated ".eh_fram" section name

2019-11-27 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo added a comment. In D70745#1760917 , @amccarth wrote: > Is `.eh_frame` the only one that matters? Should this be more general and > compare `const_sect_name` to the full name and the truncated name for any > known section names? Out of the

[Lldb-commits] [PATCH] D70770: [lldb][NFC] Remove unused CompilerType memory functions

2019-11-27 Thread Raphael Isemann via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rGf1b117394d7f: [lldb][NFC] Remove unused CompilerType memory functions (authored by teemperor). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D70770/new/

[Lldb-commits] [lldb] f1b1173 - [lldb][NFC] Remove unused CompilerType memory functions

2019-11-27 Thread Raphael Isemann via lldb-commits
Author: Raphael Isemann Date: 2019-11-27T09:51:50+01:00 New Revision: f1b117394d7f9ae6decf9730ed9d443ca1b54769 URL: https://github.com/llvm/llvm-project/commit/f1b117394d7f9ae6decf9730ed9d443ca1b54769 DIFF:

[Lldb-commits] [PATCH] D70770: [lldb][NFC] Remove unused CompilerType memory functions

2019-11-27 Thread Pavel Labath via Phabricator via lldb-commits
labath accepted this revision. labath added a comment. This revision is now accepted and ready to land. If they are indeed used, we'll find out soon enough... Repository: rLLDB LLDB CHANGES SINCE LAST ACTION https://reviews.llvm.org/D70770/new/ https://reviews.llvm.org/D70770

[Lldb-commits] [PATCH] D70772: I implemented the features listed in this document: http://www.open-std.org/jtc1/sc22/wg21/docs/papers/2017/p0616r0.pdf and built libc++ using ninja without any errors/w

2019-11-27 Thread Fady Farag via Phabricator via lldb-commits
Afadyfarag created this revision. Afadyfarag added reviewers: clayborg, aprantl, JDevlieghere, EricWF. Afadyfarag added a project: libc++. Herald added a reviewer: mclow.lists. 1. Changes: libcxx/include/numeric Repository: rG LLVM Github Monorepo https://reviews.llvm.org/D70772 Files:

[Lldb-commits] [PATCH] D70742: [LLDB] [Windows] Avoid using InitializeContext for allocating a CONTEXT. NFC.

2019-11-27 Thread Martin Storsjö via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG344bdeb797b3: [LLDB] Avoid using InitializeContext for zero-initializing a CONTEXT. NFC. (authored by mstorsjo). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION

[Lldb-commits] [PATCH] D70770: [lldb][NFC] Remove unused CompilerType memory functions

2019-11-27 Thread Raphael Isemann via Phabricator via lldb-commits
teemperor created this revision. teemperor added a reviewer: labath. Herald added subscribers: lldb-commits, JDevlieghere, abidh. Herald added a project: LLDB. All these functions are unused from what I can see. Unless I'm missing something here, this code can go the way of the Dodo.

[Lldb-commits] [lldb] 3a28042 - [lldb][NFC] Early exit in DWARFASTParserClang::ParseArrayType

2019-11-27 Thread Raphael Isemann via lldb-commits
Author: Raphael Isemann Date: 2019-11-27T09:28:01+01:00 New Revision: 3a280422b66a31af694782746ec0b5b7552a82a1 URL: https://github.com/llvm/llvm-project/commit/3a280422b66a31af694782746ec0b5b7552a82a1 DIFF: