Re: [lng-odp] [API-NEXT PATCH v3 02/11] linux-generic: pktio: initial DPDK pktio implementation

2016-02-10 Thread Maxim Uvarov
On 02/09/2016 16:47, Matias Elo wrote: Initial implementation of the DPDK pktio type. Initialization code copied from the odp-dpdk branch. Reviewed-by: Petri Savolainen Signed-off-by: Matias Elo ---

Re: [lng-odp] [API-NEXT PATCH v3 00/11] DPDK pktio implementation

2016-02-10 Thread Zoltan Kiss
I can confirm that these two changes were made On 09/02/16 13:47, Matias Elo wrote: V2: - Check the number of mbuf segments in mbuf_to_pkt() (Zoltan Kiss) - Copy DPDK RSS hash to ODP packet header in mbuf_to_pkt() (Zoltan Kiss) ___ lng-odp mailing

Re: [lng-odp] [API-NEXT PATCH v3 00/11] DPDK pktio implementation

2016-02-10 Thread Maxim Uvarov
Perti, should it be considered for master branch if we included new api for 1.7? Maxim. On 02/10/2016 13:24, Savolainen, Petri (Nokia - FI/Espoo) wrote: Ping. I have reviewed these already before v1 was sent to the list (see my tag on patches). If another opinion is needed, please send

Re: [lng-odp] [API-NEXT PATCH] performance: crypto: add odp_crypto to .gitignore file

2016-02-10 Thread Maxim Uvarov
Merged, Maxim. On 02/09/2016 22:23, Bill Fischofer wrote: Signed-off-by: Bill Fischofer --- test/performance/.gitignore | 1 + 1 file changed, 1 insertion(+) diff --git a/test/performance/.gitignore b/test/performance/.gitignore index 5836281..edcc832 100644 ---

Re: [lng-odp] [API-NEXT PATCH 2/4] helper: ip: added ipv4 address parse

2016-02-10 Thread Tilli, Juha-Matti (Nokia - FI/Espoo)
Hi, Yes, you indeed have a test in the previous patch to check that "01:02:03:04:05:06 foobar" is accepted, so it is part of the design. A very minor complaint about this patch: I would consider saying "unsigned int bytes" instead of "unsigned byte". I thought there was a problem because you

Re: [lng-odp] [PATCH] Define odp_cpumask_get_bitmap to retrieve the bitmap defined by odp_cpumask_t.

2016-02-10 Thread Maxim Uvarov
Jose, can you please resend this patch with following: 1. short message: "api: define odp_cpumask_get_bitmap to retrieve the bitmap defined by odp_cpumask_t" 2. generate patch with --subject-prefix="API-NEXT" 3. add @return to doxygen comments and please check that doxygen does not

Re: [lng-odp] [API-NEXT PATCH v3 00/11] DPDK pktio implementation

2016-02-10 Thread Zoltan Kiss
I've started to review this but now I've refocused on pulling up ODP-DPDK to 1.7. I can finish it probably on Monday only, as I'm out on Friday. On 10/02/16 10:24, Savolainen, Petri (Nokia - FI/Espoo) wrote: Ping. I have reviewed these already before v1 was sent to the list (see my tag on

[lng-odp] [API-NEXT PATCHv4 2/4] api: move include/odp.h to include/odp_api.h

2016-02-10 Thread Christophe Milard
odp.h actually describes the applicatiion interface of ODP and is logicaly moved to odp_api.h. Applications now includes . This simplifies the addition of other ODP interfaces (e.g. drivers may include odp_drv.h in the future.) Signed-off-by: Christophe Milard ---

Re: [lng-odp] [API-NEXT PATCHv4 4/4] api: odp.h to ease transition period

2016-02-10 Thread Bill Fischofer
On Wed, Feb 10, 2016 at 11:27 AM, Christophe Milard < christophe.mil...@linaro.org> wrote: > The former odp.h (now called odp_api.h) is recreated here and just > includes odp_api.h. > This is to ease the transition period for ODP applications, but > this file (odp.h) is meant to be removed in the

[lng-odp] [API-NEXT PATCHv4 4/4] api: odp.h to ease transition period

2016-02-10 Thread Christophe Milard
The former odp.h (now called odp_api.h) is recreated here and just includes odp_api.h. This is to ease the transition period for ODP applications, but this file (odp.h) is meant to be removed in the future. ODP applications should include odp_api.h, but those including odp.h will keep working

[lng-odp] [API-NEXT PATCHv5 4/4] api: odp.h to ease transition period

2016-02-10 Thread Christophe Milard
The former odp.h (now called odp_api.h) is recreated here and just includes odp_api.h. This is to ease the transition period for ODP applications, but this file (odp.h) is meant to be removed in the future. ODP applications should include odp_api.h, but those including odp.h will keep working

[lng-odp] ODP_SHM_PROC shmem flag

2016-02-10 Thread Christophe Milard
Hi, If I understand correctly, the usage of this flag tells that Non ODP processes/thread can gain access to the shared memory. My question is: through which interface? - the ODP API? (which means that non ODP processes/thread could be linked with the ODP lib and however remain non ODP) - or the

[lng-odp] [API-NEXT PATCHv5 2/4] api: move include/odp.h to include/odp_api.h

2016-02-10 Thread Christophe Milard
odp.h actually describes the applicatiion interface of ODP and is logicaly moved to odp_api.h. Applications now includes . This simplifies the addition of other ODP interfaces (e.g. drivers may include odp_drv.h in the future.) Signed-off-by: Christophe Milard ---

Re: [lng-odp] [API-NEXT PATCHv4 4/4] api: odp.h to ease transition period

2016-02-10 Thread Christophe Milard
I did not know this was an issue. will do a v5... On 10 February 2016 at 17:34, Bill Fischofer wrote: > > > On Wed, Feb 10, 2016 at 11:27 AM, Christophe Milard < > christophe.mil...@linaro.org> wrote: > >> The former odp.h (now called odp_api.h) is recreated here and

[lng-odp] [API-NEXT PATCHv4 3/4] doc: descr of structure for new interfaces

2016-02-10 Thread Christophe Milard
updates of the documentation to reflect the new structure allowing new interface addition. Signed-off-by: Christophe Milard --- doc/implementers-guide/implementers-guide.adoc | 72 +++--- doc/users-guide/users-guide.adoc | 13 +++--

[lng-odp] [API-NEXT PATCHv4 0/4] Preparing for new interfaces

2016-02-10 Thread Christophe Milard
since v3: odp.h (just including odp_api.h) added to ease transition period for apps. double include protection macro name fixed in odp_api.h since v2: removed strange characters from docs since v1: odp.h renamed to odp_api.h (and not odp/api.h as initialy proposed). This patch series implements

[lng-odp] [API-NEXT PATCHv5 0/4] Preparing for new interfaces

2016-02-10 Thread Christophe Milard
since v4: removed the extern "C" wrapping from odp.h since v3: odp.h (just including odp_api.h) added to ease transition period for apps. double include protection macro name fixed in odp_api.h since v2: removed strange characters from docs since v1: odp.h renamed to odp_api.h (and not

Re: [lng-odp] [API-NEXT PATCHv5 0/4] Preparing for new interfaces

2016-02-10 Thread Bill Fischofer
For this series: Reviewed-by: Bill Fischofer On Wed, Feb 10, 2016 at 11:48 AM, Christophe Milard < christophe.mil...@linaro.org> wrote: > since v4: > removed the extern "C" wrapping from odp.h > > since v3: > odp.h (just including odp_api.h) added to ease transition

[lng-odp] ODP_SHM_SW_ONLY shmem flag

2016-02-10 Thread Christophe Milard
Hi, As far as I understand, the ODP_SHM_SW_ONLY flag used when creating shared memory blocks is used to tell ODP that no 'HW' will try to access that shared memory. Is the ODP HW included in this?... If ODP provide HW acceleration for some functions, would the usage of this flag tell ODP that

Re: [lng-odp] ODP_SHM_PROC shmem flag

2016-02-10 Thread Maxim Uvarov
On 02/10/2016 20:43, Christophe Milard wrote: Hi, If I understand correctly, the usage of this flag tells that Non ODP processes/thread can gain access to the shared memory. My question is: through which interface? - the ODP API? (which means that non ODP processes/thread could be linked

[lng-odp] [Bug 1549] Untested API parse_tcp

2016-02-10 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=1549 --- Comment #3 from Bill Fischofer --- parse_tcp() now appears to have coverage with recent additions to the classification tests added by Bala, so this bug no longer appears relevant. -- You are receiving this mail

[lng-odp] [Bug 1548] Untested API parse_ipv6

2016-02-10 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=1548 --- Comment #3 from Bill Fischofer --- parse_ipv6() now appears to be covered with recent classification test adds by Bala, so this bug no longer appears to be relevant. -- You are receiving this mail because: You are on

[lng-odp] [Bug 2031] CID 157958: Integer handling issues: timer.c

2016-02-10 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=2031 Bill Fischofer changed: What|Removed |Added CC|

Re: [lng-odp] [API-NEXT PATCH] test: l2fwd: fix merge bug

2016-02-10 Thread Elo, Matias (Nokia - FI/Espoo)
Hi, I took a second look at the code and the patch to api-next seems OK to me. However, it seems that the original patch ('test: l2fwd: fix test getting stuck in DIRECT_RECV/POLL_QUEUE mode') has not been applied to master branch. -Matias > -Original Message- > From: lng-odp

Re: [lng-odp] [API-NEXT PATCH 2/4] helper: ip: added ipv4 address parse

2016-02-10 Thread Savolainen, Petri (Nokia - FI/Espoo)
Yes, subnet support is needed and I left it for future development. This ipv4_addr function is for single IP address input (set local or dest address, etc). It would be waste to require a (/32) subnet masks for a single IP address. Also, the same functions would be needed for IPv6. The subnet

Re: [lng-odp] [API-NEXT PATCH] test: l2fwd: fix merge bug

2016-02-10 Thread Maxim Uvarov
On 02/10/2016 13:02, Elo, Matias (Nokia - FI/Espoo) wrote: Hi, I took a second look at the code and the patch to api-next seems OK to me. However, it seems that the original patch ('test: l2fwd: fix test getting stuck in DIRECT_RECV/POLL_QUEUE mode') has not been applied to master branch.

Re: [lng-odp] [API-NEXT PATCH 2/4] helper: ip: added ipv4 address parse

2016-02-10 Thread Bala Manoharan
On 10 February 2016 at 15:36, Savolainen, Petri (Nokia - FI/Espoo) < petri.savolai...@nokia.com> wrote: > Yes, subnet support is needed and I left it for future development. This > ipv4_addr function is for single IP address input (set local or dest > address, etc). It would be waste to require a

[lng-odp] [Bug 2030] New: CID 157957: Memory - illegal accesses:odp_sysinfo_parse.c

2016-02-10 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=2030 Bug ID: 2030 Summary: CID 157957: Memory - illegal accesses:odp_sysinfo_parse.c Product: OpenDataPlane - linux- generic reference Version: 1.6 Hardware: Other

[lng-odp] [Bug 2030] CID 157957: Memory - illegal accesses:odp_sysinfo_parse.c

2016-02-10 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=2030 Mike Holmes changed: What|Removed |Added Assignee|lng-odp@lists.linaro.org|hongbo.zh...@linaro.org

[lng-odp] [Bug 2031] New: CID 157958: Integer handling issues: timer.c

2016-02-10 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=2031 Bug ID: 2031 Summary: CID 157958: Integer handling issues: timer.c Product: OpenDataPlane - linux- generic reference Version: 1.6 Hardware: Other OS: Linux Status:

Re: [lng-odp] [API-NEXT PATCH v3 00/11] DPDK pktio implementation

2016-02-10 Thread Savolainen, Petri (Nokia - FI/Espoo)
Ping. I have reviewed these already before v1 was sent to the list (see my tag on patches). If another opinion is needed, please send comments ASAP. We'd prefer to use DPDK as a pktio instead / in addition to netmap. This is no different from tun/tap, pcap, netmap, etc pktios. -Petri >

[lng-odp] [API-NEXT PATCHv20 0/9] IPC (pktio)

2016-02-10 Thread Maxim Uvarov
v20: fixed Stuart and Ivans comments. Plan is to include these patches to api-next branch first. Then define all use cases which we want to support (l2fwd, several process to one memory pool if needed, and etc.) Then do final discussion and dessision to move that to master branch.

[lng-odp] [API-NEXT PATCHv20 1/9] helper: ring: update ring with shm proc argument

2016-02-10 Thread Maxim Uvarov
Signed-off-by: Maxim Uvarov --- helper/include/odp/helper/ring.h | 2 ++ helper/ring.c| 9 - 2 files changed, 10 insertions(+), 1 deletion(-) diff --git a/helper/include/odp/helper/ring.h b/helper/include/odp/helper/ring.h index

[lng-odp] [API-NEXT PATCHv20 2/9] linux-generic: create internal pool create function with shm flags

2016-02-10 Thread Maxim Uvarov
On init odp creates odp_sched_pool. We can not modify API to add new parameter to odp_pool_param_t and this pool should not be shared between different processes. To do that implemented internal linux-generic function with parameters to created shm. Note: create shm before and then provide it to

[lng-odp] [API-NEXT PATCHv20 3/9] helper: flag to not link ring to linked list

2016-02-10 Thread Maxim Uvarov
Add flag ODPH_RING_NO_LIST to ring to not link it to linked list. Signed-off-by: Maxim Uvarov --- helper/include/odp/helper/ring.h | 21 + helper/ring.c| 3 ++- 2 files changed, 15 insertions(+), 9 deletions(-) diff --git

[lng-odp] [API-NEXT PATCHv20 4/9] helpers: remove odp_ prefix for tests source files

2016-02-10 Thread Maxim Uvarov
Prefixed were removed for validation test suite and to be consistent we need to do the same for helpers. Signed-off-by: Maxim Uvarov --- helper/test/.gitignore | 10 +- helper/test/Makefile.am | 20 ++--

[lng-odp] [API-NEXT PATCHv20 6/9] linux-generic: ring set up __odp_errno as doxygen says

2016-02-10 Thread Maxim Uvarov
Accodring to doxygen comment if ring creation fails __odp_errno should be set. Signed-off-by: Maxim Uvarov --- platform/linux-generic/pktio/ring.c | 3 +++ 1 file changed, 3 insertions(+) diff --git a/platform/linux-generic/pktio/ring.c

[lng-odp] [API-NEXT PATCHv20 7/9] linux-generic: return error for unsupported pktio calls

2016-02-10 Thread Maxim Uvarov
For some pktios like loop and ipc functions like mtu, promisc, and mac addr are not applicable. Instead of crash on deference null pointer just return error if functions are not defined. Signed-off-by: Maxim Uvarov --- platform/linux-generic/odp_packet_io.c | 24

[lng-odp] [API-NEXT PATCHv20 8/9] linux-generic: add ipc pktio support

2016-02-10 Thread Maxim Uvarov
Signed-off-by: Maxim Uvarov --- platform/linux-generic/Makefile.am | 3 + .../linux-generic/include/odp_buffer_internal.h| 3 + .../linux-generic/include/odp_packet_io_internal.h | 38 ++ .../include/odp_packet_io_ipc_internal.h | 47

[lng-odp] [API-NEXT PATCHv20 9/9] linux-generic: internal ipc_pktio test

2016-02-10 Thread Maxim Uvarov
2 example ipc pktio applications create ipc pktio to each other and do packet transfer, validation magic numbers and packets sequence counters inside it. Signed-off-by: Maxim Uvarov --- platform/linux-generic/m4/configure.m4 | 1 +

Re: [lng-odp] [API-NEXT PATCH 2/4] helper: ip: added ipv4 address parse

2016-02-10 Thread Savolainen, Petri (Nokia - FI/Espoo)
It’s better to have two helpers, one that always requires “/prefix” and other that does not. That way, it’s easy to pick the right helper to parse your string and you can be sure that a subnet string has always a prefix defined. Internally you could reuse the code, but maybe it’s not worth it

Re: [lng-odp] [API-NEXT PATCH 1/4] helper: eth: added mac address parse

2016-02-10 Thread Tilli, Juha-Matti (Nokia - FI/Espoo)
Hi, After having a discussion with Petri, I now agree that the scanf implementation without strspn is probably the best one, as the command-line arguments may be concatenated together in one string in some use cases. So, perhaps my idea of having very thorough error checking is not such a