Re: [lng-odp] [PATCH] scripts/git_hash: match more digits

2016-05-02 Thread Ricardo Salveti
| tr -d "\n") > + hash=$(git --git-dir=${ROOTDIR}/.git describe --match > 'v[0-9]*\.[0-9]*\.[0-9]*\.[0-9]*'\ > + | tr -d "\n") > if [[ $(git --git-dir=${ROOTDIR}/.git diff --shortstat 2> /dev/null \ > | tai

Re: [lng-odp] [PATCH] configure: Fix broken conditional example execution

2016-04-15 Thread Ricardo Salveti
odp_switch_SOURCES = odp_switch.c > > -if HAVE_PCAP > -TESTS = switch_run.sh > +if test_example > + if HAVE_PCAP > + TESTS = switch_run.sh > + endif > endif > EXTRA_DIST = switch_run.sh udp64.pcap > -- > 2.5.0 > > ___ > lng-odp mailing list > lng-odp@lists.linaro.org > https://lists.linaro.org/mailman/listinfo/lng-odp -- Ricardo Salveti ___ lng-odp mailing list lng-odp@lists.linaro.org https://lists.linaro.org/mailman/listinfo/lng-odp

Re: [lng-odp] [PATCH] configure: default ODP_DEBUG to false

2016-04-15 Thread Ricardo Salveti
BUG=0 > AC_ARG_ENABLE([debug], > [ --enable-debug include additional code], > -[if ! test "x$enableval" = "xyes"; then > +[if test "x$enableval" = "xyes"; then > +ODP_DEBUG=1 > + else > ODP_D

Re: [lng-odp] [PATCH] configure: default ODP_DEPUG_PRINT to false

2016-04-15 Thread Ricardo Salveti
On Fri, Apr 15, 2016 at 3:15 PM, Mike Holmes wrote: > On 15 April 2016 at 14:11, Ricardo Salveti > wrote: >> >> On Fri, Apr 15, 2016 at 1:45 PM, Mike Holmes >> wrote: >> > As we approach a production stable release and we package for >> > distribution

Re: [lng-odp] [PATCH] configure: default ODP_DEPUG_PRINT to false

2016-04-15 Thread Ricardo Salveti
P_DEBUG_PRINT=0 > fi]) > ODP_CFLAGS="$ODP_CFLAGS -DODP_DEBUG_PRINT=$ODP_DEBUG_PRINT" There is just no need for the else statemente, since the default is already 0. Same for the other patch for ODP_DEBUG. Cheers, -- Ricardo Salveti ___ lng-odp mailing list lng-odp@lists.linaro.org https://lists.linaro.org/mailman/listinfo/lng-odp

Re: [lng-odp] [PATCH] configure: default ODP_DEBUG to false

2016-04-15 Thread Ricardo Salveti
G=0 > fi]) > ODP_CFLAGS="$ODP_CFLAGS -DODP_DEBUG=$ODP_DEBUG" > -- > 2.5.0 Don't we also need to do the same for ODP_DEBUG_PRINT? Thanks, -- Ricardo Salveti ___ lng-odp mailing list lng-odp@lists.linaro.org https://lists.linaro.org/mailman/listinfo/lng-odp

Re: [lng-odp] [API-NEXT PATCHv4] api: make only the API visible

2016-04-15 Thread Ricardo Salveti
l exposure via __attribute__ should be used. Cheers, -- Ricardo Salveti ___ lng-odp mailing list lng-odp@lists.linaro.org https://lists.linaro.org/mailman/listinfo/lng-odp

Re: [lng-odp] [API-NEXT PATCHv4] api: make only the API visible

2016-04-15 Thread Ricardo Salveti
ompiling with -fvisibility=hidden. > When you do that then all symbols are hidden by default and the result is > only the ODP APIs are exposed, due to these pragmas. > > This is exactly what we want. If an implementation wishes to expose symbols > other than those that are part of the

Re: [lng-odp] [PATCH] pkg: remove packaging in ODP

2016-04-14 Thread Ricardo Salveti
dbg\|$\| \):\1${current}\2:g" > debian/control > -sed -i "s:\(libodp[a-zA-Z\-]\+linux\)\(-dbg\| \):\1${current}\2:g" > debian/rules > - > -if [ $(egrep "\.([a-z0-9]{8}\>|dirty)" .scmversion |wc -l) -gt 0 ]; then > - export DEBFULLNAME="Donald Duck

Re: [lng-odp] [PATCH] linux-generic: add arch specific *.h files to EXTRA_DIST

2016-04-13 Thread Ricardo Salveti
\ > arch/x86/odp_cpu_arch.c \ > arch/x86/odp_sysinfo_parse.c > > -- > 2.1.4 Thanks, this allows me to create the tarball on x86 and build the package on arm64 :-) Reviewed-and-tested-by: Ricardo Salveti Cheers, -- Ricardo Salveti _

Re: [lng-odp] [API-NEXT PATCHv4] api: make only the API visible

2016-04-13 Thread Ricardo Salveti
On Wed, Apr 13, 2016 at 3:51 PM, Bill Fischofer wrote: > On Wed, Apr 13, 2016 at 1:47 PM, Ricardo Salveti > wrote: >> >> On Wed, Apr 13, 2016 at 2:47 PM, Bill Fischofer >> wrote: >> > >> > On Wed, Apr 13, 2016 at 12:30 PM, Anders Roxell >> >

Re: [lng-odp] [API-NEXT PATCHv4] api: make only the API visible

2016-04-13 Thread Ricardo Salveti
gt; functions from the public ABI. >> >> Suggested-by: Ricardo Salveti >> Signed-off-by: Anders Roxell >> --- >> include/odp/api/spec/align.h | 8 >> include/odp/api/spec/atomic.h | 8 >> include/odp/ap

Re: [lng-odp] [PATCHv2] linux-generic/include/odp_packet_io_internal: add visability hidden

2016-04-12 Thread Ricardo Salveti
On Tue, Apr 12, 2016 at 5:03 AM, Maxim Uvarov wrote: > why you do this only for that functions? I think at the beginning of each > internal.[ch] we need to say: > > #pragma GCC visibility push(hidden) > > then in the bottom: > #pragma GCC visibility pop > > In that case all internal things will ma

[lng-odp] [PATCH] linux-generic/odp_impl: removing __DATE__ and __TIME__

2016-04-07 Thread Ricardo Salveti
This is so we can get reproducible builds. Besides the library version, the string already contains the git hash, which is enough to traceback the build used. Bug-Link: https://bugs.linaro.org/show_bug.cgi?id=2154 Signed-off-by: Ricardo Salveti --- platform/linux-generic/odp_impl.c | 1 - 1

Re: [lng-odp] [PATCHv2] configure: remove separate so_version file

2016-04-04 Thread Ricardo Salveti
kg/debian . > > -current=$(cat .so_version |awk -F : '{print $1}') > +current=$(grep "^ODP_LIBSO_VERSION" ${ROOT_DIR}/configure.ac| \ > + awk -F'=' '{print $2}' |awk -F : '{print $1}') > rename 's,(.*linux)(.*),${1}'&q

Re: [lng-odp] [PATCH 1/2] configure: support out-of-tree CUnit

2016-04-04 Thread Ricardo Salveti
roposal here is to simply skip the AC_CHECK_LIB & AC_CHECK_HEADERS >> and add the "-lcunit" side effect via AM_LDFLAGS _only_ when >> --with-cunit-path=DIR is used. If DIR is incorrect, the build will still >> fail, just at later stage instead of in configure stage.

Re: [lng-odp] [PATCH] configure: remove separate so_version file

2016-04-01 Thread Ricardo Salveti
r in configure.ac in ./bootstrap ? > What is the real problem with current code? Can you add that to patch > description? I had this suggestion in my head at the original patch, but decided to not raise it simply because we are already maintaining the odp version in a separated file. For me it is indeed better to have it directly in configure.ac, as that is how most projects handle it. My only suggestion would be to move this to the top of the file, as otherwise it's not necessarily trivial to find it (and later you can just have everything that needs version changes all together). Thanks, -- Ricardo Salveti ___ lng-odp mailing list lng-odp@lists.linaro.org https://lists.linaro.org/mailman/listinfo/lng-odp

Re: [lng-odp] [PATCH] configure: disconnect API version with SO version

2016-03-30 Thread Ricardo Salveti
On Wed, Mar 30, 2016 at 4:38 PM, Anders Roxell wrote: > On 30 March 2016 at 21:26, Ricardo Salveti wrote: >> On Wed, Mar 30, 2016 at 4:08 PM, Anders Roxell >> wrote: >>> We used to force applications to rebuild when a ODP released a new >>> version that ch

Re: [lng-odp] [PATCH] configure: disconnect API version with SO version

2016-03-30 Thread Ricardo Salveti
#x27;"${current}"'${2},' debian/*odp*-linux.install > > sed -i "s:\(libodp[a-zA-Z\-]\+linux\)\(-dbg\|$\| \):\1${current}\2:g" > debian/control > -- > 2.1.4 Should we break this into 2 separated patches? Might be probably good to change builddeb in a separated patch. Thanks, -- Ricardo Salveti ___ lng-odp mailing list lng-odp@lists.linaro.org https://lists.linaro.org/mailman/listinfo/lng-odp

Re: [lng-odp] [PATCH] pkgconfig: use main ODP version

2016-03-30 Thread Ricardo Salveti
c.in > @@ -5,7 +5,7 @@ includedir=@includedir@ > > Name: libodphelper-linux > Description: Helper for the ODP packet processing engine > -Version: @VERSION@ > +Version: @PKGCONFIG_VERSION@ > Libs: -L${libdir} -lodphelper-linux > Libs.private: > Cflags: -I${includedir} > -- > 2.

Re: [lng-odp] [PATCH 00/11] cleanup debian builds

2016-03-23 Thread Ricardo Salveti
ge is stripped by default > pkg/debian/control: fix bin package section name > pkg/debian/control: fix dependency for libodp-linux-dev packages > pkg/debian: run tests before creating packages +1 for the series (with v2 for patch 3, 4 and 7, and dropping patc

Re: [lng-odp] [PATCH 11/11] pkg/debian: run tests before creating packages

2016-03-23 Thread Ricardo Salveti
On Wed, Mar 23, 2016 at 1:50 PM, Anders Roxell wrote: > On 22 March 2016 at 22:53, Ricardo Salveti wrote: >> On Mon, Mar 21, 2016 at 5:04 PM, Anders Roxell >> wrote: >>> Signed-off-by: Anders Roxell >>> --- >>> pkg/debian/rules | 7 +++ >>

Re: [lng-odp] [PATCH 11/11] pkg/debian: run tests before creating packages

2016-03-23 Thread Ricardo Salveti
-test-vald \ > + --enable-test-cpp --enable-test-helper > + $(MAKE) check > +endif > + > override_dh_auto_configure: > dh_auto_configure -- --enable-static > > -- > 2.1.4 Reviewed-by: Ricardo Salveti -- Ricardo Salveti

Re: [lng-odp] [PATCHv2 04/11] rename libodphelper to libodphelper-linux

2016-03-23 Thread Ricardo Salveti
)/libodphelper-linux.la $(LIB)/libodp-linux.la > > INCFLAGS = -I$(top_srcdir)/test \ > -I$(top_srcdir)/platform/@with_platform@/include \ > diff --git a/test/validation/Makefile.inc b/test/validation/Makefile.inc > index 1535926..9f36f9d 100644 > --- a/test/validation/Makefile.inc > +++ b/test/validation/Makefile.inc > @@ -13,4 +13,4 @@ AM_LDFLAGS += -static > LIBCUNIT_COMMON = $(COMMON_DIR)/libcunit_common.la > LIBCPUMASK_COMMON = $(COMMON_DIR)/libcpumask_common.la > LIBTHRMASK_COMMON = $(COMMON_DIR)/libthrmask_common.la > -LIBODP = $(LIB)/libodphelper.la $(LIB)/libodp-linux.la > +LIBODP = $(LIB)/libodphelper-linux.la $(LIB)/libodp-linux.la > -- > 2.1.4 Reviewed-by: Ricardo Salveti -- Ricardo Salveti ___ lng-odp mailing list lng-odp@lists.linaro.org https://lists.linaro.org/mailman/listinfo/lng-odp

Re: [lng-odp] [PATCHv2 03/11] rename libodp to libodp-linux

2016-03-23 Thread Ricardo Salveti
Duck" > diff --git a/test/Makefile.inc b/test/Makefile.inc > index 183d0a5..b3cb4a5 100644 > --- a/test/Makefile.inc > +++ b/test/Makefile.inc > @@ -4,7 +4,7 @@ LIB = $(top_builddir)/lib > #in the following line, the libs using the symbols should come before > #the libs containing them! The includer is given a chance to add things > #before libodp by setting PRE_LDADD before the inclusion. > -LDADD = $(PRE_LDADD) $(LIB)/libodphelper.la $(LIB)/libodp.la > +LDADD = $(PRE_LDADD) $(LIB)/libodphelper.la $(LIB)/libodp-linux.la > > INCFLAGS = -I$(top_srcdir)/test \ > -I$(top_srcdir)/platform/@with_platform@/include \ > diff --git a/test/validation/Makefile.inc b/test/validation/Makefile.inc > index 49efbda..1535926 100644 > --- a/test/validation/Makefile.inc > +++ b/test/validation/Makefile.inc > @@ -13,4 +13,4 @@ AM_LDFLAGS += -static > LIBCUNIT_COMMON = $(COMMON_DIR)/libcunit_common.la > LIBCPUMASK_COMMON = $(COMMON_DIR)/libcpumask_common.la > LIBTHRMASK_COMMON = $(COMMON_DIR)/libthrmask_common.la > -LIBODP = $(LIB)/libodphelper.la $(LIB)/libodp.la > +LIBODP = $(LIB)/libodphelper.la $(LIB)/libodp-linux.la > -- > 2.1.4 Reviewed-by: Ricardo Salveti -- Ricardo Salveti ___ lng-odp mailing list lng-odp@lists.linaro.org https://lists.linaro.org/mailman/listinfo/lng-odp

Re: [lng-odp] [PATCH 10/11] pkg/debian/control: fix dependency for libodp-linux-dev packages

2016-03-23 Thread Ricardo Salveti
On Wed, Mar 23, 2016 at 1:47 PM, Anders Roxell wrote: > On 22 March 2016 at 22:49, Ricardo Salveti wrote: >> On Mon, Mar 21, 2016 at 5:04 PM, Anders Roxell >> wrote: >>> Signed-off-by: Anders Roxell >>> --- >>> pkg/debian/control | 2 +- >&

Re: [lng-odp] [PATCHv2 07/11] dbg/debian: add libodphelper-linux* packages

2016-03-23 Thread Ricardo Salveti
"s:\(.*odp-linux\)\(-dbg\|$\| \):\1${current}\2:g" debian/control > -sed -i "s:\(.*odp-linux\)\(.*\):\1${current}\2:g" debian/rules > +sed -i "s:\(libodp[a-zA-Z\-]\+linux\)\(-dbg\|$\| \):\1${current}\2:g" > debian/control > +sed -i "s:\(libodp[a-zA-Z\-]\

Re: [lng-odp] [PATCH 11/11] pkg/debian: run tests before creating packages

2016-03-22 Thread Ricardo Salveti
a side effect of using trunk: FAIL: ../../../test/validation/traffic_mngr/traffic_mngr_main Test: traffic_mngr_test_shaper ...FAILED 1. traffic_mngr.c:1630 - pkts_rcvd_in_order == pkts_sent Did you get that as well? Thanks, -- Ricardo Salveti ___ lng

Re: [lng-odp] [PATCH 10/11] pkg/debian/control: fix dependency for libodp-linux-dev packages

2016-03-22 Thread Ricardo Salveti
trol 8068 bytes, 116 lines md5sums Package: libodp-linux-dev ... Depends: libssl-dev And I noticed the same is happening with libodphelper-linux-dev. Thanks, -- Ricardo Salveti ___ lng-odp mailing list lng-odp@lists.linaro.org https://lists.linaro.org/mailman/listinfo/lng-odp

Re: [lng-odp] [PATCH 09/11] pkg/debian/control: fix bin package section name

2016-03-22 Thread Ricardo Salveti
pends: ${misc:Depends}, ${shlibs:Depends} > -- > 2.1.4 Reviewed-by: Ricardo Salveti -- Ricardo Salveti ___ lng-odp mailing list lng-odp@lists.linaro.org https://lists.linaro.org/mailman/listinfo/lng-odp

Re: [lng-odp] [PATCH 07/11] dbg/debian: add libodphelper-linux* packages

2016-03-22 Thread Ricardo Salveti
t; -sed -i "s:\(.*odp-linux\)\(.*\):\1${current}\2:g" debian/rules > +sed -i "s:\(libodp[a-zA-Z\-]\+linux\)\(-dbg\|$\| \):\1${current}\2:g" > debian/control > +sed -i "s:\(libodp[a-zA-Z\-]\+linux\)\(-dbg\| \):\1${current}\2:g" > debian/rules > > if [ $(egrep "\.([a-z0-9]{8}\>|dirty)" .scmversion |wc -l) -gt 0 ]; then > export DEBFULLNAME="Donald Duck" > -- > 2.1.4 Reviewed-by: Ricardo Salveti -- Ricardo Salveti ___ lng-odp mailing list lng-odp@lists.linaro.org https://lists.linaro.org/mailman/listinfo/lng-odp

Re: [lng-odp] [PATCH 06/11] helper/Makefile: add SO-version to helper lib

2016-03-22 Thread Ricardo Salveti
r)/include > > +AM_LDFLAGS += -version-number '$(ODP_LIBSO_VERSION)' > + > helperincludedir = $(includedir)/odp/helper/ > helperinclude_HEADERS = \ > $(srcdir)/include/odp/helper/linux.h \ > -- > 2.1.4 Reviewed-by: Ricardo Salveti -- Ricardo Salve

Re: [lng-odp] [PATCH 08/11] pkg/debian/rules: make sure every package is stripped by default

2016-03-22 Thread Ricardo Salveti
pkg/debian/rules > @@ -20,3 +20,4 @@ override_dh_auto_configure: > override_dh_strip: > dh_strip -p libodp-linux --dbg-package=libodp-linux-dbg > dh_strip -p libodphelper-linux --dbg-package=libodphelper-linux-dbg > + dh_strip --remaining-packages > -- > 2

Re: [lng-odp] [PATCH 05/11] scripts/builddeb: remove SO-version from -dev and -bin pkg

2016-03-22 Thread Ricardo Salveti
> > -sed -i "s:\(.*odp-linux\)\([^\.]\|$\):\1${current}\2:g" debian/control > +sed -i "s:\(.*odp-linux\)\(-dbg\|$\| \):\1${current}\2:g" debian/control > sed -i "s:\(.*odp-linux\)\(.*\):\1${current}\2:g" debian/rules > > if

Re: [lng-odp] [PATCH 04/11] rename libodphelper to libodphelper-linux

2016-03-22 Thread Ricardo Salveti
-1 +0,0 @@ > -usr/lib/*/lib*.so.* > diff --git a/pkgconfig/libodphelper.pc.in b/pkgconfig/libodphelper-linux.pc.in > similarity index 90% > rename from pkgconfig/libodphelper.pc.in > rename to pkgconfig/libodphelper-linux.pc.in > index 2993d71..

Re: [lng-odp] [PATCH 03/11] rename libodp to libodp-linux

2016-03-22 Thread Ricardo Salveti
-l) -gt 0 ]; then > export DEBFULLNAME="Donald Duck" > diff --git a/test/Makefile.inc b/test/Makefile.inc > index 183d0a5..b3cb4a5 100644 > --- a/test/Makefile.inc > +++ b/test/Makefile.inc > @@ -4,7 +4,7 @@ LIB = $(top_builddir)/lib > #in the

Re: [lng-odp] [PATCH 01/11] pkg/debian/control: add graphviz to Build-Depends

2016-03-22 Thread Ricardo Salveti
, asciidoc, mscgen, texlive-latex-recommended > +ghostscript, asciidoc, mscgen, texlive-latex-recommended, graphviz > Standards-Version: 3.9.6 > Section: libs > Homepage: http://www.opendataplane.org/ Reviewed-by: Ricardo Salveti -- Ricardo Salveti

Re: [lng-odp] [PATCH 02/11] configure: default test-helper to disabled

2016-03-22 Thread Ricardo Salveti
### > # Enable/disable test-helper > ## > -test_helper=yes > +test_helper=no > AC_ARG_ENABLE([test-helper], > [ --enable-test-helper run test in helper/test], > [if test "x$enableval" = "x

[lng-odp] [PATCH 3/3] builddeb: support creating source-only package with git archive

2016-02-22 Thread Ricardo Salveti
omake files in order to produce the build. To create the source package simply call 'scripts/builddeb source'. Signed-off-by: Ricardo Salveti --- scripts/builddeb| 13 +++-- scripts/common_pkg_build.sh | 22 +++--- 2 files changed, 30 insertions(

[lng-odp] [PATCH 2/3] pkg/debian: use dh-autoreconf by default

2016-02-22 Thread Ricardo Salveti
Since it's usually a good idea to call autoreconf when building packages, prefer that option instead of using the pre-built autoconf files with autotools-dev. Signed-off-by: Ricardo Salveti --- pkg/debian/control | 2 +- pkg/debian/rules | 9 +++-- 2 files changed, 8 insertions(

[lng-odp] [PATCH 1/3] bootstrap: force autoconf update

2016-02-22 Thread Ricardo Salveti
Since scmversion gets populated during the configure process, the only way for the cache to be updated through commits is by either running make distclean or by forcing autoconf updates when bootstrap gets called (e.g. builddeb). Signed-off-by: Ricardo Salveti --- bootstrap | 2 +- 1 file

[lng-odp] [PATCH] bootstrap: force autoconf update

2016-02-03 Thread Ricardo Salveti
Since scmversion gets populated during the configure process, the only way for the cache to be updated through commits is by either running make distclean or by forcing autoconf updates when bootstrap gets called (e.g. builddeb). Signed-off-by: Ricardo Salveti --- bootstrap | 2 +- 1 file

[lng-odp] [PATCH] README: fixing bug tracking url

2016-02-03 Thread Ricardo Salveti
There is no single OpenDataPlane product anymore, so pointing out to the generic implementation instead. Signed-off-by: Ricardo Salveti --- README | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/README b/README index cad5138..d8583be 100644 --- a/README +++ b/README @@ -45,4

[lng-odp] [PATCH] builddep: allow building only the src package

2016-02-03 Thread Ricardo Salveti
Allow the user to easily produce and use the source package when the binary build is not desired (e.g. to be uploaded in extra repositories). Signed-off-by: Ricardo Salveti --- scripts/builddeb | 10 +- 1 file changed, 9 insertions(+), 1 deletion(-) diff --git a/scripts/builddeb b