D7902: merge: introduce a clean_update() for that use-case

2020-02-05 Thread martinvonz (Martin von Zweigbergk)
martinvonz added inline comments. martinvonz marked an inline comment as done. INLINE COMMENTS > marmoute wrote in merge.py:2580 > The idea is great (I also always scratch my head at `merge.update`. However > can we can some solide documentation about what this function does ? Oh, of course we

D7902: merge: introduce a clean_update() for that use-case

2020-02-05 Thread martinvonz (Martin von Zweigbergk)
martinvonz updated this revision to Diff 19929. REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D7902?vs=19555&id=19929 BRANCH default CHANGES SINCE LAST ACTION https://phab.mercurial-scm.org/D7902/new/ REVISION DETAIL https://phab.mercurial-scm.org/

D7901: merge: introduce a revert_to() for that use-case

2020-02-05 Thread martinvonz (Martin von Zweigbergk)
martinvonz updated this revision to Diff 19930. REPOSITORY rHG Mercurial CHANGES SINCE LAST UPDATE https://phab.mercurial-scm.org/D7901?vs=19556&id=19930 BRANCH default CHANGES SINCE LAST ACTION https://phab.mercurial-scm.org/D7901/new/ REVISION DETAIL https://phab.mercurial-scm.org/

D6846: packaging: script the building of a MacOS installer using a custom python

2020-02-05 Thread mharbison72 (Matt Harbison)
mharbison72 added a comment. In D6846#119328 , @marmoute wrote: > are we talking about python library or compiled library ? Go you have any "empty" item in the various PATH used for the build ? See https://phab.mercurial-scm.org/D6846#100

D7969: exchange: check the `ui.clonebundleprefers` form while processing (issue6257)

2020-02-05 Thread mharbison72 (Matt Harbison)
mharbison72 added inline comments. mharbison72 requested review of this revision. INLINE COMMENTS > marmoute wrote in test-clonebundles.t:458-464 > Your patch is about testing error when only one of the items is bad. Then, > your tests only test it with a single item. Am I missing something or s

D7960: httpconnection: allow `httpsendfile` subclasses to suppress the progressbar

2020-02-05 Thread mharbison72 (Matt Harbison)
mharbison72 added a comment. In D7960#119446 , @marmoute wrote: > This is very unappealling ☹ could we update the `total` value in case authentication is needed instead ? Sorry, I'm not sure what you mean. The progressbar is per-file in

[Bug 6266] New: hg record caused "mpatch.mpatchError: patch cannot be decoded", 64-bit, 64 GB RAM system

2020-02-05 Thread mercurial-bugs
https://bz.mercurial-scm.org/show_bug.cgi?id=6266 Bug ID: 6266 Summary: hg record caused "mpatch.mpatchError: patch cannot be decoded", 64-bit, 64 GB RAM system Product: Mercurial Version: earlier Hardware: Other

D8084: merge: use manifestdict.walk() instead of manifestdict.matches()

2020-02-05 Thread martinvonz (Martin von Zweigbergk)
martinvonz added inline comments. INLINE COMMENTS > merge.py:1000 > """ > - > +pmmf = None > # If the repo is narrowed, filter out files outside the narrowspec. dead assignment? REPOSITORY rHG Mercurial CHANGES SINCE LAST ACTION https://phab.mercurial-scm.org/D8084/new/ REVI

D7902: merge: introduce a clean_update() for that use-case

2020-02-05 Thread marmoute (Pierre-Yves David)
This revision now requires changes to proceed. marmoute added inline comments. marmoute requested changes to this revision. INLINE COMMENTS > merge.py:2580 > > +def clean_update(ctx, wc=None): > +return update(ctx.repo(), ctx.rev(), branchmerge=False, force=True, > wc=wc) The idea is grea

D7517: filemerge: byteify the open() mode

2020-02-05 Thread marmoute (Pierre-Yves David)
marmoute added a comment. marmoute accepted this revision. I am leaning toward taking it for consistency (as @mharbison72 said) however, I also seems fine to simply abandon it. REPOSITORY rHG Mercurial CHANGES SINCE LAST ACTION https://phab.mercurial-scm.org/D7517/new/ REVISION DETAIL

D7969: exchange: check the `ui.clonebundleprefers` form while processing (issue6257)

2020-02-05 Thread marmoute (Pierre-Yves David)
This revision now requires changes to proceed. marmoute added a comment. marmoute requested changes to this revision. (feel free to put it back in review-needed if my question was silly). INLINE COMMENTS > test-clonebundles.t:458-464 > +Test a bad attribute list > + > + $ hg --config ui.clon

D7966: remotefilelog: only prefetch history in linkrevfixup

2020-02-05 Thread marmoute (Pierre-Yves David)
marmoute added a comment. marmoute accepted this revision. looks okay. REPOSITORY rHG Mercurial CHANGES SINCE LAST ACTION https://phab.mercurial-scm.org/D7966/new/ REVISION DETAIL https://phab.mercurial-scm.org/D7966 To: pulkit, #hg-reviewers, marmoute Cc: marmoute, mercurial-devel __

D7965: py3: catch AttributeError too with ImportError

2020-02-05 Thread marmoute (Pierre-Yves David)
marmoute added a comment. marmoute accepted this revision. Sounds reasonable REPOSITORY rHG Mercurial CHANGES SINCE LAST ACTION https://phab.mercurial-scm.org/D7965/new/ REVISION DETAIL https://phab.mercurial-scm.org/D7965 To: pulkit, #hg-reviewers, marmoute Cc: marmoute, mercurial-de

D7963: lfs: enable workers by default

2020-02-05 Thread marmoute (Pierre-Yves David)
marmoute added a comment. marmoute accepted this revision. Seem good to go, once the other one in the series are taken. REPOSITORY rHG Mercurial CHANGES SINCE LAST ACTION https://phab.mercurial-scm.org/D7963/new/ REVISION DETAIL https://phab.mercurial-scm.org/D7963 To: mharbison72, #h

D7962: lfs: fix the stall and corruption issue when concurrently uploading blobs

2020-02-05 Thread marmoute (Pierre-Yves David)
marmoute added a comment. marmoute accepted this revision. The patch is a bit obscur, but the explanation is strong. REPOSITORY rHG Mercurial CHANGES SINCE LAST ACTION https://phab.mercurial-scm.org/D7962/new/ REVISION DETAIL https://phab.mercurial-scm.org/D7962 To: mharbison72, #hg-r

D7961: lfs: add a method to the local blobstore to convert OIDs to file paths

2020-02-05 Thread marmoute (Pierre-Yves David)
marmoute added a comment. marmoute accepted this revision. looks like a clear win. REPOSITORY rHG Mercurial CHANGES SINCE LAST ACTION https://phab.mercurial-scm.org/D7961/new/ REVISION DETAIL https://phab.mercurial-scm.org/D7961 To: mharbison72, #hg-reviewers, marmoute Cc: marmoute, m

D7960: httpconnection: allow `httpsendfile` subclasses to suppress the progressbar

2020-02-05 Thread marmoute (Pierre-Yves David)
marmoute added a comment. This is very unappealling ☹ could we update the `total` value in case authentication is needed instead ? (also, the double sending is madness, could we have a small wireprotocol command dedicated at testing authentication first instead ?) REPOSITORY rHG Mercu

D7944: localrepo: handle ValueError during repository opening

2020-02-05 Thread marmoute (Pierre-Yves David)
marmoute added a comment. marmoute accepted this revision. urg… REPOSITORY rHG Mercurial CHANGES SINCE LAST ACTION https://phab.mercurial-scm.org/D7944/new/ REVISION DETAIL https://phab.mercurial-scm.org/D7944 To: indygreg, #hg-reviewers, marmoute Cc: marmoute, mercurial-devel ___

D7940: py3: make flush() line optional

2020-02-05 Thread marmoute (Pierre-Yves David)
This revision now requires changes to proceed. marmoute added inline comments. marmoute requested changes to this revision. INLINE COMMENTS > hghave.py:783 > > +@checkvers("pyexact", "Python == %s", (2.7, 3.5, 3.6, 3.7, 3.8, 3.9)) > +def has_python_exact(v): can we pre-generate more python ver

D7929: rust-status: add bare `hg status` support in hg-core

2020-02-05 Thread marmoute (Pierre-Yves David)
marmoute added a comment. I did a first pass on this. Nothing obviously wrong, but I am bit out of my Rust league here. I asked a couple of question. INLINE COMMENTS > status.rs:29-38 > +use std::collections::VecDeque; > +use std::{ > +borrow::Cow, > +collections::HashSet, > +fs:

D7928: rust-status: add function for sequential traversal of the working directory

2020-02-05 Thread marmoute (Pierre-Yves David)
This revision now requires changes to proceed. marmoute added a comment. marmoute requested changes to this revision. There is a lot going on in this changeset. I am counting at least: - new `BadType/BadMatch` structs, - `StatusResult` → `DirstateStatus` change, - new `StatusOptions` s

Re: Fixing default behavior of bookmarks.

2020-02-05 Thread Valentin Gatien-Baron
On Mon, Jan 27, 2020 at 6:03 PM Valentin Gatien-Baron < vgatien-ba...@janestreet.com> wrote: > > I don't think I have seen the problem you linked to about `hg update`, > but the description is terse, so I don't think I understand what is > the series of steps that leads to the bad behavior. > It

D8085: manifest: move matches method to be outside the interface

2020-02-05 Thread durin42 (Augie Fackler)
durin42 created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REVISION SUMMARY In order to adequately smoke out any legacy consumers of the method, we rename it to _matches so it's clear that it's class-private. To my amazement, all consume

D8084: merge: use manifestdict.walk() instead of manifestdict.matches()

2020-02-05 Thread durin42 (Augie Fackler)
durin42 created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REVISION SUMMARY As with other patches in this series, this avoids making a potentially-expensive copy of a manifest. REPOSITORY rHG Mercurial BRANCH default REVISION DETAIL

D8082: manifest: rewrite filesnotin to not make superfluous manifest copies

2020-02-05 Thread durin42 (Augie Fackler)
durin42 created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REVISION SUMMARY This also skips using diff() when all we care about is the filenames. I'm expecting the built in set logic to be plenty fast. For really large manifests with a m

D8083: archival: use walk() instead of matches() on manifest

2020-02-05 Thread durin42 (Augie Fackler)
durin42 created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REVISION SUMMARY All we care about is the filepaths, so this avoids a pointless copy of the manifest that we only used to extract matching filenames. REPOSITORY rHG Mercurial B

D8081: manifest: fix _very_ subtle bug with exact matchers passed to walk()

2020-02-05 Thread durin42 (Augie Fackler)
durin42 created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REVISION SUMMARY Prior to this fix, manifestdict.walk() with an exact matcher would blindly list the files in the matcher, even if they weren't in the manifest. This was exposed

D8080: context: use manifest.walk() instead of manifest.match() to get file list

2020-02-05 Thread durin42 (Augie Fackler)
durin42 created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REVISION SUMMARY The former doesn't create a whole extra manifest in order to produce the matching file list, which is all we actually cared about here. Sigh. REPOSITORY rHG Mer

D8079: manifest: remove `.new()` from the interface

2020-02-05 Thread durin42 (Augie Fackler)
durin42 created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REVISION SUMMARY Nothing used it. REPOSITORY rHG Mercurial BRANCH default REVISION DETAIL https://phab.mercurial-scm.org/D8079 AFFECTED FILES mercurial/interfaces/reposit

D7927: rust-status: add util for listing a directory

2020-02-05 Thread marmoute (Pierre-Yves David)
marmoute added a comment. marmoute accepted this revision. I am not a rust expert, but I don't see anything obviously wrong in there. I make a couple of minor comments. INLINE COMMENTS > status.rs:68 > +if skip_dot_hg && filename.as_bytes() == b".hg" && > file_type.is_dir() { > +

mercurial@44242: new changeset (1 on stable)

2020-02-05 Thread Mercurial Commits
New changeset (1 on stable) in mercurial: https://www.mercurial-scm.org/repo/hg/rev/847e582f3cc9 changeset: 44242:847e582f3cc9 branch: stable tag: tip parent: 44229:c002d504ff11 user:Matt Harbison date:Mon Feb 03 20:12:47 2020 -0500 summary: packaging: make

D8067: perf: fix list formatting in perfindex documentation

2020-02-05 Thread marmoute (Pierre-Yves David)
Closed by commit rHGcb69802f28fb: perf: fix list formatting in perfindex documentation (authored by marmoute). This revision was automatically updated to reflect the committed changes. This revision was not accepted when it landed; it landed in state "Needs Review". REPOSITORY rHG Mercurial C

D8065: test: simplify test-amend.t to avoid race condition

2020-02-05 Thread marmoute (Pierre-Yves David)
Closed by commit rHG63a4d43db8d0: test: simplify test-amend.t to avoid race condition (authored by marmoute). This revision was automatically updated to reflect the committed changes. This revision was not accepted when it landed; it landed in state "Needs Review". REPOSITORY rHG Mercurial CH

D8075: config: also respect HGRCSKIPREPO in the zeroconf extension

2020-02-05 Thread marmoute (Pierre-Yves David)
Closed by commit rHG1c530957a3ea: config: also respect HGRCSKIPREPO in the zeroconf extension (authored by marmoute). This revision was automatically updated to reflect the committed changes. This revision was not accepted when it landed; it landed in state "Needs Review". REPOSITORY rHG Mercu

D8072: config: add a function in `rcutil` to abstract HGRCSKIPREPO

2020-02-05 Thread marmoute (Pierre-Yves David)
Closed by commit rHG8a4766e38f35: config: add a function in `rcutil` to abstract HGRCSKIPREPO (authored by marmoute). This revision was automatically updated to reflect the committed changes. This revision was not accepted when it landed; it landed in state "Needs Review". REPOSITORY rHG Mercu

D8074: config: also respect HGRCSKIPREPO in hgwebdir_mod

2020-02-05 Thread marmoute (Pierre-Yves David)
Closed by commit rHG890de6f991f2: config: also respect HGRCSKIPREPO in hgwebdir_mod (authored by marmoute). This revision was automatically updated to reflect the committed changes. This revision was not accepted when it landed; it landed in state "Needs Review". REPOSITORY rHG Mercurial CHAN

D8073: config: also respect HGRCSKIPREPO in `dispatch._getlocal`

2020-02-05 Thread marmoute (Pierre-Yves David)
Closed by commit rHG9514f2fc64ca: config: also respect HGRCSKIPREPO in `dispatch._getlocal` (authored by marmoute). This revision was automatically updated to reflect the committed changes. This revision was not accepted when it landed; it landed in state "Needs Review". REPOSITORY rHG Mercuri

D8077: test: document test-copy-move-merge.t

2020-02-05 Thread marmoute (Pierre-Yves David)
Closed by commit rHG9659ec161644: test: document test-copy-move-merge.t (authored by marmoute). This revision was automatically updated to reflect the committed changes. This revision was not accepted when it landed; it landed in state "Needs Review". REPOSITORY rHG Mercurial CHANGES SINCE LA

D8078: tests/test-copies-chain-merge.t

2020-02-05 Thread martinvonz (Martin von Zweigbergk)
This revision now requires changes to proceed. martinvonz added a comment. martinvonz requested changes to this revision. Missing (proper) commit message. I assume the title line would be something like "tests: add tests for copies across a chain of merges", but I'm not sure what the body wou

D6846: packaging: script the building of a MacOS installer using a custom python

2020-02-05 Thread marmoute (Pierre-Yves David)
marmoute added a comment. are we talking about python library or compiled library ? Go you have any "empty" item in the various PATH used for the build ? REPOSITORY rHG Mercurial CHANGES SINCE LAST ACTION https://phab.mercurial-scm.org/D6846/new/ REVISION DETAIL https://phab.mercurial

D8078: tests/test-copies-chain-merge.t

2020-02-05 Thread marmoute (Pierre-Yves David)
marmoute created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REPOSITORY rHG Mercurial REVISION DETAIL https://phab.mercurial-scm.org/D8078 AFFECTED FILES tests/test-copies-chain-merge.t CHANGE DETAILS diff --git a/tests/test-copies-ch

D8077: test: document test-copy-move-merge.t

2020-02-05 Thread marmoute (Pierre-Yves David)
marmoute created this revision. Herald added a subscriber: mercurial-devel. Herald added a reviewer: hg-reviewers. REPOSITORY rHG Mercurial REVISION DETAIL https://phab.mercurial-scm.org/D8077 AFFECTED FILES tests/test-copy-move-merge.t CHANGE DETAILS diff --git a/tests/test-copy-move-me

D7834: nodemap: have some python code writing a nodemap in persistent binary form

2020-02-05 Thread marmoute (Pierre-Yves David)
marmoute added inline comments. INLINE COMMENTS > martinvonz wrote in nodemap.py:47-49 > The actual semantic of this code (the Python code) is to serialize the data. > To me, "persist" implies writing it to disk, which is not what this code > does. I think it's just misleading to call it that e