Re: RFR (XXS): 8162811: use correct IPv6 multicast socket options for AIX in PlainDatagramSocketImpl.c

2016-08-01 Thread Volker Simonis
Hi Christoph, in general your change looks good, because the setsockopt man-page on AIX only defines IPV6_JOIN_GROUP/IPV6_LEAVE_GROUP but not IPV6_ADD_MEMBERSHIP/IPV6_DROP_MEMBERSHIP. On the other hand I was surprised that the original code compiled before. Looking into the AIX headers, I found:

Re: RFR (XS): 8162819: fix minor Javadoc issues and remove warnings in java.net.Socket and java.net.Inet*Address

2016-08-01 Thread Daniel Fuchs
On 31/07/16 22:47, Langer, Christoph wrote: Hi, please review these small fixes for Javadoc issues and removal of warnings. Bug: https://bugs.openjdk.java.net/browse/JDK-8162819 Webrev: http://cr.openjdk.java.net/~clanger/webrevs/8162819.1/ Hi Christoph, The Javadoc changes look good to

RE: RFR (XS): 8162819: fix minor Javadoc issues and remove warnings in java.net.Socket and java.net.Inet*Address

2016-08-01 Thread Langer, Christoph
Hi Daniel, the warning is shown by my Eclipse IDE, javac -Xlint does not warn about unused methods, I think. So, then the tag @SuppressWarnings("unused") should probably not be used? Or what's the official OpenJDK standard for this type of warnings? Thanks Christoph > -Original Message---

RE: RFR (XXS): 8162811: use correct IPv6 multicast socket options for AIX in PlainDatagramSocketImpl.c

2016-08-01 Thread Langer, Christoph
Hi Volker, ok, I agree, I should probably hold back this merely cosmetical change for the moment and take a deeper look at the AIX multicast test failures and which fixes will be required. Thanks Christoph > -Original Message- > From: Volker Simonis [mailto:volker.simo...@gmail.com] >

Re: RFR (XS): 8162819: fix minor Javadoc issues and remove warnings in java.net.Socket and java.net.Inet*Address

2016-08-01 Thread Daniel Fuchs
Hi Christoph, On 01/08/16 10:43, Langer, Christoph wrote: Hi Daniel, the warning is shown by my Eclipse IDE, javac -Xlint does not warn about unused methods, I think. So, then the tag @SuppressWarnings("unused") should probably not be used? Or what's the official OpenJDK standard for this ty

RFR 8162876: [TEST_BUG] sun/net/www/protocol/http/HttpInputStream.java fails intermittently

2016-08-01 Thread Svetlana Nikandrova
Hello, please review this test clean-up. Test sun/net/www/protocol/http/HttpInputStream.java fails intermittently with stale threads remaining. I've done some refactoring to make sure that all request data is read, resources are closed and I also hope test is more readable now. Webrev: http:/

Re: RFR 8162876: [TEST_BUG] sun/net/www/protocol/http/HttpInputStream.java fails intermittently

2016-08-01 Thread Pavel Rappo
A couple of minor issues: 1. I wonder if "vedio" is a typo left from day 1? 26 * @summary http://www.clipstream.com vedio does not play; read() problem 2. "serverSocket != null" checks seem to be useless (serverSocket is final and initialized in constructor). 87 if (serverSocke

Re: RFR 8162876: [TEST_BUG] sun/net/www/protocol/http/HttpInputStream.java fails intermittently

2016-08-01 Thread Chris Hegarty
> On 1 Aug 2016, at 12:03, Pavel Rappo wrote: > ...return len; > > 5. I believe we should add 8162876 to @bug Strictly speaking, we should not. The @bug should capture the bug numbers that the test exercises the changes for. It is not necessary to include the bug number for a bug to the tes