Re: [RFC: 2.6 patch] remove broken net drivers

2006-11-19 Thread Geert Uytterhoeven
On Sat, 18 Nov 2006, Adrian Bunk wrote: This patch removes net drivers that: - had already been marked as BROKEN in 2.6.0 three years ago and - are still marked as BROKEN. These are the following drivers: - MAC89x0 I still have a patch lying around for this one:

TULIP_MWI fix for Cobalt

2006-11-19 Thread Martin Michlmayr
Please consider the patch below. The original consensus was that since this is documented in the errata it should be done by default rather than as a config option. I think the original author of the patch doesn't have time to submit a revised version but now that there's a new maintainer of the

Re: [PATCH] d80211: fix scan issues with new ops

2006-11-19 Thread David Kimdon
On Sun, Nov 19, 2006 at 01:21:13AM +0100, Johannes Berg wrote: If hardware shall do scanning, the hw_scan operation must be set. However, if the driver is for multiple cards that may or may not do hardware scanning, it'll need a flag. What is wrong with the driver setting the function pointer

Re: [PATCH] d80211: fix scan issues with new ops

2006-11-19 Thread Michael Buesch
On Sunday 19 November 2006 01:21, Johannes Berg wrote: If hardware shall do scanning, the hw_scan operation must be set. However, if the driver is for multiple cards that may or may not do hardware scanning, it'll need a flag. Similar issues arise with passive_scan(). This patch

Re: [PATCH] d80211: remove IEEE80211_CONF_SW_{EN,DE}CRYPT

2006-11-19 Thread Michael Buesch
On Sunday 19 November 2006 00:53, Johannes Berg wrote: There's no point in trying to tell a driver globally whether sw or hw crypto is used, if it's sw then we just don't give it keys... Besides, these weren't ever used! Remove IEEE80211_CONF_SW_DECRYPT and IEEE80211_CONF_SW_ENCRYPT.

Re: [PATCH 4/10] d80211: reduce mdev usage, fix ieee80211_rx_mgmt

2006-11-19 Thread David Kimdon
Reply-To: In-Reply-To: [EMAIL PROTECTED] --- wireless-dev.orig/net/d80211/ieee80211.c 2006-11-17 20:01:54.999703408 +0100 +++ wireless-dev/net/d80211/ieee80211.c 2006-11-17 20:01:55.659703408 +0100 @@ -210,9 +210,16 @@ static void ieee80211_key_threshold_noti

Re: [PATCH] d80211: fix scan issues with new ops

2006-11-19 Thread Johannes Berg
On Sun, 2006-11-19 at 07:56 -0800, David Kimdon wrote: What is wrong with the driver setting the function pointer to NULL for the cards that do not support scanning? Where does this requirment come from that the function pointers in struct ieee80211_wiphy be identical for all cards? Well I

Re: [PATCH] d80211: fix scan issues with new ops

2006-11-19 Thread Johannes Berg
On Sun, 2006-11-19 at 17:15 +0100, Michael Buesch wrote: - if (local-ops-hw_scan) { + if (local-ops-hw_scan local-wiphy.flags IEEE80211_HW_SCAN) { Please wrap this into () Good point :) johannes signature.asc Description: This is a digitally signed message part

Re: [PATCH 4/10] d80211: reduce mdev usage, fix ieee80211_rx_mgmt

2006-11-19 Thread Johannes Berg
+ /* if no one will get it anyway, don't even allocate it. +* unlikely because this is only relevant for APs +* where the device must be open... */ + if (unlikely(!local-apdev)) + return; Why not just let it Oops and show the bug? In what cases is it ok for

Re: [PATCH] d80211: fix scan issues with new ops

2006-11-19 Thread David Kimdon
On Sun, Nov 19, 2006 at 05:34:49PM +0100, Johannes Berg wrote: On Sun, 2006-11-19 at 07:56 -0800, David Kimdon wrote: What is wrong with the driver setting the function pointer to NULL for the cards that do not support scanning? Where does this requirment come from that the function

Re: [PATCH] d80211: fix scan issues with new ops

2006-11-19 Thread Johannes Berg
On Sun, 2006-11-19 at 08:55 -0800, David Kimdon wrote: ok. I am concerned that making this split between per driver and per card is difficult to get right. Setting or not setting a function pointer for an operation is fairly standard practice and I don't see the value in introducing yet

[BRIDGE] netlink: Convert bridge netlink code to new netlink interface

2006-11-19 Thread Thomas Graf
Removes dependency on buggy rta_buf, fixes a memory corruption bug due to a unvalidated netlink attribute, and simplifies the code. Signed-off-by: Thomas Graf [EMAIL PROTECTED] Index: net-2.6.20/net/bridge/br_netlink.c === ---

Re: [PATCH] d80211: fix scan issues with new ops

2006-11-19 Thread David Kimdon
On Sun, Nov 19, 2006 at 05:57:39PM +0100, Johannes Berg wrote: On Sun, 2006-11-19 at 08:55 -0800, David Kimdon wrote: ok. I am concerned that making this split between per driver and per card is difficult to get right. Setting or not setting a function pointer for an operation is fairly

[Fwd: [Bug 7551] New: Fluctuating and slow network perfomance]

2006-11-19 Thread Stephen Hemminger
---BeginMessage--- http://bugzilla.kernel.org/show_bug.cgi?id=7551 Summary: Fluctuating and slow network perfomance Kernel Version: 2.6.18.x Status: NEW Severity: high Owner: [EMAIL PROTECTED] Submitter: [EMAIL PROTECTED] Most recent

Re: [PATCH] d80211: fix scan issues with new ops

2006-11-19 Thread Johannes Berg
On Sun, 2006-11-19 at 09:25 -0800, David Kimdon wrote: Perhaps that is a split that we do not need? I don't see the problem that 'd80211: split ieee80211_hw' is solving. I do see what it is doing, but maybe I am missing something . . . Oh, I just figured that on 64-bit systems the _ops

Re: [PATCH] fix IGMPV3_EXP() normalization bit shift value

2006-11-19 Thread David Miller
From: David Stevens [EMAIL PROTECTED] Date: Thu, 16 Nov 2006 18:49:30 -0700 The IGMPV3_EXP() macro doesn't correctly shift the normalization bit, so time-out values are longer than they should be. Patch below for viewing and attached for applying. Thanks to Dirk Ooms for finding the problem

[PATCH][Generic netlink]: dont send empty operational attributes

2006-11-19 Thread jamal
This is probably 2.6.19 material (a little annoyance) I am testing using a new mailer - if this patch doesnt look right let me know. cheers, jamal - To unsubscribe from this list: send the line unsubscribe netdev in the body of a message to [EMAIL PROTECTED] More majordomo info at

[PATCH 0/13] move d80211 away from netdev towards wiphy

2006-11-19 Thread Johannes Berg
This is a repost of the whole patchset modified according to various comments. I've folded patches 6, 7 and 8 into one driver API update patch that is smaller than the three combined. Unfortunately, it's still very large. I've also changed the introduction of ieee80211_wiphy, in fact the patch

[PATCH 1/13] d80211: clean up some stupid list and loop code

2006-11-19 Thread Johannes Berg
for (; condition ;)?? Ever heard of while loops? Also clean up some list handling (still. *sigh*) Signed-off-by: Johannes Berg [EMAIL PROTECTED] --- wireless-dev.orig/net/d80211/ieee80211_sta.c2006-11-19 20:13:52.269275208 +0100 +++ wireless-dev/net/d80211/ieee80211_sta.c

[PATCH 2/13] d80211: reduce mdev usage

2006-11-19 Thread Johannes Berg
This patch reduces mdev usage by replacing struct net_device * arguments that are never used except for dereferencing to get struct ieee80211_local from ieee80211_ptr by struct ieee80211_local directly. Signed-off-by: Johannes Berg [EMAIL PROTECTED] --- wireless-dev.orig/net/d80211/ieee80211.c

[PATCH 3/13] d80211: reduce mdev usage

2006-11-19 Thread Johannes Berg
This patch reduces mdev usage by replacing struct net_device * arguments that are never used except for dereferencing to get struct ieee80211_local from ieee80211_ptr by struct ieee80211_local directly. Also removes -master from sub_if_data. Signed-off-by: Johannes Berg [EMAIL PROTECTED] ---

[PATCH 4/13] d80211: reduce mdev usage, change ieee80211_rx_mgmt

2006-11-19 Thread Johannes Berg
This patch reduces mdev usage by replacing struct net_device * arguments that are never used except for dereferencing to get struct ieee80211_local from ieee80211_ptr by struct ieee80211_local directly. Also, this patch changes ieee80211_rx_mgmt to no longer be callable when local-apdev is NULL.

[PATCH 5/13] d80211: reduce master ieee80211_ptr deref in scan routines

2006-11-19 Thread Johannes Berg
This patch changes a bunch of prototypes to have struct ieee80211_local* instead of struct net_device* where that makes sense. Signed-off-by: Johannes Berg [EMAIL PROTECTED] --- wireless-dev.orig/net/d80211/ieee80211.c2006-11-19 20:13:56.719275208 +0100 +++

[PATCH 6/13] d80211: change the identifier netdev to ieee80211_hw

2006-11-19 Thread Johannes Berg
Traditionally, drivers were given a struct net_device * in order to identify the wireless device. This was the master device, but I'm trying to cut down it's use. Now, there long was a comment that this might change. That time has come, this patch gives back a struct ieee80211_hw pointer.

[PATCH 7/13] d80211: add a perm_addr hardware property

2006-11-19 Thread Johannes Berg
After removing knowledge of the master net_dev from drivers, they'll still need a way to tell us which MAC address they have. This is that way, the perm_addr is initially used for all devices. Signed-off-by: Johannes Berg [EMAIL PROTECTED] --- wireless-dev.orig/include/net/d80211.h

[PATCH 9/13] d80211: remove useless driver name field

2006-11-19 Thread Johannes Berg
struct ieee80211_ops has a driver name field that's never used. Remove it. Signed-off-by: Johannes Berg [EMAIL PROTECTED] --- wireless-dev.orig/include/net/d80211.h 2006-11-19 20:14:00.039275208 +0100 +++ wireless-dev/include/net/d80211.h 2006-11-19 20:14:00.639275208 +0100 @@ -531,9

[PATCH 8/13] d80211: introduce IEEE80211_HW_FRAG flag

2006-11-19 Thread Johannes Berg
This introduces the promised IEEE80211_HW_FRAG used to determine whether the hardware can do fragmentation or not. It actually makes sense to split this capability flag out from the function pointer, maybe some hardware wants to be notified about the fragmentation threshold even though it doesn't

[PATCH 11/13] d80211: remove IEEE80211_CONF_SW_{EN,DE}CRYPT

2006-11-19 Thread Johannes Berg
There's no point in trying to tell a driver globally whether sw or hw crypto is used, if it's sw then we just don't give it keys... Besides, these weren't ever used! Remove IEEE80211_CONF_SW_DECRYPT and IEEE80211_CONF_SW_ENCRYPT. Acked-by: Michael Buesch [EMAIL PROTECTED] Signed-off-by: Johannes

[PATCH 13/13] d80211: fix scan issues with new ops

2006-11-19 Thread Johannes Berg
If hardware shall do scanning, the hw_scan operation must be set. However, if the driver is for multiple cards that may or may not do hardware scanning, it'll need a flag. Similar issues arise with passive_scan(). This patch introduces flags to fix these issues. Signed-off-by: Johannes Berg

Re: [PATCH][Generic netlink]: dont send empty operational attributes

2006-11-19 Thread Thomas Graf
* jamal [EMAIL PROTECTED] 2006-11-19 14:22 On 11/19/06, jamal [EMAIL PROTECTED] wrote: This is probably 2.6.19 material (a little annoyance) I am testing using a new mailer - if this patch doesnt look right let me know. Seems like i failed. Ok, heres the patch again.. HTML mail and

Re: [PATCH 10/13] bcm43xx: update to new d80211 driver API

2006-11-19 Thread Johannes Berg
On Sun, 2006-11-19 at 20:43 +0100, Michael Buesch wrote: On Sunday 19 November 2006 20:31, Johannes Berg wrote: --- wireless-dev.orig/drivers/net/wireless/d80211/bcm43xx/bcm43xx_debugfs.c 2006-11-19 20:12:47.629275208 +0100 +++

[PATCH 2/3] [DECnet] address: Rename rtmsg_ifa() to dn_ifaddr_notify()

2006-11-19 Thread Thomas Graf
The name rtmsg_ifa is heavly overused and confusing. Signed-off-by: Thomas Graf [EMAIL PROTECTED] Index: net-2.6.20/net/decnet/dn_dev.c === --- net-2.6.20.orig/net/decnet/dn_dev.c 2006-11-19 18:33:43.0 +0100 +++

[PATCHSET] DECNet address netlink work

2006-11-19 Thread Thomas Graf
First batch of patches to convert the DECNet address code to the new netlink interface. - To unsubscribe from this list: send the line unsubscribe netdev in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html

[PATCH 1/3] [DECnet] address: Calculate accurate message size for netlink notifications

2006-11-19 Thread Thomas Graf
Signed-off-by: Thomas Graf [EMAIL PROTECTED] Index: net-2.6.20/net/decnet/dn_dev.c === --- net-2.6.20.orig/net/decnet/dn_dev.c 2006-11-19 18:31:06.0 +0100 +++ net-2.6.20/net/decnet/dn_dev.c 2006-11-19 18:33:43.0

Re: [PATCH] IPv6: Fix NULL dereference in ipv6_del_addr()

2006-11-19 Thread David Miller
From: Ville Nuorvala [EMAIL PROTECTED] Date: Fri, 17 Nov 2006 21:27:21 +0200 YOSHIFUJI Hideaki wrote: In article [EMAIL PROTECTED] (at Fri, 17 Nov 2006 15:26:28 +0200), Ville Nuorvala [EMAIL PROTECTED] says: - dst_release(rt-u.dst); + if (rt) +

Re: [[PATCH][XFRM]: Sub-policies broke policy events

2006-11-19 Thread David Miller
From: Masahide NAKAMURA [EMAIL PROTECTED] Date: Sat, 18 Nov 2006 17:51:59 +0900 On Fri, 17 Nov 2006 08:34:44 -0500 jamal [EMAIL PROTECTED] wrote: Found the cause of my problems. Dave, this is against Linus tree because it is bug fix. Nakamura-san please ACK. cheers, jamal

Re: [PATCH 0/13] move d80211 away from netdev towards wiphy

2006-11-19 Thread Johannes Berg
Alright, a bit more thought later :) Michael noted that letting people rename their wiphys is probably a good idea to have stable based on the permanent mac address or such. Will actually require moving the perm_addr field from struct ieee80211_hw into struct wiphy (as below) too so that it's

Re: d80211: RFC: divide by zero when hw-maxssi not set

2006-11-19 Thread Dan Williams
On Fri, 2006-11-17 at 15:51 -0800, David Kimdon wrote: Hi, commit 448bf25bc9e3d70a211fdf235426472089371c43 added ieee80211_get_wireless_stats in net/d80211/ieee80211_ioctl.c. At present we get a divide by zero (oops) if the low level driver does not set the new hw-maxssi field. Perhaps:

[PATCH 4/4] atl1: Ancillary C files for Attansic L1 driver

2006-11-19 Thread Jay Cliburn
From: Jay Cliburn [EMAIL PROTECTED] This patch contains auxiliary C files for the Attansic L1 gigabit ethernet adapter driver. Signed-off-by: Jay Cliburn [EMAIL PROTECTED] --- atl1_ethtool.c | 530 +++ atl1_hw.c | 840

Re: [PATCH 2/4] atl1: Header files for Attansic L1 driver

2006-11-19 Thread Jan Engelhardt
On Nov 19 2006 14:30, Jay Cliburn wrote: + +#define LBYTESWAP( a ) ( ( ( (a) 0x00ff00ff ) 8 ) | ( ( (a) 0xff00ff00 ) 8 ) ) +#define LONGSWAP( a ) ( ( LBYTESWAP( a ) 16 ) | ( LBYTESWAP( a ) 16 ) ) +#define SHORTSWAP( a ) ( ( (a) 8 ) | ( (a) 8 ) ) Please use

Re: [PATCH 0/4] atl1: Revised Attansic L1 ethernet driver

2006-11-19 Thread Alan
Would be nice if it used atl_ not at_ so its less likely to cause namespace clashes. You have various macros for swaps that are pretty ugly - we have cpu_to and le/be_to_cpu functions for most swapping cases and these are generally optimised assembler (eg bswap on x86) AT_DESC_USED/UNUSED would

Re: bcm43xx regression 2.6.19rc3 - rc5, rtnl_lock trouble?

2006-11-19 Thread Michael Buesch
On Saturday 18 November 2006 20:02, Larry Finger wrote: Ray Lee wrote: Larry Finger wrote: Johannes Berg wrote: Hah, that's a lot more plausible than bcm43xx's drain patch actually causing this. So maybe somehow interrupts for bcm43xx aren't routed properly or something... Ray,