Hi,
On 6/13/07, Keiichi KII <[EMAIL PROTECTED]> wrote:
[...]
+static DECLARE_MUTEX(netdev_change_sem);
The preferred style these days is to use a DEFINE_MUTEX
(and the struct mutex primitives) for such locks that are used
as binary semaphores.
BTW, a comment here to note what this lock protec
I'm starting to wonder how a multi-queue NIC differs from a bunch of
bonded single-queue NICs, and if there is leverage opportunity there.
rick jones
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at http://v
On Wed, 13 Jun 2007 12:45:21 +0300
Dan Aloni <[EMAIL PROTECTED]> wrote:
> On Mon, May 14, 2007 at 08:58:40AM -0700, Stephen Hemminger wrote:
> > Kenji Kaneshige found this race between device removal and
> > registration. On unregister it is possible for the old device to
> > exist, because sysfs
jamal writes:
> I think the one described by Leonid has not just 8 tx/rx rings but also
> a separate register set, MSI binding etc iirc. The only shared resources
> as far as i understood Leonid are the bus and the ethernet wire.
AFAIK most new NIC will look like this...
I still lack a
On Sat, 2007-06-09 at 20:21 +0400, Vitaly Bordug wrote:
> device_bind_driver() error code returning has been fixed.
> release() function has been written, so that to free resources
> in correct way; the release path is now clean.
>
> Before the rework, it used to cause
> Device '[EMAIL PROTECTED
On Tue, Jun 12, 2007 at 08:04:18PM -0400, Jeff Garzik wrote:
> >
> >>Should I just drop all spidernet patches and start over?
> >
> >No. Apply the series I just sent you, dropping the one called
> >"patch 6/15", the one from Florin Malita, as it appears you'd
> >previously picked this up. The rest
Hi,
On 6/13/07, Keiichi KII <[EMAIL PROTECTED]> wrote:
From: Keiichi KII <[EMAIL PROTECTED]>
This patch contains the following changes.
create a sysfs entry for netconsole in /sys/class/misc.
This entry has elements related to netconsole as follows.
You can change configuration of netconsole(w
Pavel Emelianov wrote:
> Patrick McHardy wrote:
>
>>I'm going to push my latest patches to Dave today, the easiest way is
>>probably is you just add whatever you need to the API afterwards.
>>
>
>
> OK. Dave didn't object against the driver. Hope he will accept it as well.
>
> I have also found
Patrick McHardy wrote:
> Pavel Emelianov wrote:
>> Patrick McHardy wrote:
>>
>>> The question is how to proceed. I haven't read all mails yet, but it
>>> seems there is some disagreement about whether to create all devices
>>> in the same namespace and move them later or create them directly in
>>
Hi Keiichi,
On 6/13/07, Keiichi KII <[EMAIL PROTECTED]> wrote:
+struct netconsole_target {
+ struct list_head list;
+ int id;
+ struct netpoll np;
+};
+
+static LIST_HEAD(target_list);
+static DEFINE_SPINLOCK(target_list_lock);
Some description of the struct netconsole_targe
> -Original Message-
> From: J Hadi Salim [mailto:[EMAIL PROTECTED] On Behalf Of jamal
> For the Leonid-NIC (for lack of better name) it may be harder to do
> parallelization on rcv if you use what i said above. But you could
> use a different model on receive - such as create a single
Hi all,
I've been doing a bit of investigation work into a problem that I've
been experiencing with the latest available r8168 driver from realtek
('r8168-8.001.00') & linux kernel 2.6.21.1.
I have been experiencing wierd problems with slow outbound traffic that
seem to go away if there's t
On Wed, Jun 13, 2007 at 07:25:55PM +0900, Keiichi KII wrote:
> From: Keiichi KII <[EMAIL PROTECTED]>
>
> This patch contains the following cleanups.
> - add __init for initialization functions(option_setup() and
>init_netconsole()).
>
> Acked-by: Matt Mackall <[EMAIL PROTECTED]>
> Signed-off
On 6/13/07, Robert P. J. Day <[EMAIL PROTECTED]> wrote:
[snip]
>
> Does this makes any difference anyway? Both are same eventually?
> What is the rational behind this? Can you please help me
> understanding this?
since this is one of the TO DO items i added to the list of things at
the wiki:
ht
On Tue, 2007-06-12 at 21:54 -0400, Jeff Garzik wrote:
> Michael Ellerman wrote:
> > Linas posted the patches, I responded querying whether the bug fixes
> > should go into 2.6.22, and then you told him "you need to order your bug
> > fixes first in the queue". Which seemed pretty clear to me that y
Wow - Robert in the house, I cant resist i have to say something before
i run out;->
On Wed, 2007-13-06 at 15:12 +0200, Robert Olsson wrote:
> Haven't got all details. IMO we need to support some "bonding-like"
> scenario too. Where one CPU is feeding just one TX-ring. (and TX-buffers
> clea
On Wed, 13 Jun 2007, psr wrote:
> On 6/13/07, Shani Moideen <[EMAIL PROTECTED]> wrote:
> >
> > Replacing alloc_pages(gfp,0) with alloc_page(gfp)
> > in net/core/pktgen.c
> >
> > Signed-off-by: Shani Moideen <[EMAIL PROTECTED]>
> >
> >
> > diff --git a/net/core/pktgen.c b/net/core/pktgen.c
> >
jamal writes:
> The key arguement i make (from day one actually) is to leave the
> majority of the work to the driver.
> My view of wireless WMM etc is it is a different media behavior
> (compared to wired ethernet) which means a different view of strategy
> for when it opens the valve to al
Patrick McHardy wrote:
> Marco Berizzi wrote:
> > Patrick McHardy wrote:
> >
> >>We have some MTU opimiztations in 2.6.22-rc that might be related.
> >>Please check with tcpdump what exactly is happening and whether
> >>the 2.6.22-rc box is sending too large packets.
> >
> >
> > I have done a tcpd
Marco Berizzi wrote:
> Patrick McHardy wrote:
>
>>We have some MTU opimiztations in 2.6.22-rc that might be related.
>>Please check with tcpdump what exactly is happening and whether
>>the 2.6.22-rc box is sending too large packets.
>
>
> I have done a tcpdump capture on the external
> interface
Patrick McHardy wrote:
> Marco Berizzi wrote:
> > Hello everybody.
> > I have just upgraded from 2.6.21.3 to
> > 2.6.22-rc4 and I get a ton of
> > pmtu discovery on sa esp/blablab/blabla
> > messages (this box is running openswan).
> > Is this an expected behaviour?
>
>
> We have some MTU opimizta
On Wed, 2007-13-06 at 13:56 +0800, Zhu Yi wrote:
> The key argument for Jamal's solution is the NIC will send out 32
> packets in the full PHL in a reasonably short time (a few microsecs per
> Jamal's calculation). But for wireless, the PHL hardware has low
> probability to seize the wireless medi
Am Mittwoch, 13. Juni 2007 schrieb Patrick McHardy:
> Oliver Neukum wrote:
> > Am Mittwoch, 13. Juni 2007 schrieb Patrick McHardy:
>
> This can happen if the initial inetdev allocation when the netdevice is
> registered fails. I think it would make sense to try to allocate again
>
Zhu Yi wrote:
> On Tue, 2007-06-12 at 23:17 +0200, Patrick McHardy wrote:
>
>>I've hacked up a
>>small multiqueue simulator device and to my big surprise my testing
>>showed that Jamal's suggestion of using a single queue state seems to
>>work better than I expected. But I've been doing mostly tes
Oliver Neukum wrote:
> Am Mittwoch, 13. Juni 2007 schrieb Patrick McHardy:
This can happen if the initial inetdev allocation when the netdevice is
registered fails. I think it would make sense to try to allocate again
when adding addresses in that case, otherwise there is no way of
Am Mittwoch, 13. Juni 2007 schrieb Patrick McHardy:
> Oliver Neukum wrote:
> > Am Dienstag, 12. Juni 2007 schrieb Patrick McHardy:
> >
> >>Oliver Neukum wrote:
> >>
> >>>with 2.6.22-rc4-git2 I am getting errors when setting IP for ethernet
> >>>interfaces:
> >>>
> >>>ioctl(4, SIOCSIFADDR, 0x7fff94
Oliver Neukum wrote:
> Am Dienstag, 12. Juni 2007 schrieb Patrick McHardy:
>
>>Oliver Neukum wrote:
>>
>>>with 2.6.22-rc4-git2 I am getting errors when setting IP for ethernet
>>>interfaces:
>>>
>>>ioctl(4, SIOCSIFADDR, 0x7fff94931600) = -1 ENOBUFS (No buffer space
>>>available)
>>>
>>>The erro
Pavel Emelianov wrote:
> Patrick McHardy wrote:
>
>>The question is how to proceed. I haven't read all mails yet, but it
>>seems there is some disagreement about whether to create all devices
>>in the same namespace and move them later or create them directly in
>
>
> The agreement was that we c
From: Keiichi KII <[EMAIL PROTECTED]>
We add ioctls for adding/removing target.
If we use NETCONSOLE_ADD_TARGET ioctl,
we can dynamically add netconsole target.
If we use NETCONSOLE_REMOVE_TARGET ioctl,
we can dynamically remoe netconsole target.
We attach a sample program for ioctl.
Signed-off
From: Keiichi KII <[EMAIL PROTECTED]>
update Documentation/networking/netconsole.txt
- how to use sysfs for dynamic configurability
- how to use ioctl for dynamic configurability
Signed-off-by: Keiichi KII <[EMAIL PROTECTED]>
---
Index: mm/Documentation/networking/netconsole.txt
===
From: Keiichi KII <[EMAIL PROTECTED]>
This patch contains switch function of netpoll.
If "enabled" attribute of certain port is '1', this port is used
and the configurations of this port are unable to change.
If "enabled" attribute of certain port is '0', this port isn't used
and the configurati
From: Keiichi KII <[EMAIL PROTECTED]>
We use symbolic link for net_device.
The link in sysfs represents the corresponding network etherdevice.
-+- /sys/class/misc/
|-+- netconsole/
|-+- port1/
| |--- id [r--r--r--] id
| |--- net: [r--r--r--] net_dev: eth0,eth1,...
| ...
|---
From: Keiichi KII <[EMAIL PROTECTED]>
This patch contains the following changes for supporting multiple logging
agents.
1. extend netconsole to multiple netpolls
To send kernel messages to multiple logging agents, extend netcosnole
to be able to use multiple netpolls. Each netpoll sends k
From: Keiichi KII <[EMAIL PROTECTED]>
This patch contains the following changes.
create a sysfs entry for netconsole in /sys/class/misc.
This entry has elements related to netconsole as follows.
You can change configuration of netconsole(writable attributes such as IP
address, port number and so
From: Keiichi KII <[EMAIL PROTECTED]>
This patch contains the following cleanups.
- add __init for initialization functions(option_setup() and
init_netconsole()).
Acked-by: Matt Mackall <[EMAIL PROTECTED]>
Signed-off-by: Keiichi KII <[EMAIL PROTECTED]>
Signed-off-by: Takayoshi Kochi <[EMAIL P
From: Keiichi KII <[EMAIL PROTECTED]>
The netconsole is a very useful module for collecting kernel message under
certain circumstances(e.g. disk logging fails, serial port is unavailable).
But current netconsole is not flexible. For example, if you want to change ip
address for logging agent, in
On Mon, May 14, 2007 at 08:58:40AM -0700, Stephen Hemminger wrote:
> Kenji Kaneshige found this race between device removal and
> registration. On unregister it is possible for the old device to
> exist, because sysfs file is still open. A new device with 'eth%d'
> will select the same name, but
On 6/13/07, Shani Moideen <[EMAIL PROTECTED]> wrote:
Replacing alloc_pages(gfp,0) with alloc_page(gfp)
in net/core/pktgen.c
Signed-off-by: Shani Moideen <[EMAIL PROTECTED]>
diff --git a/net/core/pktgen.c b/net/core/pktgen.c
index b92a322..2600c7f 100644
--- a/net/core/pktgen.c
+++ b/net/c
On Tue, Jun 12, 2007 at 01:02:33PM +0200, Jarek Poplawski wrote:
...
> Of course such a problem should preferably be fixed by somebody who
> knows the code (alas I don't know netconsole), to be sure all needed
> cancels are still done after this change. I hope Jason's patch is
> right but I'm a lit
Patrick McHardy wrote:
> Pavel Emelianov wrote:
>> Patrick McHardy wrote:
>>
>
+ skb->pkt_type = PACKET_HOST;
+ skb->protocol = eth_type_trans(skb, rcv);
+ if (dev->features & NETIF_F_NO_CSUM)
+ skb->ip_summed = rcv_priv->ip_summed;
+
+ dst_release(skb->d
Am Dienstag, 12. Juni 2007 schrieb Patrick McHardy:
> Oliver Neukum wrote:
> > with 2.6.22-rc4-git2 I am getting errors when setting IP for ethernet
> > interfaces:
> >
> > ioctl(4, SIOCSIFADDR, 0x7fff94931600) = -1 ENOBUFS (No buffer space
> > available)
> >
> > The error is independant of th
Hi David,
On Wed, 13 Jun 2007 00:03:59 -0700 (PDT)
David Miller <[EMAIL PROTECTED]> wrote:
> From: MOKUNO Masakazu <[EMAIL PROTECTED]>
> Date: Wed, 13 Jun 2007 15:58:01 +0900
>
> > --- a/drivers/net/Makefile
> > +++ b/drivers/net/Makefile
> > @@ -60,6 +60,8 @@ obj-$(CONFIG_TIGON3) += tg3.o
> >
- netif_queue_stopped need not be called inside qdisc_restart as
it has been called already in qdisc_run() before the first skb
is sent, and in __qdisc_run() after each intermediate skb is
sent (note : we are the only sender, so the queue cannot get
stopped while the tx lock was got in the
- Converted to use switch/case code which looks neater.
- "if (ret == NETDEV_TX_LOCKED && lockless)" is buggy, and the lockless
check should be removed, since driver will return NETDEV_TX_LOCKED only
if lockless is true and driver has to do the locking. In the original
code as well as the la
Hi Dave,
I am splitting this patch to two, to differentiate between readability
changes (plus a bug fix) and optimization changes.
Please review.
Thanks,
- KK
--
I am sorry to miss out during Jamal's original effort to make q
On Tue, Jun 12, 2007 at 08:17:32PM +0200, Jens Axboe ([EMAIL PROTECTED]) wrote:
> On Tue, Jun 12 2007, Evgeniy Polyakov wrote:
> > On Mon, Jun 11, 2007 at 01:59:26PM +0200, Jens Axboe ([EMAIL PROTECTED])
> > wrote:
> > > Patches are against the #splice branch of the block repo, "official" url
> >
From: Bill Fink <[EMAIL PROTECTED]>
Date: Tue, 12 Jun 2007 23:38:14 -0400
> If there was a benefit, perhaps it would be useful to have a
> per-route option for setting the initial_ssthresh.
We have this per-route setting already, BIC and CUBIC just override it
with their local initial_ssthresh va
On Wednesday 13 June 2007 10:18, Dhananjay Phadke wrote:
> Mithlesh,
>
> You don't initialize max_mc_count anywhere. The multicast address pool
> can hold 16 addresses for ports {0,1} and 4 for ports {2,3}. You should
> have following line in the probe routine.
>
> > adapter->max_mc_count = (adapte
From: MOKUNO Masakazu <[EMAIL PROTECTED]>
Date: Wed, 13 Jun 2007 15:58:01 +0900
> --- a/drivers/net/Makefile
> +++ b/drivers/net/Makefile
> @@ -60,6 +60,8 @@ obj-$(CONFIG_TIGON3) += tg3.o
> obj-$(CONFIG_BNX2) += bnx2.o
> spidernet-y += spider_net.o spider_net_ethtool.o
> obj-$(CONFIG_SPIDER_NET
101 - 149 of 149 matches
Mail list logo