Re: [Numpy-discussion] Name change of the ptp() function

2013-05-10 Thread Eli Bressert
better as it is more readable. If valuerange() is not an acceptable name, maybe span()? -Eli On Fri, May 10, 2013 at 10:44 PM, Pauli Virtanen p...@iki.fi wrote: 10.05.2013 08:47, Eli Bressert kirjoitti: [clip: renaming ptp] valuerange() appears to the best most favored one. range(), arange

[Numpy-discussion] Astype and strings

2009-10-26 Thread Eli Bressert
Hi Everyone, Is Numpy supposed to behave this like this when converting an array of numbers to an array of strings with astype? print(arange(20).astype(np.str)) ['0' '1' '2' '3' '4' '5' '6' '7' '8' '9' '1' '1' '1' '1' '1' '1' '1' '1' '1' '1'] When I do the following it works fine,

[Numpy-discussion] Are masked arrays slower for processing than ndarrays?

2009-05-09 Thread Eli Bressert
? Thanks, Eli Bressert ___ Numpy-discussion mailing list Numpy-discussion@scipy.org http://mail.scipy.org/mailman/listinfo/numpy-discussion

[Numpy-discussion] accuracy issues with numpy arrays?

2008-04-29 Thread eli bressert
Hi, I'm writing a quick script to import a fits (astronomy) image that has very low values for each pixel. Mostly on the order of 10^-9. I have written a python script that attempts to take low values and put them in integer format. I basically do this by taking the mean of the 1000 lowest pixel