[openib-general] [PATCH] SDP: use container_of in place of cast to sdp_opt

2005-06-20 Thread Michael S. Tsirkin
Here's a patch to replace explicit cast to sdp_opt with container_of, removing assumptions on structure layout. As a side note, wouldnt sk_to_sdp and sdp_to_sk be better names for sdp_sk and sk_sdp? --- Use container_of in place of cast to sdp_opt. Signed-off-by: Michael S. Tsirkin <[EMAIL PROTE

Re: [openib-general] mapping between IP address and device name

2005-06-20 Thread Libor Michalek
On Mon, Jun 20, 2005 at 08:40:47PM -0700, Roland Dreier wrote: > Kevin> Maybe somebody could help me understand the proper way to > Kevin> map between an IP address assigned to a port to the "device > Kevin> name" and "port number" in the gen2 architecture. If I > Kevin> have an IP

[openib-general] Re: [PATCHv7] SDP: make SDP buildable on 2.6.12-final

2005-06-20 Thread Libor Michalek
On Mon, Jun 20, 2005 at 11:06:12AM -0700, Tom Duffy wrote: > Here is the updated patch based off r2663 and building off of 2.6.12. > > Signed-off-by: Tom Duffy <[EMAIL PROTECTED]> Thanks a lot Tom for tracking the changes this whole time. Committed revision 2665. -Libor _

Re: [openib-general] mapping between IP address and device name

2005-06-20 Thread Roland Dreier
Kevin> Maybe somebody could help me understand the proper way to Kevin> map between an IP address assigned to a port to the "device Kevin> name" and "port number" in the gen2 architecture. If I Kevin> have an IP address can I map it to a name that i get back Kevin> from ibv_get

[openib-general] mapping between IP address and device name

2005-06-20 Thread Kevin Reilly
Maybe somebody could help me understand the proper way to map between an IP address assigned to a port to the "device name" and "port number" in the gen2 architecture. If I have an IP address can I map it to a name that i get back from ibv_get_device_name() or pass to ibv_open_device().

Re: [openib-general] CQ completion handler context

2005-06-20 Thread Roland Dreier
Andrei> In what context CQ completion handler is called? I'm Andrei> talking about kernel module using ib verbs. In general you should assume it is called from an unknown context. The current mthca driver calls it from interrupt context, but future drivers might use softirq or even process

[openib-general] CQ completion handler context

2005-06-20 Thread Andrei Petrov
In what context CQ completion handler is called? I'm talking about kernel module using ib verbs. Thanks, ___ openib-general mailing list openib-general@openib.org http://openib.org/mailman/listinfo/openib-general To unsubscribe, please visit http://open

Re: [openib-general] ib_post_recv buffer re-use

2005-06-20 Thread Andrei Petrov
On Mon, Jun 20, 2005 at 02:19:16PM -0700, Grant Grundler wrote: > On Mon, Jun 20, 2005 at 01:06:24PM -0700, Andrei Petrov wrote: > > Application I'm working on needs to receive and process messages > > from RQ, so I dma_map and ib_post_recv pool of buffers. > > Then after I receive a message I pla

Re: [openib-general] ib_post_recv buffer re-use

2005-06-20 Thread Andrei Petrov
On Mon, Jun 20, 2005 at 02:19:34PM -0700, Roland Dreier wrote: > Andrei> Application I'm working on needs to receive and process > Andrei> messages from RQ, so I dma_map and ib_post_recv pool of > Andrei> buffers. Then after I receive a message I plan to reuse > Andrei> already mapp

Re: [openib-general] [PATCH] OpenSM: Set retries to 0 if RMPP

2005-06-20 Thread Tom Duffy
On Tue, 2005-06-07 at 19:27 -0400, Hal Rosenstock wrote: > I didn't try broadcast but the limited broadcast (192.168.0.255_ and it > worked. Does it for you ? I will try this next time. Not sure this is an > OpenSM issue. This wasn't an opensm issue. I have apparently gotten used to Linux where i

[openib-general] Re: [PATCH] rdma_lat-09 and results

2005-06-20 Thread Michael S. Tsirkin
Quoting r. Grant Grundler <[EMAIL PROTECTED]>: > Subject: Re: [PATCH] rdma_lat-09 and results > > On Thu, Jun 16, 2005 at 12:53:34AM +0300, Michael S. Tsirkin wrote: > > Quoting r. Grant Grundler <[EMAIL PROTECTED]>: > > > 2) I working towards making the server side a daemon. > > > > I dont see t

Re: [openib-general] ib_post_recv buffer re-use

2005-06-20 Thread Roland Dreier
Andrei> Application I'm working on needs to receive and process Andrei> messages from RQ, so I dma_map and ib_post_recv pool of Andrei> buffers. Then after I receive a message I plan to reuse Andrei> already mapped buffer for consequent ib_post_recv. Is that Andrei> safe? Should

Re: [openib-general] ib_post_recv buffer re-use

2005-06-20 Thread Grant Grundler
On Mon, Jun 20, 2005 at 01:06:24PM -0700, Andrei Petrov wrote: > Application I'm working on needs to receive and process messages > from RQ, so I dma_map and ib_post_recv pool of buffers. > Then after I receive a message I plan to reuse already mapped > buffer for consequent ib_post_recv. Is that

Re: [openib-general] [PATCH] ipoib tune rx ring size

2005-06-20 Thread Grant Grundler
On Mon, Jun 20, 2005 at 03:52:11PM -0400, William Jordan wrote: > When receiving UDP traffic on a slow host (no user level end to end > flow control), you can improve receive throughput by reducing the > number of outstanding receives. The CPU can be saturated receiving > packets which are overflow

Re: [openib-general] SDP on 2.6.12

2005-06-20 Thread Tom Duffy
On Mon, 2005-06-20 at 13:22 -0700, Johann George wrote: > SDP does not compile on the 2.6.12 kernel. It references sk_debug, > sk_localroute and sk_rcvtstamp which are no longer defined in sock.h. > (Using SVN 2663). Yup. Please see my patch. -tduffy signature.asc Description: This is a digit

[openib-general] Re: [PATCH] ipoib tune rx ring size

2005-06-20 Thread Michael S. Tsirkin
Quoting r. William Jordan <[EMAIL PROTECTED]>: > Subject: Re: [PATCH] ipoib tune rx ring size > > On 6/20/05, Grant Grundler <[EMAIL PROTECTED]> wrote: > > On Mon, Jun 20, 2005 at 06:14:04PM +0300, Michael S. Tsirkin wrote: > > > Reducing the rx ring size gives me bandwidth win of about 1%. > > >

[openib-general] SDP on 2.6.12

2005-06-20 Thread Johann George
SDP does not compile on the 2.6.12 kernel. It references sk_debug, sk_localroute and sk_rcvtstamp which are no longer defined in sock.h. (Using SVN 2663). Johann ___ openib-general mailing list openib-general@openib.org http://openib.org/mailman/listinf

[openib-general] ib_post_recv buffer re-use

2005-06-20 Thread Andrei Petrov
Application I'm working on needs to receive and process messages from RQ, so I dma_map and ib_post_recv pool of buffers. Then after I receive a message I plan to reuse already mapped buffer for consequent ib_post_recv. Is that safe? Should I worry about dma syncronisation? Thanks, __

Re: [openib-general] [PATCH] ipoib tune rx ring size

2005-06-20 Thread William Jordan
On 6/20/05, Grant Grundler <[EMAIL PROTECTED]> wrote: > On Mon, Jun 20, 2005 at 06:14:04PM +0300, Michael S. Tsirkin wrote: > > Reducing the rx ring size gives me bandwidth win of about 1%. > > Michael, > Doesn't this sound counter-intuitive to you? > > Can you share which configuration (chipset,

[openib-general] Re: [PATCHv7] SDP: make SDP buildable on 2.6.12-final

2005-06-20 Thread Tom Duffy
On Mon, 2005-06-20 at 11:28 -0700, Libor Michalek wrote: > Looks good, but I do have one question, why did you move the clearing > of 'struct sock' from 'struct socket' to the end of the function? > Specifically if we are waiting on linger during the release I don't > think we want sock to have an

[openib-general] Re: [PATCHv7] SDP: make SDP buildable on 2.6.12-final

2005-06-20 Thread Libor Michalek
On Mon, Jun 20, 2005 at 11:06:12AM -0700, Tom Duffy wrote: > Here is the updated patch based off r2663 and building off of 2.6.12. > > Index: linux-2.6.12-openib/drivers/infiniband/ulp/sdp/sdp_inet.c > === > --- linux-2.6.12-openib/dri

Re: [openib-general] [PATCH] OpenSM: Set retries to 0 if RMPP

2005-06-20 Thread Tom Duffy
On Mon, 2005-06-20 at 13:11 -0400, Hal Rosenstock wrote: > > Nevermind. Just tried it with Solaris Nevada build 16 and it works > > too! > > What's Nevada ? Sorry, that is the code name for Solaris 11, also what OpenSolaris is based off of. > Can you retry with the latest and greatest (both

[openib-general] [PATCHv7] SDP: make SDP buildable on 2.6.12-final

2005-06-20 Thread Tom Duffy
Here is the updated patch based off r2663 and building off of 2.6.12. Signed-off-by: Tom Duffy <[EMAIL PROTECTED]> Index: linux-2.6.12-openib/drivers/infiniband/ulp/sdp/sdp_rcvd.c === --- linux-2.6.12-openib/drivers/infiniband/ulp/sd

Re: [openib-general] [PATCH] OpenSM: Set retries to 0 if RMPP

2005-06-20 Thread Hal Rosenstock
Hi Tom, On Tue, 2005-06-07 at 18:37, Tom Duffy wrote: > On Tue, 2005-06-07 at 15:21 -0700, Tom Duffy wrote: > > On Tue, 2005-06-07 at 18:12 -0400, Hal Rosenstock wrote: > > > With this change, able to interoperate with Solaris 10 SA client (which > > > uses RMPP) with OpenSM > > > > Cool. I will

[openib-general] Re: [PATCH] [RMPP] fix handling of duplicate RMPP ACK

2005-06-20 Thread Hal Rosenstock
Hi Sean, On Tue, 2005-06-07 at 17:58, Sean Hefty wrote: > Hal, can you test this and see if it corrects the problems that you were > seeing on the SA side? Just tried this with Solaris 10 and it works fine either way. The problem I was having appeared related but was separate from this and has s

RE: [openib-general] [PATCH][kdapl] Small changes in dapl_hca_all oc/dapl_hca_free functions

2005-06-20 Thread Tom Duffy
On Mon, 2005-06-20 at 20:00 +0300, Itamar Rabenstein wrote: > Hi Tom, > I was just copied to original code from dapl_os_strdup() to > dapl_hca_alloc(). > so if it is a problem is it was there in the code before my patch. > But why do you think we need strncpy and not strcpy ? > name param is null t

RE: [openib-general] [PATCH][kdapl] Small changes in dapl_hca_all oc/dapl_hca_free functions

2005-06-20 Thread Itamar Rabenstein
Hi Tom, I was just copied to original code from dapl_os_strdup() to dapl_hca_alloc(). so if it is a problem is it was there in the code before my patch. But why do you think we need strncpy and not strcpy ? name param is null terminated string. Itamar > -Original Message- > From: Tom Duf

Re: [openib-general] [PATCH] ipoib tune rx ring size

2005-06-20 Thread Grant Grundler
On Mon, Jun 20, 2005 at 06:14:04PM +0300, Michael S. Tsirkin wrote: > Reducing the rx ring size gives me bandwidth win of about 1%. Michael, Doesn't this sound counter-intuitive to you? Can you share which configuration (chipset, CPU, IO bus, HCA) you measured this on? I've also seen this to be

Re: [openib-general] Re: [PATCH] mthca: add copyright statements

2005-06-20 Thread Grant Grundler
On Sun, Jun 19, 2005 at 12:13:41PM -0700, Roland Dreier wrote: > > + * Copyright (c) 2005 Mellanox Technologies (Michael S. Tsirkin). > > I believe you want to include the statement "All rights reserved." > Also, who is the copyright holder -- MST as an individual or Mellanox > Technologies?

[openib-general] Re: [PATCH] rdma_lat-09 and results

2005-06-20 Thread Grant Grundler
On Thu, Jun 16, 2005 at 12:53:34AM +0300, Michael S. Tsirkin wrote: > Quoting r. Grant Grundler <[EMAIL PROTECTED]>: > > 2) I working towards making the server side a daemon. > > I dont see this necessarily as an improvement. > I'm happy running server and client with ssh from a script > with mult

[openib-general] [PATCH] ipoib tune rx ring size

2005-06-20 Thread Michael S. Tsirkin
Reducing the rx ring size gives me bandwidth win of about 1%. Signed-off-by: Michael S. Tsirkin <[EMAIL PROTECTED]> Index: ulp/ipoib/ipoib.h === --- ulp/ipoib/ipoib.h (revision 2656) +++ ulp/ipoib/ipoib.h (working copy) @@ -62,7

Re: [openib-general] [PATCH][kdapl] Small changes in dapl_hca_alloc/dapl_hca_free functions

2005-06-20 Thread Tom Duffy
On 6/20/05, Itamar Rabenstein <[EMAIL PROTECTED]> wrote: > Small changes in dapl_hca_alloc/dapl_hca_free function > > Signed-off-by: Itamar Rabenstein <[EMAIL PROTECTED]> > > diff -Nurp -X dontdiff dat-provider_hash/dapl_hca_util.c > dat-provider/dapl_hca_util.c > --- dat-provider_hash/dapl_hca_

[openib-general] [PATCH][kdapl] Integrate dapl_hca_alloc/dapl_hca_free to dapl_provider.c

2005-06-20 Thread Itamar Rabenstein
ntegrate dapl_hca_alloc/dapl_hca_free to dapl_provider.c (no need for 2 files just for 2 simple function that kmalloc and kfree. There is not any special logic in this functions that need to separate them into different files) Signed-off-by: Itamar Rabenstein <[EMAIL PROTECTED]> diff -Nurp -X d

[openib-general] [PATCH][kdapl] Integrate dapl_hca_link_ia/dapl_hca_unlink_ia into dapl_ia.c

2005-06-20 Thread Itamar Rabenstein
Integrate dapl_hca_link_ia/dapl_hca_unlink_ia into dapl_ia.c (no need for functions that just call LIST_ADD and LIST_DEL) Signed-off-by: Itamar Rabenstein <[EMAIL PROTECTED]> diff -Nurp -X dontdiff dat-provider_simp/dapl_hca_util.c dat-provider/dapl_hca_util.c --- dat-provider_simp/dapl_hca_util

[openib-general] [PATCH][kdapl] Small changes in dapl_hca_alloc/dapl_hca_free functions

2005-06-20 Thread Itamar Rabenstein
Small changes in dapl_hca_alloc/dapl_hca_free function Signed-off-by: Itamar Rabenstein <[EMAIL PROTECTED]> diff -Nurp -X dontdiff dat-provider_hash/dapl_hca_util.c dat-provider/dapl_hca_util.c --- dat-provider_hash/dapl_hca_util.c Sun Jun 19 16:12:55 2005 +++ dat-provider/dapl_hca_util.c

[openib-general] [PATCH][kdapl] Remove dapl_hash (there is no need for the hash)

2005-06-20 Thread Itamar Rabenstein
Remove dapl_hash (there is no need for the hash) Signed-off-by: Itamar Rabenstein <[EMAIL PROTECTED]> diff -Nurp -X dontdiff dat-provider_bind/Makefile dat-provider/Makefile --- dat-provider_bind/Makefile Sun Jun 19 15:17:54 2005 +++ dat-provider/Makefile Sun Jun 19 15:24:03 2005 @@ -20,7

[openib-general] [PATCH][kdapl] Update dat_rmr_bind API

2005-06-20 Thread Itamar Rabenstein
Update dat_rmr_bind function API (added lmr_handle as input param) Signed-off-by: Itamar Rabenstein <[EMAIL PROTECTED]> Index: test/dapltest/test/dapl_bpool.c === --- test/dapltest/test/dapl_bpool.c (revision 2656) +++ test/daplt

RE: [openib-general] Re: [PATCH][kdapl]update dat_rmr_bind API & delete dapl_hash

2005-06-20 Thread Itamar Rabenstein
O.K i am resending this patch and spliting it to 5 small patches 1. Update dat_rmr_bind API (added lmr_handle input param) 2. Remove dapl_hash (there is no need for the hash) 3. Small changes in dapl_hca_alloc/dapl_hca_free functions 4. Integrate dapl_hca_link_ia/dapl_hca_unlink_ia into dapl_ia.c