Re: In defense of zero-indexed arrays.

2002-12-06 Thread Damien Neil
On Thu, Dec 05, 2002 at 02:45:39AM -0800, Michael G Schwern wrote: > Explain how having indexes (arrays, substr, etc...) in Perl 6 start at 0 > will benefit most users. Do not invoke legacy. [1] Answer 1: Ignoring legacy, it won't. Answer 2: Because C uses 0-based indexes, Parrot is written in C

Re: Loop controls

2002-05-02 Thread Damien Neil
On Wednesday, May 1, 2002, at 02:27 PM, Aaron Sherman wrote: > unless my $fh = $x.open { > die "Cannot open $x: $!"; > } else while $fh.getline -> $_ { > print; > } else { > die "No lines to read in $x"; > } I think you need a bet

Re: Some Apocalypse 4 exception handling questions.

2002-01-24 Thread Damien Neil
On Wed, Jan 23, 2002 at 06:00:21PM -0500, Melvin Smith wrote: > >final and private are completely different concepts as I understand > >them. > > I wouldn't say "completely different". They are both used for "enforcement" > of similar means, but you are correct, they are different. I view "final

Re: finalization

2001-08-28 Thread Damien Neil
On Tue, Aug 28, 2001 at 09:07:03PM -0400, Sam Tregar wrote: > Well, there's the Perl 5 reference counting solution. In normal cases > DESTROY is called as soon as it can be. Of course we're all anxious to > get into the leaky GC boat with Java and C# because we've heard it's > faster. I wonder

Re: Expunge implicit @_ passing

2001-08-28 Thread Damien Neil
On Tue, Aug 28, 2001 at 05:23:46PM -0700, David Whipp wrote: > The only good justification I've heard for "final" is as a directive > for optimization. If you declare a variable to be of a final type, then > the compiler (JIT, or whatever) can resolve method dispatch at > compile-time. If it is no

Re: Expunge implicit @_ passing

2001-08-28 Thread Damien Neil
On Tue, Aug 28, 2001 at 09:13:25AM -0400, Michael G Schwern wrote: > As the pendulum swings in the other direction you get mind-bogglingly > silly things like finalize which I just learned of today. What's so silly about finalize? It's pretty much identical to Perl's DESTROY. (Except that Java'

Re: Anyone actually experienced with object inheritance?

2001-07-02 Thread Damien Neil
On Mon, Jul 02, 2001 at 12:59:51PM -0700, David Whipp wrote: > Its not quite the same thing, but Java does have the concept of > anonymous classes (it names them 'inner' classes): Is Perl6 going > to have a similar concept? Inner classes and anonymous classes are actually different in Java. (Anon

Re: Properties and stricture

2001-06-05 Thread Damien Neil
On Tue, Jun 05, 2001 at 11:14:29PM +0100, Michael G Schwern wrote: > my $meth = "foo"; > $obj->$meth(); # $obj->foo(); > > I'm probably using the wrong terms. > > This definately can't work if $obj is of a class which is strongly > typed. You would do that in Java by using reflection.

Re: a modest proposal Re: s/./~/g

2001-04-27 Thread Damien Neil
On Thu, Apr 26, 2001 at 04:46:48PM -0700, Larry Wall wrote: > And I'm tired of hearing the argument that Perl programmers can't get > used to a different operator for concatenation. I know better--after > all, Perl is probably what got them used to . in the first place. If > you can teach dogs t

Re: a modest proposal Re: s/./~/g

2001-04-25 Thread Damien Neil
On Wed, Apr 25, 2001 at 06:19:40PM +, Fred Heutte wrote: > Yes, I know ~ is the bitwise negation operator. Have you EVER used it? Today, in fact: fcntl($fh, F_SETFL, $flags & ~O_NONBLOCK) or die "fcntl: $!"; - Damien

Re: Tying & Overloading

2001-04-24 Thread Damien Neil
On Mon, Apr 23, 2001 at 11:31:18AM -0700, Larry Wall wrote: > There are many people who would prefer . to ->, if for no other reason > than it's cleaner looking and is one less character to type. The fact > that it's become the industry standard for method call syntax is also > a point in its fav

Re: RFC 357 (v1) Perl should use XML for documentation instead of POD

2000-10-04 Thread Damien Neil
On Wed, Oct 04, 2000 at 03:15:22AM -0600, Tom Christiansen wrote: > >POD, presumably. Or maybe son-of-POD; it would be nice to have better > >support for tables and lists. > > We did this for the camel. Which, I remind the world, was > written in pod. What kinds of things got added for the c

Re: RFC 357 (v1) Perl should use XML for documentation instead of POD

2000-10-03 Thread Damien Neil
On Tue, Oct 03, 2000 at 03:42:49PM +0100, Graham Barr wrote: > On Mon, Oct 02, 2000 at 12:58:37PM -0700, Damien Neil wrote: > > What? I don't think people should be writing either XML or HTML > > as the source documentation format. I said that, quite clearly. > > T

Re: RFC 357 (v1) Perl should use XML for documentation instead of POD

2000-10-02 Thread Damien Neil
On Mon, Oct 02, 2000 at 01:24:37PM -0600, Tom Christiansen wrote: > >XML is intrinsically no more or less difficult to write than HTML. > > Wrong. I beg your pardon? > >Comparing XML to HTML is pointless, however; they are not the same > >thing. > > Wrong. And you only say that because you

Re: RFC 357 (v1) Perl should use XML for documentation instead of POD

2000-10-02 Thread Damien Neil
On Mon, Oct 02, 2000 at 09:21:51AM -0700, Glenn Linderman wrote: > Indeed, this is the key problem with human use of XML. HTML was originally > simple enough to be human writable, its later, more powerful incarnations > start losing that (but you can always use a subset for simple things, and > X

Re: RFC 357 (v1) Perl should use XML for documentation instead of POD

2000-10-01 Thread Damien Neil
On Sun, Oct 01, 2000 at 03:39:51PM -0400, Adam Turoff wrote: > I think POD's list handling is full of warts, but what follows > is much better than HTML/DocBook itemized lists: For me, they're about the same. Actually, I'd rather read an XHTML/HTML itemized list than a POD one; they both look ug

Re: RFC 328 (v2) Single quotes don't interpolate \' and \\

2000-09-30 Thread Damien Neil
On Fri, Sep 29, 2000 at 07:24:38PM -0400, Dan Sugalski wrote: > > $foo = """Things like ', ", and \ have no special meaning in here."""; > > Argh! *NO*! That way lies madness, or at least DCL's quoting mania. My > record, in a command procedure that wrote other command procedures that > submi

Re: RFC 328 (v2) Single quotes don't interpolate \' and \\

2000-09-29 Thread Damien Neil
On Fri, Sep 29, 2000 at 09:20:23PM -, Perl6 RFC Librarian wrote: > Single quotes don't interpolate \' and \\ I rather like the Python triple-quote mechanism used for this purpose: $foo = """Things like ', ", and \ have no special meaning in here."""; Of course, this doesn't help if you wa

Re: RFC 263 (v1) Add null() keyword and fundamental data type

2000-09-20 Thread Damien Neil
On Wed, Sep 20, 2000 at 02:47:01PM -0600, Tom Christiansen wrote: > In Perl, this is the null character: "\0" ... > It's a shame you don't like it, but this is the way we speak. Well, it's the way you speak. Myself, I'd call that the NUL character. :> - Damien, exercising a pet pe

Re: RFC 263 (v1) Add null() keyword and fundamental data type

2000-09-20 Thread Damien Neil
On Wed, Sep 20, 2000 at 01:21:52PM -0700, Russ Allbery wrote: > No offense to Damian, but I tried to read and understand his documentation > and I thought I was back in grad school. I don't think it's the fault of > the writing either; I think that Quantum::Superpositions is trying to do > someth

Re: RFC 263 (v1) Add null() keyword and fundamental data type

2000-09-20 Thread Damien Neil
On Wed, Sep 20, 2000 at 11:58:08AM -0700, Glenn Linderman wrote: > > I think that this is better done as a special overloaded object used > > by database modules which wish to implement SQL-style tri-state logic. > > It could be done as an overloaded object. You'd have to be able to overload all

Re: RFC 263 (v1) Add null() keyword and fundamental data type

2000-09-20 Thread Damien Neil
On Wed, Sep 20, 2000 at 04:12:09AM -, Perl6 RFC Librarian wrote: > Add null() keyword and fundamental data type I think that this is better done as a special overloaded object used by database modules which wish to implement SQL-style tri-state logic. Given that making overloaded objects fast

Re: RFC 76 (v2) Builtin: reduce

2000-09-19 Thread Damien Neil
On Tue, Sep 19, 2000 at 08:14:24PM -0600, Tom Christiansen wrote: > >Following Glenn's lead, I'm in the process of RFC'ing a new null() > >keyword and value > > As though one were not already drowning in a surfeit of subtly > dissimilar false values. Hear, hear. Three-valued logic is enough.

Re: $a in @b

2000-09-07 Thread Damien Neil
On Fri, Sep 08, 2000 at 09:45:54AM +1100, Damian Conway wrote: > I would propose that the C operation should short-circuit if the > block throws an exception, with the value of the expection determining > whether the final invocation of the block should accept the element it > was filtering: I do

Re: RFC 109 (v1) Less line noise - let's get rid of @%

2000-08-17 Thread Damien Neil
On Thu, Aug 17, 2000 at 03:10:44PM -0700, Steve Fink wrote: > My proposal would be what I implemented for perl5 a while back (Sarathy > didn't dislike it, but wasn't convinced enough to put it in): all > dereferencing can be done with ->. > > $x->@ is the same as @$x > $x->% is the same as %$x >

Re: $!

2000-08-17 Thread Damien Neil
On Thu, Aug 17, 2000 at 01:19:22PM -0500, Jarkko Hietaniemi wrote: > I recently suggested in p5p that for many system calls it could be > checked in *consta...darn, *compile* time whether they are used in > void contect, and _abort_. "No, I'm not going to let you get away > with doing a chdir() a

Re: RFC 109 (v1) Less line noise - let's get rid of @%

2000-08-16 Thread Damien Neil
On Wed, Aug 16, 2000 at 05:36:25PM -0400, Karl Glazebrook wrote: > My take: I like perl, I don't mind it the way it is. But I'd be happier if > it was a lot more like python! (indentation aside) Why, then, don't you just use Python? I'm not being sarcastic. Python is a very good language. It h

Re: RFC 109 (v1) Less line noise - let's get rid of @%

2000-08-16 Thread Damien Neil
On Wed, Aug 16, 2000 at 09:04:00PM +0200, Kai Henningsen wrote: > And context dependency is bad for people. Actually, people deal very well with context dependency. "Have you paid Bill?" "Have you paid that bill?" "It looks like a duck's bill." "The President vetoed the bill." > A rose

Re: RFC 109 (v1) Less line noise - let's get rid of @%

2000-08-16 Thread Damien Neil
On Wed, Aug 16, 2000 at 05:34:51PM -0400, Karl Glazebrook wrote: > > You appear to arguing that expressions in function argument lists should > > not be evaluated in a list context. Is this really what you mean? > > I guess I do. I guess I just hate contexts! Context is a fundemental part of Pe

Re: RFC 109 (v1) Less line noise - let's get rid of @%

2000-08-16 Thread Damien Neil
On Wed, Aug 16, 2000 at 12:31:23PM -0400, John Porter wrote: > Sorry, this is exactly the argument we get from the C/C++/Java heads, > who find perl's lack of discrimination between strings and numbers so > distasteful. But if we can gloss over the difference between a string > and a number, we c

Re: RFC 109 (v1) Less line noise - let's get rid of @%

2000-08-16 Thread Damien Neil
On Wed, Aug 16, 2000 at 10:24:09AM -0400, Karl Glazebrook wrote: > It was the response which was blithe, it just re-iterated arguments we > are all completely familar with and did not address my point in the RFC. Then perhaps we need to agree to disagree. I feel that a number of people have addr

Re: RFC 82 (listops in list context)

2000-08-15 Thread Damien Neil
On Tue, Aug 15, 2000 at 11:15:03PM -0700, Peter Scott wrote: > No, || is half-consistent at the moment: the left hand side is forced into > scalar context but the result context propagates down the right hand > side. I challenge anyone to come up with a rationalization for this that > does not

Re: Component wise || and RFC 82 (was Re: RFC 104 (v1) Backtracking)

2000-08-15 Thread Damien Neil
On Tue, Aug 15, 2000 at 10:26:13PM -0600, Nathan Torkington wrote: > I like the idea of adding the context-aware operators, but I don't > think I'd use them as often as I use "the number of things in the > array". I think most Perl programmers would be in the same camp. > Unless you can show a co

Re: RFC 84 (v1) Replace => (stringifying comma) with =>

2000-08-15 Thread Damien Neil
On Tue, Aug 15, 2000 at 11:46:04PM -0400, Stephen P. Potter wrote: > Why is it silly? Hashes and arrays are *conceptually* very similar (even > if they are extremely different implementation-wise). One of them has > implicit key, the other has an explicit key. They both provide some sort > of o

Re: RFC 109 (v1) Less line noise - let's get rid of @%

2000-08-15 Thread Damien Neil
On Tue, Aug 15, 2000 at 05:45:04PM -0400, Karl Glazebrook wrote: > I hope people will actually read the RFC before coming back with these > canned responses which I (and presumably everyone else on this list) > am completely familiar with. I used to believe that too! Honest... I think you do a si

Re: RFC 90 (v1) Builtins: zip() and unzip()

2000-08-11 Thread Damien Neil
On Fri, Aug 11, 2000 at 06:41:52PM +0100, Graham Barr wrote: > I think I like plow() or maybe just weave() weave() and ravel()? - Damien

Re: AGAINST RFC 48 (v1) Replace localtime() and gmtime() with da

2000-08-08 Thread Damien Neil
On Tue, Aug 08, 2000 at 09:46:04AM -0700, Nathan Wiger wrote: > The RFC doesn't mention localtime() for just this reason. The idea would > be localtime would be GONE in Perl 6, instead moved to Time::Local. > date() would replace it. Why is this a good idea? Perl programs have been using localti

Re: RFC 29 (v1) unlink() should be left alone

2000-08-04 Thread Damien Neil
On Fri, Aug 04, 2000 at 04:39:24PM -0400, Spider Boardman wrote: > The C (POSIX.1) remove() function is NOT just unlink() in drag. Not everywhere, at least: >REMOVE(3) FreeBSD Library Functions Manual REMOVE(3) ... > The remove() function is an alias for the unlink(