Plasma + QT Kinetic gSoC Project, Looking for co-mentor

2009-05-13 Thread Akmanalp, Mehmet A
Hello, I'm an accepted student for gsoc at Pardus [0][1]. My project was to add a plugin for KDM (among other things) to support fingerprint authentication, but we recently found out that it was already done and there is no reason to reinvent the wheel. So, I've been looking around for projects and

Re: Plasma + QT Kinetic gSoC Project, Looking for co-mentor

2009-05-14 Thread Akmanalp, Mehmet A
> Which bring us at a kind of funny situation: a project that had already been > developed is selected as a GSoC project even with tens of mentors evaluating > the proposals. Yeah, I'm hoping google will be a bit lenient because of that. > Well, in a way or another, Mehmet Ali, if you want I can

Qt Kinetic + Plasma Call For Ideas / Project Plan

2009-05-28 Thread Akmanalp, Mehmet A
Hello All, I'm the gsoc guy who's working on integrating QT Kinetic effects into libplasma. Here's a preliminary project plan and a roadmap: http://docs.google.com/View?id=dfscskwm_121fdhzq7dn Basically, what we want is a simplified set of effects and animations that Plasma developers can use with

Re: Qt Kinetic + Plasma Call For Ideas / Project Plan

2009-05-28 Thread Akmanalp, Mehmet A
On Thu, May 28, 2009 at 7:04 PM, Aaron J. Seigo wrote: > if you need an SVN account, don't hesitate to get one: Whoops, forgot to check that one out, I got one yesterday on your recommendation on IRC (makmanalp). > for instance, there's no "flip" in your list, though that's a natural effect > to

Re: Qt Kinetic + Plasma Call For Ideas / Project Plan

2009-05-28 Thread Akmanalp, Mehmet A
2009/5/28 Ivan Čukić : > One effect that I would need, that would be an extension of grow/shrink/scale > is grow/shrink/scale while moving. > Alternatively, you could make a simple move transition which could be combined > with g/s/s to achieve the desired effect. On this, do you think instead of h

Re: Qt Kinetic + Plasma Call For Ideas / Project Plan

2009-05-28 Thread Akmanalp, Mehmet A
2009/5/28 Ivan Čukić : > OK, I think I've misunderstood you. You already meant to have the effects > animated? (take flip for an example - it would animate the flip, not just show > the item flipped, right?) Yup! :) Although I guess this brings up another question: do we want transitions without an

Re: Qt Kinetic + Plasma Call For Ideas / Project Plan

2009-05-28 Thread Akmanalp, Mehmet A
2009/5/28 Alexis Ménard : >> doseries(fadein, doparallel(bounce, blur), fadeout) > That is what QSequentialAnimationGroup is doing... Yeah, and QParallelAnimationGroup, but what I mean is, do we want to use it in libplasma? Or do we just have a set bunch of animations and don't allow for combinatio

Re: Qt Kinetic + Plasma Call For Ideas / Project Plan

2009-05-28 Thread Akmanalp, Mehmet A
On Thu, May 28, 2009 at 9:38 PM, Aaron J. Seigo wrote: > Animation *a = Animator::fadeIn(item); > Animation *b = Animator::add(a, Animator::bounce(item, timesToBounce)); > a = Animator::while(b, Animator::blur(item, amount)); > Animator::add(a, Animator::fadeOut(item)); > // auto starts when event

Re: Qt Kinetic + Plasma Call For Ideas / Project Plan

2009-05-28 Thread Akmanalp, Mehmet A
On Fri, May 29, 2009 at 12:20 AM, Alexis Ménard wrote: > What about trying to achieve that with the actual grammar that is in dui, > the curly brace based language?? Check out the whole aseigo / ivan conversation above. ~ mali (http://constant.inople.net/) _

Re: Qt Kinetic + Plasma Call For Ideas / Project Plan

2009-05-29 Thread Akmanalp, Mehmet A
On Fri, May 29, 2009 at 3:43 AM, Aaron J. Seigo wrote: > Animator::bounce(item, timeToBounce, a, Animator::While); > Animator::blur(item, amount, a, Animator::While); > > not hard :) Oh yeah, I guess that's true. > this is really hard to read for me. is fadeOut in the series or in the > parallel?

Re: Qt Kinetic + Plasma Call For Ideas / Project Plan

2009-05-29 Thread Akmanalp, Mehmet A
2009/5/29 Ivan Čukić : > This starts to look like something. But I would propose an addition. > 1 - that add returns a reference to the Animation object so that the following > is possible: >     b.add(animator.blur(...)) >       .add(animator.bounce(...)) > or with << operator (like QList...) >  

Current Animations Poll for QT Kinetic + Plasma

2009-06-02 Thread Akmanalp, Mehmet A
Hello, As a result of the previous discussion [0], I set out to see what all the current plasma apps (in svn) were doing in regards to animation so I gathered some data simply by grepping for customAnimation through their sources [1], then checking out what they were doing. In short: 7 fades 2 sli

Re: Current Animations Poll for QT Kinetic + Plasma

2009-06-03 Thread Akmanalp, Mehmet A
> and looking at those same widgets, imagine what kind of animations would be > useful / cool to have (e.g. the image frame flip-over) Update. Here's some: http://blackwater.constant.inople.net/gsoc/usage2.txt Not many though. :/ -- ~ mali (http://constant.inople.net/) __

Plasma + QT Kinetic Preliminary Design Decisions

2009-06-04 Thread Akmanalp, Mehmet A
Hello, I wanted to distill the discussions made previously on the list + my thoughts and findings into something more concrete, so I can start making a prototype soon. * For grouping, our Animation object (or whatever) can just subclass QAnimationGroup. QAG supplies all we need, no need to go lowe

Re: Plasma + QT Kinetic Preliminary Design Decisions

2009-06-04 Thread Akmanalp, Mehmet A
On Thu, Jun 4, 2009 at 4:46 PM, J. Janz wrote: > 2009/6/4 Akmanalp, Mehmet A > I don't know much about kinetic (yeah, I'm out of time for my homework > research ;) ) but, since it has what's needed to "Grow / Shrink / Scale" or > "Expand / Contract i

Re: Plasma + QT Kinetic Preliminary Design Decisions

2009-06-08 Thread Akmanalp, Mehmet A
> .. and for parallel or sequential it would create, internally, QParallelAG > and/or QSequentialAG objects? ... > if it does get too messy, one option might be to make Animation not a > QAnimationGroup but give it an accessor that would return a new > QAnimationGroup based on its internal status.

What to do with the old Plasma::Animator?

2009-06-12 Thread Akmanalp, Mehmet A
Regarding these: On Thu, Jun 4, 2009 at 9:39 PM, Alexis Ménard wrote: > > > On Thu, Jun 4, 2009 at 7:16 PM, Aaron J. Seigo wrote: >> can we just extend Plasma::Animator with the new methods and deprecate all >> the >> old stuff? >> >> to keep the implementation from becoming mixed up with all the

Re: What to do with the old Plasma::Animator?

2009-06-12 Thread Akmanalp, Mehmet A
>> * mark all the methods currently in Animator as KDE_DEPRECATED Did so. I also marked the enums and the AnimatorPrivate deprecated too, and added @deprecated s to the comments. It compiles and runs fine afaik. Have I missed anything? (Changes in attachment) After reading this: http://www.koders.

Re: What to do with the old Plasma::Animator?

2009-06-13 Thread Akmanalp, Mehmet A
On Sat, Jun 13, 2009 at 2:32 AM, Aaron J. Seigo wrote: > On Friday 12 June 2009, Akmanalp, Mehmet A wrote: >> >> * mark all the methods currently in Animator as KDE_DEPRECATED >> >> Did so. I also marked the enums and the AnimatorPrivate deprecated >> too, and ad

Re: What to do with the old Plasma::Animator?

2009-06-13 Thread Akmanalp, Mehmet A
On Sat, Jun 13, 2009 at 3:58 PM, Marco Martin wrote: > uuh, is nevessary to mark deprecated AnimatorPrivate ince is well.. private? > we could even rename it to something else and keep animatorprivate for the new > stuff i suppose? Actually, I was just looking at that *right* now and thinking that

Re: What to do with the old Plasma::Animator?

2009-06-13 Thread Akmanalp, Mehmet A
On Sat, Jun 13, 2009 at 4:36 PM, Akmanalp, Mehmet A wrote: > Actually, I was just looking at that *right* now and thinking that. > AnimatorPrivateOld? AnimatorPrivate1? Ugh. Marco suggested AnimatorLegacyPrivate in #plasma, which seems in place. Although, he also sug

Re: What to do with the old Plasma::Animator?

2009-06-17 Thread Akmanalp, Mehmet A
So, today I realized that automoc gets confused if I have two animator.cpp's in plasma/ and plasma/deprecated/. Alexis suggested that I include the old animator.cpp below the new one, but that caused issues. Finally, I got it to work by giving the new animator.cpp a new filename. I called it animat

Re: Memory model in new Animator classes

2009-10-20 Thread Akmanalp, Mehmet A
On Mon, Oct 19, 2009 at 9:21 AM, Adenilson Cavalcanti wrote: > > The only problem is that internally it will create all the animation > objects and later destroy them *every* single time that the animation runs. > This design saves memory (or not, read more about it below) but probably is > expensi

Re: animation api changes

2009-12-03 Thread Akmanalp, Mehmet A
On Thu, Dec 3, 2009 at 8:24 PM, Aaron J. Seigo wrote: > * Plasma::Animation IsA QAbstractAnimation with the bare essential pure > virtuals implemented and which takes a QGraphicsWidget that should be animated Good call, I forget the reasoning of why we didn't do it this way initially but I guess

Re: 4.4 API issue: Plasma::Animation::setWidgetToAnimate

2010-01-03 Thread Akmanalp, Mehmet A
On Sun, Jan 3, 2010 at 10:41 PM, Aaron J. Seigo wrote: > hi all .. > > doing some last minute API grooming here and noticed that we have > Plasma::Animation::setWidgetToAnimate while Qt has > QVariantAnimation::setTargetObject. Hah, missed this entirely! > proposal: changed setWidgetToAnimate to

Re: animation example missing license

2010-01-04 Thread Akmanalp, Mehmet A
On Mon, Jan 4, 2010 at 4:51 AM, Aaron J. Seigo wrote: > according to svn log, the following people (other than myself) have touched > it: > >        igorto >        adasilva >        mart > i'd like to see this licensed under a standard BSD license so that it can be > used as permissively as pos