Phil somehow the server got backed up so I didn't get your first
email. Looks like you beat me to it. :-)
I've committed the suggested changes.
-sam
On Apr 5, 2006, at 1:21 PM, Phil Carns wrote:
Looks good to me. My only suggestions would be to rename it to
PVFS2_ALIGN_VAR and put it i
Looks good to me. My only suggestions would be to rename it to
PVFS2_ALIGN_VAR and put it in pvfs2-types.h in case we want to use it
elsewhere. Maybe put PVFS2_ on the SIZEOF_VOIDP too, to make sure it
doesn't ever conflict with something that autoconf generates.
-Phil
Sam Lang wrote:
Ex
Except it needs to be like this for the kernel module:
#if defined(__WORDSIZE)
#define SIZEOF_VOIDP __WORDSIZE
#elif defined(BITS_PER_LONG)
#define SIZEOF_VOIDP BITS_PER_LONG
#elif defined(INTPTR_MIN)
#if INTPTR_MIN == INT32_MIN
#define SIZEOF_VOIDP 32
#elif INTPTR_MIN == INT64_MIN
What about this? It makes pvfs2-sysint.h a bit messier at the top of
the file, but the struct definition is cleaner.
-sam
#if defined(__WORDSIZE)
#define SIZEOF_VOIDP __WORDSIZE
#elif defined(INTPTR_MIN)
#if INTPTR_MIN == INT32_MIN
#define SIZEOF_VOIDP 32
#elif INTPTR_MIN == INT64_MIN
#defi
Maybe just put something like this in pvfs2-types.h so we have a clean
#define to use in the rest of the code?
#ifdef __KERNEL__
#ifndef BITS_PER_LONG
#error "Cannot determine PVFS2_WORDSIZE"
#endif
#define PVFS2_WORDSIZE BITS_PER_LONG
#else
#ifndef INTPTR_MIN
#e
We add -Wundef with --enable-strict, but I configured my build with --
enable-strict and didn't see the warning. It looks like the kernel
module code only gets the flags specified when the kernel was built?
Once I added the -Wundef to CFLAGS in my kernel headers Makefile, I
was able to r
Ahh, -Wundef is the difference. That flag is getting set automatically
on my laptop for some reason but not on the other boxes that I try.
-Phil
Phil Carns wrote:
I'll see if I can figure out something to do based on Nathan's suggestion.
Looking a little closer today, it looks like maybe the
I'll see if I can figure out something to do based on Nathan's suggestion.
Looking a little closer today, it looks like maybe there is more of a
compiler difference (or -W flag difference) that determines if you see
the warning, rather than a kernel version?
For example, on RHEL4 (x86_64) I d
Hi Phil,
I'm not able to reproduce that warning with a 2.6.11 kernel. I'm not
sure why as the limits.h that gets included doesn't seem to define
INTPTR_MIN either. Could you just send me a patch with Nathan's
proposed fix or something similar that gets rid of those warnings for
you?
Thus spake Phil Carns:
> Actually, it does compile now that I look closer (I had a second problem
> confusing me), but it does generate quite a few warnings like this:
>
> pvfs2/include/pvfs2-sysint.h:44:5: warning: "INTPTR_MIN" is not defined
> pvfs2/include/pvfs2-sysint.h:44:19: warning: "INT32
Actually, it does compile now that I look closer (I had a second problem
confusing me), but it does generate quite a few warnings like this:
pvfs2/include/pvfs2-sysint.h:44:5: warning: "INTPTR_MIN" is not defined
pvfs2/include/pvfs2-sysint.h:44:19: warning: "INT32_MIN" is not defined
Not sure w
Is INTPTR_MIN defined in the kernel headers somewhere as well? I am
having a hard time compiling the kerne module at the moment because
/kernel/linux-2.6/pvfs2-utils.c ends up pulling in pvfs2-sysint.h. I am
using the 2.6.15.4 kernel.
-Phil
Sam Lang wrote:
This seems to work everywhere we
This seems to work everywhere we tried, so I went ahead and committed
that change. Thanks Pete!
-sam
On Apr 4, 2006, at 12:15 PM, Pete Wyckoff wrote:
[EMAIL PROTECTED] wrote on Tue, 04 Apr 2006 11:32 -0500:
Hm...actually I didn't notice before but the use of __WORDSIZE or
BITS_PER_LONG w
[EMAIL PROTECTED] wrote on Tue, 04 Apr 2006 11:32 -0500:
> Hm...actually I didn't notice before but the use of __WORDSIZE or
> BITS_PER_LONG will break on darwin (which doesn't define either).
> Previously, I fixed this by defining SIZEOF_LONG_INT and
> SIZEOF_VOID_P in pvfs2-config.h, but t
Hm...actually I didn't notice before but the use of __WORDSIZE or
BITS_PER_LONG will break on darwin (which doesn't define either).
Previously, I fixed this by defining SIZEOF_LONG_INT and
SIZEOF_VOID_P in pvfs2-config.h, but the PVFS_sys_attr_s struct now
includes padding and that struc
I've committed these changes to trunk ontop of the dbpf-onekeyval
changes.
-sam
On Mar 31, 2006, at 10:21 PM, Murali Vilayannur wrote:
Hi,
Attached patch seems to pass all my (admittedly small) tests on
both ppc64
and amd64.. Now we can run all combinations of 32 bit and 64 bit
pvfs2-c
Hi,
Attached patch seems to pass all my (admittedly small) tests on both ppc64
and amd64.. Now we can run all combinations of 32 bit and 64 bit
pvfs2-client-core and pvfs2-servers interchangeably and things should work
correctly.
It also fixes a PINT_dist_decode bug that was causing server to cras
17 matches
Mail list logo