[Rails-core] Patch review requested part deux

2007-07-18 Thread kamal
Until a solid review process is decided, here goes: #8117 - bug fix for calculations not using :foreign_key for grouped associations #6107 - don't pluralize class names if ActiveRecord::Base.pluralize_table_names set to false #8153 - fix a tiny copy and paste job for naming a test method #8717

[Rails-core] Re: collection_select

2007-07-18 Thread EddM
On Jul 19, 12:32 am, "Jack Danger Canty" <[EMAIL PROTECTED]> wrote: > > In the spirit of common naming conventions, I reckon the value_method > > and text_method parameters should default to :id and :name > > respectively. What are everyone's views on this? > > While those are very reasonable de

[Rails-core] Re: Edge Rails namespaced routing

2007-07-18 Thread Pratik
Exactly. config.load_paths was my point when I said "Putting them in a separate directory is perfect,". Also, if you're gonna namespace your models as Customer::Tag - and put them inside models/customer/tag.rb - you better name your model CustomerTag and keep it as models/customer/customer_tag.rb

[Rails-core] Re: Edge Rails namespaced routing

2007-07-18 Thread Josh Peek
On Jul 18, 4:17 pm, Pratik <[EMAIL PROTECTED]> wrote: > On a totally unrelated note, I'm completely against the idea of > namespaced models. Putting them in a separate directory is perfect, > but not naming them like Customer::Tag. Why would u need to do that ? I don't like namespaced models eith

[Rails-core] Re: collection_select

2007-07-18 Thread Jack Danger Canty
> In the spirit of common naming conventions, I reckon the value_method > and text_method parameters should default to :id and :name > respectively. What are everyone's views on this? While those are very reasonable defaults it seems like the error message would have to be quite elaborate in case

[Rails-core] Re: Edge Rails namespaced routing

2007-07-18 Thread Trevor Squires
Hey, so you're saying that you are using the same resource names (notes, tags) but you want those routes to go to different controllers? map.resources :customers do |customer| customer.resources :notes, :controller => 'customer_notes' customer.resources :tags, :controller => 'customer_ta

[Rails-core] unable to attach patch to ticket 9007

2007-07-18 Thread Craig Demyanovich
Hi everyone, I've been unable to attach a patch to my ticket http://dev.rubyonrails.org/ticket/9007 Each time I try, I receive this error message "Not Found The requested URL /attachment/ticket/9007/ plugin_install_when_svn_asp_dot_net_hack.diff was not found on this server." If I navigate t

[Rails-core] Re: Edge Rails namespaced routing

2007-07-18 Thread Pratik
So what will the table be for those namespaced models ? On 7/18/07, Andrew Kaspick <[EMAIL PROTECTED]> wrote: > > To not have naming collisions. You can't have two classes named Tag > in the same namespace (and not using one is still in a namespace.. the > default one). Pretty standard namespac

[Rails-core] Vegetarian enough?

2007-07-18 Thread Moona Naeem
Vegetarian enough? People often tell me about how they get grief from people who are "more" vegetarian than them. Isn't that strange? People who can be bothered to make a life changing decision are then chastised by the super veggies for not trying hard enough. http://2site.com/agfdxz Road Ma

[Rails-core] Re: Edge Rails namespaced routing

2007-07-18 Thread Andrew Kaspick
To not have naming collisions. You can't have two classes named Tag in the same namespace (and not using one is still in a namespace.. the default one). Pretty standard namespace stuff. +1 for namespaced models! :) On 7/18/07, Pratik <[EMAIL PROTECTED]> wrote: > > > This leads me to another sc

[Rails-core] collection_select

2007-07-18 Thread EddM
Dear Ruby on Rails Community, I am writing to propose a very minor change to the Rails framework. The helper method collection_select under Helpers::FormOptionsHelper is used to generate a tag with relevant from a given Collection, as you all know. This method's current parameters are as follow

[Rails-core] Re: Edge Rails namespaced routing

2007-07-18 Thread Pratik
> This leads me to another scenario. Namespaced models quite simply > as it stands you can in /app/models/ make a folder called /customer/ > there add tag.rb and note.rb. With models Customer::Tag and > Customer::Note. One thing is the table_name will remain "tags" and > "notes", which in t

[Rails-core] Edge Rails namespaced routing

2007-07-18 Thread Peter
Hi, I was wondering if anyone came across a similar scenario when working with namespaced routes with edge rails. Consider an application with controllers customers and products that also have other resources. map.resources :customers do |customer| customer.resources :notes customer.resourc