[Rails-core] proposal: deprecate save() in favor of save!()

2015-06-22 Thread pseidemann
hello, currently in rails you have two methods to save a record: `save` and `save!`. I think `save` is often used wrong because the return value is not always checked. even the documentation is not very clear about the subtle different about the two methods. for `save` the first sentence is: >

Re: [Rails-core] proposal: deprecate save() in favor of save!()

2015-06-22 Thread Rafael Mendonça França
I think the documentation is very clear about this: Saves the model. If the model is new a record gets created in the database, otherwise the existing record gets updated. By default, save always run validations. If any of them fail the action is cancelled and save returns false. If it is not we

Re: [Rails-core] proposal: deprecate save() in favor of save!()

2015-06-22 Thread Ryan Bigg
Changing this method's name reeks of bikeshedding. Any one with more than a day's worth of Rails experience knows the difference between these two methods and how to use them. In my experience, the return value for save is almost always checked. If we deprecate save and then have only save!,

Re: [Rails-core] proposal: deprecate save() in favor of save!()

2015-06-22 Thread Michael Pavling
On 22 Jun 2015 15:24, "pseidemann" wrote: > > hello, > > currently in rails you have two methods to save a record: `save` and `save!`. > I think `save` is often used wrong because the return value is not always checked. > even the documentation is not very clear about the subtle different about th

Re: [Rails-core] proposal: deprecate save() in favor of save!()

2015-06-23 Thread Jason Fleetwood-Boldt
Generally nearly all of the Jr. devs I work with know this, this is very basic to the early learning process of working with Rails. Most code I see uses the if @foo.save … else … end style in almost all cases and does flow control based on the return value of save. -Jason > On Jun 22, 2015,

Re: [Rails-core] proposal: deprecate save() in favor of save!()

2015-06-23 Thread Kerri Miller
OP - Would it clarify the issue in your mind if "Saves the model." were changed to "Attempts to save the model." -k- On Tue, Jun 23, 2015 at 7:36 AM, Jason Fleetwood-Boldt wrote: > Generally nearly all of the Jr. devs I work with know this, this is very > basic to the early learning process

Re: [Rails-core] proposal: deprecate save() in favor of save!()

2015-06-24 Thread pseidemann
yes I think changing the documentation in that direction already makes it really more clear On Tuesday, June 23, 2015 at 4:56:23 PM UTC+2, Kerri Miller wrote: > > OP - Would it clarify the issue in your mind if > > "Saves the model." > > were changed to > > "Attempts to save the model." > > -k-