On Sep 27, 2:02 am, "Mike Hansen" <[EMAIL PROTECTED]> wrote:
> The patch at 4201 adds the features and the documentation back :-)
> Thanks for keeping an eye open.
Likewise :-). Guess if I had read your ticket, I would have seen that
you were already on top of it.
JM
--~--~-~--~~---
Hi Jason M.,
On Fri, Sep 26, 2008 at 10:58 PM, Jason Merrill <[EMAIL PROTECTED]> wrote:
> You may want to see http://trac.sagemath.org/sage_trac/ticket/4099 for
> reference. I removed documentation for .options and .reset for
> several plot related functions, since I assumed these features were
On Sep 26, 4:07 pm, "Mike Hansen" <[EMAIL PROTECTED]> wrote:
> Hi Jason,
>
> On Fri, Sep 26, 2008 at 9:05 AM, Jason Bandlow <[EMAIL PROTECTED]> wrote:
> > A student of mine noticed the following and it looks like a bug to me
> > (at least with the documentation).
>
> This was a regression caused b
revx wrote:
> Is there an easy way to do dimensional analysis with sagemath?
>
What do you mean by "dimensional analysis"?
Jason
--~--~-~--~~~---~--~~
To post to this group, send email to sage-support@googlegroups.com
To unsubscribe from this group, send email t
Is there an easy way to do dimensional analysis with sagemath?
--~--~-~--~~~---~--~~
To post to this group, send email to sage-support@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at
http://gro
Maybe I don't understand the question exactly.
Consider the circle x^2+y^2=1, z=0, and the set S of all points
at a small distance d, say d near 1/100, from this circle. I think
that is a torus, isn't it?
You want a symbolic equation (ie, a function of d) for the points in
the intersection
of thi
On Sep 26, 2008, at 6:04 PM, cesarnda wrote:
> Actually I wanted it less yellow, if I do that or only
>
> codeSet = []
>
> or
>
> codeSet = ([])
>
> the result is the same.
You can't create a list in a "less yellow" way than calling PyList_New
(0), and that's all its doing so you're optimal.
-
Newbie to sage - trying to find a point on a line in 3D that is a
specified distance from a circle (the line is not coplanar with the
circle). Here's what I've inputed into sage:
var("line_dir_x line_dir_y line_dir_z line_p_x line_p_y line_p_z
cent_x cent_y cent_z norm_x norm_y norm_z u radius l
Actually I wanted it less yellow, if I do that or only
codeSet = []
or
codeSet = ([])
the result is the same.
On Sep 26, 1:43 pm, Robert Bradshaw <[EMAIL PROTECTED]>
wrote:
> On Sep 26, 2008, at 8:21 AM, cesarnda wrote:
>
>
>
>
>
> > I already did that and I get this:
>
> > cdef list codeSet
Hi Jason,
On Fri, Sep 26, 2008 at 9:05 AM, Jason Bandlow <[EMAIL PROTECTED]> wrote:
> A student of mine noticed the following and it looks like a bug to me
> (at least with the documentation).
>
This was a regression caused by the reworking of plot.py in 3.1.2.
I've added a patch at http://trac.
On Sep 26, 2008, at 8:21 AM, cesarnda wrote:
>
> I already did that and I get this:
>
> cdef list codeSet = []
>
> __pyx_1 = PyList_New(0); if (unlikely(!__pyx_1)) {__pyx_filename =
> __pyx_f[0]; __pyx_lineno = 210; __pyx_clineno = __LINE__; goto
> __pyx_L1_error;}
> __pyx_v_codeSet = __pyx_
On Fri, Sep 26, 2008 at 7:36 AM, Jason Grout
<[EMAIL PROTECTED]> wrote:
>
> Robert Bradshaw wrote:
>> On Sep 25, 2008, at 5:15 PM, Erik Lane wrote:
>>
>>> Yes, I saw that in the solution of the other one (and have changed my
>>> plots to take this into account), but what is the advantage of the
>>
Hi all,
A student of mine noticed the following and it looks like a bug to me
(at least with the documentation).
>From the notebook with 3.1.2 (sage prompts added for readability):
sage: plot?
File:
/home/jason/sage/local/lib/python2.5/site-packages/sage/plot/plot.py
Type:
Defi
I already did that and I get this:
cdef list codeSet = []
__pyx_1 = PyList_New(0); if (unlikely(!__pyx_1)) {__pyx_filename =
__pyx_f[0]; __pyx_lineno = 210; __pyx_clineno = __LINE__; goto
__pyx_L1_error;}
__pyx_v_codeSet = __pyx_1;
__pyx_1 = 0;
and if I don't do it that way I get:
add
Robert Bradshaw wrote:
> On Sep 25, 2008, at 5:15 PM, Erik Lane wrote:
>
>> Yes, I saw that in the solution of the other one (and have changed my
>> plots to take this into account), but what is the advantage of the
>> aspect ratio default *not* being 1? I'm very curious. I'm not a
>> mathematici
On Sep 25, 2008, at 3:45 PM, cesarnda wrote:
>
> in http://www.cosc.canterbury.ac.nz/greg.ewing/python/Pyrex/ there is
> the following example:
>
> def primes(int kmax):
> cdef int n, k, i
> cdef int p[1000]
> result = []
> if kmax > 1000:
> kmax = 1000
> k = 0
> n = 2
> while k
> >> These is_* sure are causing a lot of confusion lately...
> >
> > Indeed! I like Mike Hansen's (or your) proposal to get
> > rid of them all from the global namespace, and replace
> > them only by "is_lowercase_method_name" functions
> > that are all conceptually meaningful. Of course leave
Pong,
All of this is documented, and you can get to it by typing
sage: G.show?
Normally, the Python/Sage way of dealing with objects is to put the
object first, with a dot afterwards. Then, you can hit tab to see all
the functions available for that object, and type one ? for docs,
and ?? for s
Thanks, Mike!
I remember that there was talk about including fast_float
automatically in plot, so it's good to know it has happened already.
Stan
> Yes, it should work -- I'll fix this. However, you shouldn't have to
> manually use fast float now. When you do plot([bv1,bv2],0,1), the
> fast_fl
On Sep 26, 2008, at 12:09 AM, Simon King wrote:
>
> On Sep 25, 6:45 pm, cesarnda <[EMAIL PROTECTED]> wrote:
> ...
>> result = []
> ...
>> result.append(n)
>
> ...
>> if I compile in the notebook I get a html file showing me the
>> following lines in yellow:
>>
>> def primes(int kmax):
>>
On Sep 25, 2008, at 5:15 PM, Erik Lane wrote:
> Yes, I saw that in the solution of the other one (and have changed my
> plots to take this into account), but what is the advantage of the
> aspect ratio default *not* being 1? I'm very curious. I'm not a
> mathematician, just a student going throug
On Sep 25, 6:45 pm, cesarnda <[EMAIL PROTECTED]> wrote:
...
> result = []
...
> result.append(n)
...
> if I compile in the notebook I get a html file showing me the
> following lines in yellow:
>
> def primes(int kmax):
> result = []
> result.append(n)
> return result
>
> how can I modify
On Sep 26, 12:06 am, Robert Bradshaw <[EMAIL PROTECTED]>
wrote:
> > Indeed! I like Mike Hansen's (or your) proposal to get
> > rid of them all from the global namespace, and replace
> > them only by "is_lowercase_method_name" functions
> > that are all conceptually meaningful. Of course le
On Sep 25, 2008, at 6:11 PM, William Stein wrote:
>
> On Thu, Sep 25, 2008 at 6:06 PM, Robert Bradshaw
> <[EMAIL PROTECTED]> wrote:
>>
>>
>> On Sep 25, 2008, at 5:43 PM, William Stein wrote:
>>
>>>
>>> On Thu, Sep 25, 2008 at 5:33 PM, Quicksilver_Johny
>>> <[EMAIL PROTECTED]> wrote:
If
On Sep 25, 2008, at 7:53 PM, cesarnda wrote:
> I am using the "set([])" function, and is a set of vectors, I want to
> convert it to a set because I want to use the methods for sets
>
> On Sep 25, 9:09 pm, Jason Grout <[EMAIL PROTECTED]> wrote:
>> cesarnda wrote:
>>> is there a function that can
25 matches
Mail list logo