[U-Boot] [PATCH] MIPS: remove broken "tb0229" board

2011-12-11 Thread Wolfgang Denk
The "tb0229" board has long been unmaintained, and is broken. Remove it. Signed-off-by: Wolfgang Denk --- board/tb0229/Makefile| 47 -- board/tb0229/config.mk | 30 - board/tb0229/flash.c | 1197 -- board/tb0229/lowlevel_init.S |

[U-Boot] printf in uboot

2011-12-11 Thread Sidharth Baisane
hi, How can i use print statement in uboot ??? I tried printf in following program but its not executing it and my program hangs afterwards. void start_armboot (void) { init_fnc_t **init_fnc_ptr; char *s; #if defined(CONFIG_VFD) || defined(CONFIG_LCD) unsigned long addr; #endif *

Re: [U-Boot] [PATCH v2] MIPS: tb0229: fix compile errors

2011-12-11 Thread Wolfgang Denk
Dear Daniel Schwierzeck, In message <1323621577-13010-1-git-send-email-daniel.schwierz...@googlemail.com> you wrote: > This board breaks MAKEALL -a mips due to compile errors. > This patch fixes only the parts causing the errors to get MAKEALL > working. > > Signed-off-by: Daniel Schwierzeck >

Re: [U-Boot] [PATCH] common/cmd_nvedit.c: Add missing 'env save' preproc guard

2011-12-11 Thread Wolfgang Denk
Dear Horst Kronstorfer, In message <1323519919-7320-1-git-send-email-hkron...@frequentis.com> you wrote: > Signed-off-by: Horst Kronstorfer > --- > common/cmd_nvedit.c |2 ++ > 1 files changed, 2 insertions(+), 0 deletions(-) Applied, thanks. Best regards, Wolfgang Denk -- DENX Software

Re: [U-Boot] ext4 support?

2011-12-11 Thread Wolfgang Denk
Dear Dominic, In message you wrote: > > Just wondering if anyone is working on ext4 support? (ext2ls, ext2load) > I have seen ext4 support code in Grub 2, it should be easy to bring to > U-Boot. Is there a license issue? Iqbal and others at Samsung have been working on this lately. He told me j

Re: [U-Boot] [PATCH v2] MIPS: tb0229: fix compile errors

2011-12-11 Thread Wolfgang Denk
Dear Daniel Schwierzeck, In message <1323621577-13010-1-git-send-email-daniel.schwierz...@googlemail.com> you wrote: > This board breaks MAKEALL -a mips due to compile errors. > This patch fixes only the parts causing the errors to get MAKEALL > working. > > Signed-off-by: Daniel Schwierzeck >

Re: [U-Boot] [PATCH] powerpc/bootm: Flush ramdisk and device tree image when booting on MP

2011-12-11 Thread Wolfgang Denk
Dear Kumar Gala, In message <1323268978-26973-1-git-send-email-ga...@kernel.crashing.org> you wrote: > We already flush the kernel image after we've loaded it to ensure > visiblity to the other cores. We need to do the same thing for the > ramdisk and device tree images. In AMP boot scenarios w

Re: [U-Boot] [PATCH] mpc5200: digsy_mtc: Fix extension board detection

2011-12-11 Thread Wolfgang Denk
Dear Anatolij Gustschin, In message <1323273955-8557-1-git-send-email-ag...@denx.de> you wrote: > Switch to extension board detection using pci_find_device() > instead of detecting by i2c access to EEPROM device on > extension board. > > This is a cleaner detection method since EEPROM addresses >

[U-Boot] [PATCH] board/ti/omap2420h4/omap2420h4.c: Fix GC 4.6 build warning

2011-12-11 Thread Wolfgang Denk
Fix: omap2420h4.c: In function 'dram_init': omap2420h4.c:196:25: warning: variable 'cpu' set but not used [-Wunused-but-set-variable] Signed-off-by: Wolfgang Denk Cc: Richard Woodruff Cc: Tom Rini --- board/ti/omap2420h4/omap2420h4.c |3 +-- 1 files changed, 1 insertions(+), 2 deletions(-)

Re: [U-Boot] Pull request: u-boot-usb

2011-12-11 Thread Wolfgang Denk
Dear Remy Bohmer, In message you wrote: > The following changes since commit c90a4dd79cb17abb46689f27ff9f1c971362d6e2: > > post/post.c: Use lldiv for 64-bit divisions (2011-12-10 23:15:14 +0100) > > are available in the git repository at: > git://git.denx.de/u-boot-usb.git master > > Jana

Re: [U-Boot] Pull request: u-boot-arm/master

2011-12-11 Thread Wolfgang Denk
Dear Albert ARIBAUD, In message <4ee4b24a.5080...@aribaud.net> you wrote: > Hi Wolfgang, > > The following changes since commit c90a4dd79cb17abb46689f27ff9f1c971362d6e2: > >post/post.c: Use lldiv for 64-bit divisions (2011-12-10 23:15:14 +0100) > > are available in the git repository at: >

Re: [U-Boot] Pull request u-boot-blackfin.git (sandbox branch)

2011-12-11 Thread Wolfgang Denk
Dear Mike Frysinger, In message <1323558076-10036-1-git-send-email-vap...@gentoo.org> you wrote: > This makes sandbox work again on the latest master. > > The following changes since commit c90a4dd79cb17abb46689f27ff9f1c971362d6e2: > > post/post.c: Use lldiv for 64-bit divisions (2011-12-10 23

Re: [U-Boot] [PATCH v2 0/6] reboard: Introduce generic relocation feature

2011-12-11 Thread Graeme Russ
Hi Simon, On Mon, Dec 12, 2011 at 4:20 PM, Simon Glass wrote: > Hi Albert, > > On Sun, Dec 11, 2011 at 2:27 PM, Albert ARIBAUD > wrote: >> Hi againLe 11/12/2011 22:30, Simon Glass a écrit : >> >> Actually most of start.S is very similar across all its avatars in arch/arm, and is a

Re: [U-Boot] [PATCH] MAKEALL: Add -l option to only list build targets

2011-12-11 Thread Mike Frysinger
On Sunday 04 December 2011 06:32:47 Marek Vasut wrote: > > Should it be an equality operator instead of an assigning one? i.e: > > > > [ "$ONLY_LIST" == "y" ] && return > > 2) It's the same thing ... = and == in shell scripting. while this is true for the particular piece of code quoted, in gen

Re: [U-Boot] [PATCH 1/2] NET: NE2000: Cleanup IO accessors

2011-12-11 Thread Mike Frysinger
On Sunday 11 December 2011 08:42:07 Marek Vasut wrote: > > On Saturday 10 December 2011 20:09:30 Marek Vasut wrote: > > > Introduce ne2k_register_io(in, out), which allows user to supply two > > > functions. One for reading data from the card, the other for writing > > > data to the card. Then intr

Re: [U-Boot] [PATCH v2 4/6] reboard: arm: Add processor function library

2011-12-11 Thread Simon Glass
Hi Albert, On Sun, Dec 11, 2011 at 6:16 AM, Albert ARIBAUD wrote: > Hi Simon, > > Le 10/12/2011 20:16, Simon Glass a écrit : > >> Add a library to hold ARM assembler code which is generic across all >> ARM CPUs. At first it just holds some basic relocation code. The >> plan is to move more start.

Re: [U-Boot] [PATCH v2 0/6] reboard: Introduce generic relocation feature

2011-12-11 Thread Simon Glass
Hi Albert, On Sun, Dec 11, 2011 at 2:27 PM, Albert ARIBAUD wrote: > Hi againLe 11/12/2011 22:30, Simon Glass a écrit : > > >>> Actually most of start.S is very similar across all its avatars in >>> arch/arm, >>> and is a good candidate for being generalized. I would prefer a >>> generalization of

Re: [U-Boot] [PATCH v2 6/6] reboard: arm: Remove unused code in start.S

2011-12-11 Thread Simon Glass
Hi Albert, On Sun, Dec 11, 2011 at 6:59 AM, Albert ARIBAUD wrote: > Hi Simon, > > Le 10/12/2011 20:16, Simon Glass a écrit : > >> Now that we are using the generic relocation framework, we don't need this >> code. >> >> Note: Here we lose the ARM1176's enable_mmu code. This seems to duplicate >>

Re: [U-Boot] [PATCH v2 2/6] reboard: define CONFIG_SYS_SKIP_RELOC for all archs

2011-12-11 Thread Simon Glass
Hi Albert, On Sun, Dec 11, 2011 at 6:57 AM, Albert ARIBAUD wrote: > Le 10/12/2011 20:16, Simon Glass a écrit : > >> We are introducing a new generic relocation features and we want this to >> be the default. So we need to opt all architectures out first. Some may >> never have relocation, but tho

Re: [U-Boot] [PATCH v2 1/6] reboard: Create reloc.h and include it where needed

2011-12-11 Thread Simon Glass
Hi, On Sun, Dec 11, 2011 at 2:29 PM, Albert ARIBAUD wrote: > Hi Gream, > > Le 11/12/2011 22:45, Graeme Russ a écrit : > > >> I think the point is that when we pull stuff out of common.h into, >> say, foo.h then only include foo.h where the functionality moved into >> foo.h is _currently_ used. >>

Re: [U-Boot] [PATCH v2] powerpc/mpc83xx: set TXEQA/TXEQE value for mpc837XE sata

2011-12-11 Thread Huang Changming-R66093
Hi, Kim Do you have any comment on this patch? > -Original Message- > From: Huang Changming-R66093 > Sent: Thursday, November 17, 2011 10:16 AM > To: u-boot@lists.denx.de > Cc: Huang Changming-R66093; Phillips Kim-R1AAHA > Subject: [PATCH v2] powerpc/mpc83xx: set TXEQA/TXEQE value for mpc

Re: [U-Boot] [PATCH] nand_spl_simple: store ecc data on the stack

2011-12-11 Thread Ilya Yanok
Hi Stefano, thanks for posting this. There is a couple of comments below. On 11.12.2011 21:22, Stefano Babic wrote: > diff --git a/drivers/mtd/nand/nand_spl_simple.c > b/drivers/mtd/nand/nand_spl_simple.c > index ed821f2..a3d1af0 100644 > --- a/drivers/mtd/nand/nand_spl_simple.c > +++ b/drivers/

[U-Boot] [PATCH] arm926ejs: remove noop flush_dcache_all function

2011-12-11 Thread Ilya Yanok
Commit 2f3427c added noop cache functions implementation for arm926ejs to fix compilation of drivers depending on these functions (DaVinci EMAC in particular). Unfortunately, the bug was introduced: noop implementation calls dcache_disable which calls flush_dcache_all which in turn calls dcache_di

Re: [U-Boot] [PATCH v2 1/6] reboard: Create reloc.h and include it where needed

2011-12-11 Thread Albert ARIBAUD
Le 11/12/2011 23:29, Albert ARIBAUD a écrit : Hi Gream, Argh. s/Gream/Greame/, with my apologies. Amicalement, -- Albert. ___ U-Boot mailing list U-Boot@lists.denx.de http://lists.denx.de/mailman/listinfo/u-boot

Re: [U-Boot] [PATCH v2 1/6] reboard: Create reloc.h and include it where needed

2011-12-11 Thread Albert ARIBAUD
Hi Gream, Le 11/12/2011 22:45, Graeme Russ a écrit : I think the point is that when we pull stuff out of common.h into, say, foo.h then only include foo.h where the functionality moved into foo.h is _currently_ used. It looks like you've pulled out the functions definitions into reloc.h then i

Re: [U-Boot] [PATCH v2 0/6] reboard: Introduce generic relocation feature

2011-12-11 Thread Albert ARIBAUD
Hi againLe 11/12/2011 22:30, Simon Glass a écrit : Actually most of start.S is very similar across all its avatars in arch/arm, and is a good candidate for being generalized. I would prefer a generalization of start.S with the vector table, generic startup sequence prepare for calling board_init

Re: [U-Boot] [PATCH v2 1/6] reboard: Create reloc.h and include it where needed

2011-12-11 Thread Graeme Russ
Hi Simon, On Mon, Dec 12, 2011 at 8:33 AM, Simon Glass wrote: > Hi Albert, > > On Sun, Dec 11, 2011 at 6:52 AM, Albert ARIBAUD > wrote: >> Le 10/12/2011 20:16, Simon Glass a écrit : >> >>> Before adding new relocation functions, move this prototype out of >>> common.h where things are pretty cro

Re: [U-Boot] [PATCH v2 1/6] reboard: Create reloc.h and include it where needed

2011-12-11 Thread Albert ARIBAUD
Hi Simon, Le 11/12/2011 22:33, Simon Glass a écrit : Hi Albert, On Sun, Dec 11, 2011 at 6:52 AM, Albert ARIBAUD wrote: Le 10/12/2011 20:16, Simon Glass a écrit : Before adding new relocation functions, move this prototype out of common.h where things are pretty crowded. Signed-off-by: Sim

Re: [U-Boot] [PATCH v2 1/6] reboard: Create reloc.h and include it where needed

2011-12-11 Thread Simon Glass
Hi Albert, On Sun, Dec 11, 2011 at 6:52 AM, Albert ARIBAUD wrote: > Le 10/12/2011 20:16, Simon Glass a écrit : > >> Before adding new relocation functions, move this prototype out of >> common.h where things are pretty crowded. >> >> Signed-off-by: Simon Glass >> --- >> >>  arch/arm/cpu/arm926ejs

Re: [U-Boot] [PATCH v2 0/6] reboard: Introduce generic relocation feature

2011-12-11 Thread Simon Glass
Hi Albert, On Sun, Dec 11, 2011 at 6:47 AM, Albert ARIBAUD wrote: > Hi Simon, > > General comments here, detailed comments in reply to n/6 patches. Thanks for looking at this. > > Le 10/12/2011 20:16, Simon Glass a écrit : > >> This is the second patch series aiming to unify the various board.c

[U-Boot] [PATCH] nand_spl_simple: store ecc data on the stack

2011-12-11 Thread Stefano Babic
Currently nand_spl_simple puts it's temp data at 0x1 offset in SDRAM which is likely to contain already loaded data. The patch saves the oob data and the ecc on the stack replacing the fixed address in RAM. Signed-off-by: Stefano Babic CC: Ilya Yanok CC: Scott Wood CC: Tom Rini CC: Simon S

[U-Boot] [PATCH v3] MIPS: fix endianess handling

2011-12-11 Thread Daniel Schwierzeck
Make endianess of target CPU configurable. Use the new config option for dbau1550_el and pb1000 boards. Adapt linking of standalone applications to pass through endianess options to LD. Build tested with: - ELDK 4 mips_4KC- and mips4KCle - Sourcery CodeBench Lite 2011.03-93 With this patch all

[U-Boot] [PATCH v2] MIPS: tb0229: fix compile errors

2011-12-11 Thread Daniel Schwierzeck
This board breaks MAKEALL -a mips due to compile errors. This patch fixes only the parts causing the errors to get MAKEALL working. Signed-off-by: Daniel Schwierzeck --- Changes for v2: - removed fixes for coding style cleanup and compiler warnings Note: minimal patch to get MAKEALL -a mips wor

Re: [U-Boot] [PATCH v2 6/6] reboard: arm: Remove unused code in start.S

2011-12-11 Thread Albert ARIBAUD
Hi Simon, Le 10/12/2011 20:16, Simon Glass a écrit : Now that we are using the generic relocation framework, we don't need this code. Note: Here we lose the ARM1176's enable_mmu code. This seems to duplicate code already in U-Boot now. Can anyone comment on this? First thing would be for you

Re: [U-Boot] [PATCH v2 2/6] reboard: define CONFIG_SYS_SKIP_RELOC for all archs

2011-12-11 Thread Albert ARIBAUD
Le 10/12/2011 20:16, Simon Glass a écrit : We are introducing a new generic relocation features and we want this to be the default. So we need to opt all architectures out first. Some may never have relocation, but those that do will eventually move over to this generic relocation framework. Thi

Re: [U-Boot] [PATCH v2 1/6] reboard: Create reloc.h and include it where needed

2011-12-11 Thread Albert ARIBAUD
Le 10/12/2011 20:16, Simon Glass a écrit : Before adding new relocation functions, move this prototype out of common.h where things are pretty crowded. Signed-off-by: Simon Glass --- arch/arm/cpu/arm926ejs/davinci/spl.c |1 + arch/arm/cpu/armv7/omap-common/spl.c

Re: [U-Boot] [PATCH v2 0/6] reboard: Introduce generic relocation feature

2011-12-11 Thread Albert ARIBAUD
Hi Simon, General comments here, detailed comments in reply to n/6 patches. Le 10/12/2011 20:16, Simon Glass a écrit : This is the second patch series aiming to unify the various board.c files in each architecture into a single one. This series implements a generic relocation feature, which is

Re: [U-Boot] [ARM] Pending patches for december release?

2011-12-11 Thread Tom Rini
On Sun, Dec 11, 2011 at 6:08 AM, Albert ARIBAUD wrote: > Hi Tom, Simon, > > Le 06/12/2011 19:05, Tom Rini a écrit : > >> On Tue, Dec 6, 2011 at 10:58 AM, Simon Schwarz >>  wrote: >>> >>> Hi Albert, >>> >>> One patch: >>> http://patchwork.ozlabs.org/patch/129753/ >> >> >> I've delegated this to Al

Re: [U-Boot] [PATCH v2 4/6] reboard: arm: Add processor function library

2011-12-11 Thread Albert ARIBAUD
Hi Simon, Le 10/12/2011 20:16, Simon Glass a écrit : Add a library to hold ARM assembler code which is generic across all ARM CPUs. At first it just holds some basic relocation code. The plan is to move more start.S code here. I still don't see the point in this new file, as this code is commo

[U-Boot] Pull request: u-boot-usb

2011-12-11 Thread Remy Bohmer
The following changes since commit c90a4dd79cb17abb46689f27ff9f1c971362d6e2: post/post.c: Use lldiv for 64-bit divisions (2011-12-10 23:15:14 +0100) are available in the git repository at: git://git.denx.de/u-boot-usb.git master Jana Rapava (1): USB: Add generic ULPI layer and a viewpo

Re: [U-Boot] [PATCH v1 3/3] usb:gadget:s5p Enable the USB Gadget framework at C210 Universal

2011-12-11 Thread Remy Bohmer
Hi Lukasz, 2011/11/27 Remy Bohmer : > Hi, > > 2011/10/27 Lukasz Majewski : >> This commit enables support for USB Gadgets on the C210 Universal >> reference target. >> >> Signed-off-by: Lukasz Majewski >> Signed-off-by: Kyungmin Park >> Cc: Minkyu Kang >> --- >> Depend on: "New generic PMIC fra

Re: [U-Boot] [PATCH 1/2] NET: NE2000: Cleanup IO accessors

2011-12-11 Thread Marek Vasut
> On Saturday 10 December 2011 20:09:30 Marek Vasut wrote: > > Introduce ne2k_register_io(in, out), which allows user to supply two > > functions. One for reading data from the card, the other for writing data > > to the card. Then introduce drivers' private data, which carry pointers > > to these

[U-Boot] Pull request: u-boot-arm/master

2011-12-11 Thread Albert ARIBAUD
Hi Wolfgang, The following changes since commit c90a4dd79cb17abb46689f27ff9f1c971362d6e2: post/post.c: Use lldiv for 64-bit divisions (2011-12-10 23:15:14 +0100) are available in the git repository at: git://git.denx.de/u-boot-arm.git master Holger Brunck (1): post: fix compile issue

Re: [U-Boot] [ARM] Pending patches for december release?

2011-12-11 Thread Albert ARIBAUD
Hi Tom, Simon, Le 06/12/2011 19:05, Tom Rini a écrit : On Tue, Dec 6, 2011 at 10:58 AM, Simon Schwarz wrote: Hi Albert, One patch: http://patchwork.ozlabs.org/patch/129753/ I've delegated this to Albert already. IIUC, this is not a bug-fix patch. Its history is a bit complex and it seem

Re: [U-Boot] [PATCH] arm: add __aeabi_unwind_cpp_pr1() function to avoid linker complaints

2011-12-11 Thread Albert ARIBAUD
Hi Wolfgang, Le 10/11/2011 12:51, Wolfgang Grandegger a écrit : With the ELDK 5.1 (beta) "armv7a" toolchain I'm get the following build failure: $ ./MAKEALL mx51evk ... /opt/eldk-5.1/armv7a/sysroots/arm-linux-gnueabi/usr/lib/arm-linux- gnueabi/4.6.1/libgcc.a(bpabi.o):(.ARM.exidx+0x0

Re: [U-Boot] [ARM] Pending patches for december release?

2011-12-11 Thread Albert ARIBAUD
Hi Prafulla, Holger, Le 06/12/2011 18:59, Prafulla Wadaskar a écrit : -Original Message- From: u-boot-boun...@lists.denx.de [mailto:u-boot-boun...@lists.denx.de] On Behalf Of Holger Brunck Sent: 06 December 2011 02:24 To: Albert ARIBAUD Cc: U-Boot Subject: Re: [U-Boot] [ARM] Pending patc

Re: [U-Boot] [ARM] Pending patches for december release?

2011-12-11 Thread Albert ARIBAUD
Hi Simon, FYI: Le 06/12/2011 10:32, Simon Schwarz a écrit : Hi Albert, Here is the V2 Tom was talking about: http://patchwork.ozlabs.org/patch/129584/ This one was applied by Tom Rini to u-boot-ti/master and pulled in by me then by Wolfgang. I also have this patch in the queue which i ho

Re: [U-Boot] [ARM] Pending patches for december release?

2011-12-11 Thread Albert ARIBAUD
Hi Simon, Le 07/12/2011 17:51, Simon Glass a écrit : http://patchwork.ozlabs.org/patch/126933/ http://patchwork.ozlabs.org/patch/126930/ http://patchwork.ozlabs.org/patch/126927/ http://patchwork.ozlabs.org/patch/126931/ http://patchwork.ozlabs.org/patch/126926/ http://patchwork.ozlabs.org/patc