[PATCHv6 18/18] configs: enable DM_MDIO for LS1021A-TWR and LS1021A-TSN

2020-09-22 Thread Zhiqiang Hou
From: Vladimir Oltean The tsec driver now requires DM_MDIO when DM_ETH is enabled. To avoid build errors, enable DM_MDIO in these boards' configs before we actually add DM_MDIO support to tsec. Signed-off-by: Vladimir Oltean Signed-off-by: Hou Zhiqiang --- V6: - No code change, just move it

[PATCHv6 16/18] dts: powerpc: p2020rdb: Add eTSEC DT nodes

2020-09-22 Thread Zhiqiang Hou
From: Hou Zhiqiang P2020RDB implements 3 enhanced three-speed Ethernet controllers, and the connection is shown below: eTSEC1: Connected to RGMII switch VSC7385 eTSEC2: Connected to SGMII PHY VSC8221 eTSEC3: Connected to SGMII PHY AR8021 Signed-off-by: Hou Zhiqiang --- V6: - No

[PATCHv6 15/18] configs: P1010RDB: Enable DM_ETH config

2020-09-22 Thread Zhiqiang Hou
From: Hou Zhiqiang Enable the DM_ETH and DM_MDIO config. Signed-off-by: Hou Zhiqiang --- V6: - No change. configs/P1010RDB-PA_36BIT_NAND_defconfig | 2 ++ configs/P1010RDB-PA_36BIT_NOR_defconfig | 2 ++ configs/P1010RDB-PA_36BIT_SDCARD_defconfig | 2 ++

[PATCHv6 17/18] configs: P2020RDB: Enable DM_ETH config

2020-09-22 Thread Zhiqiang Hou
From: Hou Zhiqiang Enable the DM_ETH and DM_MDIO config. On P2020RDB, the eTSEC1 is connecting with a switch VSC7385, so also enable the fixed PHY support. Signed-off-by: Hou Zhiqiang Reviewed-by: Vladimir Oltean --- V6: - No change. configs/P2020RDB-PC_36BIT_NAND_defconfig | 3 +++

[PATCHv6 10/18] dts: powerpc: p1020rdb: Add eTSEC DT nodes

2020-09-22 Thread Zhiqiang Hou
From: Hou Zhiqiang P1020RDB implements 3 enhanced three-speed Ethernet controllers, and the connection is shown below: eTSEC1: Connected to RGMII switch VSC7385 eTSEC2: Connected to SGMII PHY VSC8221 eTSEC3: Connected to SGMII PHY AR8021 Signed-off-by: Hou Zhiqiang Reviewed-by:

[PATCHv6 12/18] configs: P1020RDB: Enable DM_ETH config

2020-09-22 Thread Zhiqiang Hou
From: Hou Zhiqiang Enable the DM_ETH and DM_MDIO config. On P1020RDB, the eTSEC1 is connecting with a switch VSC7385, so also enable the fixed PHY support. Signed-off-by: Hou Zhiqiang --- V6: - No change. configs/P1020RDB-PC_36BIT_NAND_defconfig | 3 +++

[PATCHv6 14/18] powerpc: p1010rdb: Compile legacy ethernet init function when no DM_ETH

2020-09-22 Thread Zhiqiang Hou
From: Hou Zhiqiang The board_eth_init() is only used by legacy ethernet driver framework, so do not compile it when DM_ETH config has been selected. Signed-off-by: Hou Zhiqiang Reviewed-by: Vladimir Oltean --- V6: - No change. board/freescale/p1010rdb/p1010rdb.c | 2 ++ 1 file changed, 2

[PATCHv6 11/18] powerpc: p1_p2_rdb: Don't compile board_eth_init() when DM_ETH enabled

2020-09-22 Thread Zhiqiang Hou
From: Hou Zhiqiang The board_eth_init() is only used by legacy ethernet driver framework, so do not compile it when DM_ETH config has been selected. Signed-off-by: Hou Zhiqiang Reviewed-by: Vladimir Oltean --- V6: - No change. board/freescale/p1_p2_rdb_pc/p1_p2_rdb_pc.c | 2 ++ 1 file

[PATCHv6 13/18] dts: powerpc: p1010rdb: Add eTSEC DT nodes

2020-09-22 Thread Zhiqiang Hou
From: Hou Zhiqiang P1010RDB implements 3 enhanced three-speed Ethernet controllers, and the connection is shown below: eTSEC1: Connected to RGMII PHY AR8033 eTSEC2: Connected to SGMII PHY AR8033 eTSEC3: Connected to SGMII PHY AR8033 Signed-off-by: Hou Zhiqiang --- V6: - No change.

[PATCHv6 06/18] net: tsec: Add the compatible string "gianfar" support

2020-09-22 Thread Zhiqiang Hou
From: Hou Zhiqiang Add compatible string "gianfar" support and update the device-tree-bindings doc. Signed-off-by: Hou Zhiqiang Reviewed-by: Vladimir Oltean --- V6: - No change. doc/device-tree-bindings/net/fsl-tsec-phy.txt | 2 +- drivers/net/tsec.c| 16

[PATCHv6 07/18] powerpc: mpc8xxx: Don't compile cpu_eth_init() when DM_ETH enabled

2020-09-22 Thread Zhiqiang Hou
From: Hou Zhiqiang The cpu_eth_init() is only used by the legacy ethernet driver framework. Signed-off-by: Hou Zhiqiang Reviewed-by: Vladimir Oltean --- V6: - No change. arch/powerpc/cpu/mpc8xxx/cpu.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/arch/powerpc/cpu/mpc8xxx/cpu.c

[PATCHv6 09/18] configs: p1_p2_rdb: Add the default address of vsc7385 firmware

2020-09-22 Thread Zhiqiang Hou
From: Hou Zhiqiang Add the environment 'vscfw_addr' to assign a default address for vsc7385 firmware uploading. Signed-off-by: Hou Zhiqiang --- V6: - No change. include/configs/p1_p2_rdb_pc.h | 2 ++ 1 file changed, 2 insertions(+) diff --git a/include/configs/p1_p2_rdb_pc.h

[PATCHv6 08/18] fsl: p1_p2_rdb: Move vsc7835 firmware uploading to board_early_init_r()

2020-09-22 Thread Zhiqiang Hou
From: Hou Zhiqiang Move vsc7835 firmware uploading to board_early_init_r(), so that the switch also can work in DM eTSEC driver. Signed-off-by: Hou Zhiqiang Reviewed-by: Vladimir Oltean --- V6: - No change. board/freescale/p1_p2_rdb_pc/p1_p2_rdb_pc.c | 35 +++-- 1 file

[PATCHv6 05/18] net: tsec: Add fixed-link PHY support

2020-09-22 Thread Zhiqiang Hou
From: Hou Zhiqiang The info of fixed-link PHY is described in DT node instead of getting from MII, so detect the fixed-link PHY DT node first, if it doesn't exist then probe the MII. Signed-off-by: Vladimir Oltean Signed-off-by: Hou Zhiqiang --- V6: - No change. drivers/net/tsec.c | 5

[PATCHv6 01/18] phy: make phy_connect_fixed work with a null mdio bus

2020-09-22 Thread Zhiqiang Hou
From: Vladimir Oltean It is utterly pointless to require an MDIO bus pointer for a fixed PHY device. The fixed.c implementation does not require it, only phy_device_create. Fix that. Signed-off-by: Vladimir Oltean Signed-off-by: Hou Zhiqiang Reviewed-by: Hou Zhiqiang --- V6: - No change.

[PATCHv6 03/18] net: fsl_mdio: Correct the MII management register block address

2020-09-22 Thread Zhiqiang Hou
From: Hou Zhiqiang The MII management register block offset is different between gianfar and etsec2 compatible devices, this patch is to fix this issue by adding driver data for different compatible string. Fixes: 2932c5a802a9 ("net: tsec: fsl_mdio: add DM MDIO support") Signed-off-by: Hou

[PATCHv6 02/18] net: fsl_mdio: Change to use virtual address

2020-09-22 Thread Zhiqiang Hou
From: Hou Zhiqiang Use virtual address to access the MII block registers instead of physical address. Signed-off-by: Hou Zhiqiang Reviewed-by: Vladimir Oltean --- V6: - No change. drivers/net/fsl_mdio.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

[PATCHv6 04/18] net: tsec: convert to use DM_MDIO when DM_ETH enabled

2020-09-22 Thread Zhiqiang Hou
From: Hou Zhiqiang For the platforms on which the eTSEC driver uses DM_ETH, convert its MDIO controller code to also use DM_MDIO. Note that for handling the TBI PHY (the MAC PCS for SGMII), we still don't register a udevice for it, since we can drive it locally and there is no point in doing

[PATCHv6 00/18] powerpc: convert p1010, p1020 and p2020 RDB boards to DM_ETH

2020-09-22 Thread Zhiqiang Hou
From: Hou Zhiqiang This patchset is to convert P1010, P1020 and P2020 RDB boards to DM_ETH. V5: Merged the following thread: https://patchwork.ozlabs.org/project/uboot/list/?series=174343=both=* Hou Zhiqiang (16): net: fsl_mdio: Change to use virtual address net: fsl_mdio: Correct the MII

[PATCH] board: renesas: draak: Drop CA57 reset

2020-09-22 Thread Biju Das
Renesas Draak board based on R-Car D3 has single CA53. This patch drops check for cputype from reset_cpu() and also drops the corresponding CA57 macros. While at it also dropped RST_RSTOUTCR macro which is unused. Signed-off-by: Biju Das Reviewed-by: Lad Prabhakar ---

[PATCH] board: renesas: remove empty board_early_init_f function

2020-09-22 Thread Biju Das
Remove empty board_early_init_f function, since it is disabled in ebisu and condor board configs. Signed-off-by: Biju Das Reviewed-by: Lad Prabhakar --- This patch depend upon [1] and [2] [1] https://patchwork.ozlabs.org/project/uboot/patch/20200922083044.5747-1-biju.das...@bp.renesas.com/ [2]

[PATCH] board: renesas: Remove empty s_init function

2020-09-22 Thread Biju Das
Default s_init weak function available, so remove the s_init empty function. Signed-off-by: Biju Das Reviewed-by: Lad Prabhakar --- This patch depend on [1] [1] https://patchwork.ozlabs.org/project/uboot/patch/20200922080917.4693-1-biju.das...@bp.renesas.com/ --- board/renesas/condor/condor.c

RE: [PATCHv5 02/18] configs: enable DM_MDIO for LS1021A-TWR and LS1021A-TSN

2020-09-22 Thread Z.q. Hou
Hi Vladimir, Sorry, I missed your email! > -Original Message- > From: Vladimir Oltean > Sent: 2020年7月16日 23:34 > To: Z.q. Hou > Cc: u-boot@lists.denx.de; bmeng...@gmail.com; Priyanka Jain > ; Vladimir Oltean > Subject: Re: [PATCHv5 02/18] configs: enable DM_MDIO for LS1021A-TWR > and

Re: [PATCH 5/5] x86: video: Show information about each video device

2020-09-22 Thread Bin Meng
On Sun, Sep 20, 2020 at 11:49 PM Simon Glass wrote: > > At present the 'bdinfo' command shows the framebuffer address, but not the > address of the copy framebuffer, if present. Add support for this. > > Signed-off-by: Simon Glass > --- > > cmd/bdinfo.c | 26 +- > 1 file

Re: [PATCH 2/5] x86: hob: Try to show a name instead of a GUID

2020-09-22 Thread Bin Meng
Hi Simon, On Sun, Sep 20, 2020 at 11:49 PM Simon Glass wrote: > > GUIDs are one of the seven evils of the computer world. They obfuscate the > meaning and require people to look up long hex strings to decode it. Agreed :) > > Luckily only a miniscule fraction of the 10^38 possible GUIDs are in

Re: [PATCH 3/5] x86: Allow showing details about a HOB entry

2020-09-22 Thread Bin Meng
On Sun, Sep 20, 2020 at 11:49 PM Simon Glass wrote: > > Some HOBs include information that can be decoded. Add a -v option to the > hob command, to allow this to be displayed. Add the ability to decode a > resource descriptor. > > Signed-off-by: Simon Glass > --- > > cmd/x86/hob.c | 49

Re: [PATCH 4/5] x86: Add support for more than 8 MTRRs

2020-09-22 Thread Bin Meng
On Sun, Sep 20, 2020 at 11:49 PM Simon Glass wrote: > > At present the mtrr command only support 8 MTRRs. Some SoCs have more than > that. Update the implementation to support up to 10. Read the number of > MTRRs dynamically instead. > > Signed-off-by: Simon Glass > --- > > arch/x86/cpu/mtrr.c

Re: [PATCH 1/5] x86: hob: Add way to show a single hob entry

2020-09-22 Thread Bin Meng
On Sun, Sep 20, 2020 at 11:49 PM Simon Glass wrote: > > The 'hob' command currently lists all HOB entries. Add way to list a > single entry, by index. > > Signed-off-by: Simon Glass > --- > > cmd/x86/hob.c | 16 +++- > 1 file changed, 11 insertions(+), 5 deletions(-) > Reviewed-by:

[PATCH] arm: rmobile: Use imply for BOARD_EARLY_INIT_F

2020-09-22 Thread Biju Das
Use "imply" instead of "select" for BOARD_EARLY_INIT_F config option, and then disable it on boards which don't need it. Updated grpeach_defconfig to disable BOARD_EARLY_INIT_F option for RZA1. Signed-off-by: Biju Das Reviewed-by: Lad Prabhakar --- arch/arm/Kconfig | 2 +-

Re: [PATCH v3 39/57] tpm: cr50: Add ACPI support

2020-09-22 Thread Andy Shevchenko
On Mon, Sep 21, 2020 at 2:51 PM Andy Shevchenko wrote: > > On Sun, Sep 06, 2020 at 03:43:47PM -0600, Simon Glass wrote: > > Generate ACPI information for this device so that Linux can use it > > correctly. > > > + ret = acpi_device_write_interrupt_or_gpio(ctx, (struct udevice *)dev, > > +

Re: [PATCH v3 00/57] dm: Add programatic generation of ACPI tables (part D)

2020-09-22 Thread Bin Meng
Hi Simon, On Mon, Sep 7, 2020 at 5:44 AM Simon Glass wrote: > > Note: This is part D of this effort. With this, Coral includes all > required ACPI tables. > > At present on x86 U-Boot supports creating ACPI (Advanced Configuration > and Power Interface) tables using the Intel ACPI Source

Re: [PATCH v3 39/57] tpm: cr50: Add ACPI support

2020-09-22 Thread Bin Meng
Hi Simon, On Mon, Sep 21, 2020 at 7:51 PM Andy Shevchenko wrote: > > On Sun, Sep 06, 2020 at 03:43:47PM -0600, Simon Glass wrote: > > Generate ACPI information for this device so that Linux can use it > > correctly. > > > + ret = acpi_device_write_interrupt_or_gpio(ctx, (struct udevice

Re: [PATCH v3 56/57] x86: Move include of bitops out of ACPI region

2020-09-22 Thread Bin Meng
On Mon, Sep 7, 2020 at 5:45 AM Simon Glass wrote: > > At present linux/bitops.h is included in ACPI code. This is not needed and > can cause a problem in fls64.h since BITS_PER_LONG is not defined. Move > the #include into the part not used by ACPI. > > Signed-off-by: Simon Glass > --- > > (no

Re: [PATCH v3 55/57] x86: Add a way to add to the e820 memory table

2020-09-22 Thread Bin Meng
On Mon, Sep 7, 2020 at 5:45 AM Simon Glass wrote: > > Some boards want to reserve extra regions of memory. Add a 'chosen' > property to support this. > > Signed-off-by: Simon Glass > --- > > (no changes since v1) > > arch/x86/lib/fsp/fsp_dram.c | 17 + >

[PATCH] arm: mach-rmobile: Mark the default s_init function as weak

2020-09-22 Thread Biju Das
Mark the default s_init function as weak, so that SoC's can override it if needed, and it will still be discarded if unused. Signed-off-by: Biju Das Reviewed-by: Lad Prabhakar --- arch/arm/mach-rmobile/lowlevel_init_gen3.S | 6 ++ 1 file changed, 6 insertions(+) diff --git

Re: [PATCH v3 54/57] acpi: Use defines for field lengths

2020-09-22 Thread Bin Meng
On Mon, Sep 7, 2020 at 5:45 AM Simon Glass wrote: > > A few fields have an open-coded length. Use the defines for this purpose > instead. > > Signed-off-by: Simon Glass > --- > > (no changes since v1) > > include/acpi/acpi_table.h | 5 +++-- > 1 file changed, 3 insertions(+), 2 deletions(-) >

Re: [PATCH v3 53/57] x86: fsp: Show FSP-S or FSP-M address in fsp_get_header()

2020-09-22 Thread Bin Meng
On Mon, Sep 7, 2020 at 5:45 AM Simon Glass wrote: > > At present this function only supports FSP-M but it is also used to read > FSP-S, in which case FSP-M may be zero. Add support for showing whichever > address is present in the FSP binary. > > Also change the debug() statements to log_debug()

Re: [PATCH v3 52/57] x86: fsp: Add more debugging for silicon init

2020-09-22 Thread Bin Meng
On Mon, Sep 7, 2020 at 5:45 AM Simon Glass wrote: > > If locating the FSP header hangs for whatever reason it is useful to see > where it got stuck. Add a debug print. Also show the address of the FSP-S > entry point as a sanity check. > > Signed-off-by: Simon Glass > --- > > (no changes since

Re: [PATCH v3 49/57] x86: acpi: Set the log category for x86 table generation

2020-09-22 Thread Bin Meng
On Mon, Sep 7, 2020 at 5:44 AM Simon Glass wrote: > > This file doesn't currently have a log category. Add one so that items > are logged correctly. > > Signed-off-by: Simon Glass > --- > > (no changes since v1) > > arch/x86/lib/acpi_table.c | 2 ++ > 1 file changed, 2 insertions(+) >

Re: [PATCH v3 44/57] x86: Correct the assembly guard in e820.h

2020-09-22 Thread Bin Meng
On Mon, Sep 7, 2020 at 5:44 AM Simon Glass wrote: > > This is currently in the wrong place, so including the file in the device > tree fails. Fix it. > > Signed-off-by: Simon Glass > --- > > (no changes since v1) > > Changes in v1: > - Update commit message with a comma > >

Re: [PATCH v3 45/57] x86: Add a header guard to asm/acpi_table.h

2020-09-22 Thread Bin Meng
On Mon, Sep 7, 2020 at 5:44 AM Simon Glass wrote: > > This file cannot currently be included in ASL files. Add a header guard > to permit this. > > Signed-off-by: Simon Glass > --- > > (no changes since v1) > > arch/x86/include/asm/acpi_table.h | 4 > 1 file changed, 4 insertions(+) >

Re: [PATCH v3 40/57] x86: fsp: Update the FSP API with the end-firmware method

2020-09-22 Thread Bin Meng
On Mon, Sep 7, 2020 at 5:44 AM Simon Glass wrote: > > This new method is intended to be called when UEFI shuts down the 'boot > services', i.e. any lingering code in the boot loader that might be used > by the OS. > > Add a definition for this new method and update the comments a little. > >

Re: [PATCH 5/8] sunxi: board: Save the chosen DT name in the SPL header

2020-09-22 Thread André Przywara
On 22/09/2020 02:12, Samuel Holland wrote: Hi, > On 9/21/20 7:41 PM, André Przywara wrote: >> On 03/09/2020 06:07, Samuel Holland wrote: >>> This overwrites the name loaded from the SPL image. It will be different >>> if there was previously no name provided, or if a more accurate name was >>>

Re: [PATCH v3 15/57] x86: link: Allow more space for U-Boot

2020-09-22 Thread Bin Meng
On Mon, Sep 7, 2020 at 5:44 AM Simon Glass wrote: > > The extra ACPI code increases U-Boot above it current size limit. Move > the start earlier to provide space. > > Signed-off-by: Simon Glass > --- > > (no changes since v2) > > Changes in v2: > - Add new patch to allow more space for U-Boot on

Re: [PATCH v3 05/57] x86: apl: Correct PCIE_ECAM_BASE

2020-09-22 Thread Bin Meng
On Mon, Sep 7, 2020 at 5:44 AM Simon Glass wrote: > > This value is incorrect and causes problems booting Linux. Fix it. > > Signed-off-by: Simon Glass > --- > > (no changes since v1) > > board/google/chromebook_coral/Kconfig | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) >

Re: [PATCH 0/5] edison: Support for writing an xFSTK image

2020-09-22 Thread Bin Meng
Hi Simon, On Fri, Sep 4, 2020 at 9:28 AM Simon Glass wrote: > > At present it is painful to put Edison in a hardware lab because it has > two separate recovery modes. When the board has a functioning U-Boot, DFU > can be used. Otherwise an xFSTK image must be used. > > This series converts

Re: u-boot leaves watchdog enabled by default

2020-09-22 Thread Michael Walle
Hi, Am 2020-09-22 03:18, schrieb Tom Rini: On Mon, Sep 21, 2020 at 10:56:14PM +0200, Michael Walle wrote: Hi, [..] > > >>> >> called in the bootefi case. So even if I'd do a workaround and > > >>> stop it > > >>> >> manually in my board code, I couldn't do that consistently

[PATCH] net: ravb: Remove writeext function call

2020-09-22 Thread Biju Das
The micrel phy driver is already configuring this values from device tree. So remove the redundant phy configuration call from this driver. Signed-off-by: Biju Das Reviewed-by: Lad Prabhakar --- Tested on RCar M3N board, the final configuration value is same. rxc-skew-ps 19

Re: [PATCH v3 00/17] x86: zboot: Enhance the 'zboot' command

2020-09-22 Thread Bin Meng
On Sun, Sep 6, 2020 at 4:51 AM Simon Glass wrote: > > This command is currently monolithic and does not support scripts which > want to adjust the boot process. This series updates it to be more like > 'bootm', in that it has sub-commands for each stage of the boot. This > allows some stages to

Re: [PATCH v3 07/17] x86: zboot: Set up a sub-command structure

2020-09-22 Thread Bin Meng
On Sun, Sep 6, 2020 at 4:51 AM Simon Glass wrote: > > Add subcommands to zboot. At present there is only one called 'start' > which does the whole boot. It is the default command so is optional. > > Change the 's' string variable to const while we are here. > Signed-off-by: Simon Glass >

RE: [PATCH 1/2] arm: rmobile: Add RZ/G2M SoC

2020-09-22 Thread Biju Das
Hi Marek, > -Original Message- > From: Biju Das > Sent: 21 September 2020 18:30 > To: Marek Vasut ; Nobuhiro Iwamatsu > > Cc: u-boot@lists.denx.de; Chris Paterson ; > Prabhakar Mahadev Lad > Subject: RE: [PATCH 1/2] arm: rmobile: Add RZ/G2M SoC > > > Hi Marek, > > Thanks for the

Re: [PATCH v3 10/17] x86: zboot: Add an 'load' subcommand

2020-09-22 Thread Bin Meng
On Sun, Sep 6, 2020 at 4:51 AM Simon Glass wrote: > > Add a subcommand that loads the kernel into the right places in memory. > > Signed-off-by: Simon Glass > --- > > Changes in v3: > - Move command help into the patch for each command > - Split the 'load' command into its own patch > >

<    1   2   3