On Mon, 15 Jul 2024 at 13:14, Simon Glass wrote:
>
> Fix a minor indentation / whitespace problem in a comment.
>
> Signed-off-by: Simon Glass
> ---
>
> boot/bootmeth_efi.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/boot/bootmeth_efi.c b/boot/bootmeth_efi.c
> index
On Tue, 16 Jul 2024 at 16:57, Michal Simek wrote:
>
> Fix typo in EFI_RT_VOLATILE_STORE description.
>
> Fixes: c28d32f946f0 ("efi_loader: conditionally enable SetvariableRT")
> Signed-off-by: Michal Simek
> ---
>
> lib/efi_loader/Kconfig | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
On Thu, 18 Jul 2024 at 15:05, Heinrich Schuchardt
wrote:
>
> A system has to support booting via the boot manager to be EBBR compliant.
> See the reference to variables Boot in the specification.
>
> Signed-off-by: Heinrich Schuchardt
> ---
> lib/efi_loader/Kconfig | 1 +
> 1 file changed, 1
On Wed, 10 Jul 2024 at 19:26, Caleb Connolly wrote:
>
> There was some very old code floating around for decoding symbols, it's
> incomplete and is never built. Remove it so we can add a new
> implementation.
>
> Signed-off-by: Caleb Connolly
> ---
> Makefile| 11 ---
> commo
On Mon, 8 Jul 2024 at 19:32, Tom Rini wrote:
>
> On Thu, Jul 04, 2024 at 01:04:56PM +0530, Sughosh Ganu wrote:
>
> > The aim of this patch series is to fix the current state of
> > incoherence between modules when it comes to memory usage. The primary
> > issue that this series is trying to fix is
Hi Fabio,
> -Original Message-
> From: Fabio Estevam
> Sent: Friday, July 19, 2024 10:19 PM
> To: Z.Q. Hou
> Cc: u-boot@lists.denx.de; sba...@denx.de; dl-uboot-imx
> ; tr...@konsulko.com; Peng Fan ;
> Yi Zhao ; Jiafei Pan
> Subject: Re: [PATCHv1 1/2] mp: imx8m: add cpu command support
>
Hi Simon,
> -Original Message-
> From: Simon Glass
> Sent: Friday, July 19, 2024 11:05 PM
> To: Z.Q. Hou
> Cc: u-boot@lists.denx.de; sba...@denx.de; feste...@gmail.com;
> dl-uboot-imx ; tr...@konsulko.com; Peng Fan
> ; Tao Yang
> Subject: Re: [PATCHv1 1/3] mp: imx9: add cpu command supp
Hello Simon,
On 20.07.24 01:36, Anatolij Gustschin wrote:
Hi Simon,
On Thu, 18 Jul 2024 18:36:02 +0100
Simon Glass s...@chromium.org wrote:
Drop this old code to permit removal of legacy I2C code.
Signed-off-by: Simon Glass
---
board/keymile/Kconfig | 3 --
board/keymile/common
Hello Anatolij,
On 20.07.24 01:24, Anatolij Gustschin wrote:
The conversion to DM_I2C is mandatory, rework to remove
use of legacy I2C API.
Signed-off-by: Anatolij Gustschin
Cc: Aleksandar Gerasimovski
Cc: Holger Brunck
Cc: Tomas Alvarez Vanoli
---
Changes in v2:
- convert pg_wcom_expu1_
Hello Marek,
On 20.07.24 14:40, Marek Vasut wrote:
Drop all duplicate newlines. No functional change.
Signed-off-by: Marek Vasut
---
drivers/i2c/exynos_hs_i2c.c | 1 -
drivers/i2c/i2c-uniphier.c | 1 -
drivers/i2c/imx_lpi2c.c | 1 -
drivers/i2c/muxes/i2c-mux-gpio.c | 1
Instead of using the local imx7s-warp devicetree copies from U-Boot,
convert the imx7s-warp board to OF_UPSTREAM so that the upstream
kernel devicetree can be used instead.
Signed-off-by: Fabio Estevam
---
arch/arm/dts/Makefile | 1 -
arch/arm/dts/imx7s-warp.dts | 500 ---
Instead of using the local imx7s-warp devicetree copies from U-Boot,
convert the imx7s-warp board to OF_UPSTREAM so that the upstream
kernel devicetree can be used instead.
Signed-off-by: Fabio Estevam
---
arch/arm/dts/Makefile | 1 -
arch/arm/dts/imx7s-warp.dts | 500 ---
On Sun, Jul 21, 2024 at 2:42 PM Heinrich Schuchardt
wrote:
>
> On 7/21/24 23:27, E Shattow wrote:
> > P.S. my suggestion below
> >
> > On Fri, Jul 19, 2024 at 5:06 PM E Shattow wrote:
> >>
> >> On Fri, Jul 19, 2024 at 4:12 PM Heinrich Schuchardt
> >> wrote:
> >>>
> >>> For the Milk-V Mars CM (li
On 7/21/24 23:27, E Shattow wrote:
P.S. my suggestion below
On Fri, Jul 19, 2024 at 5:06 PM E Shattow wrote:
On Fri, Jul 19, 2024 at 4:12 PM Heinrich Schuchardt
wrote:
For the Milk-V Mars CM (lite) we have only been copying sizeof(void *)
bytes to the compatible property instead of the who
P.S. my suggestion below
On Fri, Jul 19, 2024 at 5:06 PM E Shattow wrote:
>
> On Fri, Jul 19, 2024 at 4:12 PM Heinrich Schuchardt
> wrote:
> >
> > For the Milk-V Mars CM (lite) we have only been copying sizeof(void *)
> > bytes to the compatible property instead of the whole string list.
>
> Thi
Hi Maxim,
On 2024-07-21 16:53, Maxim Moskalets wrote:
> Just copy of rock-3a-rk3568_defconfig with dts for rock-3c-rk3566.
> Separated from the original due to the use of different DTS, than
> fixed primarily network support.
What does this reference to? There has never been support for ROCK 3C i
Hi Sebastian,
On 2024-07-16 22:42, Sebastian Kropatsch wrote:
> Fix multiplex configuration for PCIe1L0 and PCIe1L1 in PCIESEL_CON for
> RK3588 to correctly select between Combo PHYs and PCIe3 PHY.
> Currently, the code incorrectly muxes both ports to Combo PHYs,
> interfering with PCIe3 PHY setti
On Sat, Jul 20, 2024 at 6:47 PM E Shattow wrote:
>
> Hi, I am testing on Milk-V Mars CM Lite, and I add to these devicetree
> changes at runtime from board/starfive/visionfive2/spl.c
>
> On Thu, Jul 18, 2024 at 6:38 PM Minda Chen
> wrote:
> >
> > Add Jh7110 Cadence USB dts node, Visionfive2 defa
Make the raw-mode options depend on SPL_SYS_MMCSD_RAW_MODE in a more
direct way. This makes it easier to understand the options with
'make menuconfig'.
There are three different ways of specifying the offset:
- sector offset
- partition number
- partition type
So make these a choice, so it is mo
Rather than having every caller set this up individually, create a
common init function. This allows new fields to be added without the
risk of them being left uninited.
Signed-off-by: Simon Glass
Reviewed-by: Michael Trimarchi
---
(no changes since v1)
arch/arm/mach-imx/spl_imx_romapi.c | 1
Update the comment to match the function. Fix the indentation while we
are here.
Signed-off-by: Simon Glass
Reviewed-by: Sean Anderson
---
(no changes since v1)
include/blk.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/include/blk.h b/include/blk.h
index 7c7cf7f2b1
Rather than declaring completely separate functions, put the code for
each case into the same function. This makes it easier to read.
Signed-off-by: Simon Glass
Reviewed-by: Sean Anderson
---
(no changes since v1)
include/spl.h | 18 +++---
1 file changed, 7 insertions(+), 11 dele
At present spl_mmc_load() is the only caller of this function, passing
it a boot_device, an index into the available MMC devices. Pass the
device number instead, since it is known by the caller and simplifies
the code.
Signed-off-by: Simon Glass
Reviewed-by: Sean Anderson
---
Changes in v2:
- U
Use 'ret' as the return code, since it may not be an error and this is
the common name in U-Boot. Make sure to return the error code when
given, rather than transforming it into -1 (-EPERM).
Signed-off-by: Simon Glass
---
Changes in v2:
- Update 'return ret' to 'return 0' when ret is known to be
This check is not needed now, since printf() resolved to nothing if not
available. Drop the #ifdefs
Signed-off-by: Simon Glass
Reviewed-by: Sean Anderson
---
(no changes since v1)
common/spl/spl_mmc.c | 20 +---
1 file changed, 1 insertion(+), 19 deletions(-)
diff --git a/com
Unless function names are requested, the logging system should not
compile these into the code. Adjust the macros to handle this.
This means that turning on function names at runtime won't work unless
CONFIG_LOGF_FUNC is enabled. We could perhaps split this into a
separate option if that is a prob
Use the log subsystem instead of dev, to avoid including function names
in the code.
The CONFIG_LOGF_FUNC option can be used to enable the function name.
Signed-off-by: Simon Glass
Reviewed-by: Sean Anderson
---
(no changes since v1)
drivers/mmc/mmc.c | 49 ---
The code makes quite a few uses of __func__ which puts the function
name into the resulting SPL image. Use the log subsystem instead, to
reduce size.
The CONFIG_LOGF_FUNC option can be used to enable the function name.
Signed-off-by: Simon Glass
---
Changes in v2:
- Various updates to log messa
Define spl_set_header_raw_uboot() always so we can drop the last #ifdef
in this function.
Signed-off-by: Simon Glass
Reviewed-by: Sean Anderson
---
Changes in v2:
- Avoid changing comment
common/spl/spl.c | 10 --
1 file changed, 4 insertions(+), 6 deletions(-)
diff --git a/common/sp
This function has a number of unnecessary #ifdefs so remove them.
Signed-off-by: Simon Glass
Reviewed-by: Sean Anderson
---
(no changes since v1)
common/spl/spl.c | 22 +++---
1 file changed, 11 insertions(+), 11 deletions(-)
diff --git a/common/spl/spl.c b/common/spl/spl.c
i
These should have a CONFIG_ prefix. Add it.
Signed-off-by: Simon Glass
Fixes: 7a0d88076b9 ("Add in the ability to load and boot an uncompr...")
Reviewed-by: Sean Anderson
---
(no changes since v1)
common/spl/spl.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/common/
Rather than repeating the same code in two files (SPL and TPL), move it
to a shared filed.
Signed-off-by: Simon Glass
Reviewed-by: Dragan Simic
---
(no changes since v1)
arch/arm/include/asm/arch-rockchip/timer.h | 3 ++
arch/arm/mach-rockchip/Makefile| 4 +--
arch/arm/mach-rock
This series includes various minor fixes and tweaks found when trying
to reduce the size of MMC code in SPL.
Changes in v2:
- Avoid changing comment
- Various updates to log messages
- Drop an unnecessary cast
- Update commit message to mention the runtime impact
- Leave assert() alone since it is
Just copy of rock-3a-rk3568_defconfig with dts for rock-3c-rk3566.
Separated from the original due to the use of different DTS, than
fixed primarily network support.
Signed-off-by: Maxim Moskalets
---
configs/rock-3c-rk3566_defconfig | 93
1 file changed, 93 inse
On Thu, Jul 18, 2024 at 12:49:12PM -0600, Tom Rini wrote:
> 20e0f0897ea2 Merge tag 'v6.10-dts-raw'
[snip]
I've now pushed the v6.10-dts sync to master.
--
Tom
signature.asc
Description: PGP signature
在2024年7月21日七月 下午6:08,Simon Glass写道:
[...]
>> >> > +
>> >> > + set_scanout_in = malloc(sizeof(struct virtio_gpu_set_scanout));
>> >
>> > Could these structs be inside priv instead of allocating each one?
>>
>> Those structs are all used only once at initialization.
>>
>> We can save some runt
Now that sandbox_vpl supports UPL, add a test that checks that the
payload can be loaded by SPL and the handoff information passed through
to U-Boot proper.
Signed-off-by: Simon Glass
---
(no changes since v2)
Changes in v2:
- Support CI testing
- Rework to use alist instead of fixed-length arr
Add support for loading a UPL image from SPL. This uses the simple FIT
implementation, but also loads the full FIT just to permit more testing.
Signed-off-by: Simon Glass
---
(no changes since v1)
arch/sandbox/cpu/spl.c | 49 +-
arch/sandbox/include/asm/
UPL significantly alters the boot flow for sandbox. Add a flag to enable
this so that it can be enabled only on tests which need it.
Signed-off-by: Simon Glass
---
(no changes since v1)
arch/sandbox/cpu/start.c | 13 -
arch/sandbox/include/asm/state.h | 1 +
2 files change
Add some documentation to explain the basic concept along with a link
to the full spec.
Signed-off-by: Simon Glass
---
(no changes since v2)
Changes in v2:
- Add a link to the spec
- Add a link to the command
MAINTAINERS | 1 +
doc/usage/cmd/upl.rst | 4 ++--
doc/usage/index.rst
Use the sandbox_vpl build to test UPL since it supports a real devicetree
in SPL. The sandbox_spl build uses OF_PLATDATA.
Enable writing the UPL handoff in SPL and reading it in U-Boot proper.
Provide a test to check that this handoff works.
Note that the test uses the standard devicetree rather
Read the UPL early in boot so that it is available. For now none of the
information is used.
Signed-off-by: Simon Glass
---
(no changes since v1)
boot/Kconfig | 12 +++-
common/board_f.c | 22 ++
common/board_r.c | 2 ++
3 files changed, 35 insertions(+), 1 del
Specify the FIT and include information about each loaded image, as
required by the UPL handoff.
Write the UPL handoff into the bloblist before jumping to the next phase.
Control this using a runtime flag to avoid conflicting with other
handoff mechanisms.
Signed-off-by: Simon Glass
---
(no ch
This flag is set for simple FIT, so set it for full FIT too.
Signed-off-by: Simon Glass
---
Changes in v3:
- Split out into its own commit
common/spl/spl_fit.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/common/spl/spl_fit.c b/common/spl/spl_fit.c
index 2a097f4464c..527a5691ac6 100644
Add the basic code to create a handoff structure in SPL, so it can be
passed to the next phase. For now this is not plumbed in.
Signed-off-by: Simon Glass
---
(no changes since v2)
Changes in v2:
- Add a function to init the UPL process in SPL
MAINTAINERS | 1 +
boot/Kconfig
Add a 'upl' command to work with Universal Payload features. For now it
only supports reading and writing a handoff structure.
Signed-off-by: Simon Glass
---
(no changes since v1)
MAINTAINERS | 2 +
boot/Kconfig | 1 +
cmd/Kconfig
Add some unit tests to check that we can write a UPL handoff and read it
back.
Signed-off-by: Simon Glass
---
(no changes since v2)
Changes in v2:
- Put the upl tests under their own subcommand to avoid bootstd init
MAINTAINERS | 1 +
include/test/suites.h | 1 +
include/upl.h
Universal Payload provides a standard way of handing off control between
two firmware phases. Add support for writing the handoff information from
a structure.
Signed-off-by: Simon Glass
---
(no changes since v1)
boot/Kconfig | 8 +
boot/Makefile| 1 +
boot/upl_write.c | 622 ++
Universal Payload provides a standard way of handing off control between
two firmware phases. Add support for reading the handoff information into
a structure.
Signed-off-by: Simon Glass
---
Changes in v3:
- Allow up.h to be built by the host build
MAINTAINERS | 7 +
boot/Kconf
It is possible for U-Boot functions such as printf() to be called
within state_init(). This can end up checking gd->flags (e.g. in putc())
before global_data is set up.
Move the setup earlier to avoid this. This fixes the suppression of some
debug output in memory allocation (when enabled).
Signe
At present sandbox builds package up u-boot.bin in the .img file. This
cannot actually be executed, since it is not an ELF file.
For sandbox_vpl we want to be able to run the full boot flow.
Adjust the build rule for sandbox_vpl to package the ELF file and
thereby allow full testing of the sandbo
The existing API for these functions is different from the rest of
U-Boot, in that any error code must be obtained from the errno variable
on failure. This variable is part of the C library, so accessing it
outside of the special 'sandbox' shim-functions is not ideal.
Adjust the API to return an e
Since the removal of OF_HOSTFILE logic in board_fdt_blob_setup(), the
logic for obtaining the DT is handled in the OF_BOARD option. If a
devicetree comes from a bloblist it is immediately overwritten by this
function.
Fix this by skipping the function if a devicetree is already present.
This is s
When the devicetree comes from a bloblist, it is currently overwritten
by the appended one, if present. It should be preserved.
Adjust the logic to support this.
Fixes: 70fe2385943 ("fdt: Allow the devicetree to come from a bloblist")
Signed-off-by: Simon Glass
---
(no changes since v1)
lib/
This code is useful for loading an image in sandbox_spl so move it into
a place where it can be called as needed.
Signed-off-by: Simon Glass
---
Changes in v3:
- Use longer error messages
- Use -errno instead of inventing a new error
- Use sizeof(*header) instead of 512
- Use a block size of 1 i
Fix a missing dot in a comment, since '..' is confusing.
Signed-off-by: Simon Glass
Reviewed-by: Mattijs Korpershoek
---
(no changes since v1)
arch/sandbox/cpu/os.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/sandbox/cpu/os.c b/arch/sandbox/cpu/os.c
index a04eb5aa
The argument array is not changed by the callee, so mark it const.
Signed-off-by: Simon Glass
Reviewed-by: Mattijs Korpershoek
---
(no changes since v1)
arch/sandbox/cpu/os.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/sandbox/cpu/os.c b/arch/sandbox/cpu/os.c
Universal Payload (UPL) is an Industry Standard for firmware
components[1]. UPL is designed to improve interoperability within the
firmware industry, allowing mixing and matching of projects with less
friction and fewer project-specific implementations. UPL is
cross-platform, supporting ARM, x86 an
Hi Sean,
On Sat, 20 Jul 2024 at 16:44, Sean Anderson wrote:
>
> On 7/20/24 02:16, Simon Glass wrote:
> > The code makes quite a few uses of __func__ which puts the function
> > name into the resulting SPL image. Use the log subsystem instead, to
> > reduce size.
> >
> > The CONFIG_LOGF_FUNC optio
Hi Sean,
On Sat, 20 Jul 2024 at 16:58, Sean Anderson wrote:
>
> On 7/20/24 02:17, Simon Glass wrote:
> > Use 'ret' as the return code, since it may not be an error and this is
> > the common name in U-Boot. Make sure to return the error code when
> > given, rather than transforming it into -1 (-E
Hi Sean,
On Sat, 20 Jul 2024 at 17:11, Sean Anderson wrote:
>
> On 7/20/24 02:17, Simon Glass wrote:
> > Rather than having every caller set this up individually, create a
> > common init function. This allows new fields to be added without the
> > risk of them being left uninited.
> >
>
> What i
Hi Sean,
On Sat, 20 Jul 2024 at 16:34, Sean Anderson wrote:
>
> On 7/20/24 02:16, Simon Glass wrote:
> > This function has a number of unnecessary #ifdefs so remove them.
> >
> > Signed-off-by: Simon Glass
> > ---
> >
> > common/spl/spl.c | 22 +++---
> > 1 file changed, 11 in
Hi Tom,
On Sat, 20 Jul 2024 at 18:13, Tom Rini wrote:
>
> On Sat, Jul 20, 2024 at 01:36:02PM +0100, Simon Glass wrote:
> > Hi Tom,
> >
> > On Fri, 19 Jul 2024 at 16:25, Tom Rini wrote:
> > >
> > > On Fri, Jul 19, 2024 at 04:05:09PM +0100, Simon Glass wrote:
> > > > Hi Raymond,
> > > >
> > > > On
Hi,
On Mon, 15 Jul 2024 at 12:23, wrote:
>
> From: Lukas Funke
>
> tpm_tis_wait_init() is using the 'chip->timeout_b' field which is
> initialized in tpm_tis_init(). However, the init-function is called
> *after* tpm_tis_wait_init() introducing an uninitalized field access.
>
> This commit switc
Hi Jiaxun,
On Sat, 20 Jul 2024 at 07:58, Jiaxun Yang wrote:
>
>
>
> 在2024年7月19日七月 下午11:05,Simon Glass写道:
> > Hi Jiaxun,
> >
> > On Wed, 17 Jul 2024 at 15:34, Jiaxun Yang wrote:
> >>
> >>
> >>
> >> 在2024年5月24日五月 下午9:02,Jiaxun Yang写道:
> >> > This driver is implemened based on latest VirtIO spec.
>
Hi Sean,
On Sat, 20 Jul 2024 at 15:44, Sean Anderson wrote:
>
> On 7/20/24 08:36, Simon Glass wrote:
> > Hi Sean,
> >
> > On Thu, 18 Jul 2024 at 14:54, Sean Anderson wrote:
> >>
> >> On 7/13/24 03:00, Simon Glass wrote:
> >>> Specify the FIT and include information about each loaded image, as
>
66 matches
Mail list logo