Re: [U-Boot] [PATCH 3/8] dm: blk: Add a function to find the next block device number

2017-05-18 Thread sjg
On Wed, May 3, 2017 at 5:36 AM, Simon Glass wrote: > Hi Andy, > > On 24 April 2017 at 02:04, Andy Shevchenko wrote: >> On Mon, Apr 24, 2017 at 5:02 AM, Simon Glass wrote: >>> At present this code is inline. Move it into a function

Re: [U-Boot] [PATCH 3/8] dm: blk: Add a function to find the next block device number

2017-05-03 Thread Andy Shevchenko
On Wed, May 3, 2017 at 5:36 AM, Simon Glass wrote: > Hi Andy, > > On 24 April 2017 at 02:04, Andy Shevchenko wrote: >> On Mon, Apr 24, 2017 at 5:02 AM, Simon Glass wrote: >>> At present this code is inline. Move it into a function

Re: [U-Boot] [PATCH 3/8] dm: blk: Add a function to find the next block device number

2017-05-02 Thread Simon Glass
Hi Andy, On 24 April 2017 at 02:04, Andy Shevchenko wrote: > On Mon, Apr 24, 2017 at 5:02 AM, Simon Glass wrote: >> At present this code is inline. Move it into a function to allow it to >> be used elsewhere. >> >> Signed-off-by: Simon Glass

Re: [U-Boot] [PATCH 3/8] dm: blk: Add a function to find the next block device number

2017-04-24 Thread Andy Shevchenko
On Mon, Apr 24, 2017 at 5:02 AM, Simon Glass wrote: > At present this code is inline. Move it into a function to allow it to > be used elsewhere. > > Signed-off-by: Simon Glass > +static int blk_next_free_devnum(enum if_type if_type) > +{ > + int ret;

[U-Boot] [PATCH 3/8] dm: blk: Add a function to find the next block device number

2017-04-23 Thread Simon Glass
At present this code is inline. Move it into a function to allow it to be used elsewhere. Signed-off-by: Simon Glass --- drivers/block/blk-uclass.c | 22 -- 1 file changed, 16 insertions(+), 6 deletions(-) diff --git a/drivers/block/blk-uclass.c