Hi Andy,

On 24 April 2017 at 02:04, Andy Shevchenko <andy.shevche...@gmail.com> wrote:
> On Mon, Apr 24, 2017 at 5:02 AM, Simon Glass <s...@chromium.org> wrote:
>> At present this code is inline. Move it into a function to allow it to
>> be used elsewhere.
>>
>> Signed-off-by: Simon Glass <s...@chromium.org>
>
>> +static int blk_next_free_devnum(enum if_type if_type)
>> +{
>> +       int ret;
>> +
>> +       ret = blk_find_max_devnum(if_type);
>> +       if (ret == -ENODEV)
>> +               return 0;
>
>> +       else if (ret < 0)
>
> Useless 'else'.
>
>> +               return ret;
>> +       else
>
> Ditto.
>
>> +               return ret + 1;
>> +}

I think it is clearer with these. At least, I would ask for them to be
added if they were missing.

What do you think of this series as a whole?

Regards,
Simon
_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
https://lists.denx.de/listinfo/u-boot

Reply via email to