Re: array info request

2005-07-25 Thread J. Landman Gay
Thomas McGrath III wrote: Pardon me butting in here but I have a question: Then what is the best use of arrays? What can/should they be used for? I understand the use and need for a custom property and the need for databases but what about these here arrays??? Actually, I used arrays exactly

Re: array info request

2005-07-25 Thread Dennis Brown
Thomas, I find arrays are very useful when you want to get random as opposed to sequential access to data. Most of my arrays are generated by using the split command. I read a file in, then split it by return to get quick random access to the lines, then I get a line and split it by com

Re: Scripting Style (was re: array info request)

2005-07-25 Thread Richard Gaskin
Scott Rossi wrote: Another consideration -- assuming that at least 99 percent of developers code in lower case, line 1 below might appear to be more ambiguous than line 2: put 25 into a put 25 into A IMO, line 1 has the *appearance* of an incomplete script, while in line 2, there *may* be

Scripting Style (was re: array info request)

2005-07-25 Thread Scott Rossi
> Richard is right about double-click: it's the reason why I don't use > underscores and dashes either... If you really want to split hairs (hares?), this is a somewhat weak argument. If you use, for example, an underscore as a naming convention: _myField _myButton _myGraphic Or: my_field my_b

Re: array info request

2005-07-25 Thread Thomas McGrath III
Pardon me butting in here but I have a question: Then what is the best use of arrays? What can/should they be used for? I understand the use and need for a custom property and the need for databases but what about these here arrays??? Thank you Tom On Jul 25, 2005, at 6:13 PM, Mark Wieder wr

Re: array info request (new thread)

2005-07-25 Thread Scott Rossi
Recently, Stephen Barncard wrote: > I've found it's better to have one-word names for EVERYTHING as a > general rule and use underscores and dashes to separate words. I do > it by habit now. Don't get in the habit of using dashes (as opposed to underscores) -- Rev will often try evaluate a dash

Re: array info request

2005-07-25 Thread Mark Wieder
keith- Monday, July 25, 2005, 1:15:38 PM, you wrote: k> Ermm... :-) k> Okay, in my state of blissful ignorance I had assumed that arrays k> were effectively arranged in a spreadsheet-like manner. The array k> name is the spreadsheet (in this way of thinking), the keys are like k> a set of colu

Re: array info request (new thread)

2005-07-25 Thread Dennis Brown
I only use multiword names as keys when I want to have a multi- dimensional array for a custom property. In essence I am just substituting a space for a comma because it is much easier to read the notation: customPropArray[varX&comma&varY] vs customPropArray[varX&&varY] The names are not

RE: array info request

2005-07-25 Thread Lynch, Jonathan
>The array > name is the spreadsheet (in this way of thinking), > the keys are like > a set of column headings, and the elements are the > bits of data in > each cell. Actually - the keys of a custom property set are like the elements of an array A custom property set can be thought of as the

Re: array info request

2005-07-25 Thread Jan Schenkel
--- keith <[EMAIL PROTECTED]> wrote: > Okay, in my state of blissful ignorance I had > assumed that arrays > were effectively arranged in a spreadsheet-like > manner. The array > name is the spreadsheet (in this way of thinking), > the keys are like > a set of column headings, and the elements a

Re: array info request (new thread)

2005-07-25 Thread Eric Chatonet
Hi Stepen, Le 25 juil. 05 à 23:24, Stephen Barncard a écrit : I've found it's better to have one-word names for EVERYTHING as a general rule and use underscores and dashes to separate words. I do it by habit now. You are a good developer who always makes his work easier each day :-) Richar

RE: array info request (new thread)

2005-07-25 Thread Lynch, Jonathan
Dashes are dangerous too... -Original Message- From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] On Behalf Of Stephen Barncard Sent: Monday, July 25, 2005 5:24 PM To: How to use Revolution Subject: Re: array info request (new thread) I've found it's better to have one-word

Re: array info request (new thread)

2005-07-25 Thread Richard Gaskin
Stephen Barncard wrote: I've found it's better to have one-word names for EVERYTHING as a general rule and use underscores and dashes to separate words. I do it Generally good advice, and easy to follow since Rev provides a label property for most objects in addition to its name. Extra bonu

Re: array info request (new thread)

2005-07-25 Thread Stephen Barncard
I've found it's better to have one-word names for EVERYTHING as a general rule and use underscores and dashes to separate words. I do it by habit now. Jonathan, This is interesting about the 1-word names. I have been using multiword names without any problems. Dennis Somewhere in the d

RE: array info request

2005-07-25 Thread Lynch, Jonathan
multidimensional array. I just think the first method winds up being easier, quicker, and less confusing. -Original Message- From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] On Behalf Of keith Sent: Monday, July 25, 2005 4:16 PM To: How to use Revolution Subject: Re: array info request >&g

Re: array info request

2005-07-25 Thread keith
The internal order in which keys are stored in a custom prop is not sorted alphabetically Oh boy... It's often not so bad. Associative arrays are often addressed by the key name, so sequential order wouldn't affect that one way or another. If you need sequential access you can use numeric

Re: array info request

2005-07-25 Thread Richard Gaskin
keith wrote: The internal order in which keys are stored in a custom prop is not sorted alphabetically Oh boy... It's often not so bad. Associative arrays are often addressed by the key name, so sequential order wouldn't affect that one way or another. If you need sequential access you can

Re: array info request (new thread)

2005-07-25 Thread Dennis Brown
Jonathan, I can see why I have not had a problem. I only set the customPropertySet in order to create a set or play with the keys. I always set it back to empty immediately after (default) Then I access the custom property only using array notation mySet ["this and that words"] I continue to

RE: array info request (was: Re: Rant Re Rev Documentation)

2005-07-25 Thread keith
Sometime around 25/7/05 (at 13:40 -0400) Lynch, Jonathan said: Custom properties and custom property sets should have 1-word names. Somewhere in the docs it says otherwise, but having a space in the name of a custom property caused me trouble at one point, which was fixed when I made sure it ju

RE: array info request (new thread)

2005-07-25 Thread Lynch, Jonathan
ot;myProp"] into field "my field" -Original Message- From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] On Behalf Of Lynch, Jonathan Sent: Monday, July 25, 2005 2:50 PM To: How to use Revolution Subject: RE: array info request (new thread) I have never had a problem with mult

RE: array info request (new thread)

2005-07-25 Thread Lynch, Jonathan
mber that it was not real obvious. -Original Message- From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] On Behalf Of Dennis Brown Sent: Monday, July 25, 2005 2:43 PM To: How to use Revolution Subject: Re: array info request (new thread) Jonathan, This is interesting about the 1-word names

Re: array info request (new thread)

2005-07-25 Thread Dennis Brown
Jonathan, This is interesting about the 1-word names. I have been using multiword names without any problems. Do you recall exactly what the problem was? Was it that the array did not work as advertized, or that you had problems with sorting keys or making the key unique? Of course multi

RE: array info request (was: Re: Rant Re Rev Documentation)

2005-07-25 Thread Lynch, Jonathan
riginal Message- From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] On Behalf Of keith Sent: Monday, July 25, 2005 1:32 PM To: How to use Revolution Subject: RE: array info request (was: Re: Rant Re Rev Documentation) Sometime around 25/7/05 (at 12:55 -0400) Lynch, Jonathan said: >In simplest

RE: array info request (was: Re: Rant Re Rev Documentation)

2005-07-25 Thread keith
Sometime around 25/7/05 (at 12:55 -0400) Lynch, Jonathan said: In simplest terms: In Revolution, an array is a container that holds keys, and each key is a variable. [very helpful information snipped reluctantly!] I would suggest reading the docs about custom property sets very thoroughly,

RE: array info request (new thread)

2005-07-25 Thread Dennis Brown
On Jul 25, 2005, at 12:00 PM, keith wrote: Sometime around 25/7/05 (at 01:19 -0400) Thomas McGrath III said: I always learn best by example. Absolutely! Speaking of learning by example (or any other method, I'm not fussy! ;-) is there anything around that could help me get my head aroun

Re: array info request

2005-07-25 Thread Richard Gaskin
keith wrote: is there anything around that could help me get my head around arrays? This may help get you started: -- Richard Gaskin Managing Editor, revJournal ___

RE: array info request (was: Re: Rant Re Rev Documentation)

2005-07-25 Thread Lynch, Jonathan
ls to be wary of if you choose this method - but if you get it right, Revolution searches custom property sets very fast. -Original Message- From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] On Behalf Of keith Sent: Monday, July 25, 2005 12:00 PM To: How to use Revolution Subject: array i

array info request (was: Re: Rant Re Rev Documentation)

2005-07-25 Thread keith
Sometime around 25/7/05 (at 01:19 -0400) Thomas McGrath III said: I always learn best by example. Absolutely! Speaking of learning by example (or any other method, I'm not fussy! ;-) is there anything around that could help me get my head around arrays? Some kind of simple guide that doesn't