Re: ListView inside a ListView

2011-05-25 Thread kinnu410
ail]<http://user/SendEmail.jtp?type=node&node=3550491&i=4> > > > > ------ > If you reply to this email, your message will be added to the discussion > below: > > http://apache-wicket.1842946.n4.nabble.com/ListView-inside-a-ListView

Re: ListView inside a ListView

2011-05-25 Thread kinnu410
> email]<http://user/SendEmail.jtp?type=node&node=3550472&i=1> > > > > -- > If you reply to this email, your message will be added to the discussion > below: > > http://apache-wicket.1842946.n4.nabble.com/ListView-inside-a-ListView-tp3550315p355047

Re: ListView inside a ListView

2011-05-25 Thread Scott Swank
For clarity, I would rename the ListItems: protected void populateItem(final ListItem assetItem) { assetItem.add(new Label(...)); assetItem.add(new ListView(...) { protected void populateItem(ListItem allocationItem) { allocationItem.add(new Label(...)); } } } On We

Re: ListView inside a ListView

2011-05-25 Thread Peter Karich
> add(new ListView("allocation", > allocationListModel) { shouldn't this be item.add ? - To unsubscribe, e-mail: users-unsubscr...@wicket.apache.org For additional commands, e-mail: users-h...@wicke

ListView inside a ListView

2011-05-25 Thread kinnu410
Hello, I am trying for a ListView inside a Listview which are inter dependent. But, the error msg I am getting is WicketMessage: Unable to find component with id 'allocation' in [MarkupContainer [Component id = 0]]. This means that you declared wicket:id=allocation in your markup, bu