Re: [Vala] Small syntax request labeled loops

2008-07-02 Thread Arto Karppinen
Why not do it sh(1) style? (continue 2, break 2). I would say that the perl style is a lot clearer about what happens. If you have a lot of loops inside one another, it needs some figuring out which loops happens to be number 2 at any given point. -- Arto Karppinen -

Re: [Vala] Small syntax request labeled loops

2008-07-02 Thread Ed Schouten
* Arto Karppinen <[EMAIL PROTECTED]> wrote: > If you have a lot of loops inside one another, it needs some figuring > out which loops happens to be number 2 at any given point. I bet the compiler already stores references to the current, but also the parent scope. -- Ed Schouten <[EMAIL PROTE

Re: [Vala] Small syntax request labeled loops

2008-07-02 Thread Arto Karppinen
Ed Schouten wrote: * Arto Karppinen <[EMAIL PROTECTED]> wrote: If you have a lot of loops inside one another, it needs some figuring out which loops happens to be number 2 at any given point. I bet the compiler already stores references to the current, but also the parent scope. I was thin

Re: [Vala] Small syntax request labeled loops

2008-07-02 Thread Jürg Billeter
On Wed, 2008-07-02 at 10:20 +0300, Arto Karppinen wrote: > > > > Why not do it sh(1) style? (continue 2, break 2). > > > > I would say that the perl style is a lot clearer about what happens. > > If you have a lot of loops inside one another, it needs some figuring > out which loops happens to

Re: [Vala] How to initialize a Matrix

2008-07-02 Thread Jürg Billeter
On Thu, 2008-05-15 at 02:20 -0300, Matías De la Puente wrote: > hello all, > > i try to initialize a simple matrix: > > int[,] matrix = new int[,] { {1, 3}, {4, 8} }; We don't support initializers for multi-dimensional arrays right now, however, we certainly want to support it in future versions

Re: [Vala] operators overload

2008-07-02 Thread Jürg Billeter
On Thu, 2008-05-15 at 02:28 -0300, Matías De la Puente wrote: > vala, will include operators overload like in c#? We're not planning to support operator or method overloading, however, we might add limited support to implement operators by the use of special interfaces, similar to how it already w

Re: [Vala] operators overload

2008-07-02 Thread Sam Liddicott
* Jürg Billeter wrote, On 02/07/08 13:59: > On Thu, 2008-05-15 at 02:28 -0300, Matías De la Puente wrote: > >> vala, will include operators overload like in c#? >> > > We're not planning to support operator or method overloading, are there non-technical reasons for avoiding method overload

Re: [Vala] operators overload

2008-07-02 Thread Jürg Billeter
On Wed, 2008-07-02 at 14:08 +0100, Sam Liddicott wrote: > * Jürg Billeter wrote, On 02/07/08 13:59: > > On Thu, 2008-05-15 at 02:28 -0300, Matías De la Puente wrote: > > > > > vala, will include operators overload like in c#? > > > > > > > We're not planning to support operator or method

Re: [Vala] [PATCH] GIO nullable parameters

2008-07-02 Thread Jürg Billeter
On Tue, 2008-05-20 at 15:01 +0200, Frederik wrote: > Jürg Billeter wrote: > > On Tue, 2008-05-13 at 12:09 +0200, Frederik wrote: > >> I think in the GIO vapi bindings there are more parameters that should > >> be marked as nullable. For example: "etag" as in File.replace() or > >> "progress_callbac

Re: [Vala] operators overload

2008-07-02 Thread Sam Liddicott
* Jürg Billeter wrote, On 02/07/08 14:19: > > There are many cases where method overloading makes code harder to read, > as each method can do something completely different, and you have to > look carefully at each argument type to recognize what exact method will > be called. This is especially b

Re: [Vala] operators overload

2008-07-02 Thread Jürg Billeter
On Wed, 2008-07-02 at 15:01 +0100, Sam Liddicott wrote: > * Jürg Billeter wrote, On 02/07/08 14:19: > > > > There are many cases where method overloading makes code harder to read, > > as each method can do something completely different, and you have to > > look carefully at each argument type to

Re: [Vala] Small syntax request labeled loops

2008-07-02 Thread Travis Watkins
2008/6/30 Dov Grobgeld <[EMAIL PROTECTED]>: > A small syntax enhancement borrowed from Perl that I would like to see in > vala is labeled loops, that can be referenced in continue and break > statements. Here is an example: > > > pixels: > while(foo) { > for (int i=0; i<1000; i++) { > i