[PATCH weston] xwm: set the right cursor when hovering on the decoration borders

2013-09-18 Thread Giulio Camuffo
use the alternative cursor names used also in window.c, since the names it used previously are not guaranteed to exist in all themes. --- src/xwayland/window-manager.c | 86 +++ 1 file changed, 79 insertions(+), 7 deletions(-) diff --git a/src/xwayland/wind

Welcome to Chromium's Ozone-Wayland

2013-09-18 Thread Tiago Vignatti
Ozone is a set of C++ classes in Chromium for abstracting different window systems on Linux. It provides abstraction for the construction of accelerated surfaces underlying Aura UI framework, input devices assignment and event handling. http://www.chromium.org/developers/design-documents/ozone

Re: [blink-dev] Welcome to Chromium's Ozone-Wayland

2013-09-18 Thread Jan Keromnes
Exciting news! Thanks Tiago. On Wed, Sep 18, 2013 at 2:24 PM, Tiago Vignatti < tiago.vigna...@linux.intel.com> wrote: > Ozone is a set of C++ classes in Chromium for abstracting different window > systems on Linux. It provides abstraction for the construction of > accelerated surfaces underlying

Re: [blink-dev] Welcome to Chromium's Ozone-Wayland

2013-09-18 Thread Kenneth Rohde Christiansen
Congratulation on releasing this, Tiago and Kalyan! Good work guys! Kenneth On Wed, Sep 18, 2013 at 3:30 PM, Jan Keromnes wrote: > Exciting news! Thanks Tiago. > > > On Wed, Sep 18, 2013 at 2:24 PM, Tiago Vignatti > wrote: >> >> Ozone is a set of C++ classes in Chromium for abstracting differen

Re: [blink-dev] Welcome to Chromium's Ozone-Wayland

2013-09-18 Thread Robert Kroeger
Awesome! Rob. On Wednesday, September 18, 2013, Kenneth Rohde Christiansen wrote: > Congratulation on releasing this, Tiago and Kalyan! > > Good work guys! > Kenneth > > On Wed, Sep 18, 2013 at 3:30 PM, Jan Keromnes > > > wrote: > > Exciting news! Thanks Tiago. > > > > > > On Wed, Sep 18, 2013

Tests for wl_signal and wl_resource

2013-09-18 Thread Marek Ch
Hey, I wrote these tests, could you please review it? Additionaly, I modified test-runner so that now it prints how many leaks are present in test. Regards, Marek Ch ___ wayland-devel mailing list wayland-devel@lists.freedesktop.org http://lists.freed

[PATCH 1/3] tests: extended message when leak in test is detected

2013-09-18 Thread Marek Ch
When memory or fd leak is detected, print how many blocks of memory were allocated and not freed, respectively how many files were opened/unclosed. --- tests/test-runner.c | 17 ++--- 1 file changed, 14 insertions(+), 3 deletions(-) diff --git a/tests/test-runner.c b/tests/test-runner

[PATCH 2/3] tests: add unit tests for wl_signal

2013-09-18 Thread Marek Ch
Test wl_signal initialization, adding and getting listeners and emitting --- tests/Makefile.am | 4 +- tests/signal-test.c | 114 2 files changed, 117 insertions(+), 1 deletion(-) create mode 100644 tests/signal-test.c diff --git a/tests/M

[PATCH 3/3] tests: add wl_resource tests

2013-09-18 Thread Marek Ch
--- tests/Makefile.am | 4 +- tests/resources-test.c | 167 + 2 files changed, 170 insertions(+), 1 deletion(-) create mode 100644 tests/resources-test.c diff --git a/tests/Makefile.am b/tests/Makefile.am index 3806cb6..9c673ae 100644 --- a/

[PATCH 0/2] v2, Notify clients when the native mode is switched

2013-09-18 Thread Hardening
This revised version takes in account the comment of Pekka Paalanen and Jason Ekstrand. Hardening (2): Rename current, origin, scale, origin_scale Notify clients on mode_switch() src/compositor-drm.c | 57 --- src/compositor-fbdev.c| 3 +- src/compositor-headl

[PATCH 1/2] Rename current, origin, scale, origin_scale

2013-09-18 Thread Hardening
This patch renames that fields to have consistent names. --- src/compositor-drm.c | 58 +++ src/compositor-fbdev.c| 4 ++-- src/compositor-headless.c | 4 ++-- src/compositor-rdp.c | 12 +- src/compositor-rpi.c | 4 ++-- src

[PATCH 2/2] Notify clients on mode_switch()

2013-09-18 Thread Hardening
This patch implements the notification of clients during mode_switch. As discussed on IRC, clients are notified of mode_switch only when the "native" mode is changed and activated. That means that if the native mode is changed and the compositor had activated a temporary mode for a fullscreen surfa

Vertex clipping and primitive types

2013-09-18 Thread Sam Spilsbury
Hey all, I've started playing around with trying to get weston surfaces (or views as they will later be called) to use arbitrary vertex meshes. This would allow for more complex geometry and effects with the demo compositor. Currently, the vertex clipping implementation supports up to eight verti

Re: Vertex clipping and primitive types

2013-09-18 Thread Bill Spitzak
Sam Spilsbury wrote: Hey all, I've started playing around with trying to get weston surfaces (or views as they will later be called) to use arbitrary vertex meshes. Do you have an explanation for "views"? I thought wayland already supported putting the same buffer in more than one surface,

[RFC wayland] scanner: provide convenience defines for NULL handlers

2013-09-18 Thread Peter Hutterer
Instead of NULL, a client that doesn't implement all callbacks of a listener can use named defines to increase readability of the code. For example: const struct wl_pointer_listener pointer_listener = { WL_POINTER_ENTER_HANDLER_NONE, WL_POINTER_LEAVE_HANDLER_NONE, motion_ha

Re: Vertex clipping and primitive types

2013-09-18 Thread Sam Spilsbury
Hi Bill, On Sep 19, 2013 11:49 AM, "Bill Spitzak" wrote: > > > > Sam Spilsbury wrote: >> >> Hey all, >> >> I've started playing around with trying to get weston surfaces (or >> views as they will later be called) to use arbitrary vertex meshes. >> > > Do you have an explanation for "views"? I tho