Re: [web2py] Re: Need help in standardizing my coding and naming schemes before I start my main project

2011-02-03 Thread Rupesh Pradhan
How about you show me couple (say 5) of the database structures of the applications that you have already written? I can go through it and get some practical ideas.

[web2py] Re: Need help in standardizing my coding and naming schemes before I start my main project

2011-02-01 Thread Massimo Di Pierro
The wizard convention is the following: - table and field names are lower case - table names have a t_ prefix - field names have a f_ prefix - reference fields have the same name as the table being referenced (but with f_, not t_) you can then use shortcuts: Person = db.define_table('t_person',F

Re: [web2py] Re: Need help in standardizing my coding and naming schemes before I start my main project

2011-02-01 Thread Martin Barnard
I'd be cautious about some of those field names. I'm not about to look them up, but they look suspiciously like they may collide with reserved words. I'm looking particularly hard at 'type' and 'text'. You may want to check that. Martin. I don't mind typing the extra characters now that work boug

[web2py] Re: Need help in standardizing my coding and naming schemes before I start my main project

2011-02-01 Thread howesc
i try to use pythonic naming conventions in my database. i prefer: db.define_table('address_type', Field('name')) db.define_table('contact', Field('name')) db.define_table('address', Field('contact', db.contact), Field('type', db.address_type), Field('text')) but perhaps mainly because i don't

Re: [web2py] Re: Need help in standardizing my coding and naming schemes before I start my main project

2011-02-01 Thread Martin Barnard
General request for comments & corrections from the more experienced (than me) programmers in this group please. I really don't want to be giving bad advice. Anyway, on to the advice... Rupesh, In the end, it doesn't matter what scheme you use, as long as you find it easy & your practices are con

[web2py] Re: Need help in standardizing my coding and naming schemes before I start my main project

2011-01-31 Thread Rupesh Pradhan
I have seen that before. Its about python coding style. I am trying to discuss database table and field naming style here. Care to comment on the following table structure, please: db.define_table('lu_address_type', Field('name')) db.define_table('contact', Field('name')) db.define_table('add

[web2py] Re: Need help in standardizing my coding and naming schemes before I start my main project

2011-01-31 Thread howesc
I like the python style guide here: http://www.python.org/dev/peps/pep-0008/ has tips on naming conventions and such. i personally don't prefix table names or field names. and i let web2py name the primary key "id". most of the time my reference fields share the same name as the table they r

[web2py] Re: Need help in standardizing my coding and naming schemes before I start my main project

2011-01-31 Thread Rupesh Pradhan
I am trying to standardize my naming schemes for my database, table and fields. I am trying to follow the one given below. Please share with me your scheme. Standard Database Table Naming Scheme = Table name: --- small caps with underscore look-up tabl

[web2py] Re: Need help in standardizing my coding and naming schemes before I start my main project

2011-01-27 Thread Rupesh Pradhan
Thanks a lot MARTIN for the nitpick. REALLY needed that! Inspite of what you mentioned that you are relatively new to web2py, that was a lot of help. I don't know if other are going to help me out as much as you did. But since you did take the trouble to pore through my code, I was hoping that

[web2py] Re: Need help in standardizing my coding and naming schemes before I start my main project

2011-01-27 Thread Rupesh Pradhan
Thanks a lot for sharing the philosophy behind coding!!! I get the point. Now for some *real* help by nitpicking at my coding!

[web2py] Re: Need help in standardizing my coding and naming schemes before I start my main project

2011-01-27 Thread cjrh
On Jan 27, 4:09 am, Rupesh Pradhan wrote: > I have made enough of mistakes in learing how to code and analyse software > coding properly and now my application are basically a bloatware and > increasing in complexity year after year. Good! That application is probably your greatest source of lea