Re: [webkit-dev] renaming ASSERT macro

2008-07-02 Thread Simon Hausmann
On Wednesday 02 July 2008 09:40:19 Jörg Bornemann wrote: > Hi Darin, > > Thanks for your detailed comments! > > > Adding to Assertions.h will not cause it to be included in > > public headers. Assertions.h is not designed to be used in public > > headers; it's for internal use inside the WebKit pr

Re: [webkit-dev] renaming ASSERT macro

2008-07-02 Thread Mark Rowe
On 2008-07-02, at 00:40, Jörg Bornemann wrote: Hi Darin, Thanks for your detailed comments! Adding to Assertions.h will not cause it to be included in public headers. Assertions.h is not designed to be used in public headers; it's for internal use inside the WebKit project. I've just ex

Re: [webkit-dev] renaming ASSERT macro

2008-07-02 Thread Jörg Bornemann
Hi Darin, Thanks for your detailed comments! > Adding to Assertions.h will not cause it to be included in > public headers. Assertions.h is not designed to be used in public > headers; it's for internal use inside the WebKit project. I've just executed the following: find . -name '*.h' -exec

Re: [webkit-dev] renaming ASSERT macro

2008-07-01 Thread Darin Adler
On Jul 1, 2008, at 10:39 AM, Paul Pedriana wrote: > IMO in an ideal world ASSERT would have a unique prefix (e.g. WTF_) > in order to guarantee collision avoidance as WebKit is ported to > different platforms and different usage. I can see a number of other > places in WebKit where this prac

Re: [webkit-dev] renaming ASSERT macro

2008-07-01 Thread Darin Adler
On Jul 1, 2008, at 10:39 AM, Paul Pedriana wrote: > On a related note, I would like to propose (possibly in a separate > email) that the CRASH macro in Assertions.h that ASSERT uses be > augmented to the following for improved debugging and portability > across most platforms: That sounds l

Re: [webkit-dev] renaming ASSERT macro

2008-07-01 Thread Paul Pedriana
As Darin suggests, there seem to be two questions:     1 whether it's useful to have a different name for ASSERT.     2 whether it's worthwhile to make a large code change to reflect the different name. With regard to question 1, IMO in an ideal world ASSERT would have a unique prefix (e.g. W

Re: [webkit-dev] renaming ASSERT macro

2008-07-01 Thread Darin Adler
On Jul 1, 2008, at 1:45 AM, Jörg Bornemann wrote: > This solution is easy to do, leads to the smallest source diff but > is a very dirty hack, which will lead to problems on WinCE, because > we will include windows.h in public headers. Adding to Assertions.h will not cause it to be included

Re: [webkit-dev] renaming ASSERT macro

2008-07-01 Thread Jörg Bornemann
Darin Adler wrote: >> Well, this is a small change but also a very bad idea. Not because of >> compilation time, but because of the crappy Windows headers which define >> *a* *lot* of global stuff. E.g. the XSLT parser of WebKit won't build >> because there's a "#define ERROR " which breaks an enu

Re: [webkit-dev] renaming ASSERT macro

2008-06-27 Thread Darin Adler
On Jun 27, 2008, at 1:50 AM, Jörg Bornemann wrote: > Well, this is a small change but also a very bad idea. Not because of > compilation time, but because of the crappy Windows headers which > define > *a* *lot* of global stuff. E.g. the XSLT parser of WebKit won't build > because there's a "#de

Re: [webkit-dev] renaming ASSERT macro

2008-06-27 Thread Jörg Bornemann
Darin Adler wrote: > Then lets add this to Assertion.h: > > #if PLATFORM(WINCE) // or whatever is the right if > #include > #endif > > I'd prefer this to a global change to the entire WebKit project. You really want to include in every single webkit file? Well, this is a small cha

Re: [webkit-dev] renaming ASSERT macro

2008-06-26 Thread Darin Adler
On Jun 26, 2008, at 5:16 AM, Jörg Bornemann wrote: > That means ATM that I have to make sure to always include > _before_ Assertion.h. Then lets add this to Assertion.h: #if PLATFORM(WINCE) // or whatever is the right if #include #endif I'd prefer this to a global change to t

[webkit-dev] renaming ASSERT macro

2008-06-26 Thread Jörg Bornemann
Hi *, I'd like to rename the ASSERT macro from JavaScriptCore/wtf/Assertions.h to something that doesn't clash with the Win32 ASSERT macro. There's already a hack that undefines this macro before the definition in Assertion.h. This is an easy work-around but on Windows CE (where I'm developin